Tworzenie odwołania zewnętrznego (łącza) do zakresu komórek w innym skoroszycie

Istnieje możliwość odwoływania się do zawartości komórek w innym skoroszycie przez utworzenie odwołania zewnętrznego. Odwołanie zewnętrzne (nazywane również łączem) to odwołanie do komórki lub zakresu w arkuszu innego skoroszytu programu Excel albo odwołanie do zdefiniowanej nazwy w innym skoroszycie. Można odwoływać się do określonego zakresu komórek lub zdefiniowanej nazwy zakresu komórek, można także zdefiniować nazwę dla odwołania zewnętrznego.

Co chcesz zrobić?

Więcej informacji o odwołaniach zewnętrznych

Tworzenie odwołania zewnętrznego między komórkami w różnych skoroszytach

Tworzenie odwołania zewnętrznego do zdefiniowanej nazwy w innym skoroszycie

Definiowanie nazwy zawierającej odwołanie zewnętrzne do komórek w innym skoroszycie

Więcej informacji o odwołaniach zewnętrznych

Mimo podobieństw, między odwołaniami zewnętrznymi i odwołaniami do komórek występują istotne różnice. Odwołania zewnętrzne są używane podczas pracy z dużymi ilościami danych lub złożonymi formułami znajdującymi się w kilku skoroszytach. Są tworzone w inny sposób oraz inaczej wyświetlane w komórce lub na pasku formuły.

Możliwości efektywnego stosowania odwołań zewnętrznych

Odwołania zewnętrzne są szczególnie przydatne w sytuacjach, gdy przechowywanie dużych modeli arkuszy razem w jednym skoroszycie jest niepraktyczne.

  • Scalanie danych z kilku skoroszytów      Można połączyć skoroszyty od wielu użytkowników lub z wielu działów, a następnie zintegrować potrzebne dane w jednym zbiorczym skoroszycie. W ten sposób po zmianie w skoroszytach źródłowych nie trzeba ręcznie zmieniać skoroszytu zbiorczego.

  • Tworzenie różnych widoków danych    Można wprowadzić wszystkie dane do jednego lub wielu skoroszytów źródłowych, a następnie utworzyć skoroszyt raportów zawierający odwołania zewnętrzne tylko do potrzebnych danych.

  • Upraszczanie wielkich, skomplikowanych modeli      Dzieląc skomplikowany model na kilka wzajemnie zależnych skoroszytów można pracować na modelu bez otwierania wszystkich powiązanych arkuszy. W mniejszych skoroszytach łatwiej wprowadzać zmiany, wymagają one mniej pamięci i można je szybciej otwierać, zapisywać i obliczać.

Sposoby tworzenia odwołań zewnętrznych

W przypadku tworzenia odwołania zewnętrznego za pomocą odwołania do komórki można również zastosować formuły do informacji. Przełączając między różnymi typami odwołań do komórki, można również kontrolować, które komórki są połączone w przypadku przeniesienia odwołania zewnętrznego. Jeśli na przykład zostanie użyte odwołanie względne, po przeniesieniu odwołania zewnętrznego komórki, które są z nim połączone, zmienią się, aby odzwierciedlić jego nowe położenie w arkuszu.

Podczas tworzenia odwołania zewnętrznego z jednego skoroszytu do innego należy odwoływać się do komórek, do których jest tworzone łącze, za pomocą nazwy. Aby utworzyć odwołanie zewnętrzne, można użyć nazwy, która jest już zdefiniowana, lub można zdefiniować nazwę podczas tworzenia odwołania zewnętrznego. Nazwa ułatwia zapamiętanie zawartości komórek, do których prowadzi odwołanie. Odwołania zewnętrzne używające nazw zdefiniowanych nie zmieniają się podczas ich przenoszenia, ponieważ nazwa odwołuje się do określonej komórki lub zakresu komórek. Aby odwołanie zewnętrzne używające nazwy zdefiniowanej zmieniało się podczas jego przenoszenia, można zmienić nazwę użytą w odwołaniu zewnętrznym lub zmienić komórki, do których odwołuje się nazwa.

Wygląd odwołania zewnętrznego do innego skoroszytu

Formuły z odwołaniami zewnętrznymi do innych skoroszytów są wyświetlane na dwa sposoby, w zależności od tego, czy skoroszyt źródłowy — czyli skoroszyt dostarczający dane do formuły — jest otwarty, czy zamknięty.

Gdy źródło jest otwarte, odwołanie zewnętrzne składa się z nazwy skoroszytu ujętej w nawiasy kwadratowe ([ ]), nazwy arkusza, wykrzyknika (!) oraz komórek, od których formuła jest zależna. Na przykład poniższa formuła dodaje komórki C10:C25 ze skoroszytu o nazwie Budżet.xls.

Odwołanie zewnętrzne

=SUMA([Budżet.xlsx]Roczny!C10:C25)

Gdy źródło jest zamknięte, odwołanie zewnętrzne zawiera całą ścieżkę.

Odwołanie zewnętrzne

=SUMA('C:\Raporty\[Budżet.xlsx]Roczny'!C10:C25)

Uwaga : Jeśli nazwa innego arkusza lub skoroszytu zawiera znaki niealfabetyczne, tę nazwę (lub ścieżkę) należy ująć w znaki cudzysłowu pojedynczego.

Formuły łączące się z nazwą zdefiniowaną w innym skoroszycie zawierają nazwę skoroszytu, znak wykrzyknika (!) oraz tę zdefiniowaną nazwę. Na przykład poniższa formuła dodaje komórki z zakresu o nazwie Sprzedaż, znajdującego się w skoroszycie o nazwie Budżet.xlsx.

Odwołanie zewnętrzne

=SUMA(Budżet.xlsx!Sprzedaż)

Początek strony

Tworzenie odwołania zewnętrznego między komórkami w różnych skoroszytach

  1. Otwórz skoroszyt, który ma zawierać odwołanie zewnętrzne (skoroszyt docelowy), oraz skoroszyt zawierający dane, które chcesz połączyć (skoroszyt źródłowy).

  2. W skoroszycie źródłowym kliknij przycisk Zapisz Obraz przycisku na pasku narzędzi Szybki dostęp.

  3. Zaznacz komórki, w których chcesz utworzyć odwołanie zewnętrzne.

  4. Wpisz = (znak równości). Aby wykonać obliczenia lub funkcje na wartości odwołania zewnętrznego, wpisz operator lub funkcję poprzedzającą odwołanie zewnętrzne.

  5. Przełącz do skoroszytu źródłowego, a następnie kliknij arkusz zawierający komórki, które chcesz połączyć.

  6. Zaznacz komórki, które chcesz połączyć.

  7. Powróć do skoroszytu docelowego. Zostanie dodane odwołanie do skoroszytu źródłowego i komórek wybranych w poprzednim kroku.

  8. Opcjonalnie w arkuszu docelowym edytuj lub zmień formułę.

  9. Naciśnij klawisze CTRL+SHIFT+ENTER.

Początek strony

Tworzenie odwołania zewnętrznego do zdefiniowanej nazwy w innym skoroszycie

  1. Otwórz skoroszyt, który ma zawierać odwołanie zewnętrzne (skoroszyt docelowy), oraz skoroszyt zawierający dane, które chcesz połączyć (skoroszyt źródłowy).

  2. W skoroszycie źródłowym kliknij przycisk Zapisz Obraz przycisku na pasku narzędzi Szybki dostęp.

  3. Zaznacz komórki, w których chcesz utworzyć odwołanie zewnętrzne.

  4. Wpisz = (znak równości). Aby wykonać obliczenia lub funkcje na wartości odwołania zewnętrznego, wpisz operator lub funkcję poprzedzającą odwołanie zewnętrzne.

  5. Na karcie Widok w grupie Okno kliknij przycisk Przełącz okna, kliknij skoroszyt źródłowy, a następnie kliknij arkusz zawierający komórki, które chcesz połączyć.

    Grupa Okno na karcie Widok

  6. Naciśnij klawisz F3, a następnie zaznacz nazwę, do której łącze ma prowadzić.

Początek strony

Definiowanie nazwy zawierającej odwołanie zewnętrzne do komórek w innym skoroszycie

  1. Otwórz skoroszyt docelowy oraz skoroszyt źródłowy.

  2. W skoroszycie docelowym na karcie Formuły w grupie Nazwy zdefiniowane kliknij przycisk Definiuj nazwę.

    Obraz Wstążki programu Excel

  3. W oknie dialogowym Nowa nazwa w polu Nazwa wpisz nazwę zakresu.

  4. Usuń zawartość pola Odwołuje się do i zatrzymaj kursor w tym polu.

    Jeśli nazwa zawiera formułę, wprowadź tę formułę, a następnie umieść kursor w miejscu, w którym ma się znaleźć odwołanie zewnętrzne. Na przykład wpisz =SUMA(), a następnie umieść kursor między nawiasami.

  5. Na karcie Widok w grupie Okno kliknij przycisk Przełącz okna, kliknij skoroszyt źródłowy, a następnie kliknij arkusz zawierający komórki, które chcesz połączyć.

    Grupa Okno na karcie Widok

  6. Zaznacz komórkę lub zakres komórek, do których łącze ma prowadzić.

  7. W oknie dialogowym Nowa nazwa kliknij przycisk OK.

Początek strony

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×