Tworzenie nowej bazy danych

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W tym artykule omówiono podstawowy proces uruchamiania Access i tworzenia bazy danych, który będzie używany na wszystkich komputerach, nie w sieci Web. Objaśniono, jak utworzyć bazie danych dla komputerów stacjonarnych przy użyciu szablonu i sposobu tworzenia bazy danych od podstaw, tworząc własnych tabel, formularzy, raportów i innych obiektów bazy danych. Objaśniono także technik, które umożliwiają uzyskanie istniejących danych do nowej bazy danych.

W tym artykule

Omówienie

Tworzenie bazy danych przy użyciu szablonu

Tworzenie bazy danych bez użycia szablonu.

Skopiuj dane z innego źródła do tabeli programu Access

Importowanie, dołączanie lub łączenie danych z innego źródła

Dodawanie części aplikacji

Otwieranie istniejącej bazy danych programu Access

Omówienie

Przy pierwszym uruchomieniu programu Access lub zamknij bazę danych bez zamykania programu Access, zostanie wyświetlony widok Microsoft Office Backstage.

Widok Backstage jest to punkt początkowy, z której można utworzyć nową bazę danych, Otwieranie istniejącej bazy danych, wyświetlać proponowane zawartości z Office.com — wszystko za pomocą programu Access można wykonać do pliku bazy danych lub poza bazy danych, a nie w w ramach bazy danych.

Tworzenie bazy danych

Po otwarciu programu Access, widok Backstage Wyświetla kartę Nowy. Karta Nowy udostępnia kilka sposobów, które można utworzyć nową bazę danych:

  • Pusta baza danych    Jeśli chcesz, można rozpocząć od podstaw. To jest dobrym rozwiązaniem, jeśli masz bardzo precyzyjne wymagania lub masz istniejące dane, które chcesz uwzględnić lub dołączyć.

  • Szablon, który jest zainstalowany wraz z programu Access    Korzystanie z szablonu Jeśli rozpoczęła się nowy projekt, a potem ułatwiają rozpoczęcie. Access zawiera kilka szablonów zainstalowanych domyślnie.

  • Szablonu na podstawie Office.com    Oprócz szablonów dołączonych do programu Access można znaleźć wiele więcej szablonów na Office.com. Szablony są dostępne na karcie Nowy, nawet bez Otwórz przeglądarkę sieci.

Dodawanie do bazy danych

Gdy pracujesz w bazie danych, możesz dodać pola, tabel lub części aplikacji.

Części aplikacji są funkcję, która pozwala użyć kilka obiektów bazy danych powiązanych ze sobą tak, jakby były jednym. Na przykład części aplikacji mogą się składać z tabeli i formularza, który jest oparta na tabeli. Możesz dodać tabeli i formularza w tym samym czasie, przy użyciu część aplikacji.

Możesz również utworzyć kwerendy, formularze, raporty, makra — wszystkie obiekty bazy danych, które są używane do pracy z.

Tworzenie bazy danych przy użyciu szablonu

Access zawiera wiele szablonów, których można użyć jako-jest lub jako początkowego punktu. Szablon jest gotowy do użycia bazy danych, która zawiera wszystkich tabel, kwerend, formularzy, makra i raporty potrzebne do wykonywania określonych zadań. Na przykład są szablony, które umożliwia śledzenie problemów, zarządzanie kontaktami lub rejestrowanie wydatków. Niektóre szablony zawierają kilka przykładowych rekordów demonstrujących ich zastosowanie.

Jeśli jeden z tych szablonów odpowiada potrzebom użytkownika, skorzystanie z niego jest najszybszą metodą uruchomienia bazy danych. Jednak jeśli przechowujesz dane w innym programie, który chcesz zaimportować do programu Access mogą zdecydujesz, że warto utworzyć bazę danych bez przy użyciu szablonu. Szablony mają zdefiniowaną strukturę danych, a może wymagać wiele sposobów dostosowanie istniejących danych do struktury szablonu.

  1. Jeśli masz bazę danych, na karcie plik kliknij przycisk Zamknij. Widok Backstage Wyświetla kartę Nowy.

  2. Kilka zestawów szablony są dostępne na karcie Nowy, niektóre z nich są wbudowane w programie Access. Dodatkowe szablony można pobrać z Office.com. W następnej sekcji w tym artykule, aby uzyskać szczegółowe informacje.

  3. Wybierz szablon, którego chcesz użyć.

  4. Program Access proponuje nazwę pliku bazy danych w polu Nazwa pliku — możesz zmienić nazwę pliku, jeśli chcesz. Aby zapisać bazę danych w innym folderze niż wyświetlony poniżej pola Nazwa pliku, kliknij pozycję Obraz przycisku , przejdź do folderu, w którym chcesz zapisać go, a następnie kliknij przycisk OK. Opcjonalnie można utworzyć i łączenie bazy danych w witrynie programu SharePoint.

    Uwaga : Mimo że oba za pomocą programu SharePoint, pulpitu bazy danych połączonych z witryną programu SharePoint nie jest taki sam, jak bazy danych sieci web za pomocą usług programu Access. Aby użyć bazie danych dla komputerów stacjonarnych, musi mieć zainstalowany program Access. Bazy danych sieci web można używać z przeglądarki sieci web.

  5. Kliknij pozycję Utwórz.

    Program Access utworzy bazy danych na podstawie szablonu wybrane, a następnie otwarcie bazy danych. Wiele szablonów zostanie wyświetlony formularz, w którym można rozpocząć wprowadzanie danych. Jeśli szablon zawiera dane przykładowe, można usunąć każdy rekord, klikając selektor rekordu (Pole zacieniowane lub pasek z lewej strony rekordu), a następnie wykonaj następujące czynności:

    Na karcie Narzędzia główne w grupie rekordy kliknij przycisk Usuń. Obraz przycisku

  6. Aby rozpocząć wprowadzanie danych, kliknij pierwszą pustą komórkę w formularzu i zacznij pisać. Umożliwia przeglądanie w poszukiwaniu innych formularzy i raportów, które mają być okienko nawigacji. Niektóre szablony zawierają formularza nawigacji, dzięki czemu można przechodzić między obiektami inną bazę danych.

Aby uzyskać więcej informacji na temat pracy z szablonami zobacz artykuł Używanie szablonu do utworzenia bazy danych programu Access pulpitu.

Początek strony

Tworzenie bazy danych bez użycia szablonu.

Jeśli interesuje Cię nie przy użyciu szablonu, możesz utworzyć bazy danych, tworzenie własnych tabel, formularzy, raportów i innych obiektów bazy danych. W większości przypadków wymaga co najmniej jedną z następujących czynności:

  • Wprowadzanie, wklejania, lub importowanie danych do tabeli, która jest tworzona podczas tworzenia nowej bazy danych, a następnie powtórzenie tego procesu dla nowych tabel tworzonych przy użyciu polecenia Tabela na karcie Tworzenie.

  • Importowanie danych z innych źródeł i tworzenie nowych tabel w procesie.

Tworzenie pustej bazy danych

  1. Na karcie plik kliknij pozycję Nowy, a następnie kliknij przycisk Pusta baza danych.

  2. Wpisz nazwę pliku w polu Nazwa pliku. Aby zmienić lokalizację pliku z domyślną, kliknij przycisk Przeglądaj w poszukiwaniu lokalizacji w celu umieszczenia bazy danych Obraz przycisku (obok pola Nazwa pliku ), przejdź do nowej lokalizacji, a następnie kliknij przycisk OK.

  3. Kliknij pozycję Utwórz.

    Program Access utworzy bazę danych z pustą tabelę o nazwie Tabela1 i otwierając Tabela1 w widoku arkusza danych. Kursor zostanie umieszczony w pierwszą pustą komórkę w kolumnie kliknij pozycję Dodaj.

  4. Zacznij wpisywać dodać dane, lub można wkleić dane z innego źródła w sposób opisany w sekcji, Skopiuj dane z innego źródła do tabeli programu Access.

Wprowadzanie danych w widoku arkusza danych zaprojektowano w sposób bardzo podobny do pracy w arkuszu programu Excel. Struktura tabeli jest tworzona podczas wprowadzania danych. Po dodaniu nowej kolumny w arkuszu danych nowe pole jest zdefiniowane w tabeli. Program Access automatycznie ustawia typ danych każdego pola, na podstawie danych, które można wprowadzić.

Jeśli nie chcesz wprowadzać dane w tabeli Tabela1 w tej chwili, kliknij przycisk Zamknij Obraz przycisku . Jeśli wprowadzono zmiany do tabeli, program Access wyświetli monit o zapisanie zmian. Kliknij przycisk Tak, aby zapisać zmiany, kliknij przycisk nie, aby je odrzucić lub kliknij przycisk Anuluj, aby pozostawić tabelę otwartą.

Porada : Program Access szuka pliku o nazwie Blank.accdb w folderze [zainstaluj dysk]: \Program Files\Microsoft Office\Templates\1033\Access\. Jeśli istnieje, Blank.accdb jest szablonu dla wszystkich nowych pustych baz danych, z wyjątkiem bazy danych sieci web. Każda zawartość, który zawiera jest dziedziczone przez wszystkie nowe, puste bazy danych. To jest dobrym sposobem dystrybuować domyślnych, takich jak numery części lub zastrzeżenia firmy i zasady. Należy pamiętać, że Blank.accdb nie ma wpływu na utworzenie pustej nowych baz danych sieci web.

Ważne : Jeśli Tabela1 zostanie zamknięty bez zapisywania co najmniej raz, program Access usunie całą tabelę, nawet jeśli zostały wprowadzone dane w nim.

Dodawanie tabeli

Możesz dodać nowe tabele z istniejącą bazą danych za pomocą poleceń w grupie tabele na karcie Tworzenie.

Obraz Wstążki programu Access

Tworzenie tabeli w widoku arkusza danych    W widoku arkusza danych można wprowadzać dane bezpośrednio i program Access utworzy w tle strukturę tabeli. Nazwy pól są przypisywane liczbowo (pole1, Pole2 itd.), a program Access automatycznie ustawia typ danych każdego pola, na podstawie wprowadzanych danych.

  1. Na karcie Tworzenie w grupie tabele kliknij tabelę. Obraz przycisku

    Program Access utworzy tabelę i zaznacza pierwszą pustą komórkę w kolumnie kliknij pozycję Dodaj.

  2. Na karcie pola w grupie Dodawanie i usuwanie kliknij typ pola, które chcesz dodać. Jeśli nie widzisz żądanego typu, kliknij pozycję Więcej pól Obraz przycisku .

  3. Program Access wyświetli listę często używanych typów pól. Kliknij odpowiedni typ pola, a program Access doda nowe pole w arkuszu danych na stronie punktu wstawiania.

    Możesz przenieść pola, przeciągając ją. Podczas przeciągania pola w arkuszu danych, jest wyświetlany pionowy pasek wstawiania rozmieszczenie pola.

  4. Aby dodać dane, zacznij pisać w pierwszej pustej komórce lub wklej dane z innego źródła w sposób opisany w sekcji Kopiowanie danych z innego źródła do tabeli programu Access.

  5. Aby zmienić nazwę kolumny (pola), kliknij dwukrotnie nagłówek kolumny, a następnie wpisz nową nazwę.

    Do każdego pola, należy nadać nazwę opisową tak, aby ustalić, co zawiera po wyświetleniu w okienku Lista pól.

  6. Aby przenieść kolumnę, kliknij jej nagłówek, aby zaznaczyć kolumnę, a następnie przeciągnij kolumnę do lokalizacji, która ma. Można również zaznaczyć wiele sąsiadujących kolumn, a następnie przeciągnij je do nowej lokalizacji w całym dokumencie. Aby zaznaczyć wiele sąsiadujących kolumn, kliknij nagłówek kolumny pierwszej kolumny, a następnie, przytrzymując naciśnięty klawisz SHIFT, kliknij nagłówek ostatniej kolumny.

Tworzenie tabeli w widoku projektu    W widoku projektu należy najpierw utworzyć strukturę tabeli. Możesz, a następnie przełącz się do widoku arkusza danych wprowadzanie danych lub wprowadzania danych przy użyciu innej metody, na przykład wklejania lub importowania.

  1. Na karcie Tworzenie w grupie tabele kliknij Projekt tabeli. Obraz przycisku

  2. Dla każdego pola w tabeli wpisz nazwę w kolumnie Nazwa pola, a następnie wybierz typ danych z listy Typ danych.

  3. Jeśli chcesz, możesz wpisz opis dla każdego pola w kolumnie Opis. Opis następnie jest wyświetlany na pasku stanu, gdy kursor znajduje się w tym polu w widoku arkusza danych. Opis jest także używany jako tekst na pasku stanu dla wszystkich formantów w formularzu lub raporcie, które są tworzone, przeciągając pole z okienka Lista pól, a dla wszystkich formantów, które zostały utworzone dla tego pola korzystając z Kreatora formularzy lub Kreatora raportów.

  4. Po dodaniu wszystkich pól Zapisz tabelę:

    • Na karcie Plik kliknij przycisk Zapisz.

  5. Możesz rozpocząć wpisywanie danych w tabeli w dowolnej chwili przez przełączenie do widoku arkusza danych i klikając pierwszą pustą komórkę. Można również wkleić dane z innego źródła, zgodnie z opisem w sekcji, Skopiuj dane z innego źródła do tabeli programu Access.

Ustawianie właściwości pola w widoku projektu    Niezależnie od sposobu utworzenia tabeli jest dobrym pomysłem jest sprawdzić i ustawić właściwości pola. Niektóre właściwości są dostępne w widoku arkusza danych, niektóre właściwości można ustawić tylko w widoku projektu. Aby przełączyć się do widoku projektu, kliknij prawym przyciskiem myszy tabelę w okienku nawigacji, a następnie kliknij polecenie Widok projektu. Aby wyświetlić właściwości pola, kliknij pole w siatce projektu. Właściwości są wyświetlane poniżej siatki projektu, w obszarze Właściwości pola.

Aby zobaczyć opis każdej właściwości pola, kliknij pozycję właściwości i przeczytaj opis w polu obok listy właściwości w obszarze Właściwości pola. Więcej informacji można uzyskać, klikając przycisk Pomoc.

W poniższej tabeli opisano niektóre z właściwości pola, które są często dostosowywane.

Właściwość

Opis

Rozmiar pola

W przypadku pól tekstowych ta właściwość określa maksymalną liczbę znaków, które mogą być przechowywane w tym polu. Wartość maksymalna to 255. Dla pól typu Liczba ta właściwość określa typ Liczba, która będzie przechowywana (liczba całkowita długa podwójny, i tak dalej). Najbardziej efektywne przechowywanie danych zaleca się przydzielenie co najmniej wielkość odstępu uważasz, że potrzebujesz danych. Możesz dostosować wartość do góry później w razie potrzeby.

Format

Ta właściwość określa sposób wyświetlania danych. Nie dotyczy rzeczywistych danych, jak są one przechowywane w tym polu. Można wybrać wstępnie zdefiniowany format lub wprowadź format niestandardowy.

Maska wprowadzania

Ta właściwość służy do określania wzorzec dla wszystkich danych, które ma zostać wprowadzony w tym polu. Dzięki temu, upewnij się, że wszystkie dane zostały wprowadzone poprawnie i czy zawiera wymaganą liczbę znaków. Aby uzyskać pomoc dotyczącą tworzenia maski wprowadzania danych kliknij przycisk Przycisk Konstruktor po prawej stronie pola właściwości.

Wartość domyślna

Użyj tej właściwości, aby określić wartość domyślna, który będzie wyświetlany w tym polu zostanie dodany nowy rekord za każdym razem. Na przykład jeśli masz pola Data/Godzina, w którym zawsze chcesz zarejestrować datę rekord został dodany, jako wartość domyślną można wprowadzić "Date()" (bez cudzysłowów).

Wymagane

Ta właściwość określa, czy wartość jest wymagane w tym polu. Jeśli ta właściwość jest ustawiona na Tak, Access nie umożliwia dodawanie nowego rekordu, o ile nie zawierają żadnej wartości dla tego pola.

Początek strony

Skopiuj dane z innego źródła do tabeli programu Access

Jeśli dane są aktualnie zapisane w innym programie, na przykład Excel, można skopiować i wkleić go w tabeli programu Access. Zazwyczaj to działa najlepiej, jeśli dane są już podzielone na kolumny, jak w arkuszu programu Excel. Jeśli dane znajdują się w edytorze tekstów, najlepiej jest rozdzielić kolumny danych przy użyciu karty lub przekonwertować dane do tabeli w edytorze tekstów, przed skopiowaniem danych. Jeśli dane wymagają edycji lub zmian (na przykład, które będą rozdzielone imion Imię i nazwisko), można to zrobić przed skopiowaniem danych, zwłaszcza jeśli nie znasz programu Access.

Podczas wklejania danych do pustej tabeli, program Access ustawia typ danych każdego pola według rodzaju danych nim znajdzie. Na przykład jeśli pole zawiera nic, ale wartości dat, program Access zastosuje danych daty/godziny dla tego pola Typ. Jeśli pole zawiera tylko wyrazy "tak" i "nie", program Access zastosuje tak/nie danych wpisz w polu.

Program Access nadaje nazwy pola w zależności od znajdzie w pierwszym wierszu wklejone dane. Jeśli pierwszy wiersz wklejanych danych jest podobny do następnych wierszach, Access określa, czy pierwszy wiersz stanowi część danych, a przypisuje pola nazwy ogólne (F1, F2 itd.). Jeśli pierwszy wiersz wklejanych danych nie jest podobny do następnych wierszy, Access określa, że pierwszy wiersz zawiera nazwy pól. Program Access odpowiednio nazwy pól i nie ma pierwszego wiersza w danych.

Jeśli program Access przypisuje pole rodzajowy nazw, należy zmienić nazwę pola tak szybko, jak to możliwe, aby uniknąć zamieszania. Wykonaj poniższe kroki:

  1. Naciśnij klawisze CTRL + S, aby zapisać tabelę.

  2. W widoku arkusza danych kliknij dwukrotnie nagłówek każdej kolumny, a następnie wpisz nazwę opisową pola dla każdej kolumny.

  3. Ponownie zapisz tabelę.

Uwaga : Przełączenie do widoku projektu i edytując nazwy pól, zmienić nazwę pola. Aby przełączyć się do widoku projektu, kliknij prawym przyciskiem myszy tabelę w okienku nawigacji, a następnie kliknij polecenie Widok projektu. Aby wrócić do widoku arkusza danych, kliknij dwukrotnie tabelę w okienku nawigacji.

Początek strony

Importowanie, dołączanie lub łączenie danych z innego źródła

Może być danych, który jest przechowywany w innym programie, a chcesz zaimportować te dane do nowej tabeli lub dołączyć do istniejącej tabeli w programie Access. Mogą pracować z osobami, które przechowują swoje dane w innych programach i chcesz pracować z nimi w programie Access za pomocą łączenia z nim. W obu przypadkach programu Access ułatwia pracę z danymi z innych źródeł. Dane można zaimportować z arkusza programu Excel, z tabeli w innej bazie danych programu Access, z listy programu SharePoint lub z różnych innych źródeł. Proces, którego używasz różni się w zależności od źródła, ale poniższej procedury spowoduje rozpoczęcie pracy.

  1. W programie Access na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij polecenie dla typu pliku, który importujesz.

    Grupa Importowanie i łączenie na karcie Dane zewnętrzne

    Na przykład Jeśli importujesz dane z arkusza programu Excel, kliknij pozycję Excel. Jeśli nie widzisz potrzebnego typu programu, kliknij przycisk więcej.

    Uwaga : Jeśli nie możesz znaleźć odpowiedniego typu formatu w grupie Importowanie i łączenie, może być konieczne uruchom program, w którym został pierwotnie utworzony danych i zapisywanie danych w typowych formacie pliku (na przykład rozdzielany plik tekstowy ) przed można Impo za pomocą tego oprogramowania t te dane do programu Access.

  2. W oknie dialogowym Pobieranie danych zewnętrznych kliknij przycisk Przeglądaj, Aby znaleźć plik źródła danych, lub wpisz pełną ścieżkę pliku danych źródłowych w polu Nazwa pliku.

  3. Kliknij odpowiednią opcję (wszystkie programy umożliwiają importowanie i niektóre umożliwiają dołączanie lub łączenie) w obszarze Określ sposób i miejsce przechowywania danych w bieżącej bazie danych. Można utworzyć nową tabelę z importowanymi danymi lub (w przypadku niektórych programów) można dołączyć dane do istniejącej tabeli lub utworzyć tabelę połączoną, która obsługuje łącze do danych w programie źródłowym.

  4. Jeśli zostanie uruchomiony Kreator, postępuj zgodnie z instrukcjami na kilku następnych stronach kreatora. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

    Jeśli importujesz obiektów lub łączenie tabel z bazy danych programu Access, zostanie wyświetlone okno dialogowe Importowanie obiektów lub Połącz tabele. Wybierz elementy, a następnie kliknij przycisk OK.

    Proces dokładnie zależy od tego, czy chcesz zaimportować, dołączanie lub łączenie danych.

  5. Program Access wyświetli monit o tego, czy chcesz zapisywanie szczegółów operacji importu ukończoną. Jeśli uważasz, że będziesz wykonywać w przyszłości tej samej operacji importu, kliknij przycisk Zapisz kroki importowania, a następnie wprowadź szczegółowe informacje. Następnie można łatwo powtórzyć operację w przyszłości, klikając pozycję Zapisane operacje importowania Obraz przycisku w grupie Importowanie i łączenie na karcie Dane zewnętrzne. Jeśli nie chcesz zapisywać szczegółów operacji, kliknij przycisk Zamknij.

Jeśli wybierzesz Importowanie tabeli programu Access importuje dane do nowej tabeli, a następnie wyświetli tabeli w grupie tabele w okienku nawigacji. Jeśli zdecydujesz się dołączanie danych do istniejącej tabeli, dane są dodawane do tej tabeli. Jeśli zdecydujesz się łącza do danych, program Access utworzy tabelę połączoną w grupie tabel w okienku nawigacji.

Początek strony

Dodawanie części aplikacji

Części aplikacji umożliwia dodawanie funkcji do istniejącej bazy danych. Części aplikacji może być tak proste jak jednej tabeli lub mogą zawierać kilka powiązanych obiekty, takie jak tabelę i formularz związany.

Na przykład część aplikacji komentarzy składa się z tabeli z polem typu Autonumerowanie identyfikator, pole daty i pola typu Nota. Można ją dodać do dowolnej bazy danych i używać go jako-jest lub z minimalnymi dostosowywania.

  1. Otwórz bazę danych, do którego chcesz dodać część aplikacji.

  2. Kliknij kartę Tworzenie.

  3. W grupie szablonów kliknij Części aplikacji. Zostanie wyświetlona lista dostępnych części.

  4. Kliknij pozycję część aplikacji, którą chcesz dodać.

Początek strony

Otwieranie istniejącej bazy danych programu Access

  1. Na karcie Plik kliknij pozycję Otwórz.

  2. W oknie dialogowym Otwieranie przejdź do bazy danych, którą chcesz otworzyć.

  3. Wykonaj jedną z następujących czynności:

    • Kliknij dwukrotnie bazę danych, aby otworzyć go w trybie domyślnym, określonym w oknie dialogowym Opcje programu Access lub trybu, w którym została ustawiona przez zasady administracyjne.

    • Kliknij przycisk Otwórz do otwierania bazy danych współużytkowania w środowisku wielu użytkowników, tak aby inni użytkownicy mogli czytać i zapisu w bazie danych.

    • Kliknij strzałkę obok przycisku Otwórz, a następnie kliknij przycisk Otwórz tylko do odczytu, aby otworzyć bazę danych, aby dostęp tylko do odczytu, tak aby można wyświetlić, ale nie można go edytować. Inni użytkownicy nadal mogą odczytu i zapisu do bazy danych.

    • Kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz z wyłącznością do bazy danych przy użyciu wyłącznego dostępu. Jeśli masz bazy danych Otwórz z wyłącznością dostępu wszystkich osób, które próbuje Otwórz bazę danych, otrzymuje komunikat "plik już w użyciu".

    • Kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz z wyłącznością tylko do odczytu, aby otworzyć bazę danych, aby dostęp tylko do odczytu. Inni użytkownicy mogą otworzyć bazę danych, ale są ograniczone do trybu tylko do odczytu.

Uwaga : Można bezpośrednio Otwórz plik danych w formacie pliku zewnętrznego, na przykład dBASE, Microsoft Exchange lub Excel. Można również bezpośrednio otwierać dowolny źródło danych ODBC, takich jak Microsoft SQL Server. Program Access automatycznie tworzy nową bazę danych programu Access w tym samym folderze co plik danych i dodaje łącza do każdej tabeli w zewnętrznej bazie danych.

Porady

  • Aby otworzyć jeden z ostatnio otwieranych baz danych, na karcie plik kliknij pozycję ostatnie, a następnie kliknij nazwę pliku dla tej bazy danych. Program Access otworzy bazę danych przy użyciu tych samych ustawień opcji, które znajdował się podczas ostatniego, który został otwarty. Jeśli nie jest wyświetlany na liście ostatnio używanych plików, na karcie plik kliknij pozycję Opcje. W oknie dialogowym Opcje programu Access kliknij pozycję Ustawienia klienta. W obszarze Wyświetlanie wprowadź liczbę dokumentów będzie wyświetlana na liście ostatnio używanych dokumentów, maksymalnie 50.

    Można również wyświetlać ostatnio używanych baz danych w widoku pasek Backstage nawigacji dostępu kliknij dwa: 1) na karcie plik, (2) ostatnio używane bazy danych, którą chcesz otworzyć. U dołu karty ostatnie zaznacz pole wyboru szybko uzyskać dostęp do tej liczby ostatnio używanych baz danych, a następnie Dostosuj liczba baz danych, aby wyświetlić.

  • Podczas otwierania bazy danych, klikając polecenie Otwórz kartę plik, możesz wyświetlić listę skrótów do baz danych, otwierane wcześniej, klikając pozycję Moje ostatnie dokumenty w oknie dialogowym Otwieranie.

Początek strony

Co chcesz zrobić?

Poznaj strona wprowadzenie do programu Microsoft Office Access

Tworzenie bazy danych przy użyciu szablonu

Tworzenie bazy danych bez użycia szablonu.

Skopiuj dane z innego źródła do tabeli programu Access

Importowanie, dołączanie lub łączenie danych z innego źródła

Otwieranie istniejącej bazy danych programu Access

Tworzenie niestandardowego pustego szablonu

Poznaj strona wprowadzenie do programu Microsoft Office Access

Przy pierwszym uruchomieniu programu Access lub zamknij bazę danych bez zamykania programu Access, zostanie wyświetlona strona Wprowadzenie do programu Microsoft Office Access.

Strona Wprowadzenie do programu Microsoft Office Access

Ta strona jest punkt początkowy, z której można utworzyć nową bazę danych, Otwieranie istniejącej bazy danych lub wyświetlanie danych programu Microsoft Office Online.

Tworzenie bazy danych przy użyciu szablonu

Program Access oferuje wiele różnych szablonów, których można użyć, aby przyspieszyć proces tworzenia bazy danych. Szablon jest gotowy do użycia bazę danych zawierającą wszystkich tabel, kwerend, formularzy i raportów potrzebne do wykonywania określonych zadań. Na przykład są szablony, które umożliwia śledzenie problemów, zarządzanie kontaktami lub rejestrowanie wydatków. Niektóre szablony zawierają kilka przykładowych rekordów demonstrujących ich zastosowanie. Szablony baz danych może służyć jako są one lub dostosowywać je do potrzeb.

Jeśli jeden z tych szablonów odpowiada potrzebom użytkownika, skorzystanie z niego jest najszybszą metodą uruchomienia bazy danych. Jednak jeśli przechowujesz dane w innym programie, który chcesz zaimportować do programu Access mogą zdecydujesz, że warto utworzyć bazę danych bez przy użyciu szablonu. Szablony mają zdefiniowaną strukturę danych, a może wymagać wiele sposobów dostosowanie istniejących danych do struktury szablonu.

  1. Jeśli masz bazę danych, kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Zamknij bazę danych Obraz przycisku , aby wyświetlić stronę Wprowadzenie do programu Microsoft Office Access.

  2. Kilka szablonów witryny są wyświetlane na środku strony Wprowadzenie do programu Microsoft Office Access, a kolejne staną się dostępne po kliknięciu łącza w okienku Kategorie szablonów. Dodatkowe szablony można pobrać z witryny Office Online w sieci Web. W następnej sekcji w tym artykule, aby uzyskać szczegółowe informacje.

  3. Kliknij szablon, którego chcesz użyć.

  4. Program Access proponuje nazwę pliku bazy danych w polu Nazwa pliku — możesz zmienić nazwę pliku, jeśli chcesz. Aby zapisać bazę danych w innym folderze niż wyświetlony poniżej pola Nazwa pliku, kliknij pozycję Obraz przycisku , przejdź do folderu, w którym chcesz zapisać go, a następnie kliknij przycisk OK. Opcjonalnie można utworzyć i łączenie bazy danych w witrynie programu SharePoint.

  5. Kliknij przycisk Utwórz (lub pobrać, szablonu witryny Office Online).

    Program Access utworzy lub pobierze bazę danych i jego otwarciu. Zostanie wyświetlony formularz, w którym można rozpocząć wprowadzanie danych. Jeśli szablon zawiera dane przykładowe, można usunąć każdy rekord, klikając selektor rekordu (Pole zacieniowane lub pasek z lewej strony rekordu), a następnie wykonaj następujące czynności:

    Na karcie Narzędzia główne w grupie rekordy kliknij przycisk Usuń. Obraz przycisku

  6. Aby rozpocząć wprowadzanie danych, kliknij pierwszą pustą komórkę w formularzu i zacznij pisać. Przeglądaj w poszukiwaniu innych formularzy i raportów, które mają być za pomocą okienka nawigacji.

Pobieranie szablonu z witryny Office Online

Jeśli nie możesz znaleźć szablonu, który odpowiada Twoim potrzebom na stronie Wprowadzenie do programu Microsoft Office Access i są połączone z Internetem, można skorzystać z witryny Office Online w sieci Web, większy wybór.

  1. Na stronie Wprowadzenie do programu Microsoft Office Access w obszarze więcej w witrynie Office Online, kliknij pozycję Szablony.

    Strona główna szablonów w witrynie Office Online jest wyświetlany w oknie przeglądarki.

  2. Użyj nawigacji w witrynie Office Online i narzędzia wyszukiwania, aby znaleźć odpowiedni szablon programu Access, którego chcesz użyć, a następnie postępuj zgodnie z instrukcjami, aby ją pobrać. Po pobraniu szablonu pliku bazy danych jest zostało pobrane na komputer i otwarty w nowym wystąpieniu programu Access. W większości przypadków szablon jest przeznaczony do otworzyć formularz wprowadzania danych, tak aby można rozpocząć wprowadzanie danych natychmiast.

Aby uzyskać więcej informacji na temat pracy z szablonami zobacz artykuł przewodnika do szablonów programu Access 2007.

Początek strony

Tworzenie bazy danych bez użycia szablonu.

Jeśli interesuje Cię nie przy użyciu szablonu, możesz utworzyć bazy danych, tworzenie własnych tabel, formularzy, raportów i innych obiektów bazy danych. W większości przypadków to zazwyczaj obejmuje jedną lub obie z następujących czynności:

  • Wprowadzanie, wklejania, lub importowanie danych do tabeli, która jest tworzona podczas tworzenia nowej bazy danych, a następnie powtórzenie tego procesu dla nowych tabel tworzonych przy użyciu polecenia Tabela na karcie Tworzenie.

  • Importowanie danych z innych źródeł i tworzenie nowych tabel w procesie.

Tworzenie pustej bazy danych
  1. Na stronie Wprowadzenie do programu Microsoft Office Access w obszarze Nowa pusta baza danych, kliknij pozycję Pusta baza danych.

    Przycisk Pusta baza danych

  2. W okienku Pusta baza danych wpisz nazwę pliku w polu Nazwa pliku. Jeśli nie podasz rozszerzenia nazwy pliku, dostęp dodaje ją. Aby zmienić lokalizację pliku z domyślną, kliknij przycisk Przeglądaj w poszukiwaniu lokalizacji w celu umieszczenia bazy danych Obraz przycisku (obok pola Nazwa pliku ), przejdź do nowej lokalizacji, a następnie kliknij przycisk OK.

  3. Kliknij pozycję Utwórz.

    Program Access utworzy bazę danych z pustą tabelę o nazwie Tabela1 i otwierając Tabela1 w widoku arkusza danych. Kursor zostanie umieszczony w pierwszą pustą komórkę w kolumnie Dodaj nowe pole.

  4. Zacznij wpisywać dodać dane, lub można wkleić dane z innego źródła w sposób opisany w sekcji, Skopiuj dane z innego źródła do tabeli programu Access.

Wprowadzanie informacji w widoku arkusza danych zaprojektowano w sposób bardzo podobny do pracy w arkuszu Microsoft Office Excel 2007. Struktura tabeli jest tworzona podczas wprowadzania danych — dowolnym momencie dodać nową kolumnę do tabeli, jest definiowane nowe pole. Access automatycznie ustawia typ danych każdego pola, na podstawie wprowadzanych danych.

Jeśli nie chcesz wprowadzić informacje w Tabela1 w tej chwili, kliknij przycisk Zamknij Obraz przycisku . Jeśli wprowadzono zmiany w tabeli, program Access wyświetli monit o zapisanie zmian w tabeli. Kliknij przycisk Tak, aby zapisać zmiany, kliknij przycisk nie, aby je odrzucić lub kliknij przycisk Anuluj, aby pozostawić tabelę otwartą.

Ważne : Jeśli Tabela1 zostanie zamknięty bez zapisywania co najmniej raz, program Access usunie całą tabelę, nawet jeśli zostały wprowadzone dane w nim.

Dodawanie tabeli

Możesz dodać nowe tabele z istniejącą bazą danych za pomocą poleceń w grupie tabele na karcie Tworzenie.

Obraz wstążki programu Access

Tworzenie tabeli w widoku arkusza danych    W widoku arkusza danych można wprowadzać dane bezpośrednio i program Access utworzy w tle strukturę tabeli. Nazwy pól są przypisywane liczbowo (pole1, Pole2 itd.), a program Access automatycznie ustawia typ danych każdego pola, na podstawie wprowadzanych danych.

  1. Na karcie Tworzenie w grupie tabele kliknij tabelę. Obraz przycisku

    Program Access utworzy tabelę i zaznacza pierwszą pustą komórkę w kolumnie Dodaj nowe pole.

    Uwaga : Jeśli nie widzisz z kolumną Dodaj nowe pole mogą znajdować się w widoku projektu, a nie widok arkusza danych. Aby przełączyć się do widoku arkusza danych, kliknij dwukrotnie tabelę w okienku nawigacji. Program Access wyświetli monit o zapisanie nowej tabeli i następnie przełączy się do widoku arkusza danych.

  2. Na karcie Arkusz danych w grupie pola i kolumny kliknij Nowe pole. Obraz przycisku

    Program Access wyświetli okienko Szablony pól, które zawiera listę często używanych typów pól. Jeśli kliknij dwukrotnie lub przeciągnij jeden z tych pól do arkusza danych, program Access doda pole o tej nazwie i ustawia jego właściwości na wartości odpowiednie dla tego typu pola. Właściwości można zmienić później, jeśli chcesz. Jeśli przeciągniesz pole, przeciągnij go na ekranie obszar arkusza danych, który zawiera dane. Jest wyświetlany pionowy pasek wstawiania pokazujący, gdzie pole zostanie umieszczone.

  3. Aby dodać dane, zacznij pisać w pierwszej pustej komórce lub wklej dane z innego źródła w sposób opisany w sekcji Kopiowanie danych z innego źródła do tabeli programu Access.

  4. Aby zmienić nazwę kolumny (pola), kliknij dwukrotnie nagłówek kolumny, a następnie wpisz nową nazwę.

    Zaleca się nadać nazwę opisową do każdego pola jest tak, aby ustalić, co zawiera po wyświetleniu w okienku Lista pól.

  5. Aby przenieść kolumnę, kliknij jej nagłówek, aby zaznaczyć kolumnę, a następnie przeciągnij kolumnę do lokalizacji, które mają.

    Można również zaznaczyć wiele sąsiadujących kolumn, a następnie przeciągnij je do nowej lokalizacji w całym dokumencie. Aby zaznaczyć wiele sąsiadujących kolumn, kliknij nagłówek kolumny pierwszej kolumny, a następnie, przytrzymując naciśnięty klawisz SHIFT, kliknij nagłówek ostatniej kolumny.

Tworzenie tabeli w widoku projektu    W widoku projektu należy najpierw utworzyć strukturę nowej tabeli. Możesz, a następnie przełącz się do widoku arkusza danych wprowadzanie danych lub wprowadzania danych przy użyciu innej metody, na przykład wklejania lub importowania.

  1. Na karcie Tworzenie w grupie tabele kliknij Projekt tabeli. Obraz przycisku

  2. Dla każdego pola w tabeli wpisz nazwę w kolumnie Nazwa pola, a następnie wybierz typ danych z listy Typ danych.

    Uwaga : Jeśli nie widzisz kolumny Nazwa pola i Typ danych, może być w widoku arkusza danych, a nie widok projektu. Aby przełączyć się do widoku projektu, kliknij prawym przyciskiem myszy tabelę w okienku nawigacji, a następnie kliknij Widok projektu Obraz przycisku . Access zostanie wyświetlony monit o podanie nazwy nowej tabeli, a następnie przełączy się do widoku projektu.

  3. Jeśli chcesz, możesz wpisz opis dla każdego pola w kolumnie Opis. Opis następnie jest wyświetlany na pasku stanu, gdy kursor znajduje się w tym polu w widoku arkusza danych. Opis jest także używany jako tekst na pasku stanu dla wszystkich formantów w formularzu lub raporcie, które są tworzone, przeciągając pole z okienka Lista pól, a dla wszystkich formantów, które zostały utworzone dla tego pola korzystając z Kreatora formularzy lub Kreatora raportów.

  4. Po dodaniu wszystkich pól Zapisz tabelę:

    • Kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office i kliknij przycisk Zapisz lub naciśnij klawisze CTRL + S Obraz przycisku .

  5. Możesz rozpocząć wpisywanie danych w tabeli w dowolnej chwili przez przełączenie do widoku arkusza danych i klikając pierwszą pustą komórkę. Można również wkleić dane z innego źródła, zgodnie z opisem w sekcji, Skopiuj dane z innego źródła do tabeli programu Access.

Tworzenie tabeli przy użyciu szablonu    Program Access zawiera szablony do często używanych typów tabel. Po kliknięciu myszą pojedynczy można tworzenie struktury tabeli wykonania z polami już skonfigurowana i gotowa do użycia. W razie potrzeby można dodać lub usunąć pola, tak aby tabeli do potrzeb.

  1. Na karcie Tworzenie w grupie Tabele kliknij pozycję Szablony tabel, a następnie wybierz jeden z dostępnych szablonów z listy.

  2. Aby dodać dane, zacznij pisać w pierwszej pustej komórce lub wklej dane z innego źródła w sposób opisany w sekcji, Skopiuj dane z innego źródła do tabeli programu Access.

    • Aby usunąć kolumnę   

      1. Kliknij prawym przyciskiem myszy nagłówek kolumny, a następnie kliknij pozycję Usuń kolumnę Obraz przycisku .

    • Aby dodać nową kolumnę   

      1. Na karcie Arkusz danych w grupie pola i kolumny kliknij Nowe pole. Obraz przycisku

      2. Program Access wyświetli okienko Szablony pól, które zawiera listę często używanych typów pól. Jeśli kliknij dwukrotnie lub przeciągnij jeden z tych pól do arkusza danych, program Access doda pole o tej nazwie i ustawia jego właściwości na wartości odpowiednie dla tego typu pola. Właściwości można zmienić później, jeśli chcesz. Jeśli przeciągniesz pole, przeciągnij go na ekranie obszar arkusza danych, który zawiera dane. Jest wyświetlany pionowy pasek wstawiania pokazujący, gdzie pole zostanie umieszczone.

  3. Zapisz tabelę:

    • Kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office i kliknij przycisk Zapisz lub naciśnij klawisze CTRL + S Obraz przycisku .

Ustawianie właściwości pola w widoku projektu    Niezależnie od sposobu utworzenia tabeli jest dobrym pomysłem jest sprawdzić i ustawić właściwości pola. To jest możliwe tylko w widoku projektu. Aby przełączyć się do widoku projektu, kliknij prawym przyciskiem myszy tabelę w okienku nawigacji, a następnie kliknij polecenie Widok projektu. Aby wyświetlić właściwości pola, kliknij pole w siatce projektu. Właściwości są wyświetlane poniżej siatki projektu, w obszarze Właściwości pola.

Aby zobaczyć opis każdej właściwości pola, kliknij pozycję właściwości i przeczytaj opis w polu obok listy właściwości w obszarze Właściwości pola. Bardziej szczegółowe informacje można uzyskać, naciskając klawisz F1.

W poniższej tabeli opisano niektóre z właściwości pola, które są często dostosowywane.

Właściwość

Opis

Rozmiar pola

W przypadku pól tekstowych ta właściwość określa maksymalną liczbę znaków, które mogą być przechowywane w tym polu. Wartość maksymalna to 255. Dla pól typu Liczba ta właściwość określa typ Liczba, która będzie przechowywana (liczba całkowita długa podwójny, i tak dalej). Najbardziej efektywne przechowywanie danych zaleca się przydzielenie co najmniej wielkość odstępu uważasz, że potrzebujesz danych. Możesz dostosować wartość do góry później w razie potrzeby.

Format

Ta właściwość określa sposób wyświetlania danych. Nie dotyczy rzeczywistych danych, jak są one przechowywane w tym polu. Można wybrać wstępnie zdefiniowany format lub wprowadź format niestandardowy.

Maska wprowadzania

Ta właściwość służy do określania wzorzec dla wszystkich danych, które ma zostać wprowadzony w tym polu. Dzięki temu, upewnij się, że wszystkie dane zostały wprowadzone poprawnie i czy zawiera wymaganą liczbę znaków. Aby uzyskać pomoc dotyczącą tworzenia maski wprowadzania danych kliknij przycisk Przycisk Konstruktor po prawej stronie pola właściwości.

Wartość domyślna

Użyj tej właściwości, aby określić wartość domyślna, który będzie wyświetlany w tym polu zostanie dodany nowy rekord za każdym razem. Na przykład jeśli masz pola Data/Godzina, w którym zawsze chcesz zarejestrować datę rekord został dodany, jako wartość domyślną można wprowadzić "Date()" (bez cudzysłowów).

Wymagane

Ta właściwość określa, czy wartość jest wymagane w tym polu. Jeśli ta właściwość jest ustawiona na Tak, Access nie umożliwia dodawanie nowego rekordu, o ile nie zawierają żadnej wartości dla tego pola.

Początek strony

Skopiuj dane z innego źródła do tabeli programu Access

Jeśli dane są aktualnie zapisane w innym programie, na przykład Office Excel 2007 można skopiować i wkleić go w tabeli programu Access. Zazwyczaj to działa najlepiej, jeśli dane są już podzielone na kolumny, jak w arkuszu programu Excel. Jeśli dane znajdują się w edytorze tekstów, najlepiej jest rozdzielić kolumny danych przy użyciu karty lub przekonwertować dane do tabeli w edytorze tekstów, przed skopiowaniem danych. Jeśli dane wymagają edycji lub zmian (na przykład, które będą rozdzielone imion Imię i nazwisko), można to zrobić przed skopiowaniem danych, szczególnie jeśli nie znasz programu Access.

Podczas wklejania danych do pustej tabeli, program Access ustawia typ danych każdego pola według rodzaju danych nim znajdzie. Na przykład jeśli pole zawiera nic, ale wartości dat, program Access zastosuje danych daty/godziny dla tego pola Typ. Jeśli pole zawiera tylko wyrazy "tak" i "nie", program Access zastosuje tak/nie danych wpisz w polu.

Program Access nadaje nazwy pola w zależności od znajdzie w pierwszym wierszu wklejone dane. Jeśli pierwszy wiersz wklejanych danych jest podobny do następnych wierszach, Access określa, czy pierwszy wiersz stanowi część danych, a przypisuje pola nazwy ogólne (F1, F2 itd.). Jeśli pierwszy wiersz wklejanych danych nie jest podobny do następnych wierszy, Access określa, że pierwszy wiersz zawiera nazwy pól. Program Access odpowiednio nazwy pól i nie ma pierwszego wiersza w danych.

Jeśli program Access przypisuje pole rodzajowy nazw, należy zmienić nazwę pola tak szybko, jak to możliwe, aby uniknąć zamieszania. Wykonaj poniższe kroki:

  1. Zapisz tabelę.

    • Kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office i kliknij przycisk Zapisz lub naciśnij klawisze CTRL + S Obraz przycisku .

  2. W widoku arkusza danych kliknij dwukrotnie nagłówek każdej kolumny, a następnie wpisz odpowiednią nazwę pola dla każdej kolumny. To może wyglądać jak pisanie na danych, ale wiersz nagłówków kolumn zawiera nazwy pól, a nie dane.

  3. Ponownie zapisz tabelę.

Uwaga : Przełączenie do widoku projektu i edytując nazwy pól, zmienić nazwę pola. Aby przełączyć się do widoku projektu, kliknij prawym przyciskiem myszy tabelę w okienku nawigacji, a następnie kliknij polecenie Widok projektu. Aby wrócić do widoku arkusza danych, kliknij dwukrotnie tabelę w okienku nawigacji.

Początek strony

Importowanie, dołączanie lub łączenie danych z innego źródła

Może być danych, który jest przechowywany w innym programie, a potem zaimportować te dane do nowej tabeli lub dołączyć do istniejącej tabeli w programie Access. Mogą pracować z osobami, które przechowują swoje dane w innych programach i chcesz pracować z nimi w programie Access za pomocą łączenia z nim. W obu przypadkach programu Access ułatwia pracę z danymi z innych źródeł. Dane można zaimportować z arkusza programu Excel, z tabeli w innej bazie danych programu Access, z listy programu SharePoint lub z różnych innych źródeł. Proces, którego używasz różni się w zależności od źródła, ale poniższej procedury spowoduje rozpoczęcie pracy.

  1. W programie Access na karcie Dane zewnętrzne w grupie Importowanie kliknij polecenie dla typu pliku, który importujesz.

    Obraz wstążki programu Access

    Na przykład Jeśli importujesz dane z arkusza programu Excel, kliknij pozycję Excel. Jeśli nie widzisz potrzebnego typu programu, kliknij przycisk więcej.

    Uwaga : Jeśli nie możesz znaleźć odpowiedniego typu formatu w grupie Importowanie, może być konieczne uruchom program, w którym został pierwotnie utworzony dane, a następnie użyj tego programu, aby zapisać dane w pliku typowych formatowanie (na przykład rozdzielany plik tekstowy ), aby można było zaimportować dane do programu Access.

  2. W oknie dialogowym Pobieranie danych zewnętrznych kliknij przycisk Przeglądaj, Aby znaleźć plik źródła danych, lub wpisz pełną ścieżkę pliku danych źródłowych w polu Nazwa pliku.

  3. Kliknij odpowiednią opcję (wszystkie programy umożliwiają importowanie i niektóre umożliwia dołączanie lub łączenie) w obszarze Określ sposób i miejsce przechowywania danych w bieżącej bazie danych. Można utworzyć nową tabelę z importowanymi danymi lub (w przypadku niektórych programów) można dołączyć dane do istniejącej tabeli lub utworzyć tabelę połączoną, która obsługuje łącze do danych w programie źródłowym.

  4. Jeśli zostanie uruchomiony Kreator, postępuj zgodnie z instrukcjami na kilku następnych stronach kreatora. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

    Jeśli importujesz obiektów lub łączenie tabel z bazy danych programu Access, zostanie wyświetlone okno dialogowe Importowanie obiektów lub Połącz tabele. Wybierz elementy, a następnie kliknij przycisk OK.

    Proces dokładnie zależy od tego, czy chcesz zaimportować, dołączanie lub łączenie danych.

  5. Program Access wyświetli monit o tego, czy chcesz zapisywanie szczegółów operacji importu ukończoną. Jeśli uważasz, że będziesz wykonywać w przyszłości tej samej operacji importu, kliknij przycisk Zapisz kroki importowania, a następnie wprowadź szczegółowe informacje. Następnie można łatwo powtórzyć operację później, klikając pozycję Zapisane operacje importowania Obraz przycisku w grupie Importowanie na karcie Dane zewnętrzne. Jeśli nie chcesz zapisywać szczegółów operacji, kliknij przycisk Zamknij.

Jeśli wybierzesz Importowanie tabeli programu Access importuje dane do nowej tabeli, a następnie wyświetli tabeli w grupie tabele w okienku nawigacji. Jeśli zdecydujesz się dołączanie danych do istniejącej tabeli, dane są dodawane do tej tabeli. Jeśli zdecydujesz się łącza do danych, program Access utworzy tabelę połączoną w grupie tabel w okienku nawigacji.

Początek strony

Otwieranie istniejącej bazy danych programu Access
  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Otwórz.

  2. W oknie dialogowym Otwieranie przejdź do bazy danych, którą chcesz otworzyć.

  3. Wykonaj jedną z następujących czynności:

    • Kliknij dwukrotnie bazę danych, aby otworzyć go w trybie domyślnym, określonym w oknie dialogowym Opcje programu Access lub trybu, w którym została ustawiona przez zasady administracyjne.

    • Kliknij przycisk Otwórz, aby otworzyć bazę danych do udostępnionego w środowisku wielu użytkowników, tak aby inni użytkownicy mogli czytać i zapisu w bazie danych.

    • Kliknij strzałkę obok przycisku Otwórz, a następnie kliknij przycisk Otwórz tylko do odczytu, aby otworzyć bazę danych, aby dostęp tylko do odczytu, tak aby można wyświetlić, ale nie można go edytować. Inni użytkownicy nadal mogą odczytu i zapisu do bazy danych.

    • Kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz z wyłącznością do bazy danych programu access z wyłącznością. Jeśli masz bazy danych Otwórz z wyłącznością dostępu wszystkich osób, które próbuje Otwórz bazę danych, otrzymuje komunikat "plik już w użyciu".

    • Kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz z wyłącznością tylko do odczytu, aby otworzyć bazę danych, aby dostęp tylko do odczytu. Inni użytkownicy mogą otworzyć bazę danych, ale są ograniczone do trybu tylko do odczytu.

Jeśli nie możesz znaleźć bazę danych, którą chcesz otworzyć   

  1. W oknie dialogowym Otwieranie kliknij pozycję Mój komputer lub na liście rozwijanej Szukaj kliknij pozycję Mój komputer.

  2. Na liście dysków kliknij prawym przyciskiem myszy dysk, na którym sądzisz może zawierać bazy danych, a następnie kliknij wyszukiwania.

  3. Wprowadź kryteria wyszukiwania w oknie dialogowym Wyniki wyszukiwania, a następnie kliknij wyszukiwania, aby wyszukać bazę danych.

  4. Jeśli baza danych zostanie znaleziona, kliknij ją dwukrotnie, aby go otworzyć.

  5. Należy kliknąć Anulowanie w oknie dialogowym Otwieranie bazy danych otworzyć. Zamknij okno dialogowe Wyników wyszukiwania.

Uwaga : Można bezpośrednio Otwórz plik danych w formacie pliku zewnętrznego, na przykład dBASE, Paradox, Microsoft Exchange lub Excel. Można również bezpośrednio otwierać dowolny źródło danych ODBC, takich jak Microsoft SQL Server lub Microsoft FoxPro. Program Access automatycznie tworzy nową bazę danych programu Access w tym samym folderze co plik danych i dodaje łącza do każdej tabeli w zewnętrznej bazie danych.

Porady
  • Aby otworzyć jeden z ostatnio otwieranych baz danych, kliknij nazwę pliku dla tej bazy danych na liście Otwórz ostatnio używane bazy danych na stronie Wprowadzenie do programu Microsoft Office Access. Program Access otworzy bazę danych z tymi samymi ustawieniami opcji, które miał on ostatnim otwarciu. Jeśli na liście ostatnio używanych plików nie jest wyświetlane, kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij przycisk Opcje programu Access. W oknie dialogowym Opcje programu Access kliknij przycisk Zaawansowane. W obszarze Wyświetlanie wprowadź liczbę dokumentów, aby wyświetlić na liście ostatnio używanych dokumentów maksymalnie 9.

  • Podczas otwierania bazy danych, klikając Przycisk Microsoft Office Obraz przycisku pakietu Office i za pomocą polecenia Otwórz, możesz wyświetlić listę skrótów do baz danych, otwierane wcześniej, klikając pozycję Moje ostatnie dokumentyOtwieranie okna dialogowego.

Początek strony

Tworzenie niestandardowego pustego szablonu

Po utworzeniu nowej, pustej bazy danych program Access otworzy nową tabelę, w którym można wprowadzać dane, ale tworzy nie innych obiektów w bazie danych. Jeśli chcesz innych obiektów, takich jak formularze, raporty, makra lub dodatkowe tabele przedstawianie na wszystkich nowych baz danych, które można tworzyć, możesz utworzyć niestandardowe pustego szablonu, zawierającego tych obiektów. Następnie w następnym razem, Utwórz nową bazę danych, go będą już zawierać tych obiektów w szablonie. Oprócz tych obiektów szablon może zawierać tabele wstępnie z danych, a także wszelkie specjalne ustawienia konfiguracji, właściwości bazy danych, odwołania lub kod, który chcesz mieć na wszystkich nowych baz danych.

Załóżmy, że masz zbiór makra, które chcesz użyć w wszystkich projektów. Jeśli tworzysz pustego szablonu zawierającego te makra programu Access zawiera ich w nowych baz danych, które można utworzyć.

Możesz utworzyć pustą szablony w formacie pliku Office Access 2007, format pliku programu Access 2002 – 2003 lub na format pliku programu Access 2000. Szablon musi mieć nazwę Blank.accdb format pliku Office Access 2007 i Blank.mdb dla starszych formatach plików.

  • Jeśli domyślny format pliku jest ustawiona na programu Access 2000 lub Access 2002 – 2003, program Access użyje Blank.mdb jako nazwę pliku pustego szablonu. Nowa baza danych zostanie utworzona w formacie pliku jako Blank.mdb. Na przykład nawet w przypadku domyślnego formatu pliku programu Access 2000, jeśli szablon o nazwie Blank.mdb jest w formacie pliku programu Access 2002 – 2003, nowych baz danych utworzonych będzie w formacie programu Access 2002 – 2003.

  • Jeśli ustawiono domyślnego formatu pliku programu Access 2007, program Access użyje Blank.accdb jako nazwę pliku pustego szablonu.

Jak zmienić domyślny format pliku

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Opcje programu Access.

  2. W oknie dialogowym Opcje programu Access kliknij pozycję Popularne.

  3. W obszarze Tworzenie baz danych wybierz odpowiedni format z listy rozwijanej domyślny format pliku.

Tworzenie pustego szablonu, wykonaj jedną z następujących czynności:

  • Utworzyć nowej bazy danych (można nadaj mu nazwę puste i nadaj mu nazwę tymczasowe), a następnie zaimportować lub obiekty, które mają zostać uwzględnione w szablonie.

  • Utwórz kopię istniejącej bazy danych, która już zawiera obiekty, które mają w szablonie, a następnie usuń wszystkie obiekty, których nie chcesz.

Po umieszczeniu obiekty, które mają w szablonie, należy zapisać go do określonej lokalizacji.

  1. Kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Zapisz jako.

  2. W obszarze Zapisz bazę danych w innym formacie kliknij format pliku, który ma dla szablonu.

  3. W oknie dialogowym Zapisywanie jako przejdź do jednej z tych folderów, dwa szablonu:

    • Folder szablonów systemu    Na przykład C:\Program Files\Microsoft Office\Templates\1033\Access

    • Folder szablonów użytkownika    Na przykład:

      • W Windows Vista    name\AppData\Roaming\Microsoft\Templates c:\Users\user

      • W systemie Microsoft Windows Server 2003 lub Microsoft Windows XP    C:\Documents and Settings\nazwa w przypadku aplikacji\Microsoft\Templates

        Uwaga : Pusty szablon w folderze szablonów System zastępuje pusty szablony w wszystkie foldery szablon użytkownika.

  4. W polu Nazwa pliku wpisz Blank.accdb (lub Blank.mdb, jeśli jest tworzony szablon starszej wersji), a następnie kliknij przycisk Zapisz.

Teraz, gdy nowy szablon znajduje się w miejscu, podczas tworzenia nowej, pustej bazy danych, obiekty w szablonie są domyślnie zawarte w nowej bazy danych, które można utworzyć. Program Access otworzy nową tabelę w widoku arkusza danych, jak podczas tworzenia nowego pustego baz danych bez przy użyciu szablonu.

Aby zakończyć korzystanie z pustego szablonu, usuń lub zmień plik o nazwie Blank.accdb (lub Blank.mdb we wcześniejszych wersjach programu Access).

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×