Tworzenie nowej bazy danych

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

W tym artykule opisano podstawowy proces uruchamiania Access i tworzenie bazy danych, która będzie używana na komputerach stacjonarnych, a nie w sieci Web. W tym artykule wyjaśniono, jak utworzyć bazę danych dla komputerów stacjonarnych przy użyciu szablonu i jak zbudować bazę danych od podstaw, tworząc własne tabele, formularze, raporty i inne obiekty bazy danych. Omówiono też niektóre techniki, których można użyć w celu uzyskania istniejących danych w nowej bazie danych.

W tym artykule

Omówienie

Tworzenie bazy danych przy użyciu szablonu

Tworzenie bazy danych bez użycia szablonu

Kopiowanie danych z innego źródła do tabeli programu Access

Importowanie, dołączanie lub łączenie danych z innego źródła

Dodawanie części aplikacji

Otwieranie istniejącej bazy danych programu Access

Korzystasz z programu Access 2007?

Omówienie

Gdy po raz pierwszy uruchomisz program Access lub zamkniesz bazę danych bez zamykania programu Access, zostanie wyświetlony widok Microsoft Office Backstage.

Widok Backstage to punkt początkowy, w którym można utworzyć nową bazę danych, otworzyć istniejącą bazę danych, wyświetlić polecaną zawartość z Office.com — wszystko, czego można użyć w programie Access do pliku bazy danych lub poza bazą danych, w przeciwieństwie do w bazie danych.

Tworzenie bazy danych

Po otwarciu programu Access w widoku Backstage jest wyświetlana Nowa karta. Nowa karta udostępnia kilka sposobów tworzenia nowej bazy danych:

  • Pusta baza danych    Jeśli chcesz, możesz zacząć od podstaw. Jest to dobry sposób, jeśli masz bardzo określone wymagania projektowe lub masz istniejące dane, które musisz uwzględnić lub dołączyć.

  • Szablon instalowany z programem Access    Jeśli rozpoczynasz nowy projekt, możesz skorzystać z szablonu, aby zacząć od początku. Program Access zawiera kilka szablonów, które są domyślnie instalowane.

  • Szablon z Office.com    Oprócz szablonów, które są dostępne w programie Access, możesz znaleźć wiele dodatkowych szablonów w witrynie Office.com. Nie trzeba nawet otwierać przeglądarki, ale szablony te są dostępne na karcie nowe .

Dodawanie do bazy danych

Po zakończeniu pracy z bazą danych możesz dodawać pola, tabele lub części aplikacji.

Składniki aplikacji to funkcja umożliwiająca używanie kilku powiązanych obiektów bazy danych w taki sam sposób, jak gdyby były. Na przykład część aplikacji może składać się z tabeli i formularza opartego na tabeli. Tabelę i formularz można dodać w tym samym czasie, korzystając z części aplikacji.

Możesz również tworzyć kwerendy, formularze, raporty, makra — wszystkie obiekty bazy danych, z którymi pracujesz.

Tworzenie bazy danych przy użyciu szablonu

Program Access zawiera wiele szablonów, które można wykorzystać jako punkt wyjściowy lub jako punkt wyjścia. Szablon to gotowa do użycia baza danych zawierająca wszystkie tabele, zapytania, formularze, makra i raporty potrzebne do wykonania określonego zadania. Na przykład istnieją szablony, za pomocą których można śledzić problemy, zarządzać kontaktami lub rejestrować wydatki. Niektóre szablony zawierają kilka przykładowych rekordów, które pomogą wykazać ich użycie.

Jeśli jednym z tych szablonów odpowiada Twoim potrzebom, korzystanie z niej jest zazwyczaj najszybszym sposobem na rozpoczęcie pracy z bazą danych. Jeśli jednak masz dane w innym programie, który chcesz zaimportować do programu Access, możesz zdecydować, czy można utworzyć bazę danych bez użycia szablonu. Szablony mają już zdefiniowaną strukturę danych i mogą wymagać wielu prac w celu dostosowania istniejących danych do struktury szablonu.

  1. Jeśli baza danych jest otwarta, na karcie plik kliknij pozycję Zamknij. Widok Backstage wyświetla nową kartę.

  2. Kilka zestawów szablonów jest dostępnych na nowej karcie, z których niektóre są wbudowane w program Access. Możesz pobrać dodatkowe szablony z Office.com. Aby uzyskać szczegółowe informacje, zobacz następną sekcję w tym artykule.

  3. Wybierz szablon, którego chcesz użyć.

  4. Program Access sugeruje nazwę pliku bazy danych w polu Nazwa pliku — Jeśli chcesz, możesz zmienić nazwę pliku. Aby zapisać bazę danych w innym folderze niż wyświetlone poniżej pola Nazwa pliku, kliknij pozycję Obraz przycisku , przejdź do folderu, w którym chcesz go zapisać, a następnie kliknij przycisk OK. Opcjonalnie możesz utworzyć i połączyć bazę danych z witryną programu SharePoint.

    Uwaga: Chociaż obaj użytkownicy korzystają z programu SharePoint, baza danych dla komputerów stacjonarnych połączonych z witryną programu SharePoint nie jest taka sama, jak baza danych sieci Web przy użyciu usług programu Access. Aby można było korzystać z bazy danych dla komputerów stacjonarnych, musi być zainstalowany program Access. Baza danych sieci Web może być używana w przeglądarce sieci Web.

  5. Kliknij przycisk Utwórz.

    Program Access utworzy bazę danych na podstawie wybranego szablonu, a następnie otworzy bazę danych. W przypadku wielu szablonów jest wyświetlany formularz, w którym można rozpocząć wprowadzanie danych. Jeśli szablon zawiera przykładowe dane, możesz usunąć każdy rekord, klikając selektor rekordu (pole cieniowane lub pasek po lewej stronie rekordu), a następnie wykonując następujące czynności:

    Na karcie Narzędzia główne w grupie Rekordy kliknij przycisk Usuń. Button image

  6. Aby rozpocząć wprowadzanie danych, kliknij pierwszą pustą komórkę w formularzu i zacznij pisać. Użyj okienko nawigacji, aby przeglądać inne formularze lub raporty, które mogą być używane. Niektóre szablony zawierają formularz nawigacji umożliwiający przechodzenie między różnymi obiektami bazy danych.

Aby uzyskać więcej informacji na temat pracy z szablonami, zobacz artykuł Tworzenie bazy danych programu Access dla komputerów stacjonarnych przy użyciu szablonu.

Początek strony

Tworzenie bazy danych bez użycia szablonu

Jeśli nie chcesz używać szablonu, możesz utworzyć bazę danych, tworząc własne tabele, formularze, raporty i inne obiekty bazy danych. W większości przypadków dotyczy to co najmniej jednego z następujących sposobów:

  • Wprowadzanie, wklejanie lub importowanie danych do tabeli utworzonej podczas tworzenia nowej bazy danych, a następnie powtarzanie procesu przy użyciu nowych tabel utworzonych za pomocą polecenia tabela na karcie Tworzenie .

  • Importowanie danych z innych źródeł i tworzenie nowych tabel w procesie.

Tworzenie pustej bazy danych

  1. Na karcie plik kliknij pozycję Nowy, a następnie kliknij pozycję pusta baza danych.

  2. W polu Nazwa pliku wpisz nazwę pliku. Aby zmienić lokalizację pliku z domyślnego, kliknij pozycję Przeglądaj w poszukiwaniu lokalizacji, aby umieścić Obraz przycisku bazy danych(obok pola Nazwa pliku ), przejdź do nowej lokalizacji, a następnie kliknij przycisk OK.

  3. Kliknij przycisk Utwórz.

    Program Access utworzy bazę danych z pustą tabelą o nazwie Tabela1, a następnie zostanie otwarta tabela Tabela1 w widoku arkusza danych. Kursor zostanie umieszczony w pierwszej pustej komórce w kolumnie kliknij, aby dodać .

  4. Zacznij pisać, aby dodać dane, lub wklej dane z innego źródła zgodnie z opisem w sekcji Kopiowanie danych z innego źródła do tabeli programu Access.

Wprowadzanie danych w widoku arkusza danych jest bardzo podobne do pracy w arkuszu programu Excel. Struktura tabeli jest tworzona podczas wprowadzania danych. Po dodaniu nowej kolumny do arkusza danych w tabeli jest zdefiniowane nowe pole. Program Access automatycznie ustawia typ danych każdego pola na podstawie wprowadzonych danych.

Jeśli nie chcesz w tym momencie wprowadzać danych w tabeli Tabela1, kliknij pozycję Zamknij Button image . Po wprowadzeniu jakichkolwiek zmian w tabeli program Access wyświetli monit o zapisanie zmian. Kliknij przycisk tak , aby zapisać zmiany, kliknij przycisk nie , aby je odrzucić, lub kliknij przycisk Anuluj , aby pozostawić tabelę otwartą.

Porada:  Program Access szuka pliku o nazwie blank. accdb w folderze znajdującym się pod adresem [install Drive]: \Program Files\Microsoft Office\Templates\1033\Access\. Jeśli istnieje, pusty. accdb to szablon dla wszystkich nowych pustych baz danych, z wyłączeniem baz danych sieci Web. Każda zawartość, którą zawiera, jest dziedziczona przez wszystkie nowe puste bazy danych. Jest to dobry sposób na rozpowszechnianie zawartości domyślnej, takiej jak numery części lub odzyskanie i zasady firmy. Pamiętaj, że pole blank. accdb nie ma wpływu na tworzenie pustych nowych baz danych sieci Web.

Ważne: Jeśli zamkniesz tabelę Tabela1 bez jej zapisywania co najmniej raz, program Access usunie całą tabelę, nawet jeśli w niej wprowadzono dane.

Dodawanie tabeli

Nowe tabele można dodawać do istniejącej bazy danych przy użyciu poleceń w grupie tabele na karcie Tworzenie .

Obraz Wstążki programu Access

Tworzenie tabeli w widoku arkusza danych    W widoku arkusza danych możesz natychmiast wprowadzić dane i umożliwić programowi Access utworzenie struktury tabeli w tle. Nazwy pól są przypisywane liczbowo (Pole1, Pole2 itd.), a program Access automatycznie ustawia typ danych każdego pola na podstawie wprowadzonych danych.

  1. Na karcie Tworzenie w grupie Tabele kliknij pozycję Tabela. Button image

    Program Access utworzy tabelę i zaznaczy pierwszą pustą komórkę w kolumnie kliknij, aby dodać .

  2. Na karcie pola w grupie Dodawanie & usuwanie kliknij typ pola, które chcesz dodać. Jeśli odpowiedni typ nie jest widoczny, kliknij pozycję więcej pól Obraz przycisku .

  3. Program Access wyświetli listę często używanych typów pól. Kliknij odpowiedni typ pola, a program Access doda nowe pole do arkusza danych w punkcie wstawiania.

    Możesz przenieść pole, przeciągając je. Po przeciągnięciu pola w arkuszu danych zostanie wyświetlony pionowy pasek wstawiania, w którym zostanie umieszczone pole.

  4. Aby dodać dane, zacznij pisać w pierwszej pustej komórce lub wklej dane z innego źródła zgodnie z opisem w sekcji Kopiowanie danych z innego źródła do tabeli programu Access.

  5. Aby zmienić nazwę kolumny (pola), kliknij dwukrotnie nagłówek kolumny, a następnie wpisz nową nazwę.

    Należy nadać opisową nazwę każdemu polu, tak aby można było powiedzieć, co zawiera on w okienku Lista pól .

  6. Aby przenieść kolumnę, kliknij jej nagłówek, aby zaznaczyć kolumnę, a następnie przeciągnij kolumnę w odpowiednie miejsce. Możesz również zaznaczyć wiele sąsiadujących kolumn, a następnie przeciągnąć je w nowe miejsce jednocześnie. Aby zaznaczyć wiele sąsiadujących kolumn, kliknij nagłówek kolumny pierwszej kolumny, a następnie przytrzymaj naCIŚNIĘTY klawisz SHIFT i kliknij nagłówek kolumny w ostatniej kolumnie.

Tworzenie tabeli w widoku projektu    W widoku projektu należy najpierw utworzyć strukturę tabeli. Następnie przełącz się do widoku arkusza danych, aby wprowadzić dane, lub wprowadź dane, korzystając z innej metody, takiej jak wstawianie lub importowanie.

  1. Na karcie Tworzenie w grupie tabele kliknij pozycję Projekt tabeli. Obraz przycisku

  2. W przypadku każdego pola w tabeli wpisz nazwę w kolumnie Nazwa pola , a następnie wybierz typ danych z listy Typ danych .

  3. Jeśli chcesz, możesz wpisać opis każdego pola w kolumnie Opis . Opis zostanie wyświetlony na pasku stanu, gdy kursor znajduje się w tym polu w widoku arkusza danych. Opis jest również używany jako tekst na pasku stanu dla kontrolek w formularzu lub raporcie tworzonym przez przeciągnięcie pola z okienka Lista pól i dla wszystkich kontrolek utworzonych dla tego pola podczas korzystania z Kreatora formularzy lub Kreatora raportów.

  4. Po dodaniu wszystkich pól Zapisz tabelę:

    • Na karcie Plik kliknij przycisk Zapisz.

  5. W dowolnym momencie możesz rozpocząć wpisywanie danych w tabeli, przełączając się do widoku arkusza danych i klikając pierwszą pustą komórkę. Możesz również wkleić dane z innego źródła, zgodnie z opisem w sekcji Kopiowanie danych z innego źródła do tabeli programu Access.

Ustawianie właściwości pola w widoku projektu    Niezależnie od sposobu utworzenia tabeli warto sprawdzić i ustawić właściwości pola. Niektóre właściwości są dostępne w widoku arkusza danych, ale niektóre właściwości mogą być ustawiane tylko w widoku projektu. Aby przełączyć się do widoku projektu, kliknij prawym przyciskiem myszy tabelę w okienku nawigacji, a następnie kliknij polecenie Widok projektu. Aby wyświetlić właściwości pola, kliknij pole w siatce projektu. Właściwości są wyświetlane poniżej siatki projektu w obszarze Właściwości pola.

Aby wyświetlić opis każdej właściwości pola, kliknij właściwość i Przeczytaj opis w polu obok listy właściwości w obszarze Właściwości pola. Aby uzyskać bardziej szczegółowe informacje, kliknij przycisk Pomoc.

W poniższej tabeli opisano niektóre właściwości pól, które są często dostosowywane.

Właściwość

Opis

Rozmiar pola

W przypadku pól tekstowych ta właściwość określa maksymalną liczbę znaków, które mogą być przechowywane w polu. Maksymalna wartość to 255. W przypadku pól typu Liczba ta właściwość określa typ liczby, która będzie przechowywana (liczba całkowita długa, Podwójna itd.). Aby zapewnić najbardziej wydajne przechowywanie danych, zaleca się przydzielenie najmniejszej ilości miejsca potrzebnego na dane. W razie potrzeby możesz dostosować wartość później.

Formatowanie

Ta właściwość określa sposób wyświetlania danych. Nie wpływa na faktyczne dane przechowywane w polu. Możesz wybrać wstępnie zdefiniowany format lub wprowadzić format niestandardowy.

Maska wprowadzania

Za pomocą tej właściwości można określić wzorzec dla wszystkich danych, które zostaną wprowadzone w tym polu. Pomaga to sprawdzić, czy wszystkie dane są wprowadzone poprawnie i czy zawierają wymaganą liczbę znaków. Aby uzyskać pomoc dotyczącą tworzenia maski wprowadzania, kliknij pozycję Przycisk Konstruktor po prawej stronie pola właściwości.

Wartość domyślna

Za pomocą tej właściwości można określić wartość domyślną, która będzie wyświetlana w tym polu za każdym razem, gdy zostanie dodany nowy rekord. Jeśli na przykład masz pole typu Data/godzina, w którym zawsze chcesz rejestrować datę dodania rekordu, możesz wpisać "Data ()" (bez cudzysłowów) jako wartość domyślną.

Wymagane

Właściwość ta określa, czy w tym polu jest wymagana wartość. Jeśli ustawisz tę właściwość na tak, program Access nie zezwoli na dodanie nowego rekordu, dopóki nie zostanie wprowadzona wartość dla tego pola.

Początek strony

Kopiowanie danych z innego źródła do tabeli programu Access

Jeśli dane są obecnie przechowywane w innym programie, na przykład w programie Excel, możesz je skopiować i wkleić do tabeli programu Access. Zazwyczaj jest to najlepsze rozwiązanie, jeśli dane są już rozdzielone na kolumny, ponieważ znajdują się w arkuszu programu Excel. Jeśli dane są w programie do przetwarzania tekstu, najlepiej rozdzielić kolumny danych przy użyciu kart lub przekonwertować je na tabelę w programie do przetwarzania tekstów, zanim skopiujesz dane. Jeśli dane wymagają edycji lub manipulacji (na przykład oddzielaj imiona i nazwiska), warto to zrobić przed skopiowaniem danych, szczególnie jeśli nie znasz programu Access.

Po wklejeniu danych do pustej tabeli program Access ustawia typ danych każdego pola w zależności od tego, jakiego typu dane są tam znalezione. Jeśli na przykład pole "wkleine" nie zawiera wartości dat, w programie Access zostanie zastosowany typ danych Data/godzina do tego pola. Jeśli pole zawiera tylko wyrazy "tak" i "nie", program Access stosuje typ danych tak/nie do pola.

Program Access nadaje nazwy polom w zależności od tego, co znajduje się w pierwszym wierszu danych, które zostały wcześniej skopiowane. Jeśli pierwszy wiersz danych wklejenia jest podobny do poniższego tekstu, program Access ustali, że pierwszy wiersz jest częścią danych i przypisuje pola nazwy ogólne (F1, F2 itd.). Jeśli pierwszy wiersz wklejenia danych nie jest podobny do wierszy, które obserwujesz, program Access ustali, że pierwszy wiersz zawiera nazwy pól. Program Access odpowiednio nadaje polom pola i nie zawiera pierwszego wiersza danych.

Jeśli program Access przypisze nazwy pól ogólnych, należy jak najszybciej zmienić nazwy pól, aby uniknąć nieporozumień. Wykonaj następujące kroki:

  1. Naciśnij klawisze CTRL + S, aby zapisać tabelę.

  2. W widoku arkusza danych kliknij dwukrotnie każdy nagłówek kolumny, a następnie wpisz opisową nazwę pola dla każdej kolumny.

  3. Ponownie Zapisz tabelę.

Uwaga: Możesz również zmienić nazwy pól, przełączając się do widoku projektu i edytując w nim nazwy pól. Aby przełączyć się do widoku projektu, kliknij prawym przyciskiem myszy tabelę w okienku nawigacji, a następnie kliknij polecenie Widok projektu. Aby przełączyć z powrotem do widoku arkusza danych, kliknij dwukrotnie tabelę w okienku nawigacji.

Początek strony

Importowanie, dołączanie lub łączenie danych z innego źródła

Być może dane są przechowywane w innym programie i chcesz je zaimportować do nowej tabeli lub dołączyć je do istniejącej tabeli w programie Access. Możesz także pracować z osobami, które przechowują dane w innych programach, i chcesz pracować z nimi w programie Access, łącząc je. W każdym z tych sposobów program Access ułatwia pracę z danymi z innych źródeł. Dane z arkusza programu Excel można zaimportować z tabeli w innej bazie danych programu Access, z listy programu SharePoint lub z różnych innych źródeł. Proces, którego używasz, różni się nieco w zależności od źródła, ale wykonanie poniższej procedury spowoduje rozpoczęcie pracy.

  1. W programie Access na karcie dane zewnętrzne w grupie Importowanie & kliknij polecenie dla typu importowanego pliku.

    Grupa Importowanie i łączenie na karcie Dane zewnętrzne

    Jeśli na przykład importujesz dane z arkusza programu Excel, kliknij pozycję Excel. Jeśli nie widzisz potrzebnego typu programu, kliknij pozycję więcej.

    Uwaga: Jeśli nie możesz znaleźć odpowiedniego typu formatu w grupie łącze importowania & , może być konieczne uruchomienie programu, w którym dane zostały pierwotnie utworzone, a następnie użycie tego programu w celu zapisania danych we wspólnym formacie pliku (na przykład rozdzielany plik tekstowy ), zanim będzie można impor t to dane w programie Access.

  2. W oknie dialogowym pobieranie danych zewnętrznych kliknij przycisk Przeglądaj , aby znaleźć plik danych źródłowych, lub wpisz pełną ścieżkę pliku danych źródłowych w polu Nazwa pliku .

  3. Kliknij odpowiednią opcję (wszystkie programy pozwalają na importowanie, a niektóre umożliwiają dołączanie lub łączenie) w obszarze Określanie sposobu i miejsca przechowywania danych w bieżącej bazie danych. Możesz utworzyć nową tabelę, w której są używane importowane dane, lub (za pomocą kilku programów) można dołączyć dane do istniejącej tabeli lub utworzyć tabelę połączoną z danymi w programie źródłowym.

  4. Jeśli zostanie uruchomiony Kreator, postępuj zgodnie z instrukcjami na kolejnych kilku stronach kreatora. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

    Po zaimportowaniu obiektów lub łączenia tabel z bazy danych programu Access zostanie wyświetlone okno dialogowe Importowanie obiektów lub Łączenie tabel . Wybierz odpowiednie elementy, a następnie kliknij przycisk OK.

    Dokładny proces zależy od tego, czy użytkownik zdecyduje się zaimportować, dołączyć lub połączyć dane.

  5. W programie Access zostanie wyświetlony monit o to, czy chcesz zapisać szczegóły właśnie ukończonej operacji importowania. Jeśli uważasz, że ta sama operacja importowania będzie wykonywana w przyszłości, kliknij pozycję Zapisz kroki importowania, a następnie wprowadź szczegóły. Następnie możesz łatwo powtórzyć operację w przyszłości, klikając pozycję zapisane operacjeimportowania Obraz przycisku w grupie łącze importowania & na karcie dane zewnętrzne . Jeśli nie chcesz zapisywać szczegółów operacji, kliknij przycisk Zamknij.

W przypadku wybrania opcji importowania tabeli program Access zaimportuje dane do nowej tabeli, a następnie tabela jest wyświetlana w grupie tabele w okienku nawigacji. W przypadku wybrania opcji dołączania danych do istniejącej tabeli dane zostaną dodane do tej tabeli. W przypadku wybrania linku do danych program Access utworzy tabelę połączoną w grupie tabele w okienku nawigacji.

Początek strony

Dodawanie części aplikacji

W celu dodania funkcji do istniejącej bazy danych można użyć części aplikacji. Część aplikacji może być prosta jako pojedyncza tabela lub może zawierać kilka powiązanych obiektów, takich jak tabela i formularz związany.

Na przykład część komentarza składa się z tabeli z polem Identyfikator autoNumer, polem daty i polem typu Nota. Możesz je dodać do dowolnej bazy danych i użyć jej jako-lub do minimalnego dostosowania.

  1. Otwórz bazę danych, do której chcesz dodać część aplikacji.

  2. Kliknij kartę Tworzenie .

  3. W grupie Szablony kliknij pozycję części aplikacji. Zostanie wyświetlona lista dostępnych części.

  4. Kliknij część aplikacji, którą chcesz dodać.

Początek strony

Otwieranie istniejącej bazy danych programu Access

  1. Na karcie Plik kliknij pozycję Otwórz.

  2. W oknie dialogowym otwieranie przejdź do bazy danych, którą chcesz otworzyć.

  3. Wykonaj jedną z następujących czynności:

    • Kliknij dwukrotnie bazę danych, aby ją otworzyć w trybie domyślnym określonym w oknie dialogowym Opcje programu Access lub w trybie ustawionym za pomocą zasad administracyjnych.

    • Kliknij przycisk Otwórz , aby otworzyć bazę danych dla współdzielonego dostępu w orodowisku wielodostępnym, aby umożliwić użytkownikom odczytywanie i zapisywanie w bazie danych.

    • Kliknij strzałkę obok przycisku Otwórz , a następnie kliknij polecenie Otwórz tylko do odczytu , aby otworzyć bazę danych w trybie tylko do odczytu, aby można było ją wyświetlać, ale nie można jej edytować. Inni użytkownicy mogą nadal czytać i zapisywać dane w bazie danych.

    • Kliknij strzałkę obok przycisku Otwórz , a następnie kliknij polecenie Otwórz z wyłącznością, aby otworzyć bazę danych za pomocą programu Access z wyłącznością. Jeśli baza danych jest otwarta z wyłącznym dostępem, każdy inny użytkownik próbujący otworzyć bazę danych otrzymuje komunikat "plik jest już w użyciu".

    • Kliknij strzałkę obok przycisku Otwórz , a następnie kliknij polecenie Otwórz z wyłącznością tylko do odczytu , aby otworzyć bazę danych w trybie tylko do odczytu. Inni użytkownicy mogą nadal otwierać bazę danych, ale są one ograniczone do trybu tylko do odczytu.

Uwaga: Plik danych można otworzyć bezpośrednio w formacie pliku zewnętrznego, takiego jak dBASE, Microsoft Exchange lub Excel. Możesz również bezpośrednio otworzyć dowolne źródło danych ODBC, takie jak Microsoft SQL Server. Program Access automatycznie utworzy nową bazę danych programu Access w tym samym folderze, w którym znajduje się plik danych, i doda linki do każdej tabeli w zewnętrznej bazie danych.

Porady

  • Aby otworzyć dowolną z ostatnio otwieranych baz danych, na karcie plik kliknij pozycję ostatnie, a następnie kliknij nazwę pliku tej bazy danych. Program Access otworzy bazę danych przy użyciu tych samych ustawień opcji, które obowiązywały przy ostatnim otwarciu. Jeśli lista ostatnio używanych plików nie jest wyświetlana, na karcie plik kliknij pozycję Opcje. W oknie dialogowym Opcje programu Access kliknij pozycję Ustawienia klienta. W obszarze Wyświetlaniewprowadź liczbę dokumentów, które mają być wyświetlane na liście ostatnio używanych dokumentów, maksymalnie 50.

    Ostatnie bazy danych można też wyświetlić na pasku nawigacyjnym widoku Backstage, a w przypadku dostępu dwukrotnego kliknięcia: 1) karta plik , 2) Ostatnia baza danych, którą chcesz otworzyć. U dołu karty ostatnie zaznacz pole wyboru szybko Uzyskuj dostęp do tej liczby ostatnio używanych baz danych , a następnie dostosuj liczbę wyświetlanych baz danych.

  • Jeśli otwierasz bazę danych, klikając polecenie Otwórz na karcie plik , możesz wyświetlić listę skrótów do baz danych, które zostały wcześniej otwarte, klikając pozycję Moje ostatnie dokumenty w oknie dialogowym otwieranie .

Początek strony

Korzystasz z programu Access 2007?

Gdy po raz pierwszy uruchomisz program Access lub zamkniesz bazę danych bez zamykania programu Access, zostanie wyświetlona strona wprowadzenie do programu Microsoft Office Access .

Strona Wprowadzenie do programu Microsoft Office Access

Ta strona jest punktem początkowym, od którego można utworzyć nową bazę danych, otworzyć istniejącą bazę danych lub wyświetlić proponowaną zawartość z witryny Microsoft Office Online.

Program Access oferuje szeroki wachlarz szablonów, których można użyć w celu przyspieszenia procesu tworzenia bazy danych. Szablon to gotowa do użycia baza danych zawierająca wszystkie tabele, zapytania, formularze i raporty potrzebne do wykonania określonego zadania. Na przykład istnieją szablony, za pomocą których można śledzić problemy, zarządzać kontaktami lub rejestrować wydatki. Niektóre szablony zawierają kilka przykładowych rekordów, które pomogą wykazać ich użycie. Można korzystać z baz danych szablonów lub dostosować je do własnych potrzeb.

Jeśli jednym z tych szablonów odpowiada Twoim potrzebom, korzystanie z niej jest zazwyczaj najszybszym sposobem na rozpoczęcie pracy z bazą danych. Jeśli jednak masz dane w innym programie, który chcesz zaimportować do programu Access, możesz zdecydować, czy można utworzyć bazę danych bez użycia szablonu. Szablony mają już zdefiniowaną strukturę danych i mogą wymagać wielu prac w celu dostosowania istniejących danych do struktury szablonu.

  1. Jeśli masz otwartą bazę danych, kliknij przycisk pakietu Microsoft Office , a następnie kliknij polecenie Zamknij bazę Obraz przycisku , aby wyświetlić stronę wprowadzenie do programu Microsoft Office Access .

  2. Kilka proponowanych szablonów jest wyświetlanych na środku strony wprowadzenie do programu Microsoft Office Access i jest dostępna po kliknięciu łączy w okienku Kategorie szablonów . Dodatkowe szablony można pobrać z witryny Office Online w sieci Web. Aby uzyskać szczegółowe informacje, zobacz następną sekcję w tym artykule.

  3. Kliknij szablon, którego chcesz użyć.

  4. Program Access sugeruje nazwę pliku bazy danych w polu Nazwa pliku — Jeśli chcesz, możesz zmienić nazwę pliku. Aby zapisać bazę danych w innym folderze niż wyświetlone poniżej pola Nazwa pliku, kliknij pozycję Obraz przycisku , przejdź do folderu, w którym chcesz go zapisać, a następnie kliknij przycisk OK. Opcjonalnie możesz utworzyć i połączyć bazę danych z witryną programu SharePoint.

  5. Kliknij pozycję Utwórz (lub Pobierz, aby utworzyć szablon usługi Office Online).

    Program Access utworzy lub pobierze bazę danych, a następnie otworzy ją. Zostanie wyświetlony formularz, w którym można rozpocząć wprowadzanie danych. Jeśli szablon zawiera przykładowe dane, możesz usunąć każdy rekord, klikając selektor rekordu (pole cieniowane lub pasek po lewej stronie rekordu), a następnie wykonując następujące czynności:

    Na karcie Narzędzia główne w grupie Rekordy kliknij przycisk Usuń. Button image

  6. Aby rozpocząć wprowadzanie danych, kliknij pierwszą pustą komórkę w formularzu i zacznij pisać. Okienko nawigacji umożliwia przeglądanie w poszukiwaniu innych formularzy lub raportów, które mogą być używane.

Jeśli nie możesz znaleźć szablonu odpowiadającego Twoim potrzebom na stronie wprowadzenie do programu Microsoft Office Access i masz połączenie z Internetem, możesz eksplorować większy wybór w witrynie Office Online w sieci Web.

  1. Na stronie wprowadzenie do programu Microsoft Office Access w obszarze więcej w witrynie Office Onlinekliknij pozycję Szablony.

    Strona główna szablonów w witrynie Office Online jest wyświetlana w oknie przeglądarki.

  2. Za pomocą narzędzi nawigacyjnych i wyszukiwania w usłudze Office Online Znajdź szablon programu Access, którego chcesz użyć, i postępuj zgodnie z instrukcjami, aby go pobrać. Podczas pobierania szablonu plik bazy danych jest pobierany na komputer i otwierany w nowym wystąpieniu programu Access. W większości przypadków szablon służy do otwierania formularza wprowadzania danych, aby można było od razu rozpocząć wprowadzanie danych.

Aby uzyskać więcej informacji na temat pracy z szablonami, zobacz artykuł Tworzenie bazy danych programu Access dla komputerów stacjonarnych przy użyciu szablonu.

Początek strony

Jeśli nie chcesz używać szablonu, możesz utworzyć bazę danych, tworząc własne tabele, formularze, raporty i inne obiekty bazy danych. W większości przypadków zwykle dotyczy to co najmniej jednego z następujących sposobów:

  • Wprowadzanie, wklejanie lub importowanie danych do tabeli utworzonej podczas tworzenia nowej bazy danych, a następnie powtarzanie procesu przy użyciu nowych tabel utworzonych za pomocą polecenia tabela na karcie Tworzenie .

  • Importowanie danych z innych źródeł i tworzenie nowych tabel w procesie.

  1. Na stronie rozpoczynaNie pracy z programem Microsoft Office Access w obszarze Nowa pusta baza danychkliknij pozycję pusta baza danych.

    Przycisk Pusta baza danych

  2. W okienku pusta baza danych wpisz nazwę pliku w polu Nazwa pliku . Jeśli nie podasz rozszerzenia nazwy pliku, program Access doda je do Ciebie. Aby zmienić lokalizację pliku z domyślnego, kliknij pozycję Przeglądaj w poszukiwaniu lokalizacji, aby umieścić Obraz przycisku bazy danych(obok pola Nazwa pliku ), przejdź do nowej lokalizacji, a następnie kliknij przycisk OK.

  3. Kliknij przycisk Utwórz.

    Program Access utworzy bazę danych z pustą tabelą o nazwie Tabela1, a następnie zostanie otwarta tabela Tabela1 w widoku arkusza danych. Kursor zostanie umieszczony w pierwszej pustej komórce w kolumnie Dodaj nowe pole .

  4. Zacznij pisać, aby dodać dane, lub wklej dane z innego źródła zgodnie z opisem w sekcji Kopiowanie danych z innego źródła do tabeli programu Access.

Wprowadzanie informacji w widoku arkusza danych jest bardzo podobne do pracy w arkuszu Microsoft Office Excel 2007. Struktura tabeli jest tworzona podczas wprowadzania danych — za każdym razem, gdy dodasz nową kolumnę do tabeli, zdefiniowano nowe pole. Program Access automatycznie ustawia typ danych każdego pola na podstawie wprowadzonych danych.

Jeśli nie chcesz w tej chwili wprowadzać informacji w tabeli Tabela1, kliknij pozycję Zamknij Button image . W przypadku wprowadzenia jakichkolwiek zmian w tabeli program Access wyświetli monit o zapisanie zmian w tabeli. Kliknij przycisk tak , aby zapisać zmiany, kliknij przycisk nie , aby je odrzucić, lub kliknij przycisk Anuluj , aby pozostawić tabelę otwartą.

Ważne: Jeśli zamkniesz tabelę Tabela1 bez jej zapisywania co najmniej raz, program Access usunie całą tabelę, nawet jeśli w niej wprowadzono dane.

Nowe tabele można dodawać do istniejącej bazy danych przy użyciu poleceń w grupie tabele na karcie Tworzenie .

Obraz wstążki programu Access

Tworzenie tabeli w widoku arkusza danych    W widoku arkusza danych możesz natychmiast wprowadzić dane i umożliwić programowi Access utworzenie struktury tabeli w tle. Nazwy pól są przypisywane liczbowo (Pole1, Pole2 itd.), a program Access automatycznie ustawia typ danych każdego pola na podstawie wprowadzonych danych.

  1. Na karcie Tworzenie w grupie Tabele kliknij pozycję Tabela. Button image

    Program Access utworzy tabelę i wybierze pierwszą pustą komórkę w kolumnie Dodaj nowe pole .

    Uwaga: Jeśli nie widzisz kolumny Dodaj nowe pole , być może jesteś w widoku projektu zamiast w widoku arkusza danych. Aby przełączyć się do widoku arkusza danych, kliknij dwukrotnie tabelę w okienku nawigacji. W programie Access zostanie wyświetlony monit o zapisanie nowej tabeli, a następnie przełączenie do widoku arkusza danych.

  2. Na karcie Arkusz danych w grupie Pola i kolumny kliknij pozycję Nowe pole. Obraz przycisku

    W programie Access zostanie wyświetlone okienko Szablony pól zawierające listę często używanych typów pól. Jeśli klikniesz dwukrotnie lub przeciągniesz jedno z tych pól do arkusza danych, program Access doda pole o tej nazwie i ustawi jego właściwości na odpowiednie wartości dla tego typu pola. Jeśli chcesz, możesz później zmienić właściwości. Jeśli przeciągniesz pole, musisz przeciągnąć je do obszaru arkusza danych zawierającego dane. Zostanie wyświetlony pionowy pasek wstawiania z wyświetlonym miejscem, w którym ma się znajdować pole.

  3. Aby dodać dane, zacznij pisać w pierwszej pustej komórce lub wklej dane z innego źródła zgodnie z opisem w sekcji Kopiowanie danych z innego źródła do tabeli programu Access.

  4. Aby zmienić nazwę kolumny (pola), kliknij dwukrotnie nagłówek kolumny, a następnie wpisz nową nazwę.

    Dobrą praktyką jest nadawanie zrozumiałej nazwy każdemu polu, dzięki czemu można stwierdzić, co zawiera to pole, gdy jest ono wyświetlane w okienku Lista pól .

  5. Aby przenieść kolumnę, kliknij jej nagłówek, aby zaznaczyć kolumnę, a następnie przeciągnij kolumnę w odpowiednie miejsce.

    Możesz również zaznaczyć wiele sąsiadujących kolumn, a następnie przeciągnąć je w nowe miejsce jednocześnie. Aby zaznaczyć wiele sąsiadujących kolumn, kliknij nagłówek kolumny pierwszej kolumny, a następnie przytrzymaj naCIŚNIĘTY klawisz SHIFT i kliknij nagłówek kolumny w ostatniej kolumnie.

Tworzenie tabeli w widoku projektu    W widoku projektu należy najpierw utworzyć strukturę nowej tabeli. Następnie przełącz się do widoku arkusza danych, aby wprowadzić dane, lub wprowadź dane, korzystając z innej metody, takiej jak wstawianie lub importowanie.

  1. Na karcie Tworzenie w grupie tabele kliknij pozycję Projekt tabeli. Obraz przycisku

  2. W przypadku każdego pola w tabeli wpisz nazwę w kolumnie Nazwa pola , a następnie wybierz typ danych z listy Typ danych .

    Uwaga: Jeśli nie widzisz nazwy pola i kolumn typu danych , być może jesteś w widoku arkusza danych, a nie w widoku projektu. Aby przełączyć się do widoku projektu, kliknij prawym przyciskiem myszy tabelę w okienku nawigacji, a następnie kliknij pozycję Widok projektu Button image . W programie Access zostanie wyświetlony monit o podanie nazwy nowej tabeli, a następnie przełączenie do widoku projektu.

  3. Jeśli chcesz, możesz wpisać opis każdego pola w kolumnie Opis . Opis zostanie wyświetlony na pasku stanu, gdy kursor znajduje się w tym polu w widoku arkusza danych. Opis jest również używany jako tekst na pasku stanu dla kontrolek w formularzu lub raporcie tworzonym przez przeciągnięcie pola z okienka Lista pól i dla wszystkich kontrolek utworzonych dla tego pola podczas korzystania z Kreatora formularzy lub Kreatora raportów.

  4. Po dodaniu wszystkich pól Zapisz tabelę:

    • Kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Zapiszlub naciśnij klawisze CTRL + S Button image .

  5. W dowolnym momencie możesz rozpocząć wpisywanie danych w tabeli, przełączając się do widoku arkusza danych i klikając pierwszą pustą komórkę. Możesz również wkleić dane z innego źródła, zgodnie z opisem w sekcji Kopiowanie danych z innego źródła do tabeli programu Access.

Tworzenie tabeli przy użyciu szablonu    Program Access udostępnia szablony często używanych typów tabel. Jednym kliknięciem myszy można utworzyć kompletną strukturę tabeli za pomocą pól, które zostały już skonfigurowane i będą gotowe do użycia. W razie potrzeby możesz dodać lub usunąć pola, aby tabela zmieściła się na potrzeby.

  1. Na karcie Tworzenie w grupie tabele kliknij pozycję Szablony tabel , a następnie wybierz z listy dowolny z dostępnych szablonów.

  2. Aby dodać dane, zacznij pisać w pierwszej pustej komórce lub wklej dane z innego źródła zgodnie z opisem w sekcji Kopiowanie danych z innego źródła do tabeli programu Access.

    • Aby usunąć kolumnę    

      1. Kliknij prawym przyciskiem myszy nagłówek kolumny, a następnie kliknij polecenie Usuń kolumnę Obraz przycisku .

    • Aby dodać nową kolumnę    

      1. Na karcie Arkusz danych w grupie Pola i kolumny kliknij pozycję Nowe pole. Obraz przycisku

      2. W programie Access zostanie wyświetlone okienko Szablony pól zawierające listę często używanych typów pól. Jeśli klikniesz dwukrotnie lub przeciągniesz jedno z tych pól do arkusza danych, program Access doda pole o tej nazwie i ustawi jego właściwości na odpowiednie wartości dla tego typu pola. Jeśli chcesz, możesz później zmienić właściwości. Jeśli przeciągniesz pole, musisz przeciągnąć je do obszaru arkusza danych zawierającego dane. Zostanie wyświetlony pionowy pasek wstawiania z wyświetlonym miejscem, w którym ma się znajdować pole.

  3. Zapisz tabelę:

    • Kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Zapiszlub naciśnij klawisze CTRL + S Button image .

Ustawianie właściwości pola w widoku projektu    Niezależnie od sposobu utworzenia tabeli warto sprawdzić i ustawić właściwości pola. Można to zrobić tylko w widoku projektu. Aby przełączyć się do widoku projektu, kliknij prawym przyciskiem myszy tabelę w okienku nawigacji, a następnie kliknij polecenie Widok projektu. Aby wyświetlić właściwości pola, kliknij pole w siatce projektu. Właściwości są wyświetlane poniżej siatki projektu w obszarze Właściwości pola.

Aby wyświetlić opis każdej właściwości pola, kliknij właściwość i Przeczytaj opis w polu obok listy właściwości w obszarze Właściwości pola. Aby uzyskać bardziej szczegółowe informacje, naciśnij klawisz F1.

W poniższej tabeli opisano niektóre właściwości pól, które są często dostosowywane.

Właściwość

Opis

Rozmiar pola

W przypadku pól tekstowych ta właściwość określa maksymalną liczbę znaków, które mogą być przechowywane w polu. Maksymalna wartość to 255. W przypadku pól typu Liczba ta właściwość określa typ liczby, która będzie przechowywana (liczba całkowita długa, Podwójna itd.). Aby zapewnić najbardziej wydajne przechowywanie danych, zaleca się przydzielenie najmniejszej ilości miejsca potrzebnego na dane. W razie potrzeby możesz dostosować wartość później.

Formatowanie

Ta właściwość określa sposób wyświetlania danych. Nie wpływa na faktyczne dane przechowywane w polu. Możesz wybrać wstępnie zdefiniowany format lub wprowadzić format niestandardowy.

Maska wprowadzania

Za pomocą tej właściwości można określić wzorzec dla wszystkich danych, które zostaną wprowadzone w tym polu. Pomaga to sprawdzić, czy wszystkie dane są wprowadzone poprawnie i czy zawierają wymaganą liczbę znaków. Aby uzyskać pomoc dotyczącą tworzenia maski wprowadzania, kliknij pozycję Przycisk Konstruktor po prawej stronie pola właściwości.

Wartość domyślna

Za pomocą tej właściwości można określić wartość domyślną, która będzie wyświetlana w tym polu za każdym razem, gdy zostanie dodany nowy rekord. Jeśli na przykład masz pole typu Data/godzina, w którym zawsze chcesz rejestrować datę dodania rekordu, możesz wpisać "Data ()" (bez cudzysłowów) jako wartość domyślną.

Wymagane

Właściwość ta określa, czy w tym polu jest wymagana wartość. Jeśli ustawisz tę właściwość na tak, program Access nie zezwoli na dodanie nowego rekordu, dopóki nie zostanie wprowadzona wartość dla tego pola.

Początek strony

Jeśli dane są obecnie przechowywane w innym programie, na przykład Office Excel 2007, możesz je skopiować i wkleić do tabeli programu Access. Zazwyczaj jest to najlepsze rozwiązanie, jeśli dane są już rozdzielone na kolumny, ponieważ znajdują się w arkuszu programu Excel. Jeśli dane są w programie do przetwarzania tekstu, najlepiej rozdzielić kolumny danych przy użyciu kart lub przekonwertować je na tabelę w programie do przetwarzania tekstów, zanim skopiujesz dane. Jeśli dane wymagają edycji lub manipulacji (na przykład rozdzielając imiona i nazwiska), warto to zrobić przed skopiowaniem danych, szczególnie jeśli nie znasz programu Access.

Po wklejeniu danych do pustej tabeli program Access ustawia typ danych każdego pola w zależności od tego, jakiego typu dane są tam znalezione. Jeśli na przykład pole "wkleine" nie zawiera wartości dat, w programie Access zostanie zastosowany typ danych Data/godzina do tego pola. Jeśli pole zawiera tylko wyrazy "tak" i "nie", program Access stosuje typ danych tak/nie do pola.

Program Access nadaje nazwy polom w zależności od tego, co znajduje się w pierwszym wierszu danych, które zostały wcześniej skopiowane. Jeśli pierwszy wiersz danych wklejenia jest podobny do poniższego tekstu, program Access ustali, że pierwszy wiersz jest częścią danych i przypisuje pola nazwy ogólne (F1, F2 itd.). Jeśli pierwszy wiersz wklejenia danych nie jest podobny do wierszy, które obserwujesz, program Access ustali, że pierwszy wiersz zawiera nazwy pól. Program Access odpowiednio nadaje polom pola i nie zawiera pierwszego wiersza danych.

Jeśli program Access przypisze nazwy pól ogólnych, należy jak najszybciej zmienić nazwy pól, aby uniknąć nieporozumień. Wykonaj następujące kroki:

  1. Zapisz tabelę.

    • Kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Zapiszlub naciśnij klawisze CTRL + S Button image .

  2. W widoku arkusza danych kliknij dwukrotnie każdy nagłówek kolumny, a następnie wpisz prawidłową nazwę pola dla każdej kolumny. Może wyglądać tak, jakby piszesz dane, ale wiersz nagłówka kolumny zawiera nazwy pól, a nie dane.

  3. Ponownie Zapisz tabelę.

Uwaga: Możesz również zmienić nazwy pól, przełączając się do widoku projektu i edytując w nim nazwy pól. Aby przełączyć się do widoku projektu, kliknij prawym przyciskiem myszy tabelę w okienku nawigacji, a następnie kliknij polecenie Widok projektu. Aby przełączyć z powrotem do widoku arkusza danych, kliknij dwukrotnie tabelę w okienku nawigacji.

Początek strony

Być może dane są przechowywane w innym programie i chcesz je zaimportować do nowej tabeli lub dołączyć je do istniejącej tabeli w programie Access. Możesz także pracować z osobami, które przechowują dane w innych programach, i chcesz pracować z nimi w programie Access, łącząc je. W każdym z tych sposobów program Access ułatwia pracę z danymi z innych źródeł. Dane z arkusza programu Excel można zaimportować z tabeli w innej bazie danych programu Access, z listy programu SharePoint lub z różnych innych źródeł. Proces, którego używasz, różni się nieco w zależności od źródła, ale wykonanie poniższej procedury spowoduje rozpoczęcie pracy.

  1. W programie Access na karcie dane zewnętrzne w grupie Importowanie kliknij polecenie dla typu importowanego pliku.

    Obraz wstążki programu Access

    Jeśli na przykład importujesz dane z arkusza programu Excel, kliknij pozycję Excel. Jeśli nie widzisz potrzebnego typu programu, kliknij pozycję więcej.

    Uwaga: Jeśli nie możesz znaleźć odpowiedniego typu formatu w grupie Importowanie , może być konieczne uruchomienie programu, w którym dane zostały pierwotnie utworzone, a następnie użycie tego programu w celu zapisania danych w typowym formacie pliku (na przykład rozdzielany plik tekstowy ), zanim będzie można zaimportować te dane. do programu Access.

  2. W oknie dialogowym pobieranie danych zewnętrznych kliknij przycisk Przeglądaj , aby znaleźć plik danych źródłowych, lub wpisz pełną ścieżkę pliku danych źródłowych w polu Nazwa pliku .

  3. Kliknij odpowiednią opcję (wszystkie programy zezwalają na importowanie, a niektóre umożliwiają dołączanie lub łączenie) w obszarze Określ sposób i miejsce przechowywania danych w bieżącej bazie danych. Możesz utworzyć nową tabelę, w której są używane importowane dane, lub (za pomocą kilku programów) można dołączyć dane do istniejącej tabeli lub utworzyć tabelę połączoną z danymi w programie źródłowym.

  4. Jeśli zostanie uruchomiony Kreator, postępuj zgodnie z instrukcjami na kolejnych kilku stronach kreatora. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

    Po zaimportowaniu obiektów lub łączenia tabel z bazy danych programu Access zostanie wyświetlone okno dialogowe Importowanie obiektów lub Łączenie tabel . Wybierz odpowiednie elementy i kliknij przycisk OK.

    Dokładny proces zależy od tego, czy użytkownik zdecyduje się zaimportować, dołączyć lub połączyć dane.

  5. W programie Access zostanie wyświetlony monit o to, czy chcesz zapisać szczegóły właśnie ukończonej operacji importowania. Jeśli uważasz, że ta sama operacja importowania będzie wykonywana w przyszłości, kliknij pozycję Zapisz kroki importowania, a następnie wprowadź szczegóły. Następnie możesz łatwo powtarzać tę operację później, klikając pozycję zapisane operacje importowania Obraz przycisku w grupie Importowanie na karcie dane zewnętrzne . Jeśli nie chcesz zapisywać szczegółów operacji, kliknij przycisk Zamknij.

W przypadku wybrania opcji importowania tabeli program Access zaimportuje dane do nowej tabeli, a następnie tabela jest wyświetlana w grupie tabele w okienku nawigacji. W przypadku wybrania opcji dołączania danych do istniejącej tabeli dane zostaną dodane do tej tabeli. W przypadku wybrania linku do danych program Access utworzy tabelę połączoną w grupie tabele w okienku nawigacji.

Początek strony

  1. Kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Otwórz.

  2. W oknie dialogowym otwieranie przejdź do bazy danych, którą chcesz otworzyć.

  3. Wykonaj jedną z następujących czynności:

    • Kliknij dwukrotnie bazę danych, aby ją otworzyć w trybie domyślnym określonym w oknie dialogowym Opcje programu Access lub w trybie ustawionym za pomocą zasad administracyjnych.

    • Kliknij przycisk Otwórz , aby otworzyć bazę danych programu Access dla współużytkowanego środowiska z wieloma użytkownikami, aby umożliwić użytkownikom odczytywanie i zapisywanie w bazie danych.

    • Kliknij strzałkę obok przycisku Otwórz , a następnie kliknij polecenie Otwórz tylko do odczytu , aby otworzyć bazę danych w trybie tylko do odczytu, aby można było ją wyświetlać, ale nie można jej edytować. Inni użytkownicy mogą nadal czytać i zapisywać dane w bazie danych.

    • Kliknij strzałkę obok przycisku Otwórz , a następnie kliknij polecenie Otwórz z wyłącznością, aby otworzyć bazę danych z wyłącznym dostępem. Jeśli baza danych jest otwarta z wyłącznym dostępem, każdy inny użytkownik próbujący otworzyć bazę danych otrzymuje komunikat "plik jest już w użyciu".

    • Kliknij strzałkę obok przycisku Otwórz , a następnie kliknij polecenie Otwórz z wyłącznością tylko do odczytu , aby otworzyć bazę danych w trybie tylko do odczytu. Inni użytkownicy mogą nadal otwierać bazę danych, ale są one ograniczone do trybu tylko do odczytu.

Jeśli nie możesz znaleźć bazy danych, którą chcesz otworzyć    

  1. W oknie dialogowym otwieranie kliknij pozycję mój komputer lub kliknij pozycję mój komputer na liście rozwijanej Szukaj w .

  2. Na liście dysków kliknij prawym przyciskiem myszy dysk, który może zawierać bazę danych, a następnie kliknij polecenie Wyszukaj.

  3. Wpisz kryteria wyszukiwania w oknie dialogowym wyniki wyszukiwania , a następnie kliknij pozycję Wyszukaj , aby wyszukać bazę danych.

  4. Jeśli baza danych zostanie znaleziona, kliknij ją dwukrotnie, aby ją otworzyć.

  5. Aby otworzyć bazę danych, należy kliknąć przycisk Anuluj w oknie dialogowym otwieranie . Następnie zamknij okno dialogowe wyniki wyszukiwania .

Uwaga: Plik danych można otworzyć bezpośrednio w formacie pliku zewnętrznego, takiego jak dBASE, Paradox, Microsoft Exchange lub Excel. Możesz również bezpośrednio otworzyć dowolne źródło danych ODBC, takie jak Microsoft SQL Server lub Microsoft FoxPro. Program Access automatycznie utworzy nową bazę danych programu Access w tym samym folderze, w którym znajduje się plik danych, i doda linki do każdej tabeli w zewnętrznej bazie danych.

  • Aby otworzyć dowolną z ostatnio otwieranych baz danych, kliknij nazwę pliku tej bazy danych na liście Otwórz ostatnio używane bazy danych na stronie wprowadzenie do programu Microsoft Office Access . W programie Access zostanie otwarta baza danych z takimi samymi ustawieniami, jakie obowiązywały podczas ostatniego otwierania. Jeśli lista ostatnio używanych plików nie jest wyświetlana, kliknij przycisk pakietu Microsoft Office , a następnie kliknij pozycję Opcje programu Access. W oknie dialogowym Opcje programu Access kliknij pozycję Zaawansowane. W obszarze Wyświetlaniewprowadź liczbę dokumentów, które mają być wyświetlane na liście ostatnio używanych dokumentów, maksymalnie dziewięć.

  • Jeśli otwierasz bazę danych, klikając przycisk pakietu Microsoft Office , a następnie używając polecenia Otwórz , możesz wyświetlić listę skrótów do baz danych, które zostały wcześniej otwarte, klikając pozycję Moje ostatnie dokumenty w otwartym okno dialogowe.

Początek strony

Podczas tworzenia nowej pustej bazy danych program Access otwiera nową tabelę, w której można wprowadzać dane, ale nie tworzy żadnych innych obiektów w bazie danych. Jeśli chcesz, aby inne obiekty, takie jak formularze, raporty, makra lub dodatkowe tabele, były obecne we wszystkich nowo tworzonych bazach danych, możesz utworzyć niestandardowy pusty szablon zawierający te obiekty. Następnie następnym razem, gdy utworzysz nową bazę danych, będzie ona już zawierać te obiekty w szablonie. Oprócz tych obiektów szablon może zawierać tabele wstępnie wypełnione danymi, a także wszelkie specjalne ustawienia konfiguracji, właściwości bazy danych, odwołania lub kod, które mają być dostępne we wszystkich nowych bazach danych.

Załóżmy na przykład, że masz kolekcję makr, których chcesz używać we wszystkich projektach. Jeśli utworzysz pusty szablon zawierający te makra, program Access będzie je zawierał we wszystkich nowo tworzonych bazach danych.

Puste szablony można tworzyć w formacie pliku Office Access 2007, w formacie pliku programu Access 2002-2003 lub w formacie pliku programu Access 2000. Szablon musi mieć nazwę blank. accdb dla formatu pliku Office Access 2007 oraz plik blank. mdb we wcześniejszych formatach plików.

  • Jeśli domyślny format pliku jest ustawiony na program Access 2000 lub Access 2002-2003, program Access użyje pustego pliku mdb jako pustej nazwy pliku szablonu. Nowa baza danych zostanie utworzona w tym samym formacie pliku, co plik blank. mdb. Na przykład, nawet jeśli domyślnym formatem plików jest program Access 2000, jeśli szablon o nazwie blank. mdb jest w formacie pliku programu Access 2002-2003, wszystkie nowo utworzone bazy danych zostaną wprowadzone w formacie Access 2002-2003.

  • Jeśli domyślny format pliku jest ustawiony na program Access 2007, w programie Access jako nazwa pliku dla pustego szablonu zostanie użyta wartość blank. accdb.

Jak zmienić domyślny format pliku?

  1. Kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Opcje programu Access.

  2. W oknie dialogowym Opcje programu Access kliknij pozycję popularne.

  3. W obszarze Tworzenie baz danychwybierz odpowiedni format z listy rozwijanej domyślny format pliku .

Aby utworzyć pusty szablon, wykonaj dowolną z następujących czynności:

  • Utwórz nową bazę danych (możesz nazwać ją pustą lub nadać jej tymczasową nazwę), a następnie zaimportuj lub Utwórz obiekty, które chcesz uwzględnić w szablonie.

  • Utwórz kopię istniejącej bazy danych, która zawiera już obiekty, które chcesz umieścić w szablonie, a następnie usuń wszelkie niepotrzebne obiekty.

Po umieszczeniu obiektów, które chcesz umieścić w szablonie, musisz zapisać go w określonej lokalizacji.

  1. Kliknij przycisk pakietu Microsoft Office, a następnie wskaż polecenie Zapisz jako.

  2. W obszarze Zapisz bazę danych w innym formaciekliknij odpowiedni format pliku szablonu.

  3. W oknie dialogowym Zapisywanie jako przejdź do jednego z następujących dwóch folderów szablonów:

    • Folder szablonów systemowych    Na przykład C:\Program Files\Microsoft Office\Templates\1033\Access

    • Folder szablonów użytkownika    Przykład:

      • W Windows Vista    c:\Users\user name\AppData\Roaming\Microsoft\Templates

      • W systemie Microsoft Windows Server 2003 lub Microsoft Windows XP    C:\Documents and and name\Application Aplikacji\microsoft\szablony

        Uwaga: Pusty szablon w folderze szablonów systemowych zastępuje puste szablony w folderach szablonów użytkowników.

  4. W polu Nazwa pliku wpisz blank. accdb (lub blank. mdb), jeśli tworzysz szablon we wcześniejszej wersji, a następnie kliknij przycisk Zapisz.

Po utworzeniu nowej pustej bazy danych w nowym szablonie zostaną uwzględnione wszystkie obiekty w szablonie, które są domyślnie tworzone w nowej bazie danych. W programie Access zostanie otwarta nowa tabela w widoku arkusza danych, ponieważ podczas tworzenia nowych pustych baz danych bez użycia szablonu.

Aby zrezygnować z używania pustego szablonu, usuń plik o nazwie blank. accdb (lub blank. mdb), aby uzyskać dostęp do wcześniejszych wersji programu Access.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×