Tworzenie modelu danych w programie Excel

Tworzenie modelu danych w programie Excel

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Model danych umożliwia Integracja danych z wielu tabel, efektywne tworzenie relacyjne źródło danych w skoroszycie programu Excel. W programie Excel modele danych są używane przejrzysty, dostarczając tabelaryczny dane używane w tabelach przestawnych i wykresów przestawnych. Model danych jest zwizualizować jako kolekcja tabel w listę pól, a w większości przypadków, będzie jeszcze nigdy nie wiadomo, że jest dostępna.

Przed rozpoczęciem pracy z modelem danych jest potrzebne do uzyskania niektóre dane. W tym firma Microsoft będzie Użyj Get i przekształcanie środowisko (Power Query), dlatego warto przejąć kroku i Obejrzyj klip wideo lub wykonaj naszego przewodnika nauki na pobieranie i przekształcenie i dodatku Power Pivot.

Gdzie jest PowerPivot?

Gdzie jest pobieranie i Przekształć (Power Query)?

  • Excel 2016 i Excel dla usługi Office 365 — pobierania i przekształcania (Power Query) został zintegrowany z programem Excel na karcie dane.

  • Program Excel 2013 — Power Query jest dodatek, która wchodzi w programie Excel, ale musi zostać aktywowana. Przejdź do pozycji plik > Opcje > Dodatki w Zarządzanie listy rozwijanej u dołu okienka, zaznacz Dodatki COM > Przejdź. Zaznacz Dodatek Microsoft Power Query dla programu Excel, następnie przycisk OK, aby go uaktywnić. Karta Power Query zostaną dodane do wstążki.

  • Program Excel 2010Pobieranie i instalowanie dodatku Power Query. Po uaktywnieniu karty Power Query zostaną dodane do wstążki.

Wprowadzenie

Najpierw musisz uzyskać niektóre dane.

  1. W programie Excel 2016 i w programie Excel dla usługi Office 365 za pomocą danych > pobierania i przekształcania danych > Pobieranie danych do importowania danych z liczbą źródeł danych zewnętrznych, takich jak plik tekstowy, skoroszyt programu Excel, witryny sieci Web, programu Microsoft Access, SQL Server lub innego relacyjne bazy danych zawierającej wiele powiązanych tabel.

    W programie Excel 2013 i 2010, przejdź do Dodatku Power Query > Pobieranie danych zewnętrznych i wybierz źródło danych.

  2. Program Excel jest wyświetlany monit o wybranie tabeli. Jeśli chcesz dodać wiele tabel z tego samego źródła danych, zaznacz opcję Włącz zaznaczanie wielu tabel . Po wybraniu wielu tabel programu Excel automatycznie tworzy modelu danych.

    Uwaga: W tych przykładach użyto programu skoroszytu programu Excel z fikcyjnej uczniów szczegółowych informacji na temat klas i ocen. Można pobrać naszych modelu danych uczniów przykładowego skoroszytui wykonać opisane czynności. Możesz także pobrać wersję z modelem danych złożonym..

    Pobieranie i Przekształć Nawigator (Power Query)
  3. Zaznacz jedną lub więcej tabel, a następnie kliknij przycisk Załaduj.

    Jeśli potrzebujesz do edycji źródła danych, możesz wybrać opcję Edytuj. Aby uzyskać więcej informacji, zobacz: Wprowadzenie do edytora zapytań (Power Query).

Możesz teraz masz modelu danych, zawierającą wszystkie tabele zaimportowane i pojawi się Lista pól tabeli przestawnej.

Uwagi: 

  • Modele są tworzone niejawnie w przypadku jednoczesnego zaimportowania w programie Excel co najmniej dwóch tabel.

  • Modele są tworzone jawnie, korzystając z dodatku programu Power Pivot do importowania danych. W dodatku model jest reprezentowane w układzie kartach podobne do programu Excel, w którym każda karta zawiera dane tabelaryczne. Zobacz Pobieranie danych przy użyciu dodatek Power Pivot, aby uzyskać podstawowe informacje o importowanie danych przy użyciu bazy danych programu SQL Server.

  • Model może zawierać jedną tabelę. Aby utworzyć modelu, na podstawie jednej tabeli, zaznacz tabelę i kliknij pozycję Dodaj do modelu danych w Power Pivot. Można to zrobić, jeśli chcesz korzystać z funkcji Power Pivot, takich jak filtrowanych zestawów danych, kolumny obliczeniowe, pola obliczeniowe, kluczowych wskaźników wydajności i hierarchie.

  • Relacje między tabelami mogą być tworzone automatycznie w razie importowania powiązanych tabel, które mają relacje oparte na kluczu podstawowym i obcym. Program Excel zwykle może używać zaimportowanych informacji o relacjach jako podstawy relacji między tabelami w modelu danych.

  • Aby uzyskać porady dotyczące zmniejszania rozmiaru modelu danych zobacz Tworzenie modelu danych zapewniającego wydajną obsługę pamięci za pomocą programu Excel i dodatku Power Pivot.

  • Aby uzyskać więcej informacji, zobacz Samouczek: Analiza danych tabel przestawnych przy użyciu modelu danych w programie Excel.

Porada: Skąd wiadomo, jeśli skoroszyt zawiera Model danych? Przejdź do pozycji Power Pivot > Zarządzaj. Jeśli zobaczysz przypominających arkusz danych modelu istnieje. Zobacz: Określanie źródeł danych używanych w modelu danych skoroszytu , aby dowiedzieć się więcej.

Tworzenie relacji między tabelami

Następnym krokiem jest utworzenie relacji między tabelami, więc możesz pobrać dane z dowolnej z nich. Każda tabela musi mieć klucz podstawowy lub unikatowe pole Identyfikator, takie jak identyfikator uczniów lub numer zajęć. Najprostszym sposobem jest przeciągania i upuszczania tych pól, aby połączyć je w dodatku Power Pivot w Widok diagramu.

  1. Wybierz pozycję PowerPivot > Zarządzaj.

  2. Na karcie Narzędzia główne wybierz pozycję Widok diagramu.

  3. Zostaną wyświetlone wszystkie zaimportowanych tabel, a chcesz może zająć trochę czasu, aby zmienić rozmiar ich w zależności od tego, jak wiele pól ma każdego z nich.

  4. Następnie przeciągnij klucz podstawowy z jednej tabeli do drugiej. Poniższy przykład jest widok diagramu naszych tabel uczniów:

    Widoku diagramu relacji modelu danych dodatku kwerendy

    Firma Microsoft utworzono następujące łącza:

    • tbl_Students | ID studenta > tbl_Grades | ID studenta

      Innymi słowy przeciągnij pole ID studenta z tabeli uczniów lub studentów do pola Identyfikator uczniów w tabeli ocen.

    • tbl_Semesters | Identyfikator semestru > tbl_Grades | Semestru

    • tbl_Classes | Klasy numer > tbl_Grades | Liczba zajęć

    Uwagi: 

    • Nazwy pól nie musi być taka sama w celu utworzenia relacji, ale muszą być tego samego typu danych.

    • Łączniki w Widoku diagramu jest "1" na jednej stronie, a "*" z drugiej strony. Oznacza to, że nie ma relacji jeden do wielu między tabelami i określa, jak dane są używane w tabel przestawnych. Zobacz: relacje między tabelami w modelu danych , aby dowiedzieć się więcej.

    • Tylko łączniki wskazują, że istnieje relacja między tabelami. Są faktyczną niewidoczne pola, które są połączone ze sobą. Aby wyświetlić łącza, przejdź do Dodatku PowerPivot > Zarządzaj > Projektowanie > Relacje > Zarządzanie relacjami. W programie Excel, możesz przejść do dane > Relacje.

Tworzenie tabeli przestawnej lub wykresu przestawnego za pomocą modelu danych

Skoroszyt programu Excel może zawierać tylko jeden Model danych, ale tego modelu zawierać wiele tabel, których można używać wielokrotnie w całym skoroszycie. Możesz dodać więcej tabel do istniejącego modelu danych w dowolnym momencie.

  1. W Power Pivotprzejdź do pozycji Zarządzaj.

  2. Na karcie Narzędzia główne zaznacz tabelę przestawną.

  3. Wybierz miejsce, w którym chcesz umieścić tabelę przestawną: nowy arkusz lub bieżącej lokalizacji.

  4. Kliknij przycisk OK, a program Excel doda pustą tabelę przestawną z okienka Lista pól wyświetlane po prawej stronie.

    Lista pól tabeli przestawnej programu Power Pivot

Dalej, Tworzenie tabeli przestawnejlub wykresu przestawnego. Jeśli masz już utworzony relacje między tabelami, możesz użyć dowolnej z ich pól w tabeli przestawnej. Firma Microsoft już utworzony relacje w modelu danych uczniów przykładowego skoroszytu.

Dodawanie istniejących, niepowiązanych danych do modelu danych

Załóżmy, że zostały zaimportowane lub skopiowanego dużej ilości danych, aby użyć w modelu, ale nie zostały dodane do modelu danych. Przekazywanie nowych danych do modelu jest prostsze niż się wydaje.

  1. Rozpocznij, wybierając dowolną komórkę w obrębie dane, które chcesz dodać do modelu. Może być dowolny zakres danych, ale najlepiej danych w formacie tabeli programu Excel .

  2. Dodaj dane, stosując jedną z tych metod:

  3. Kliknij pozycję Power Pivot > Dodaj do modelu danych.

  4. Kliknij przycisk Wstaw > Tabela przestawna, a następnie zaznacz Dodaj te dane do modelu danych w oknie dialogowym Tworzenie tabeli przestawnej.

Zakres lub tabela teraz zostanie dodane do modelu jako tabelę połączoną. Aby uzyskać więcej informacji na temat pracy z tabelami połączonymi w modelu, zobacz Dodawanie danych przy użyciu połączonych tabel w dodatku Power Pivot.

Dodawanie danych do tabeli Power Pivot

W Power Pivot nie można dodać wiersza do tabeli, wpisując bezpośrednio w nowym wierszu, jak w arkuszu programu Excel. Ale możesz dodać wiersze, kopiując i wklejająclub aktualizowanie danych źródłowych i odświeżania modelu dodatku Power Pivot.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Prowadnice nauki GET i przekształcenie i dodatku Power Pivot

Wprowadzenie do edytora zapytań (Power Query)

Tworzenie modelu danych zapewniającego wydajną obsługę pamięci za pomocą programu Excel i dodatku Power Pivot

Samouczek: Analiza danych tabel przestawnych przy użyciu modelu danych w programie Excel

Dowiedz się, jakie dane źródeł używanych w modelu danych skoroszytu

Relacje między tabelami w modelu danych

Pobierz skoroszyt przykładowy Model danych uczniów

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×