Tworzenie lub usuwanie tabeli programu Excel w arkuszu

Po utworzeniu tabeli (wcześniej nazywanej listą) w arkuszu programu Microsoft Office Excel można zarządzać danymi w tabeli i analizować je niezależnie od danych poza tabelą. Można na przykład filtrować kolumny tabeli, dodawać wiersze sum, stosować formatowanie do tabeli oraz publikować tabelę na serwerze z uruchomionym programem Windows SharePoint Services 3.0.

Dane w tabeli programu Excel

Jeśli nie chcesz już pracować z danymi w tabeli, możesz przekonwertować tabelę na zwykły zakres, zachowując zastosowane formatowanie stylu. Jeśli tabela nie jest już potrzebna, można ją usunąć.

Uwaga : Tabel programu Excel nie należy mylić z tabelami danych, które są częścią pakietu poleceń analizy warunkowej. Aby uzyskać więcej informacji na temat tabel danych, zobacz Obliczanie wielu wyników za pomocą tabeli danych.

Co chcesz zrobić?

Tworzenie tabeli

Konwertowanie tabeli na zakres danych

Usuwanie tabeli

Tworzenie tabeli

Tabelę można utworzyć na dwa sposoby. Można wstawić tabelę o domyślnym stylu tabeli lub sformatować dane jako tabelę w wybranym przez siebie stylu.

Wstawianie tabeli

  1. W arkuszu zaznacz zakres komórek, które chcesz umieścić w tabeli. Komórki mogą być puste lub zawierać dane.

  2. Na karcie Wstawianie w grupie Tabele kliknij przycisk Tabela.

    Obraz Wstążki programu Excel

    Skrót klawiaturowy  Można także nacisnąć klawisze CTRL+L lub CTRL+T.

  3. Jeśli zaznaczony zakres zawiera dane, które mają być wyświetlane jako nagłówki tabeli, zaznacz pole wyboru Moja tabela ma nagłówki.

    Jeśli pole Moja tabela ma nagłówki nie zostanie zaznaczone, nagłówki tabeli będą zawierały domyślne nazwy. Można zmienić domyślne nazwy, wpisując własny tekst.

    Uwaga : Jeśli nie chcesz, aby nagłówki tabeli były wyświetlane, możesz później je wyłączyć. Aby uzyskać więcej informacji na temat wyłączania nagłówków tabeli, zobacz Włączanie lub wyłączanie nagłówków w tabeli programu Excel.

Porady

  • Po utworzeniu tabeli zostanie wyświetlony obszar Narzędzia tabel wraz z kartą Projektowanie. Za pomocą narzędzi znajdujących się na karcie Projektowanie można dostosowywać i edytować tabelę.

  • W przeciwieństwie do list programu Office Excel 2003 tabele nie mają specjalnego wiersza (oznaczonego znakiem *) do szybkiego dodawania nowych wierszy. Aby uzyskać więcej informacji na temat dodawania lub wstawiania wierszy w tabeli, zobacz Dodawanie i usuwanie wierszy i kolumn w tabeli programu Excel.

Formatowanie danych jako tabeli

  1. Zaznacz w arkuszu zakres pustych komórek lub komórek zawierających dane, które chcesz szybko sformatować jako tabelę.

  2. Na karcie Narzędzia główne w grupie Style kliknij pozycję Formatuj jako tabelę.

    Obraz Wstążki programu Excel

    Uwaga : W przypadku użycia polecenia Formatuj jako tabelę program Office Excel automatycznie wstawia tabelę.

  3. W obszarze Jasny, Średni lub Ciemny kliknij styl tabeli, którego chcesz użyć.

    Uwaga : Niestandardowe style tabeli są dostępne w obszarze Niestandardowe, gdy zostanie utworzony co najmniej jeden styl niestandardowy. Aby uzyskać więcej informacji na temat tworzenia niestandardowego stylu tabeli, zobacz Formatowanie tabeli programu Excel.

Porady

  • Po utworzeniu tabeli zostanie wyświetlony obszar Narzędzia tabel wraz z kartą Projektowanie. Za pomocą narzędzi znajdujących się na karcie Projektowanie można dostosowywać i edytować tabelę.

  • W przeciwieństwie do list programu Office Excel 2003 tabele nie mają specjalnego wiersza (oznaczonego znakiem *) do szybkiego dodawania nowych wierszy. Aby uzyskać więcej informacji na temat dodawania lub wstawiania wierszy w tabeli, zobacz Dodawanie i usuwanie wierszy i kolumn w tabeli programu Excel.

Początek strony

Konwertowanie tabeli na zakres danych

  1. Kliknij w dowolnym miejscu tabeli.

    Porada : Zostanie wyświetlony obszar Narzędzia tabel wraz z kartą Projektowanie.

  2. Na karcie Projektowanie w grupie Narzędzia kliknij pozycję Konwertuj na zakres

    Obraz Wstążki programu Excel

    Uwaga : Po przekonwertowaniu tabeli na zakres danych funkcje tabeli nie są już dostępne. Na przykład nagłówki wierszy nie zawierają już strzałek sortowania i filtrowania, a odwołania strukturalne (odwołania, które używają nazw tabel) używane w formułach zmieniają się na standardowe odwołania do komórek.

Porady

  • Można także kliknąć tabelę prawym przyciskiem myszy, wskazać polecenie Tabela, a następnie kliknąć polecenie Konwertuj na zakres.

  • Natychmiast po utworzeniu tabeli można też kliknąć przycisk Cofnij Obraz przycisku na pasku narzędzi Szybki dostęp, aby przekonwertować tabelę z powrotem na zakres.

Początek strony

Usuwanie tabeli

  1. Zaznacz tabelę w arkuszu.

  2. Naciśnij klawisz DELETE.

Porada : Aby usunąć tabelę, która została właśnie utworzona, można też kliknąć przycisk Cofnij Obraz przycisku na pasku narzędzi Szybki dostęp.

Początek strony

Czy te informacje były pomocne?

Jak możemy to poprawić?

Jak możemy to poprawić?

Aby chronić swoją prywatność, nie dołączaj do opinii informacji o kontakcie. Przejrzyj nasze zasady zachowania poufności informacji.

Dziękujemy za opinię!