Tworzenie lub usuwanie tabeli programu Excel

Tworzenie lub usuwanie tabeli programu Excel

Utworzenie tabeli w arkuszu programu Excel pozwala nie tylko łatwiej zarządzać danymi i je analizować, ale daje też dostęp do wbudowanych funkcji filtrowania, sortowania i cieniowania wierszy przy użyciu opcji Wiersze naprzemienne oraz umożliwia stosowanie różnych formuł w obszarze Wiersz sumy.

Przykładowe dane sformatowane jako tabela programu Excel

Uwagi : 

  • Tabel programu Excel nie należy mylić z tabelami danych, które są częścią pakietu poleceń analizy warunkowej (Narzędzia danych na karcie Dane). Zobacz Wprowadzenie do analizy warunkowej, aby uzyskać więcej informacji.

  • Zrzuty ekranu w tym artykule zostały wykonane w programie Excel 2016. Jeśli masz inną wersję programu, wygląd może się nieco różnić, ale funkcje pozostają takie same, chyba że zaznaczono inaczej.

Tworzenie tabeli przy użyciu wybranego stylu

  1. W zakresie komórek zaznacz dowolną komórkę, którą chcesz uwzględnić w tabeli.

  2. Na karcie Narzędzia główne kliknij pozycję Style > Formatuj jako tabelę > wybierz odpowiedni styl z tabeli Galeria stylów.

    Galeria stylów programu Excel dla pozycji Formatuj jako tabelę
  3. Program Excel automatycznie wyróżni zakres danych dla tabeli, a adres zakresu będzie widoczny w oknie dialogowym Formatowanie jako tabeli. W razie potrzeby zakres ten można jednak dostosować. Jeśli górny wiersz zaznaczonego zakresu zawiera dane, których chcesz użyć jako nagłówków tabeli, zaznacz pole wyboru Moja tabela ma nagłówki. Jeśli nie zostanie zaznaczone pole wyboru Moja tabela ma nagłówki, nad danymi w tabeli zostaną dodane nagłówki z nazwami domyślnymi, takimi jak Kolumna1 i Kolumna2. W dowolnym momencie możesz zmodyfikować domyślne nazwy nagłówków. Aby uzyskać więcej informacji, zobacz Włączanie lub wyłączanie nagłówków w programie Excel.

    Przykład użycia pozycji Formatuj jako tabelę na karcie Narzędzia główne w celu automatycznego zaznaczenia zakresu danych

    Po kliknięciu przycisku OK program Excel sformatuje zakres danych jako tabelę przy użyciu wybranego stylu.

    W dowolnej chwili możesz zmienić bieżący styl, wybierając nowy z Galerii stylów. Możesz również utworzyć własny styl tabeli, który będzie używany w bieżącym skoroszycie, wybierając opcję Nowy styl tabeli w Galerii stylów. Utworzony niestandardowy styl tabeli będzie dostępny w ramach bieżącego skoroszytu po kliknięciu pozycji Formatuj jako tabelę > Niestandardowe w obszarze Galeria stylów. Aby uzyskać więcej informacji, zobacz Formatowanie tabeli programu Excel.

  1. W zakresie komórek zaznacz dowolną komórkę, którą chcesz uwzględnić w tabeli.

  2. Kliknij pozycję Wstawianie > Tabela.

    Grupa Tabele na karcie Wstawianie

    Porada : Skrót klawiaturowy: Naciśnij klawisze Ctrl+T lub Ctrl+L.

  3. W przypadku użycia tej metody program Excel wyświetli okno dialogowe Tworzenie tabeli. Jeśli górny wiersz zaznaczonego zakresu zawiera dane, których chcesz użyć jako nagłówków tabeli, zaznacz pole wyboru Moja tabela ma nagłówki.

    Tworzenie tabeli

    Jeśli nie zostanie zaznaczone pole Moja tabela ma nagłówki, nad danymi w tabeli zostaną dodane nagłówki z nazwami domyślnymi, takimi jak Kolumna1 i Kolumna2. W dowolnym momencie można zmodyfikować domyślne nazwy nagłówków. Aby uzyskać więcej informacji, zobacz Włączanie lub wyłączanie nagłówków w programie Excel.

  • Po utworzeniu tabeli zostanie udostępniony obszar Narzędzia tabel z wyświetloną kartą Projektowanie. Za pomocą narzędzi na karcie Projektowanie można dostosować lub edytować tabelę. Należy pamiętać, że karta Projektowanie jest widoczna dopiero po zaznaczeniu co najmniej jednej komórki w tabeli.

    Obraz opcji Narzędzia tabel na Wstążce, kiedy jest zaznaczona komórka tabeli

    Na komputerach Mac opcje tabeli są dostępne w karcie Tabela na Wstążce.

  • Po utworzeniu tabeli obok niej zostanie wyświetlony przycisk Szybka analiza Obraz przycisku . Kliknij ten przycisk, aby wyświetlić narzędzia pomocne podczas analizy danych, takie jak formatowanie warunkowe, wykresy przebiegu w czasie, wykresy i formuły.

  • Aby dodać wiersz, możesz po prostu zacząć wpisywać w dowolnym miejscu w pustym wierszu bezpośrednio pod tabelą lub zaznaczyć ostatnią komórkę w ostatnim wierszu tabeli i nacisnąć klawisz Tab.

    W powyższym przykładzie naciśnięcie klawisza Tab po zaznaczeniu komórki C4 spowoduje dodanie piątego wiersza do tabeli i przeniesienie zaznaczenia do pierwszej kolumny w nowym wierszu — komórki A5.

    Zaznacz ostatnią komórkę i naciśnij klawisz Tab, aby dodać nowy wiersz tabeli

Usuwanie tabeli bez utraty danych i formatowania

Po utworzeniu tabeli jej funkcjonalność może nie być już potrzebna. Warty zachowania może być sam styl tabeli, ale bez funkcjonalności. Aby nie utracić zastosowanego formatowania stylu tabeli po zaprzestaniu pracy z jej danymi, można przekonwertować tabelę na standardowy zakres danych w arkuszu.

  1. Kliknij w dowolnym miejscu tabeli.

    Zostanie wyświetlona karta Narzędzia tabel na wstążce.

  2. Na karcie Projektowanie w grupie Narzędzia kliknij pozycję Konwertuj na zakres

    Obraz Wstążki programu Excel

    -- LUB --

    Kliknij prawym przyciskiem myszy tabelę i kliknij pozycję Konwertuj na zakres.

    Na komputerach Mac przejdź do pozycji Tabela > Konwertuj na zakres

    Po przekonwertowaniu tabeli na zakres danych funkcje tabeli nie są już dostępne. Na przykład nagłówki wierszy nie zawierają już strzałek sortowania i filtrowania, a wszelkie odwołania strukturalne używane w formułach zmieniają się na standardowe odwołania do komórek. Aby uzyskać więcej informacji, zobacz Używanie odwołań strukturalnych w tabelach programu Excel.

Usuwanie całej tabeli

  1. Zaznacz całą tabelę, wybierając dowolną komórkę nagłówka i naciskając klawisze Ctrl+A w celu zaznaczenia wszystkich jej komórek.

  2. Naciśnij klawisz Delete.

Czyszczenie danych z zachowaniem tabeli

Aby zachować strukturę i formatowanie tabeli, ale usunąć dane, wykonaj następujące czynności:

  1. Zaznacz wszystkie wiersze z tabeli z wyjątkiem nagłówków.

  2. Na karcie Narzędzia główne przejdź do pozycji Edytowanie > Wyczyść > Wyczyść zawartość.

  3. Aby wyczyścić nagłówki, zaznacz wszystkie komórki w danym wierszu i wybierz pozycję Wyczyść > Wyczyść zawartość.

Uwaga : Jeśli zaznaczysz całą tabelę, użycie polecenia Wyczyść > Wyczyść zawartość spowoduje usunięcie przez program Excel zaznaczonych danych, a także tabeli.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Omówienie tabel programu Excel

Klip wideo: tworzenie i formatowanie tabeli programu Excel

Sumowanie danych w tabeli programu Excel

Formatowanie tabeli programu Excel

Zmienianie rozmiaru tabeli przez dodanie lub usunięcie wierszy i kolumn

Filtrowanie danych w zakresie lub tabeli

Konwertowanie tabeli na zakres

Używanie odwołań strukturalnych w tabelach programu Excel

Problemy ze zgodnością tabel w programie Excel

Eksportowanie tabeli programu Excel do programu SharePoint

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×