Tworzenie konspektu danych (grupowanie danych) w arkuszu

Aby pogrupować dane umieszczone na liście danych i podsumować tę listę, można utworzyć konspekt mający do ośmiu poziomów — po jednym dla każdej grupy. Na każdym poziomie wewnętrznym, który jest reprezentowany przez wyższą liczbę w grupie symbole konspektu, wyświetlane są dane szczegółowe dla wcześniejszego poziomu zewnętrznego, który jest reprezentowany przez niższą liczbę w grupie symboli konspektu. Konspekt umożliwia szybkie wyświetlenie wierszy lub kolumn podsumowań, a także wyświetlenie danych szczegółowych poszczególnych grup. Konspekt można utworzyć dla wierszy (tak jak w poniższym przykładzie), dla kolumn lub dla wierszy i kolumn.

Konspekt listy
Wiersz danych sprzedaży w konspekcie, zawierający dane pogrupowane według regionów geograficznych i miesięcy, z wyświetlonymi wieloma wierszami podsumowań i szczegółów.

1.  Aby wyświetlić wiersze dla danego poziomu, kliknij odpowiednie symbole konspektu Jeden Dwa Trzy .

2.  Poziom 1 zawiera sumę sprzedaży dla wszystkich wierszy.

3.  Poziom 2 zawiera sumy sprzedaży dla poszczególnych miesięcy w poszczególnych regionach.

4.  Poziom 3 zawiera wiersze szczegółów (w tym przypadku wiersze od 11 do 13).

5.  Aby rozwinąć lub zwinąć dane konspektu, kliknij odpowiednio symbole konspektu plus albo minus .

Co chcesz zrobić?

Tworzenie konspektu wierszy

Tworzenie konspektu kolumn

Pokazywanie lub ukrywanie danych konspektu

Dostosowywanie konspektu przy użyciu stylów

Kopiowanie danych konspektu

Ukrywanie lub usuwanie konspektu

Tworzenie raportu podsumowującego z wykresem

Tworzenie konspektu wierszy

  1. Upewnij się, że każda kolumna danych, które chcesz uwzględnić w konspekcie, ma etykietę w pierwszym wierszu i każda kolumna zawiera podobne fakty, a zakres nie zawiera pustych wierszy ani kolumn.

  2. Upewnij się, że wiersze szczegółów mają dołączony wiersz podsumowania — sumę częściową. Wykonaj jedną z następujących czynności:

    Wstawianie wierszy podsumowań przy użyciu polecenia Suma częściowa    

    • Użyj polecenia Suma częściowa, które pozwala wstawić funkcję SUMY.CZĘŚCIOWE bezpośrednio poniżej lub powyżej każdej grupy wierszy szczegółów i automatycznie utworzyć konspekt. Aby uzyskać więcej informacji o używaniu funkcji sum częściowych, zobacz temat SUMY.CZĘŚCIOWE, funkcja.

      Wstawianie własnych wierszy podsumowań    

    • Wprowadź własne wiersze podsumowań z formułami bezpośrednio pod lub nad każdą grupą wierszy szczegółów. Na przykład pod (lub nad) wierszami z danymi sprzedaży za marzec i kwiecień użyj funkcji SUMA, aby uzyskać sumę częściową sprzedaży w tych miesiącach. W dalszej części tego tematu znajduje się tabela przedstawiająca odpowiedni przykład.

  3. Określ, czy wiersze podsumowań są umieszczone pod, czy nad wierszami szczegółów. Na karcie Dane w grupie Konspekt kliknij przycisk uruchamiania okna dialogowego Konspekt.
    W grupie Konspekt kliknij przycisk uruchamiania okna dialogowego

  4. Jeżeli wiersze podsumowań znajdują się nad wierszami szczegółów, usuń zaznaczenie pola wyboru Wiersze podsumowań poniżej szczegółów. W przeciwnym razie pozostaw je zaznaczone.

  5. Utwórz konspekt danych. Wykonaj jedną z następujących czynności:

    Automatyczne tworzenie konspektu danych

    1. W razie potrzeby zaznacz komórkę w zakresie komórek, dla których ma być utworzony konspekt.

    2. Na karcie Dane w grupie Konspekt kliknij strzałkę poniżej przycisku Grupuj, a następnie kliknij polecenie Autokonspekt.

      Kliknij strzałkę poniżej przycisku Grupuj, a następnie kliknij polecenie Autokonspekt

    Ręczne tworzenie konspektu danych

    Ważne :  W przypadku ręcznego grupowania poziomów konspektu najlepiej wyświetlić wszystkie dane, aby uniknąć pomyłek przy grupowaniu wierszy.

    1. Utwórz konspekt grupy zewnętrznej.

      Jak utworzyć konspekt grupy zewnętrznej

      1. Zaznacz wszystkie podrzędne wiersze podsumowań oraz powiązane z nimi wiersze szczegółów.

        Na przykład w danych poniżej wiersz 6 zawiera sumy częściowe wierszy od 2 do 5, wiersz 10 zawiera sumy częściowe wierszy od 7 do 9, a wiersz 11 zawiera sumy końcowe. Aby pogrupować wszystkie dane szczegółowe dla wiersza 11, należy zaznaczyć wiersze od 2 do 10.

         

        A

        B

        C

        1

        Region

        Miesiąc

        Sprzedaż

        2

        Wschód

        Marzec

        96470 zł

        3

        Wschód

        Marzec

        41010 zł

        4

        Wschód

        Marzec

        71150 zł

        5

        Wschód

        Marzec

        29570 zł

        6

        Wschód

        Suma w marcu

        238200 zł

        7

        Wschód

        Kwiecień

        42570 zł

        8

        Wschód

        Kwiecień

        18290 zł

        9

        Wschód

        Kwiecień

        65500 zł

        10

        Wschód

        Suma w kwietniu

        126360 zł

        11

        Suma dla regionu wschodniego

        364560 zł

        Ważne : Zaznaczenie nie powinno obejmować wiersza podsumowania (wiersza 11).

      2. Na karcie Dane w grupie Konspekt kliknij przycisk Grupuj, kliknij pozycję Wiersze, a następnie kliknij przycisk OK.

        Kliknij pozycję Wiersze, a następnie kliknij przycisk OK

        Symbole konspektu są wyświetlane na ekranie obok grupy.

    2. Ewentualnie utwórz konspekt wewnętrznej, zagnieżdżonej grupy — wiersze szczegółów dotyczące odpowiedniej sekcji danych.

      Jak utworzyć konspekt wewnętrznych, zagnieżdżonych grup (grup wierszy szczegółów)

      1. Dla każdej wewnętrznej, zagnieżdżonej grupy zaznacz wiersze szczegółów przylegające do wiersza zawierającego wiersz podsumowania.

        W poniższym przykładzie w celu pogrupowania wierszy od 2 do 5, podsumowanych w wierszu 6, należy zaznaczyć wiersze od 2 do 5. Aby pogrupować wiersze od 7 do 9, podsumowane w wierszu 10, należy zaznaczyć wiersze od 7 do 9.

         

        A

        B

        C

        1

        Region

        Miesiąc

        Sprzedaż

        2

        Wschód

        Marzec

        96470 zł

        3

        Wschód

        Marzec

        41010 zł

        4

        Wschód

        Marzec

        71150 zł

        5

        Wschód

        Marzec

        29570 zł

        6

        Wschód

        Suma w marcu

        238200 zł

        7

        Wschód

        Kwiecień

        42570 zł

        8

        Wschód

        Kwiecień

        18290 zł

        9

        Wschód

        Kwiecień

        65500 zł

        10

        Wschód

        Suma w kwietniu

        126360 zł

        11

        Suma dla regionu wschodniego

        364560 zł

        Ważne : Zaznaczenie nie powinno obejmować wiersza podsumowania.

      2. Na karcie Dane w grupie Konspekt kliknij przycisk Grupuj.

        Kliknij przycisk Grupuj na karcie Dane

        Symbole konspektu są wyświetlane na ekranie obok grupy.

      3. Kontynuuj zaznaczanie i grupowanie wierszy wewnętrznych, aż utworzysz wszystkie poziomy, które ma obejmować konspekt.

      4. Aby rozgrupować wiersze, zaznacz je, a następnie na karcie Dane w grupie Konspekt kliknij przycisk Rozgrupuj.

        Możesz także rozgrupować sekcje konspektu bez usuwania całego konspektu. Przytrzymaj naciśnięty klawisz SHIFT i kliknij przycisk Pole plus lub Pole minus dla grupy, a następnie na karcie Dane w grupie Konspekt kliknij przycisk Rozgrupuj.

        Ważne : Jeśli konspekt zostanie rozgrupowany, gdy dane szczegółowe będą ukryte, wiersze szczegółów mogą pozostać ukryte. Aby wyświetlić dane, przeciągnij wskaźnikiem myszy przez widoczne numery wierszy przylegających do ukrytych wierszy. Na karcie Narzędzia główne w grupie Komórki kliknij przycisk Formatowanie, wskaż pozycję Ukryj i odkryj i kliknij polecenie Odkryj wiersze.

Początek strony

Tworzenie konspektu kolumn

  1. Upewnij się, że każdy wiersz danych, które chcesz uwzględnić w konspekcie, ma etykietę w pierwszej kolumnie, że każdy wiersz zawiera podobne fakty, a zakres nie zawiera pustych wierszy ani kolumn.

  2. Wstaw własne kolumny podsumowań z formułami bezpośrednio po prawej lub po lewej stronie każdej grupy kolumn szczegółów. W tabeli wymienionej w kroku 4 poniżej znajduje się odpowiedni przykład.

    Uwaga :  Aby można było utworzyć konspekt danych według kolumn, muszą istnieć kolumny podsumowań zawierające formuły odwołujące się do komórek we wszystkich kolumnach szczegółów danej grupy.

  3. Określ, czy kolumna podsumowania jest położona po prawej, czy po lewej stronie kolumn szczegółów. Na karcie Dane w grupie Konspekt kliknij przycisk uruchamiający okno dialogowe Konspekt.

    Jak określić lokalizację kolumny podsumowania

    1. Na karcie Dane w grupie Konspekt kliknij przycisk uruchamiający okno dialogowe Konspekt.

      W grupie Konspekt kliknij przycisk uruchamiania okna dialogowego

    2. Jeśli kolumna podsumowania znajduje się po lewej stronie kolumny szczegółów, wyczyść pole wyboru Kolumny podsumowań po prawej stronie szczegółów. Jeśli kolumna podsumowania znajduje się po prawej stronie kolumny szczegółów, zaznacz pole wyboru Kolumny podsumowań po prawej stronie szczegółów.

    3. Kliknij przycisk OK.

  4. Aby utworzyć konspekt danych, wykonaj jedną z następujących czynności:

    Automatyczne tworzenie konspektu danych

    1. W razie potrzeby zaznacz komórkę w zakresie.

    2. Na karcie Dane w grupie Konspekt kliknij strzałkę poniżej przycisku Grupuj, a następnie kliknij polecenie Autokonspekt.

    Ręczne tworzenie konspektu danych

    Ważne :  W przypadku ręcznego grupowania poziomów konspektu najlepiej wyświetlić wszystkie dane, aby uniknąć pomyłek przy grupowaniu kolumn.

    1. Utwórz konspekt grupy zewnętrznej.

      Jak utworzyć konspekt grupy zewnętrznej (wszystkie kolumny z wyjątkiem sumy końcowej)

      1. Zaznacz wszystkie podrzędne kolumny podsumowań oraz powiązane z nimi dane szczegółowe.

        W poniższym przykładzie kolumna E zawiera sumy częściowe kolumn od B do D, kolumna I zawiera sumy częściowe kolumn od F do H, a kolumna J zawiera sumy końcowe. Aby pogrupować wszystkie dane szczegółowe dla kolumny J, należy zaznaczyć kolumny od B do I.

         

        A

        B

        C

        D

        E

        L

        Bez ograniczeń

        g

        I

        S

        1

        Region

        Sty

        Lut

        Mar

        Kwartał1

        Kwi

        Maj

        Cze

        Kwartał2

        Półrocze1

        2

        Wschód

        371

        504

        880

        1755

        186

        653

        229

        1068

        2823

        3

        Zachód

        192

        185

        143

        520

        773

        419

        365

        1557

        2077

        4

        Północ

        447

        469

        429

        1345

        579

        180

        367

        1126

        2471

        5

        Południe

        281

        511

        410

        1202

        124

        750

        200

        1074

        2276

        Ważne : Zaznaczenie nie powinno obejmować kolumny J (sum końcowych).

      2. Na karcie Dane w grupie Konspekt kliknij przycisk Grupuj.

        Kliknij przycisk Grupuj na karcie Dane

        Symbole konspektu są wyświetlane na ekranie obok grupy.

    2. Opcjonalnie możesz utworzyć konspekt wewnętrznej, zagnieżdżonej grupy (poszczególnych grup kolumn szczegółów).

      Jak utworzyć konspekt wewnętrznej, zagnieżdżonej grupy (grup kolumn szczegółów)

      1. Dla każdej wewnętrznej, zagnieżdżonej grupy zaznacz kolumny szczegółów przylegające do kolumny zawierającej kolumnę podsumowania.

        Aby w poniższym przykładzie pogrupować kolumny od B do D, których podsumowanie znajduje się w kolumnie E, należy zaznaczyć kolumny od B do D. Aby pogrupować kolumny od F do H, których podsumowanie znajduje się w kolumnie I, należy zaznaczyć kolumny od F do H.

         

        A

        B

        C

        D

        E

        L

        Bez ograniczeń

        g

        I

        S

        1

        Region

        Sty

        Lut

        Mar

        Kwartał1

        Kwi

        Maj

        Cze

        Kwartał2

        Półrocze1

        2

        Wschód

        371

        504

        880

        1755

        186

        653

        229

        1068

        2823

        3

        Zachód

        192

        185

        143

        520

        773

        419

        365

        1557

        2077

        4

        Północ

        447

        469

        429

        1345

        579

        180

        367

        1126

        2471

        5

        Południe

        281

        511

        410

        1202

        124

        750

        200

        1074

        2276

        Ważne : Zaznaczenie grupy nie powinno obejmować kolumny podsumowania.

      2. Na karcie Dane w grupie Konspekt kliknij przycisk Grupuj.

        Kliknij przycisk Grupuj na karcie Dane

        Symbole konspektu są wyświetlane na ekranie obok grupy.

  5. Kontynuuj zaznaczanie i grupowanie kolumn wewnętrznych, aż utworzysz wszystkie poziomy, które ma obejmować konspekt.

  6. Aby rozgrupować kolumny, zaznacz je, a następnie na karcie Dane w grupie Konspekt kliknij przycisk Rozgrupuj.

Na karcie Dane kliknij przycisk Rozgrupuj

Możesz także rozgrupować sekcje konspektu bez usuwania całego konspektu. Przytrzymaj naciśnięty klawisz SHIFT i kliknij przycisk Pole plus lub Pole minus dla grupy, a następnie na karcie Dane w grupie Konspekt kliknij przycisk Rozgrupuj.

Jeśli konspekt zostanie rozgrupowany, gdy dane szczegółowe będą ukryte, kolumny szczegółów mogą pozostać ukryte. Aby wyświetlić dane, przeciągnij wskaźnikiem myszy przez widoczne litery kolumn przylegających do ukrytych kolumn. Na karcie Narzędzia główne w grupie Komórki kliknij przycisk Formatuj, wskaż polecenie Ukryj i odkryj i kliknij polecenie Odkryj kolumny.

Początek strony

Pokazywanie lub ukrywanie danych konspektu

  1. Jeśli nie widać symboli konspektu Jeden Dwa Trzy , plus i minus , kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Opcje programu Excel (Excel 2007) LUB kliknij kartę Plik (inne wersje), a następnie kliknij pozycję Opcje, kliknij kategorię Zaawansowane, w sekcji Opcje wyświetlania dla tego arkusza wybierz arkusz, a następnie zaznacz pole wyboru Pokaż symbole konspektu po zastosowaniu konspektu.

  2. Kliknij przycisk OK.

  3. Wykonaj co najmniej jedną z następujących czynności:

    Pokazywanie lub ukrywanie danych szczegółowych grupy    

    • Aby wyświetlić dane szczegółowe grupy, kliknij przycisk plus odpowiadający tej grupie.

    • Aby ukryć dane szczegółowe grupy, kliknij przycisk minus odpowiadający tej grupie.

      Rozwijanie lub zwijanie całego konspektu do określonego poziomu    

    • W grupie symboli konspektu Jeden Dwa Trzy kliknij liczbę oznaczającą odpowiedni poziom. Dane szczegółowe znajdujące się na niższych poziomach zostaną ukryte.

      Jeśli na przykład konspekt składa się z czterech poziomów, można wyświetlić wszystkie poziomy oprócz czwartego, klikając przycisk trzy .

      Pokazywanie lub ukrywanie wszystkich danych szczegółowych konspektu    

    • Aby wyświetlić wszystkie dane szczegółowe, kliknij najniższy poziom w grupie symboli konspektu Jeden Dwa Trzy . Jeśli na przykład istnieją trzy poziomy konspektu, kliknij przycisk trzy .

    • Aby ukryć wszystkie dane szczegółowe, kliknij przycisk jeden .

Początek strony

Dostosowywanie konspektu przy użyciu stylów

Dla wierszy konspektu program Microsoft Excel używa stylów takich jak WierszPoziom_1 i WierszPoziom_2. W przypadku kolumn konspektu program Excel używa stylów takich jak KolPoziom_1 i KolPoziom_2. Dzięki pogrubieniu, kursywie i innym formatom tekstu style ułatwiają odróżnianie wierszy i kolumn podsumowań od pozostałych danych. Zmieniając definicje poszczególnych stylów, można zastosować inne formaty tekstu i komórek, aby dostosować wygląd konspektu. Styl można zastosować podczas tworzenia konspektu lub po jego utworzeniu.

Wykonaj co najmniej jedną z następujących czynności:

Automatyczne stosowanie stylu do wiersza lub kolumny podsumowania    

  1. Na karcie Dane w grupie Konspekt kliknij przycisk uruchamiający okno dialogowe Konspekt.

    W grupie Konspekt kliknij przycisk uruchamiania okna dialogowego

  2. Zaznacz pole wyboru Style automatyczne.

Stosowanie stylu do istniejącego wiersza lub istniejącej kolumny podsumowania    

  1. Zaznacz komórki, do których chcesz zastosować style konspektu.

  2. Na karcie Dane w grupie Konspekt kliknij przycisk uruchamiający okno dialogowe Konspekt.

    W grupie Konspekt kliknij przycisk uruchamiania okna dialogowego

  3. Zaznacz pole wyboru Style automatyczne.

  4. Kliknij przycisk Zastosuj style.

Do formatowania danych objętych konspektem można też użyć autoformatowania.

Początek strony

Kopiowanie danych konspektu

  1. Jeśli nie widać symboli konspektu Jeden Dwa Trzy , plus i minus , kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Opcje programu Excel (Excel 2007) LUB kartę Plik (inne wersje), a następnie kliknij pozycję Opcje, kliknij kategorię Zaawansowane, w sekcji Opcje wyświetlania dla tego arkusza wybierz arkusz, a następnie zaznacz pole wyboru Pokaż symbole konspektu po zastosowaniu konspektu.

  2. Korzystając z symboli konspektu Jeden Dwa Trzy , minus i plus , ukryj dane szczegółowe, których nie chcesz skopiować.

    Aby uzyskać więcej informacji, zobacz Pokazywanie lub ukrywanie danych konspektu.

  3. Zaznacz zakres wierszy podsumowań.

  4. Na karcie Narzędzia główne w grupie Edytowanie kliknij przycisk Znajdź i zaznacz, a następnie kliknij polecenie Przejdź do.

    Kliknij przycisk Znajdź i zaznacz, a następnie kliknij pozycję Przejdź do

  5. Kliknij przycisk Przejdź do — specjalnie.

  6. Kliknij przycisk Tylko widoczne komórki.

  7. Kliknij przycisk OK, a następnie skopiuj dane.

Początek strony

Ukrywanie lub usuwanie konspektu

Uwaga : Ukrycie lub usunięcie konspektu nie powoduje usunięcia danych.

Ukrywanie konspektu

  • (Excel 2007) Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Opcje programu Excel LUB kartę Plik (inne wersje), kliknij pozycję Opcje, kliknij kategorię Zaawansowane, w sekcji Opcje wyświetlania dla tego arkusza wybierz arkusz zawierający konspekt, który chcesz ukryć, a następnie wyczyść pole wyboru Pokaż symbole konspektu po zastosowaniu konspektu.

Usuwanie konspektu

  1. Kliknij arkusz.

  2. Na karcie Dane w grupie Konspekt kliknij przycisk Rozgrupuj, a następnie kliknij polecenie Wyczyść konspekt.

    Kliknij przycisk Rozgrupuj, a następnie kliknij pozycję Wyczyść konspekt

    Ważne : Jeśli konspekt zostanie usunięty, gdy dane szczegółowe będą ukryte, wiersze lub kolumny szczegółów mogą pozostać ukryte. Aby wyświetlić te dane, należy przeciągnąć wskaźnikiem myszy przez widoczne numery wierszy lub litery kolumn przylegających do ukrytych wierszy lub kolumn. Na karcie Narzędzia główne w grupie Komórki należy kliknąć przycisk Formatuj, wskazać polecenie Ukryj i odkryj, a następnie kliknąć polecenie Odkryj wiersze lub Odkryj kolumny.

Początek strony

Tworzenie raportu podsumowującego z wykresem

Załóżmy, że trzeba utworzyć raport podsumowujący dane, który zawiera tylko sumy oraz wykres tych sum. Najczęściej można to zrobić przez:

  1. Utworzenie raportu podsumowującego.

    1. Utwórz konspekt danych.

      Aby uzyskać więcej informacji, zobacz Tworzenie konspektu wierszy lub Tworzenie konspektu kolumn.

    2. Ukryj szczegóły, klikając symbole konspektu Jeden Dwa Trzy , plus i minus , aby pokazać tylko sumy, tak jak w poniższym przykładzie konspektu wierszy:

      Konspekt listy z wyświetlonymi tylko wierszami sum

    3. Aby uzyskać więcej informacji, zobacz Pokazywanie lub ukrywanie danych konspektu.

  2. Utworzenie wykresu na podstawie raportu podsumowującego.

    1. Zaznacz dane podsumowania, dla których chcesz utworzyć wykres.

      Aby na przykład utworzyć wykres dotyczący tylko sum dla nazwisk Ciesielska i Bator, bez sum końcowych, należy na powyższym przykładzie zaznaczyć komórki od A1 do C11.

    2. Utwórz wykres. Na przykład na karcie Wstawianie w grupie Wykresy kliknij pozycję Polecane wykresy albo wybierz inny typ wykresu.

      Jeśli wykres zostanie utworzony przy użyciu Kreatora wykresów, będzie wyglądał podobnie, jak w poniższym przykładzie.

      Wykres utworzony na podstawie sum częściowych

      Jeśli szczegóły listy danych konspektu zostaną pokazane lub ukryte, wykres zostanie odpowiednio zaktualizowany, tak aby zawierał te dane lub ich nie zawierał.

Początek strony

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×