Tworzenie kodów SPP

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W skrócie pracy kodów struktury podziału (SPP) są liczbami konspekt, które można zastosować do zadań i edytować dostosowany do określonych potrzeb firmy. Program Project automatycznie oferuje podstawowych numerów konspektu dla każdego zadania, ale możesz zastosować schemat dostosowane konspektu projektu w dowolnym momencie.

Następną sekcję dotyczy tylko programu Microsoft Project 2016, 2013 i 2010.

Co chcesz zrobić?

Tworzenie niestandardowych kodów SPP

Ponowne numerowanie kodów SPP

Używanie podstawowych numerów konspektu

Tworzenie niestandardowych kodów SPP

  1. Kliknij pozycję Widok, a następnie wybierz widok arkusza, taki jak Arkusz zadań lub Arkusz zasobów.

  2. Kliknij pozycję Projekt. W grupie Właściwości kliknij przycisk SPP, a następnie kliknij pozycję Definiuj kod.

    Obraz opcji Definiuj kod przycisku SPP

  3. Możesz utworzyć kody specyficzne dla projektu w polu Prefiks kodu projektu. Używać możesz małych i wielkich liter, cyfr i symboli.

Obraz okna dialogowego Definicja kodu SPP

  1. Aby ustawić kod dla zadań pierwszego poziomu, w pierwszym wierszu kolumny Sekwencja wybierz z listy rozwijanej typ znaku. Można wybrać cyfry, małe i wielkie litery albo połączenie cyfr, liter i innych symboli.

  2. W kolumnie Długość ustaw liczbę znaków dla każdego poziomu ciągu kodu. Kliknij pozycję Dowolna, aby zezwolić na dowolną liczbę znaków w odniesieniu do tego poziomu.

  3. W kolumnie Separator wybierz znak oddzielający kod jednego poziomu od kodu następnego poziomu.

    Domyślnym separatorem jest kropka. Można wybrać inne znaki lub nie użyć żadnego znaku separatora.

    Uwaga : Nie można jednocześnie użyć znaku separatora jako elementu kodu.

  4. Ustaw ciąg kodu dla każdego poziomu wciętych zadań w konspekcie.

    Aby określić indywidualne kody dla każdego poziomu, kliknij następny wiersz i wypełnij pola w kolumnach Sekwencja, Długość i Separator.

  5. Jeśli kod SPP w programie Project nie ma być automatycznie przypisywany do każdego nowego wprowadzonego zadania, usuń zaznaczenie pola wyboru Generuj kod SPP dla nowego zadania.

  6. Aby zezwolić na używanie tego samego kodu SPP w przypadku wielu zadań, usuń zaznaczenie pola wyboru Weryfikuj unikatowość nowych kodów SPP.

Ponowne numerowanie kodów SPP

Przenoszenie lub usuwanie zadań w programie Project nie powoduje automatycznej ponownej numeracji kodów SPP w przypadku, gdy są używane w dokumentach lub innych systemach niepołączonych z plikiem programu Project. Oznacza to, że kody pozostałych zadań będą prawdopodobnie niepoprawne. Oto jak można spowodować ponowne ponumerowanie kodów SPP dla potrzeb wszystkich lub wybranych zadań:

  1. Kliknij pozycję Widok, a następnie wybierz widok arkusza (taki jak Arkusz zadań) zawierający zadania, które mają być ponownie ponumerowane.

  2. Wybierz zadania, które mają być ponownie ponumerowane. Pierwsze wybrane zadanie nie zostanie ponownie ponumerowane.

    Aby ponownie ponumerować kody SPP wszystkich zadań, nie wybieraj żadnych zadań.

  3. Kliknij pozycję Projekt. W grupie Właściwości kliknij przycisk SPP, a następnie kliknij pozycję Ponumeruj ponownie.

    Obraz karty Projekt, przycisku SPP, polecenia Ponumeruj ponownie w menu rozwijanym.

  4. Kliknij pozycję zaznaczone zadania Aby ponownie ponumerować kodów dla zaznaczonych zadań.

    Kliknij pozycję Cały projekt, aby ponownie ponumerować kody wszystkich zadań w projekcie.

    Obraz okna dialogowego Ponowne numerowanie kodów SPP

Używanie podstawowych numerów konspektu

Jeśli szczegółowa struktura, jaką zapewniają kody SPP, jest niepotrzebna, można użyć konspektu podstawowego.

Każde zadanie w programie Project automatycznie otrzymuje numer w konspekcie na podstawie miejsca zajmowanego przez to zadanie w strukturze listy zadań. Na przykład pierwsze zadanie na liście zadań ma numer 1. Jeśli ma ono trzy podzadania, otrzymują one numery 1.1, 1.2 i 1.3.

Numerów w konspekcie składają się tylko liczby, a nie można ich edytować. Zmieniają one automatycznie podczas przenoszenia zadania w górę lub w dół na liście zadań i po zwiększanie lub zmniejszanie wcięcia zadań.

Aby wyświetlić numery w konspekcie, należy dodać pole Numer w konspekcie do widoku tabela lub arkusz. Numery w konspekcie można także dodać bezpośrednio do nazw zadań:

  1. Przejdź do widoku Wykres Gantta lub Arkusz zadań.

  2. Kliknij pozycję Format, a następnie w grupie Pokaż/Ukryj zaznacz pole Numer w konspekcie.

Początek strony

W tej sekcji dotyczy tylko programu Microsoft Project 2007.

Co chcesz zrobić?

Więcej informacji na temat kodów SPP

Definiowanie niestandardowych kodów SPP

Ponowne numerowanie kodów SPP

Więcej informacji na temat kodów SPP

Istnieją dwa typy kodów SPP w programie Microsoft Office Project: numery w konspekcie i niestandardowych kodów SPP. W tym artykule poniższych sekcjach, aby dowiedzieć się więcej.

Numerów konspektu

Numery konspektu są najprostszy typ kodu SPP. Program Microsoft Office Project oblicza automatycznie numer w konspekcie dla każdego zadania tworzony numerowanie na strukturze konspektu listy zadań. Na przykład pierwszego zadania na liście zadań ma numer 1. Jeśli to zadanie ma podzadania trzy, podzadania są numerowane 1.1, 1.2 oraz 1.3.

Numerów w konspekcie składają się tylko liczb (nie litery), a nie można ich edytować. Należy jednak zmieniają one automatycznie podczas przenoszenia zadania w górę lub w dół na liście zadań i po zwiększanie lub zmniejszanie wcięcia zadań. Na przykład jeśli podzadania obecnie ma numer 3.5.4 i po przeniesieniu jeden wiersz na liście w górę, numer w konspekcie jest automatycznie aktualizowane do 3.5.3. Jeśli następnie zmniejsz wcięcie podzadania sam numer w konspekcie jest automatycznie aktualizowana do 3.6.

Porada : Do wyświetlania numerów w konspekcie, pole Numer w konspekcie można dodać do widoku tabela lub arkusz lub istnieje możliwość wyświetlania numerów w konspekcie obok nazwy zadania. Do wyświetlania numerów w konspekcie obok nazwy zadania, w menu Narzędzia kliknij polecenie Opcje, a następnie kliknij kartę Widok. W obszarze Opcje konspektu zaznacz pole wyboru Pokaż numer w konspekcie.

Kody SPP niestandardowe

Jeśli projekt będzie korzystać z konieczności szczegółowe kodów SPP, które składają się z określonej długości, sekwencji lub zestawy liter i cyfr, można zdefiniować pojedynczy niestandardowe SPP maska kodu projektu. (Nie programu project można mieć więcej niż maska kodu niestandardowego jednego). Niestandardowy kod SPP został zapisany w polu SPP.

Jako z numerów konspektu każdego poziomu niestandardowego kodu SPP reprezentuje poziom konspektu na liście zadań. Za pomocą formatu unikatowe dla każdego poziomu kodu, a poziomami znajduje się w kodzie zgodnie z hierarchii zadania, zadania sumaryczne i podzadania.

Na przykład jeśli planujesz fazowy projektów, które dostosowanie dyrektywy organizacji dla nadchodzących roku obrachunkowego, możesz utworzyć niestandardowej maski kodu SPP, reprezentująca poszczególnych zadań przy użyciu odpowiedniej dyrektywy, kwartał i project. Kod, jaki może być zadania, które ma niestandardowego kodu SPP programu CustSat.Q3.CSTools.11, co oznacza, że zadanie 11 w projekcie uaktualnianie narzędzia obsługi klienta, które rozpoczyna się w trzecim kwartale i które obsługuje dyrektywy firm zadowolenia dla planowanej roku obrachunkowego.

Początek strony

Definiowanie niestandardowych kodów SPP

  1. W menu Widok kliknij polecenie Widok arkusza, takich jak widoku Arkusz zadań.

    Aby użyć widoku, który nie jest wyświetlana w menu Widok, kliknij polecenie Więcej widoków, kliknij widok, którego chcesz użyć na liście Widoki, a następnie kliknij przycisk Zastosuj.

  2. W menu Projekt wskaż SPP, a następnie kliknij polecenie Definiuj kod.

  3. Aby odróżnić zadania w tym projekcie od zadania w innych projektach, wpisz prefiks kodu specyficzne dla projektu w polu Prefiks kodu projektu.

    Ten prefiks pomaga do identyfikacji projektu na najwyższym poziomie kodu SPP. Prefiks może być przydatne w identyfikacji podprojektów w projekcie głównym lub podczas tworzenia współzależności zadań w projektach.

    Prefiks kodu projektu można wprowadzić dowolną kombinację cyfr, wielkich i małych liter i symboli.

  4. Aby określić ciąg kodu dla zadań pierwszego poziomu w pierwszym wierszu w kolumnie kolejność, kliknij odpowiedni typ znak, który ma być używany dla tego poziomu:

    • Kliknij przycisk cyfry (uporządkowane), aby wyświetlić liczbowe kod SPP dla tego poziomu (na przykład 1, 2 i 3 dla pierwszych trzech zadań sumarycznych w projekcie).

    • Kliknij pozycję Wielkie litery (uporządkowane), aby wyświetlić wielkie litery alfabetycznie kodów SPP (na przykład A, B i C dla pierwszych trzech zadań sumarycznych w projekcie).

    • Kliknij pozycję małe litery (uporządkowane), aby wyświetlić małe alfabetycznie kodów SPP (na przykład, b i c dla pierwszych trzech zadań sumarycznych w projekcie).

    • Kliknij pozycję znaki (nieuporządkowane) do wyświetlania dowolną kombinację cyfr i wielkich i małych liter (na przykład Arch1, Bud1 i Insp1 dla pierwszych trzech zadań sumarycznych w projekcie).

      Wybranie tej opcji daje największą elastyczność wprowadzania niestandardowych kodów SPP.. Project wyświetla gwiazdkę (*) w polu SPP, dopóki nie zostanie wprowadzony lub wpisany ciąg znaków dla tego poziomu kodu SPP.

  5. W kolumnie czas trwania wpisz lub wybierz liczbę znaków dla każdego poziomu ciągu kodu. Możesz wprowadzić dokładna liczba znaków lub zaznacz opcję dowolny umożliwia dowolną liczbę znaków dla tego poziomu kodu.

    Można na przykład wpisać 3 aby trzy znaki obowiązkowe liczby znaków, aby wprowadzić w jeden poziom kodu SPP. Całkowitą długość kodu SPP może zawierać od 1 do 255 znaków.

  6. W kolumnie Separator wpisz lub wybierz znak oddzielający ciąg kod jednego poziomu od ciągu kodu następnego poziomu.

    Domyślnie znak separatora jest kropka. Za pomocą różnych separatora każdego poziomu kodu.

    Możesz również wybrać nie chcesz używać dowolny znak separatora między poziomami kodu. W polu Separator Usuń znak separatora.

  7. Określ jeden ciąg kodu dla każdego poziomu wciętych zadań w konspekcie.

    Aby określić ciągi poszczególnych kodów dla każdego poziomu, kliknij następny wiersz i wypełnij pola w kolumnach Sekwencja, długość i Separator.

  8. Jeśli nie chcesz projekt, aby automatycznie przypisywany kodu SPP każdego wprowadzonego nowe zadanie, wyczyść pole wyboru Generuj kod SPP dla nowego zadania.

  9. Aby zezwolić na używanie tego samego kodu SPP w przypadku wielu zadań, wyczyść pole wyboru Weryfikuj unikatowość nowych kodów SPP.

Uwaga : 

  • Znak, który jest używany jako separator nie można również użyć jako część kodu. Na przykład łącznik jest używany jako separator, nie można używać łącznika w kodzie, który umożliwia przedstawienie zadania.

  • Nie można zdefiniować więcej niż jeden zestaw kodów SPP dla projektu. Jeśli potrzebujesz wyświetlić dodatkowe struktury organizacyjnej zadań, w polach niestandardowych umożliwia tworzenie lub stosowanie oddzielny zestaw kodów.

  • Aby wyświetlić kody SPP, należy dodać pole SPP do widoku.

  • Aby zmienić kod SPP dla zadanie sumaryczne i wszystkie jego podzadań, należy zmienić istniejący kod, lub ustawianie gwiazdek, kod SPP zadania sumarycznego na inny zestaw znaków.

    Na przykład kodu SPP dla określonych podzadania jest Ph3.Prj5.Arch.Task3. "Task3" oznacza podzadania "Opracowanie planów", a "Arch" oznacza zadania sumarycznego "Architektury rozwiązanie". Nazwa zadania sumarycznego jest zmieniana na "Rozwiązania projektowe", a konieczna jest aktualizacja kod zadanie sumaryczne i wszystkie jego podzadań. Możesz zmodyfikować kodu SPP, tak aby zadania sumarycznego jest reprezentowany przez "Des" i kod SPP dla "plany rozwoju" podzadania jest automatycznie aktualizowana do Ph3.Prj5.Des.Task3.

Ponowne numerowanie kodów SPP

Po przeniesieniu lub usunięciu zadań ich niestandardowych kodów SPP może nie być już w poprawnej kolejności. Projekt nie automatycznie aktualizowane kodów SPP, ponieważ możesz korzystać z tych kodów SPP w folderze dokumenty lub inne systemy, które nie są połączone z pliku projektu. Można ponownie ponumerować kody SPP wszystkich zadań lub wybranych zadań:

  1. W menu Widok kliknij polecenie Widok arkusza, który zawiera zadania, które mają być ponownie ponumerowane, taki jak Arkusz zadań.

    Aby użyć widoku, który nie jest wyświetlana w menu Widok, kliknij polecenie Więcej widoków, kliknij widok, którego chcesz użyć na liście Widoki, a następnie kliknij przycisk Zastosuj.

  2. Wybierz zadania, które mają być ponownie ponumerowane. (Nie otrzymuje pierwszego zadania w wybrane zadania. Służy jako punkt odniesienia dla ponowne numerowanie innych zadań.)

    Aby ponownie ponumerować kody SPP wszystkich zadań, nie wybieraj żadnych zadań.

  3. W menu Projekt wskaż polecenie SPP, a następnie kliknij ponownie ponumerowane.

  4. Aby poprawić sekwencji kod SPP dla wybranych sąsiadujących zadań, kliknij zaznaczone zadania.

    Aby poprawić sekwencji kod SPP dla wszystkich zadań w projekcie, kliknij pozycję cały projekt.

Uwaga : 

  • Jeśli projekt zawiera podprojektów, można zmieniać numerację niektórych lub wszystkich zadań w poszczególnych podprojektów, wyświetlając wszystkie podzadania. Kliknij pozycję Pokaż Pokaz , a następnie kliknij pozycję Wszystkie podzadania. (Projekt nie zmienia się numerację zadania z podprojektów, które nie są wyświetlane.)

  • Ponowne numerowanie podprojektów, które są wstawiane do projektu głównego powoduje także kod oznaczający poszczególnych podprojektów na poziomie projektu.

  • Aby wyświetlić kody SPP, możesz dodać kolumnę SPP do widoku arkusza.

  • Aby zmienić kodów SPP, gdy program Project oblicza je w menu Projekt, wskaż polecenie SPP, a następnie kliknij Definiuj kod. W kolumnie sekwencji Zmień typ znaku dowolnego poziomu maski kodu. Gdy zaktualizujesz kod na poziomie zadania sumarycznego, wszystkie podzadania tego zadania sumaryczne są automatycznie aktualizowane.

    W przypadku trudności zmieniania własnych kodów SPP, mogą być dla jednej z następujących przyczyn:

    • Chcesz zmienić kodu SPP, który zawiera maski kodu, po kodzie została obliczona     Jeśli utworzono maski kodu SPP, a kodów SPP zostały już obliczone dla zadań, możesz zmienić kodu SPP, tylko według zmiana definicji poziomu maski kodu. Po zmiana definicji poziomów maski kodu, można zmienić dowolnego poziomu maski kodu z uporządkowanych liczb, uporządkowana wielkie litery, numerowana małe litery lub znaki Nieuporządkowana do innego typu.

    • Chcesz zmienić kodów SPP na niższym poziomie na liście zadań     Nie można zmienić znaki w kod SPP dla podzadania, tylko w przypadku zadania sumarycznego, gdzie jest definiowana tego poziomu kodu SPP.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×