Tworzenie kaskadowego pola listy

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Kaskadowe pola list ułatwiają użytkownikom szybsze wypełnianie formularzy i upewnić się, że użytkownicy będą wprowadzać dane poprawnie. W tym artykule opisano, jak tworzyć i wypełniać kaskadowego pola listy z danymi. W programie Microsoft Office InfoPath można wypełnić listę z danymi, która używa wartości z formularza, wartości z zewnętrznego dokumentu Extensible Markup Language (XML) lub wartości z bazy danych programu Microsoft Office Access.

W tym artykule

Co to jest kaskadowego pola listy?

Krok 1: Wstawianie kaskadowego pola listy

Krok 2: Zawiera dane

Co to jest kaskadowego pola listy?

Kaskadowe pole listy to pole listy z opcjami, które zmiany na podstawie wartości w innym polu listy wybranego użytkownika. Na przykład jeśli użytkownik kliknie przyprawy w polu Kategorie pokazano na poniższej ilustracji, pole produktów wyświetli listy przypraw.

Przykład kaskadowego pola listy

Poniżej pokazano, jak projektowanie szablonu formularza przy użyciu dwóch listy pól, gdzie jest filtrowana drugiego pola listy na podstawie wartości wybranych przez użytkownika w pierwszym polu listy. Po zmianie wartości w pierwszym polu listy, filtr zostanie automatycznie zastosowana do drugiego pola listy, co spowoduje zmianę wartości.

Informacje dotyczące zgodności

Filtry można używać tylko w szablonach formularzy, które służą do wypełniania w programie InfoPath. Filtry nie są dostępne w szablonach formularzy zgodnych z przeglądarką.

Początek strony

Krok 1: Wstawianie kaskadowego pola listy

Aby utworzyć kaskadowe pole listy, możesz wstawić dwa pola listy w szablonie formularza.

Uwaga: Po wstawieniu kaskadowego pola listy w szablonie formularza upewnij się, że dwóch list nie znajdują się w sekcja powtarzająca się lub tabela powtarzająca się.

  1. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  2. W obszarze Wstaw kontrolki w okienku zadań formanty kliknij Pole listy rozwijanej. Gdy użytkownik wypełnia formularz, który jest oparty na szablonie formularza, zaznaczenia w tym polu listy rozwijanej określi opcji, które są dostępne w drugim polu listy.

  3. Kliknij pole listy. Szablon formularza powinna już zawierać pola listy rozwijanej i pole listy standardowy.

    Pole listy rozwijanej i pole listy w formularzu

  4. Kliknij dwukrotnie pole listy rozwijanej, wstawiony w szablonie formularza w kroku 2.

  5. W oknie dialogowym Właściwości pola listy rozwijanej kliknij kartę dane.

  6. W polu Nazwa pola wpisz Pole_listy1, a następnie kliknij przycisk OK.

  7. Kliknij dwukrotnie pole listy wstawione w szablonie formularza w kroku 3.

  8. W oknie dialogowym Właściwości pola listy kliknij kartę dane.

  9. W polu Nazwa pola wpisz listBox2Cascade, a następnie kliknij przycisk OK.

Początek strony

Krok 2: Zawiera dane

Teraz, gdy pola listy umieszczono w szablonie formularza, musisz podać dane, które będą one zawierać. Następnie należy zastosować filtr, tak aby opcji w drugim polu listy są oparte na wybranej przez użytkownika w pierwszym polu listy.

W tej sekcji wyjaśniono, jak pól list połączyć się z danymi przy użyciu trzech metod typowych: Dodawanie danych do formularza. Łączenie formularza do istniejącego dokumentu XML zawierający dane; lub łączenie formularza do bazy danych, która zawiera dane. Aby zakończyć tworzenie kaskadowego pola listy, kliknij odpowiednią metodę, który ma być używany na poniższej liście.

Łączenie z danymi w formularzu

Nawiązywanie połączenia z zewnętrznym dokumentem XML

Nawiązywanie połączenia z bazą danych

Łączenie z danymi w formularzu

W tej sekcji dowiesz się, jak do wypełniania pól listy z danymi w formularzu. Aby to zrobić, musisz najpierw skonfigurować pola w szablonie formularza, aby mogli wprowadzać nazwy kategorii i zestaw produktów dla każdej kategorii.

Konfigurowanie pól w szablonie formularza

  1. Jeśli okienko zadań Źródło danych nie jest widoczny, kliknij pozycję Źródła danych, w menu Widok.

  2. W okienku zadań Źródło danych kliknij prawym przyciskiem myszy grupę mojePola, a następnie kliknij przycisk Dodaj.

  3. W polu Nazwa w oknie dialogowym Dodawanie pola lub grupy wpisz Kategorie_i_produkty.

  4. Na liście Typ kliknij pozycję grupy.

  5. Zaznacz pole wyboru Powtarzanie, a następnie kliknij przycisk OK.

  6. W okienku zadań Źródło danych kliknij prawym przyciskiem myszy grupę Kategorie_i_produkty.

  7. W polu Nazwa w oknie dialogowym Dodawanie pola lub grupy wpisz kategorii, a następnie kliknij przycisk OK. To pole będzie zawierać nazwy kategorii dla pierwszego pola listy.

  8. Kliknij prawym przyciskiem myszy grupę Kategorie_i_produkty, a następnie kliknij przycisk Dodaj.

  9. W polu Nazwa w oknie dialogowym Dodawanie pola lub grupy wpisz produktu.

  10. Zaznacz pole wyboru Powtarzanie, a następnie kliknij przycisk OK. To pole będzie zawierać nazwy produktów dla drugiego pola listy.

Ponieważ to pole listy zostanie wypełniona danych z formularza, danych musi zostać dodana do formularza. Aby to zrobić, uzyskuje do tworzenia wartości domyślnych dla pól produktów i kategorii.

Porada

Można także tworzyć pola list zawierające wartości wpisywane przez użytkowników w formularzu się. W tym celu należy skojarzyć pole listy z polami, które są powiązane z kontrolek w formularzu. Gdy użytkownik wprowadzi wartości do kontrolek, zmienianie opcji w polu listy.

Tworzenie wartości domyślnych

  1. W menu Narzędzia kliknij polecenie Wartości domyślne.

  2. W oknie dialogowym Edytuj wartości domyślne w grupie Kategorie_i_produkty zaznacz pole Category (nie czyszcząc pole wyboru), a następnie w polu wartość domyślna wpisz ryby.

  3. Wybierz pole typu produktu (nie czyszcząc pole wyboru), a następnie w polu wartość domyślna wpisz kraba mięso.

  4. Kliknij prawym przyciskiem myszy pole produkt, a następnie kliknij pozycję Dodaj inne produkt powyżej. Umożliwia dodanie drugiego produktu na ryby jako wartość domyślna.

  5. Kliknij prawym przyciskiem myszy drugiego wystąpienia tego pola produktu (nie czyszcząc pole wyboru), a następnie w polu wartość domyślna wpisz łososia.

  6. Kliknij prawym przyciskiem myszy grupę Kategorie_i_produkty, a następnie kliknij pozycję Dodaj inne Kategorie_i_produkty poniżej. Dzięki temu można dodać drugiej kategorii jako wartość domyślna.

  7. Wykonanie powyższych czynności spowoduje umożliwia określenie wartości domyślnych dla drugiego wystąpienia pola Kategoria i produktusłodycze, Cheddar i mleko czekoladowe, odpowiednio.

  8. Kliknij przycisk OK.

Teraz, gdy wprowadzono wartości domyślnych dla pól produktów i kategorii, można nawiązać z pierwszego pola listy danych, które zostały wprowadzone.

Połączyć dane z pierwszego pola listy

  1. W szablonie formularza kliknij dwukrotnie pole listy rozwijanej, wcześniej wstawiony.

  2. Kliknij kartę Dane.

  3. W oknie dialogowym Właściwości pola listy rozwijanej w obszarze pozycje w polu listy, kliknij pozycję Sprawdź wartości w źródle danych formularza.

  4. Kliknij pozycję Wybierz wyrażenie XPath Obraz przycisku obok pola wpisów.

  5. W oknie dialogowym Wybieranie pola lub grupy, w grupie Kategorie_i_produkty kliknij pole kategorii, a następnie kliknij przycisk OK dwa razy.

Teraz należy połączyć drugiego pola listy danych. Podczas tworzenia tej połączenie danych, można zastosować filtr do drugiego pola listy. Do wypełnienia drugiego pola listy odpowiednimi produktami według wybranej kategorii w pierwszym polu listy. Filtr porównuje wartość wybraną w pierwszym polu listy (Pole_listy1) z listą kategoriami zapisanymi w formularzu (pole Kategoria).

Połączenia z danymi drugie pole listy

  1. W szablonie formularza kliknij dwukrotnie standardowe pole listy wcześniej wstawiony.

  2. Kliknij kartę Dane.

  3. W oknie dialogowym Właściwości pola listy w obszarze pozycje w polu listy, kliknij pozycję Sprawdź wartości w źródle danych formularza.

  4. Kliknij pozycję Wybierz wyrażenie XPath Obraz przycisku obok pola wpisów.

  5. W oknie dialogowym Wybieranie pola lub grupy, w grupie Kategorie_i_produkty kliknij pole produkt, a następnie kliknij Filtrowanie danych.

  6. W oknie dialogowym Filtrowanie danych kliknij przycisk Dodaj.

  7. W oknie dialogowym Określanie warunków filtrowania kliknij pozycję Wybierz pola lub grupy w pierwszym polu.

  8. W oknie dialogowym Wybieranie pola lub grupy kliknij Pole_listy1, a następnie kliknij przycisk OK.

  9. W oknie dialogowym Określanie warunków filtrowania kliknij w trzecim polu Wybieranie pola lub grupy.

  10. W oknie dialogowym Wybieranie pola lub grupy kliknij pole kategorii, a następnie kliknij przycisk OK, aby zamknąć wszystkie otwarte okna dialogowe.

Teraz, gdy masz połączenie drugiego pola listy z danymi i zastosowaniu filtru, możesz przystąpić do testowania pól listy, aby upewnić się, że działają poprawnie.

Testowanie pól listy

  1. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

  2. W polu listy rozwijanej kliknij pozycję ryby. Standardowe pole listy należy wyświetlić pusty wiersz, Mięso krabów i łososia.

    Uwaga: Pusty wiersz umożliwia użytkownikom wyczyść wyboru w polu listy.

Jeśli pola listy nie działają poprawnie, zweryfikuj filtr drugiego pola listy upewnić się, że różni się Pole_listy1 z polem kategorii.

Powrót do początku sekcji

Nawiązywanie połączenia z zewnętrznym dokumentem XML

W tej sekcji dowiesz się, jak utworzyć połączenie danych z dokumentu XML, która zawiera wartości produktów i kategorii. Dokument XML będzie dodatkowego źródła danych. Aby utworzyć to połączenie danych, należy utworzyć dokument XML, skojarzyć pola listy w szablonie formularza z dokumentu XML, a następnie zastosować filtr do drugiego pola listy, tak aby odpowiednio zmienia się na liście produktów.

Przed formularz można skojarzyć z pomocnicze źródło danych, należy utworzyć dokument XML.

Tworzenie dokumentu XML

  1. Uruchom Notatnik lub innego edytora tekstu.

  2. Skopiuj i wklej następujące dane XML do edytora tekstów:

    <?xml version="1.0" encoding="UTF-8"?>
    <ListBoxData>
    <CategoriesAndProducts>
    <Categories>Seafood</Categories>
    <Products>
    <Product>Crab meat</Product>
    </Products>
    <Products>
    <Product>Salmon</Product>
    </Products>
    </CategoriesAndProducts>
    <CategoriesAndProducts>
    <Categories>Dairy</Categories>
    <Products>
    <Product>Chocolate milk</Product>
    </Products>
    <Products>
    <Product>Cheddar</Product>
    </Products>
    </CategoriesAndProducts>
    </ListBoxData>
  3. Zapisz plik na komputerze jako listBoxData.xml.

Teraz, gdy użytkownik utworzył dokumentu XML, podłącz je do szablonu formularza. Spowoduje to utworzenie pomocnicze źródło danych.

Łączenie dokumentu XML do szablonu formularza

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Odbierz dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij dokument XML, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora kliknij przycisk Przeglądaj, wybierz plik listBoxData.xml, który został zapisany na komputerze, a następnie kliknij przycisk Otwórz.

  6. Na następnej stronie kreatora kliknij pole wyboru Uwzględnij dane jako plik zasobów w szablonie formularza lub części szablonu, a następnie kliknij przycisk Dalej.

  7. Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz Plik_xml_danych_pola_listy.

  8. Zaznacz pole wyboru automatycznie Pobierz dane po otwarciu formularza. Gwarantuje to, że dane pola listy będą dostępne każdym razem, gdy formularz jest otwarty, zamiast użytkownika do kwerendy dla niego.

  9. Kliknij przycisk Zakończ.

  10. W oknie dialogowym Połączenia danych kliknij przycisk Zamknij.

Teraz możesz przystąpić do połączenia z pierwszego pola listy w szablonie formularza z danymi w dokumencie XML.

Połączyć dane z pierwszego pola listy

  1. W szablonie formularza kliknij dwukrotnie pole listy rozwijanej, wcześniej wstawiony.

  2. Kliknij kartę Dane.

  3. W oknie dialogowym Właściwości pola listy rozwijanej w obszarze pozycje w polu listy, kliknij pozycję Sprawdź wartości z zewnętrznego źródła danych.

  4. W oknie dialogowym źródło danych kliknij Plik_xml_danych_pola_listy.

  5. Kliknij pozycję Wybierz wyrażenie XPath Obraz przycisku obok pola wpisów.

  6. W oknie dialogowym Wybieranie pola lub grupy w grupie Kategorie_i_produkty kliknij pole kategorii.

    Uwaga: Żółte tło w oknie dialogowym Wybieranie pola lub grupy wskazuje, że pracujesz z pomocnicze źródło danych.

  7. Kliknij dwa razy przycisk OK.

Teraz masz połączenie drugiego pola listy do dokumentu XML. Podczas tworzenia to połączenie danych, można zastosować filtr do drugiego pola listy. Do wypełnienia drugiego pola listy odpowiednimi produktami według wybranej kategorii w pierwszym polu listy. Filtr porównuje wartość wybraną w pierwszym polu listy (Pole_listy1) z listą kategoriami zapisanymi w formularzu (pole Kategoria).

Połączenia z danymi drugie pole listy

  1. W szablonie formularza kliknij dwukrotnie standardowe pole listy wcześniej wstawiony.

  2. Kliknij kartę Dane.

  3. W oknie dialogowym Właściwości pola listy w obszarze pozycje w polu listy, kliknij pozycję Sprawdź wartości z zewnętrznego źródła danych.

  4. W oknie dialogowym źródło danych kliknij Plik_xml_danych_pola_listy.

  5. Kliknij pozycję Wybierz wyrażenie XPath Obraz przycisku obok pola wpisów.

  6. W oknie dialogowym Wybieranie pola lub grupy, w grupie Kategorie_i_produkty rozwiń grupę produkty, a następnie kliknij pole produkt.

  7. Kliknij opcję Filtruj dane.

  8. W oknie dialogowym Filtrowanie danych kliknij przycisk Dodaj.

  9. W oknie dialogowym Określanie warunków filtrowania kliknij pozycję Wybierz pola lub grupy w pierwszym polu.

  10. W polu źródło danych w oknie dialogowym Wybieranie pola lub grupy kliknij pozycję główny.

  11. Kliknij Pole_listy1, a następnie kliknij przycisk OK.

  12. W oknie dialogowym Określanie warunków filtrowania kliknij w trzecim polu Wybieranie pola lub grupy.

  13. W polu źródło danych w oknie dialogowym Wybieranie pola lub grupy kliknij pozycję Plik_xml_danych_pola_listy (pomocnicze), a następnie kliknij Kategorie.

  14. Kliknij przycisk OK, aby zamknąć wszystkie otwarte okna dialogowe.

Teraz, gdy masz połączenie drugiego pola listy z dokumentem XML i zastosowaniu filtru, możesz przystąpić do testowania pól listy, aby upewnić się, że działają poprawnie.

Testowanie pól listy

  1. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

  2. W polu listy rozwijanej kliknij pozycję ryby. Standardowe pole listy należy wyświetlić tylko pusty wiersz, Mięso krabów i łososia.

    Uwaga: Pusty wiersz umożliwia użytkownikom wyczyść wyboru w polu listy.

Jeśli pola listy nie działają poprawnie, zweryfikuj filtr drugiego pola listy upewnić się, że różni się Pole_listy1 z polem kategorii.

Powrót do początku sekcji

Nawiązywanie połączenia z bazą danych

W tej sekcji dowiesz się, jak utworzyć połączenie danych z dwóch tabel w bazie danych programu Access. W tym celu należy skojarzyć pola list w szablonie formularza z bazą danych, a następnie zastosować filtr do drugiego pola listy, tak aby liście prawidłowo wyświetlane w drugim polu Lista zmian według wartości wybranej w pierwszym polu listy. W tym przykładzie zostanie przyjęto założenie, że baza danych programu Access zawiera dwie tabele o nazwie kategorie i produkty i że dwie tabele są powiązane ze sobą według pola CategoryID, który jest używany w każdej tabeli.

Tabela kategorii   

IDKategorii

NazwaKategorii

1

Ryby

2

Nabiał

Tabela produkty   

ProductID

IDKategorii

ProductName

1

1

Mięso krabów

2

1

Łososia

3

2

Mleko czekoladowe

4

2

Cheddar

Nawiązywanie połączenia ze źródłem danych szablonu formularza

Najpierw należy utworzyć połączenie danych między szablonu formularza i tabelami w bazie danych. Ponieważ można tylko wyświetlać dane z bazy danych, zamiast ich modyfikować, bazy danych programu Access będzie pomocnicze źródło danych dla szablonu formularza.

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Odbierz dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij bazy danych (Microsoft SQL Server lub Microsoft Office Access tylko), a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora kliknij opcję Wybierz bazę danych, a następnie przejdź do, a następnie kliknij dwukrotnie bazę danych programu Access na dysku twardym.

  6. W oknie dialogowym Wybieranie tabeli kliknij tabelę, która zawiera dane, które mają być wyświetlane na liście pierwszy (w tym przykładzie tabela kategorii), a następnie kliknij przycisk OK. Określa tabeli jako tabela podstawowa połączenia danych.

  7. W kreatorze kliknij pozycję Dodaj tabelę.

  8. W oknie dialogowym Dodawanie tabeli lub kwerendy kliknij tabelę, która zawiera dane, które mają być wyświetlane na liście drugi (w tym przykładzie tabela Produkty), a następnie kliknij przycisk Dalej.

  9. W oknie dialogowym Edytowanie relacji upewnij się, że pola łączące są prawidłowe. W tym przykładzie tabele są powiązane ze sobą według pola CategoryID.

    Porada: Jeśli pola łączące są nieprawidłowe, zaznacz pola, a następnie kliknij Usuwanie relacji. Następnie kliknij przycisk Dodaj relację, zaznacz odpowiednich pól, a następnie kliknij przycisk OK.

  10. Kliknij przycisk Zakończ.

    Uwaga: W tym przykładzie tabela kategorii pozostaje w relacji jeden do wielu z tabelą produktów, co oznacza, że dla każdej kategorii może być wiele produktów. W bazie danych tego rodzaju relacji jest zwykle ustalane za pomocą pól klucza. W tym przypadku pole klucza CategoryID umożliwia dostęp do skojarzyć odpowiedni zestaw produktów do odpowiedniej kategorii.

  11. W Kreatorze Przejrzyj struktury źródła danych. Powinny być widoczne dwie tabele połączone ze sobą: tabeli podstawowej i tabeli pomocniczej. Aby wyświetlić poszczególnych pól w tabeli, zaznacz pole wyboru Pokaż kolumny w tabeli. Po zakończeniu przeglądania struktury danych, kliknij przycisk Dalej.

  12. Wyczyść pole wyboru Przechowaj kopię danych w szablonie formularza, a następnie kliknij przycisk Dalej.

  13. W polu Wprowadź nazwę dla tego połączenia danych na następnej stronie kreatora wpisz nazwę połączenia danych.

  14. Zaznacz pole wyboru automatycznie Pobierz dane po otwarciu formularza.

  15. Kliknij przycisk Zakończ, a następnie kliknij przycisk Zamknij w oknie dialogowym Połączenia danych.

Na pierwszej liście połączyć się z danymi

Teraz, gdy masz połączenie danych z pomocnicze źródło danych, umożliwia nawiązanie połączenia z pierwszego pola listy w szablonie formularza z tabelami w bazie danych.

  1. W szablonie formularza kliknij dwukrotnie pole listy rozwijanej, wcześniej wstawiony.

  2. Kliknij kartę Dane.

  3. W oknie dialogowym Właściwości pola listy rozwijanej w obszarze pozycje w polu listy, kliknij pozycję Sprawdź wartości z zewnętrznego źródła danych.

  4. W oknie dialogowym źródło danych upewnij się, że jest zaznaczona opcja utworzone połączenie danych.

  5. Kliknij pozycję Wybierz wyrażenie XPath Obraz przycisku obok pola wpisów.

  6. W oknie dialogowym Wybieranie pola lub grupy kliknij nazwę tabeli, która zawiera dane, które mają być wyświetlane na liście rozwijanej (w tym przykładzie d: kategorie ), a następnie kliknij przycisk OK.

    Uwaga: Żółte tło w oknie dialogowym Wybieranie pola lub grupy wskazuje, że pracujesz z pomocnicze źródło danych.

  7. Kliknij pozycję Wybierz wyrażenie XPath Obraz przycisku obok pola wartości.

  8. W oknie dialogowym Wybieranie pola lub grupy, upewnij się, że pola łączące (w tym przykładzie : CategoryID ) jest zaznaczone, a następnie kliknij przycisk OK. Jest to wartość, która zostanie zapisana po dokonaniu wyboru w polu listy.

  9. Kliknij pozycję Wybierz wyrażenie XPath Obraz przycisku obok pola Nazwa wyświetlana.

  10. W oknie dialogowym Wybieranie pola lub grupy, kliknij nazwę pola, które mają być wyświetlane na liście rozwijanej (w tym przykładzie : NazwaKategorii ).

  11. Kliknij dwa razy przycisk OK.

Łączenie z danymi drugie pole listy

Teraz masz połączenia z bazą danych drugie pole listy. Podczas tworzenia to połączenie danych, można zastosować filtr do drugiego pola listy. Do wypełnienia drugiego pola listy z odpowiednimi wartościami, na podstawie wartości wybranej w pierwszym polu listy.

  1. W szablonie formularza kliknij dwukrotnie standardowe pole listy.

  2. Kliknij kartę Dane.

  3. W oknie dialogowym Właściwości pola listy w obszarze pozycje w polu listy, kliknij pozycję Sprawdź wartości z zewnętrznego źródła danych.

  4. W oknie dialogowym źródło danych upewnij się, że jest zaznaczona opcja utworzone połączenie danych.

  5. Kliknij pozycję Wybierz wyrażenie XPath Obraz przycisku obok pola wpisów.

  6. W oknie dialogowym Wybieranie pola lub grupy Rozwiń grupy podstawowej (w tym przykładzie d: kategorie ), a następnie kliknij pomocniczej grupę, której odpowiada tabelę, która zawiera dane, które mają być wyświetlane w polu listy kaskadowe (w tym przykład produktów ).

  7. Kliknij opcję Filtruj dane.

  8. W oknie dialogowym Filtrowanie danych kliknij przycisk Dodaj.

  9. W oknie dialogowym Określanie warunków filtru w pierwszym polu upewnij się, że jest zaznaczone pole łączące z tabeli pomocniczej (w tym przykładzie produkty ).

    Ważne: Jeśli pola łączące mieć tej samej nazwy w obu tabelach, upewnij się, wybierz pozycję poprawne. Pola z każdej tabeli są sortowane razem na liście. W związku z tym służy otaczającego nazw pól do określenia, który jest poprawne. W tym przykładzie możemy zaznacz pole CategoryID pojawi się z innych pól z tabeli Produkty.

  10. W trzecim polu kliknij Wybieranie pola lub grupy.

  11. W polu źródło danych w oknie dialogowym Wybieranie pola lub grupy kliknij głównego, kliknij pole Pole_listy1, a następnie kliknij przycisk OK.

    Filtr porównuje wartość wybraną w polu listy rozwijanej (Pole_listy1) z listy wartości w polu listy standardowy została skonfigurowana.

  12. Kliknij przycisk OK trzy razy, aby powrócić do okna dialogowego Właściwości pola listy.

  13. Kliknij pozycję Wybierz wyrażenie XPath Obraz przycisku obok pola wartości.

  14. W oknie dialogowym Wybieranie pola lub grupy wybierz wartość, która ma zostać zapisany po dokonaniu wyboru w polu listy. W tym przykładzie chcemy Zapisz pole ProductID do późniejszego użycia. W związku z tym, możemy wybierz : ProductID grupy, a następnie kliknij przycisk OK.

  15. Kliknij pozycję Wybierz wyrażenie XPath Obraz przycisku obok pola Nazwa wyświetlana.

  16. W oknie dialogowym Wybieranie pola lub grupy, kliknij nazwę pola, które mają być wyświetlane w polu listy (w tym przykładzie : ProductName ).

  17. Kliknij dwa razy przycisk OK.

Testowanie pól listy

Teraz, gdy masz połączenie z bazą danych drugie pole listy i zastosowaniu filtru, możesz przystąpić do testowania pól listy, aby upewnić się, że działają poprawnie.

  1. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

  2. Wybierz wartość w polu listy rozwijanej. Standardowe pole listy należy wyświetlić odpowiednie wartości z tabeli pomocniczej, w zależności od wybranego pola łączących.

Porada: Jeśli pola listy nie działają poprawnie, zweryfikuj filtr drugiego pola listy, aby upewnić się, że jej Pole_listy1 z pole CategoryID.

Powrót do początku sekcji

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×