Tworzenie i uruchamianie makr

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W programie Word możesz automatyzowanie często wykonywanych zadań przez tworzenie i uruchamianie makr. Makro to szereg poleceń i instrukcji zgrupowanych w jedno polecenie automatycznego wykonania określonego zadania.

Aby zaoszczędzić czas na często wykonywanych zadaniach, połącz odpowiednie czynności w makro. Najpierw musisz zarejestrować makro. Następnie możesz je uruchomić, klikając przycisk na pasku narzędzi Szybki dostęp lub naciskając kombinację klawiszy. Zależy to od konfiguracji makra.

  1. Kliknij pozycję Widok > Makra > Zarejestruj makro.

    Polecenie Zarejestruj makro

  2. Wpisz nazwę makra.

    Pole Nazwa makra

  3. Aby móc korzystać z tego makra we wszystkich nowo tworzonych dokumentach, dla pola Przechowaj makro w ustaw opcję Wszystkie dokumenty (Normal.dotm).

    Pole służące do wyboru miejsca przechowywania makra

  4. Aby makro było uruchamiane po kliknięciu przycisku, kliknij pozycję Przycisk.

    Kliknij, aby przypisać makro do przycisku

  5. Kliknij nowe makro (o nazwie Normal.NewMacros.<nazwa Twojego makra>) i kliknij pozycję Dodaj.

    Makro i przycisk Dodaj

  6. Kliknij pozycję Modyfikuj.

    Przycisk Modyfikuj w oknie Dostosowywanie paska narzędzi Szybki dostęp

  7. Wybierz obraz przycisku, wpisz odpowiednią nazwę i kliknij dwa razy przycisk OK.

    Opcje przycisku w oknie Modyfikowanie przycisku

  8. Zarejestruj teraz czynności. Kliknij polecenia lub naciśnij klawisze dla każdej czynności w zadaniu. Program Word zarejestruje te kliknięcia i sekwencje klawiszy.

    Uwaga : Aby zaznaczyć tekst podczas rejestrowania makra, użyj klawiatury. W makrach nie są rejestrowane zaznaczenia wskaźnikiem myszy.

  9. Aby zatrzymać rejestrowanie, kliknij pozycję Widok > Makra > Zatrzymaj rejestrowanie.

    Polecenie Zatrzymaj rejestrowanie

Przycisk makra pojawi się na pasku narzędzi Szybki dostęp.

Przycisk makra na pasku narzędzi Szybki dostęp

Aby uruchomić makro, kliknij ten przycisk.

  1. Kliknij pozycję Widok > Makra > Zarejestruj makro.

    Polecenie Zarejestruj makro

  2. Wpisz nazwę makra.

    Pole Nazwa makra

  3. Aby móc korzystać z tego makra we wszystkich nowo tworzonych dokumentach, dla pola Przechowaj makro w ustaw opcję Wszystkie dokumenty (Normal.dotm).

    Pole służące do wyboru miejsca przechowywania makra

  4. Aby makro było uruchamiane po naciśnięciu skrótu klawiaturowego, kliknij pozycję Klawiatura.

    Kliknij, aby przypisać makro do skrótu klawiaturowego

  5. W polu Naciśnij nowy klawisz skrótu wpisz kombinację klawiszy.

  6. Sprawdź, czy ta kombinacja nie jest już przypisana do czegoś innego. Jeśli ta kombinacja jest już przypisana, spróbuj użyć innej kombinacji.

  7. Aby móc korzystać z tego skrótu klawiaturowego we wszystkich nowo tworzonych dokumentach, upewnij się, że dla pola Zapisz zmiany w jest ustawiona opcja Normal.dotm.

  8. Kliknij pozycję Przypisz.

  9. Zarejestruj teraz czynności. Kliknij polecenia lub naciśnij klawisze dla każdej czynności w zadaniu. Program Word zarejestruje te kliknięcia i sekwencje klawiszy.

    Uwaga : Aby zaznaczyć tekst podczas rejestrowania makra, użyj klawiatury. W makrach nie są rejestrowane zaznaczenia wskaźnikiem myszy.

  10. Aby zatrzymać rejestrowanie, kliknij pozycję Widok > Makra > Zatrzymaj rejestrowanie.

    Polecenie Zatrzymaj rejestrowanie

Aby uruchomić makro, naciśnij klawisze skrótu klawiaturowego.

Aby uruchomić makro, kliknij odpowiedni przycisk na pasku narzędzi Szybki dostęp, naciśnij skrót klawiaturowy lub skorzystaj z listy Makra.

  1. Kliknij pozycję Widok > Makra > Wyświetl makra.

    Polecenie Wyświetl makra

  2. Na liście w obszarze Nazwa makra kliknij nazwę makra, które chcesz uruchomić.

  3. Kliknij przycisk Uruchom .

Aby udostępnić makro z jednego dokumentu we wszystkich nowych dokumentach, dodaj je do szablonu Normal.dotm.

  1. Otwórz dokument zawierający makro.

  2. Kliknij pozycję Widok > Makra > Wyświetl makra.

    Polecenie Wyświetl makra

  3. Kliknij przycisk Organizator .

    Przycisk Organizator w oknie Makra

  4. Kliknij makro, które chcesz dodać do szablonu Normal.dotm, a następnie kliknij przycisk Kopiuj.

  1. Kliknij pozycję Plik > Opcje > Dostosowywanie Wstążki.

  2. W obszarze Wybierz polecenia z kliknij pozycję Makra.

  3. Kliknij odpowiednie makro.

  4. W obszarze Dostosowywanie wstążki kliknij kartę i grupę niestandardową, do których chcesz dodać makro.

Jeśli nie masz grupy niestandardowej, kliknij pozycję Nowa grupa. Następnie kliknij pozycję Zmień nazwę i wpisz nazwę grupy niestandardowej.

  1. Kliknij przycisk Dodaj.

  2. Kliknij pozycję Zmień nazwę, aby wybrać obraz makra i wpisać odpowiednią nazwę.

  3. Kliknij przycisk OK dwa razy.

  1. Na karcie Deweloper w grupie Kod kliknij przycisk Makra.

  2. W polu Nazwa makra wpisz nazwę makra.

    Uwaga : Jeśli nowe makro zostanie nadana taką samą nazwę jak wbudowane makro w programie Word, akcje nowego makra zastąpią wbudowane makro. Aby wyświetlić listę wbudowanych makr, na liście makra w kliknij pozycję Polecenia programu Word.

  3. Na liście makra w kliknij szablon lub dokument, w którym chcesz przechowywać makro.

    Aby udostępnić makro we wszystkich dokumentach, należy kliknąć przycisk plik Normal.dotm.

  4. Kliknij przycisk Utwórz, aby otworzyć Edytor Visual Basic.

Po otwarciu Edytora Visual Basic, może być więcej informacji na temat pracy z języka Visual Basic for Applications. Aby uzyskać więcej informacji kliknij pozycję Microsoft Visual Basic Help w menu Pomoc lub naciśnij klawisz F1.

Możesz nagrać sekwencji akcji lub od podstaw można napisać makro, wprowadzając kod aplikacji w Edytor Visual Basic języka Visual Basic.

Uwaga : Aby pracować z makrami w Office Word 2007, należy wyświetlić kartę Deweloper.

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Opcje programu Word.

  2. Kliknij pozycję Popularne.

  3. W obszarze najczęściej używane opcje w pracy z programem Word zaznacz pole wyboru Pokaż kartę Deweloper na Wstążce.

    Uwaga : Wstążka to element udostępniany przez interfejs użytkownika Microsoft Office Fluent.

  1. Na karcie Deweloper w grupie Kod kliknij przycisk Zarejestruj makro.

    Grupa Kod na karcie Deweloper
  2. W polu Nazwa makra wpisz nazwę makra.

    Uwaga : Jeśli nowe makro zostanie nadana taką samą nazwę jak wbudowane makro w Office Word 2007, akcje nowego makra zastąpią wbudowane makro. Aby wyświetlić listę wbudowanych makr, na karcie Deweloper w grupie Kod kliknij przycisk makra. Na liście makra w kliknij pozycję Polecenia programu Word.

  3. W polu Przechowaj makro w kliknij szablon lub dokument, w którym chcesz przechowywać makro.

    Ważne : Aby udostępnić makro we wszystkich dokumentach, należy kliknąć przycisk plik Normal.dotm.

  4. W polu Opis wpisz opis makra.

  5. Wykonaj jedną z następujących czynności:

    • Rozpocznij rejestrowanie    Aby rozpocząć rejestrowanie makra bez przypisywania go do przycisku na pasku narzędzi Szybki dostęp lub do klawisza skrótu, kliknij przycisk OK.

    • Przycisk Utwórz    Aby przypisać makro do przycisku na pasku narzędzi Szybki dostęp, wykonaj następujące czynności:

      1. Kliknij przycisk.

      2. W obszarze Dostosuj pasek narzędzi Szybki dostęp wybierz dokument (lub wszystkie dokumenty), dla którego chcesz dodać makro do paska narzędzi Szybki dostęp.

        Ważne : Aby udostępnić makro we wszystkich dokumentach, należy kliknąć przycisk plik Normal.dotm.

      3. W obszarze Wybierz polecenia z okno dialogowe kliknij makro, które są rejestrowane, a następnie kliknij przycisk Dodaj.

      4. Aby dostosować przycisku, kliknij przycisk Modyfikuj.

      5. W obszarze Symbol kliknij symbol, który ma być używany dla tego przycisku.

      6. W polu Nazwa wyświetlana wpisz nazwę makra, które mają być wyświetlane.

      7. Kliknij przycisk OK dwa razy, aby rozpocząć rejestrowanie makra.

        Symbol, który możesz wybrać jest wyświetlany na pasku narzędzi Szybki dostęp. Nazwa wpisane jest wyświetlana po wskazaniu symbol.

    • Przypisywanie skrótu klawiaturowego    Aby przypisać makro do skrótu klawiaturowego, wykonaj następujące czynności:

      1. Kliknij pozycję Klawiatura.

      2. W polu polecenia kliknij makro, które są rejestrowane.

      3. W polu Naciśnij nowy klawisz skrótu wpisz kombinacji klawiszy, która ma być, a następnie kliknij przycisk Przypisz.

      4. Kliknij przycisk Zamknij, aby rozpocząć rejestrowanie makra.

  6. Wykonaj akcje, które chcesz uwzględnić w makrze.

    Uwaga : Podczas rejestrowania makra można użyć myszy do klikania poleceń i opcji, ale nie do zaznaczania tekstu. Aby zaznaczyć tekst, należy użyć klawiatury. Aby uzyskać więcej informacji na temat zaznaczania tekstu przy użyciu klawiatury zobacz Zaznacz tekst.

  7. Aby zatrzymać rejestrowanie akcji, w grupie Kod kliknij przycisk Zatrzymaj rejestrowanie.

Zmienianie skrót klawiaturowy dla makra

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Opcje programu Word.

  2. Kliknij pozycję Dostosuj.

  3. Obok skrótów klawiaturowych kliknij przycisk Dostosuj.

  4. Na liście Kategorie kliknij przycisk makra.

  5. Na liście makra kliknij makro, które chcesz zmienić.

  6. W polu Naciśnij nowy klawisz skrótu wpisz kombinację klawiszy, której chcesz wybrać.

  7. Zaznacz pole obok Bieżące klawisze, aby upewnić się, że nie są przypisywane kombinacji klawiszy, która już za pomocą innego zadania.

  8. Na liście Zapisz zmiany w kliknij opcję odpowiadającą, gdzie chcesz uruchomić makro.

    Ważne : Aby udostępnić makro we wszystkich dokumentach, należy kliknąć przycisk plik Normal.dotm.

  9. Kliknij przycisk Zamknij.

  1. Na karcie Deweloper w grupie Kod kliknij przycisk Makra.

    Grupa Kod na karcie Deweloper

  2. Na liście w obszarze Nazwa makra kliknij makro, które chcesz uruchomić.

  3. Kliknij przycisk Uruchom.

  1. Na karcie Deweloper w grupie Kod kliknij przycisk Makra.

    Grupa Kod na karcie Deweloper

  2. W polu Nazwa makra wpisz nazwę makra.

    Uwaga : Jeśli nowe makro zostanie nadana taką samą nazwę jak wbudowane makro w Office Word 2007, akcje nowego makra zastąpią wbudowane makro. Aby wyświetlić listę wbudowanych makr, na liście makra w kliknij pozycję Polecenia programu Word.

  3. Na liście makra w kliknij szablon lub dokument, w którym chcesz przechowywać makro.

    Aby udostępnić makro we wszystkich dokumentach, należy kliknąć przycisk plik Normal.dotm.

  4. Kliknij przycisk Utwórz, aby otworzyć Edytor Visual Basic.

Po otwarciu Edytora Visual Basic, może być więcej informacji na temat pracy z języka Visual Basic for Applications. Aby uzyskać więcej informacji kliknij pozycję Microsoft Visual Basic Help w menu Pomoc lub naciśnij klawisz F1.

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×