Tworzenie histogramu

Histogram jest wykresem kolumnowym przedstawiającym dane dotyczące częstotliwości.

Uwaga: Ten temat dotyczy tylko tworzenia histogramu. Aby uzyskać informacje na temat wykresów Pareto (posortowany histogram), zobacz Tworzenie wykresu Pareto.

  1. Zaznacz dane.

    (Typowe przykładowe dane histogramu).

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Kliknij pozycję Wstawianie > Wstaw wykres statystyczny > Histogram.

    Polecenie Histogram dostępne przy użyciu przycisku Wstaw wykres statystyczny

    Możesz również utworzyć histogram na karcie wszystkie wykresy w obszarze Polecane wykresy.

Porady: 

  • Użyj kart projektowanie i Formatowanie , aby dostosować wygląd wykresu.

  • Jeśli nie widzisz tych kart, kliknij w obrębie histogramu, aby dodać kartę Narzędzia wykresów do wstążki.

Karty Projektowanie i Formatowanie dla obszaru Narzędzia wykresów

  1. Kliknij prawym przyciskiem myszy poziomą oś wykresu, kliknij polecenie Formatuj oś, a następnie kliknij pozycję Opcje osi.

    Polecenie Formatuj oś w menu skrótów
  2. Korzystając z informacji podanych w poniższej tabeli, można wybrać opcje, które mają być ustawiane w okienku zadań Formatowanie osi .

    Opcja

    Opis

    Według kategorii

    Wybierz tę opcję, jeśli kategorie (oś pozioma) są oparte na tekście zamiast liczbie. Histogram będzie grupować te same kategorie i sumować wartości na osi wartości.

    Porada: Aby zliczyć liczbę wystąpień ciągów tekstowych, dodaj kolumnę i wypełnij ją wartością „1”, a następnie wykreśl histogram i ustaw przedziały Według kategorii.

    Automatyczne

    Jest to ustawienie domyślne histogramów. Szerokość pojemnika jest obliczana przy użyciu normalnej reguły odwołania w Scotta.

    Szerokość przedziału

    Wprowadź dodatnią dziesiętną liczbę punktów danych w każdym zakresie.

    Liczba przedziałów

    Wprowadź liczbę przedziałów histogramu (w tym przedziałów przepełnienia i niedopełnienia).

    Przedział przepełnienia

    Zaznacz to pole wyboru, aby utworzyć pojemnik dla wszystkich wartości powyżej wartości w polu po prawej stronie. Aby zmienić wartość, wprowadź w polu inną liczbę dziesiętną.

    Przedział niedopełnienia

    Zaznacz to pole wyboru, aby utworzyć pojemnik dla wszystkich wartości poniżej lub równy wartości w polu po prawej stronie. Aby zmienić wartość, wprowadź w polu inną liczbę dziesiętną.

    Okienko zadań Formatowanie osi

Porada: Aby zapoznać się z dodatkowymi informacjami na temat wykresu histogramu i sposobu, w jaki ułatwia on wizualizację danych statystycznych, zobacz ten wpis w blogu na wykresie histogram, Pareto i Skrzynka i whisky przez zespół programu Excel. Możesz również pouczyć się więcej na temat innych nowych typów wykresów opisanych w tym wpisie w blogu.

Opcja Automatyczna (normalna reguła odwołań Scotta)   

Formuła dla opcji Automatyczna

Zgodnie z regułą odniesienia normalnego Scotta minimalizowane jest obciążenie w wariancji histogramu w porównaniu z zestawem danych przy założeniu normalnego rozkładu danych.

Opcja zasobnik przepełnienia   

Formuła dla opcji Przedział przepełnienia

Opcja zasobnik nadmiarowy   

Formuła dla opcji Przedział niedopełnienia
  1. Upewnij się, że załadowano dodatek Analysis ToolPak. Aby uzyskać więcej informacji, zobacz Ładowanie dodatku Analysis ToolPak w programie Excel.

  2. W arkuszu wpisz dane wejściowe w jednej kolumnie, dodając ewentualnie etykietę w pierwszej komórce.

    Pamiętaj o użyciu ilościowych danych numerycznych, takich jak ilości elementów lub wyniki testów. Narzędzie Histogram nie obsługuje jakościowych danych numerycznych, takich jak numery identyfikacyjne wprowadzone jako tekst.

  3. W następnej kolumnie wpisz wartości graniczne w kolejności rosnącej, dodając ewentualnie etykietę w pierwszej komórce.

    Warto użyć własnych wartości granicznych, ponieważ mogą się okazać przydatniejsze do analizy. Jeśli nie wprowadzisz wartości granicznych, narzędzie Histogram utworzy równomiernie rozłożone interwały graniczne, używając jako punktów początkowych i końcowych wartości minimalnych i maksymalnych w zakresie wejściowym.

  4. Kliknij pozycję Dane > Analiza danych.

    Przycisk Analiza danych w grupie Analiza danych

  5. Kliknij pozycję Histogram > OK.

    Okno dialogowe Analiza danych

  6. W obszarze Wejście zrób tak:

    1. W polu Zakres wejściowy wprowadź odwołanie do komórki dotyczącej zakresu danych zawierającego liczby wejściowe.

    2. W polu Zakres graniczny wprowadź odwołanie do komórki dotyczące zakresu zawierającego wartości graniczne.

      Jeśli w arkuszu były używane etykiety kolumn, możesz je uwzględnić w odwołaniach do komórek.

      Porada: Zamiast ręcznego wprowadzania odwołań możesz kliknąć przycisk Obraz przycisku , aby tymczasowo zwinąć okno dialogowe i wybrać zakresy w arkuszu. Ponowne kliknięcie przycisku powoduje rozwinięcie okna dialogowego.

  7. Jeśli etykiety kolumn zostały uwzględnione w odwołaniach do komórek, zaznacz pole wyboru Etykiety.

  8. W obszarze Opcje danych wyjściowych wybierz lokalizację danych wyjściowych.

    Możesz umieścić histogram w tym samym arkuszu, w nowym arkuszu bieżącego skoroszytu lub w nowym skoroszycie.

  9. Zaznacz co najmniej jedno z następujących pól wyboru:

    Pareto (posortowany histogram) Powoduje wyświetlenie danych uporządkowanych według malejącej częstotliwości występowania.

    Łączny udział procentowy     Powoduje wyświetlenie łącznych udziałów procentowych i dodanie wiersza łącznego udziału procentowego do wykresu histogramu.

    Wykres wyjściowy     Powoduje wyświetlenie osadzonego wykresu histogramu.

  10. Kliknij przycisk OK.

    Jeśli chcesz dostosować histogram, możesz zmienić etykiety tekstowe i kliknąć dowolne miejsce na wykresie histogramu, aby użyć przycisków elementy wykresu, Style wykresui Filtr wykresu po prawej stronie wykresu.

  1. Zaznacz dane.

    (Typowe przykładowe dane histogramu).

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Kliknij pozycję Wstawianie > Wykres.

    Przycisk Wykres w grupie Ilustracje na karcie Wstawianie w programie Word
  3. W oknie dialogowym Wstawianie wykresu w obszarze wszystkie wykresykliknij pozycję histogram , a następnie kliknij przycisk OK.

Porady: 

  • Użyj kart projektowanie i Formatowanie na Wstążce, aby dostosować wygląd wykresu.

  • Jeśli nie widzisz tych kart, kliknij w obrębie histogramu, aby dodać kartę Narzędzia wykresów do wstążki.

Karty Projektowanie i Formatowanie dla obszaru Narzędzia wykresów

  1. Kliknij prawym przyciskiem myszy poziomą oś wykresu, kliknij polecenie Formatuj oś, a następnie kliknij pozycję Opcje osi.

    Polecenie Formatuj oś w menu skrótów
  2. Korzystając z informacji podanych w poniższej tabeli, można wybrać opcje, które mają być ustawiane w okienku zadań Formatowanie osi .

    Opcja

    Opis

    Według kategorii

    Wybierz tę opcję, jeśli kategorie (oś pozioma) są oparte na tekście zamiast liczbie. Histogram będzie grupować te same kategorie i sumować wartości na osi wartości.

    Porada: Aby zliczyć liczbę wystąpień ciągów tekstowych, dodaj kolumnę i wypełnij ją wartością „1”, a następnie wykreśl histogram i ustaw przedziały Według kategorii.

    Automatyczne

    Jest to ustawienie domyślne histogramów.

    Szerokość przedziału

    Wprowadź dodatnią dziesiętną liczbę punktów danych w każdym zakresie.

    Liczba przedziałów

    Wprowadź liczbę przedziałów histogramu (w tym przedziałów przepełnienia i niedopełnienia).

    Przedział przepełnienia

    Zaznacz to pole wyboru, aby utworzyć pojemnik dla wszystkich wartości powyżej wartości w polu po prawej stronie. Aby zmienić wartość, wprowadź w polu inną liczbę dziesiętną.

    Przedział niedopełnienia

    Zaznacz to pole wyboru, aby utworzyć pojemnik dla wszystkich wartości poniżej lub równy wartości w polu po prawej stronie. Aby zmienić wartość, wprowadź w polu inną liczbę dziesiętną.

    Okienko zadań Formatowanie osi

Porada: Aby zapoznać się z dodatkowymi informacjami na temat wykresu histogramu i sposobu, w jaki ułatwia on wizualizację danych statystycznych, zobacz ten wpis w blogu na wykresie histogram, Pareto i Skrzynka i whisky przez zespół programu Excel. Możesz również pouczyć się więcej na temat innych nowych typów wykresów opisanych w tym wpisie w blogu.

Wykonaj poniższe czynności, aby utworzyć histogram w programie Excel dla komputerów Mac:

  1. Zaznacz dane.

    (Typowe przykładowe dane histogramu).

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Na wstążce kliknij kartę Wstawianie , a następnie kliknij pozycję Ikona wykresu statystycznego (ikonastatystyczna ) i w obszarze histogramwybierz pozycję histogram.

Porady: 

  • Aby dostosować wygląd wykresu, Skorzystaj z kart projektowanie i Formatowaniewykresu .

  • Jeśli nie widzisz kart projektowanie i Formatowanie wykresu, kliknij w dowolnym miejscu histogramu, aby dodać je do wstążki.

Aby utworzyć histogram w programie Excel 2011 dla komputerów Mac, musisz pobrać dodatek innej firmy. Zobacz: nie mogę znaleźć dodatku Analysis ToolPak w programie Excel 2011 dla komputerów Mac, Aby uzyskać więcej szczegółów.

W Excel Online można wyświetlić histogram (wykres kolumnowy, na którym są wyświetlane dane dotyczące częstotliwości), ale nie można go utworzyć, ponieważ wymaga to dodatku Analysis ToolPak, Excel dodatku nieobsługiwanego przez Excel Online.

Jeśli masz aplikację klasyczną Excel, możesz użyć przycisku Edytuj w programie Excel , aby otworzyć Excel na pulpicie i utworzyć histogram.

Przycisk edytowania w programie Excel

  1. Naciśnij, aby zaznaczyć dane.

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Jeśli korzystasz z telefonu, naciśnij ikonę edycji Ikona Edytuj , aby wyświetlić Wstążkę. a następnie naciśnij pozycję Narzędzia główne.

  3. Naciśnij pozycję wstaw > wykresy > histogramu.

    W razie potrzeby możesz dostosować elementy wykresu.

    Uwaga: Ta funkcja jest dostępna tylko dla posiadaczy subskrypcji usługi Office 365. Jeśli jesteś subskrybentem usługi Office 365, upewnij się, że masz najnowszą wersję pakietu Office.

    Wypróbuj usługę Office 365 lub najnowszą wersję programu Excel

  1. Naciśnij, aby zaznaczyć dane.

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Jeśli korzystasz z telefonu, naciśnij ikonę edycji Ikona Edytuj , aby wyświetlić Wstążkę, a następnie naciśnij pozycję Narzędzia główne.

  3. Naciśnij pozycję wstaw > wykresy > histogramu.

Aby utworzyć histogram w Excel, należy podać dwa typy danych — dane, które mają zostać zanalizowane, oraz numery pojemników przedstawiające interwały, według których ma być mierzona częstość. Dane w arkuszu muszą być zorganizowane w dwóch kolumnach. Te kolumny muszą zawierać następujące dane:

  • Dane wejściowe    Dane, które chcesz analizować, za pomocą narzędzia Histogram.

  • Numery pojemników    Te liczby reprezentują interwały, które mają być używane przez narzędzie Histogram do mierzenia danych wejściowych w analizie danych.

Gdy korzystasz z narzędzia histogram, Excel liczy liczbę punktów danych w każdym zasobniku danych. Punkt danych jest zawarty w określonym pojemniku, jeśli liczba jest większa od najmniejszej i równej lub mniejszej od największej wartości w pojemniku danych. W przypadku pominięcia zakresu zbioru Excel zostanie utworzony zestaw równomiernie rozłożonych pojemników między minimalną i maksymalną wartością danych wejściowych.

Wyniki analizy histogramu są wyświetlane w nowym arkuszu (lub w nowym skoroszycie) i zawiera tabelę histogramu oraz wykres kolumnowy, który odzwierciedla dane w tabeli Histogram.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×