Tworzenie formularzy i raportów programu Access na podstawie listy programu SharePoint

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Można tworzyć formularze i raporty z listy programu SharePoint i używać ich jako widoków. Użytkownicy witryny programu SharePoint, którzy mają zainstalowany program Access 2007 można otworzyć tych formularzy i raportów przy użyciu menu Widok listy programu SharePoint. Istnieje możliwość dostępu widok domyślny dla listy.

Widoki utworzone za pomocą Access 2007 są przechowywane w pliku bazy danych na serwerze Windows SharePoint Services. Po otwarciu widoku listy programu SharePoint, program Access zostanie uruchomiony, i wyświetla formularza lub raportu. Ponieważ baza danych znajduje się w witrynie programu SharePoint, można otworzyć widok przez innych użytkowników witryny. Użytkownik nie musi znać lokalizacji w witrynie programu SharePoint, pliku bazy danych, który zawiera widok programu Access w celu korzystanie z widoku. Ponadto użytkownik nie musi nawet się dowiedzieć, jak zacząć dostęp — jest to obsługiwane automatycznie przez witryny programu SharePoint.

Uwaga : Aby utworzyć lub zmodyfikować widok programu Access w witrynie programu SharePoint oraz używać tego widoku, użytkownik musi mieć zainstalowany program Access 2007 na komputerze.

Co chcesz zrobić?

Tworzenie widoku listy programu SharePoint w programie Access

Dostępu do widok domyślny dla listy programu SharePoint

Używanie widoku listy programu SharePoint w programie Access

Modyfikowanie widoku listy programu SharePoint w programie Access

Tworzenie widoku listy programu SharePoint w programie Access

Program Access jest uruchamiany automatycznie po utworzeniu widoku listy programu SharePoint dla programu Access. W programie Access można utworzyć widok na podstawie różnorodnych szablonów formularzy i raportów, a następnie dostosować go. Publikując widok w witrynie programu SharePoint, można go łatwo udostępnić innym użytkownikom.

Uwaga : Aby utworzyć widok listy programu SharePoint, należy mieć uprawnienie Zarządzanie listami programu Windows SharePoint Services, które domyślnie jest zawarte w poziomie uprawnień Projektowanie.

Poniższa procedura umożliwia utworzenie widoku listy programu SharePoint w programie Access wyświetlanego w przeglądarce.

  1. W witrynie programu SharePoint w menu Widok Menu rozwijane kliknij polecenie Utwórz widok.

  2. Na stronie Tworzenie widoku kliknij przycisk Widok programu Access.

    Zostanie uruchomiony program Access, a następnie zostanie wyświetlony monit o zapisanie lokalnej kopii bazy danych, która będzie zawierać nowy widok.

  3. W oknie dialogowym Zapisywanie kopii lokalnej przejdź do lokalizacji na komputerze, gdzie ma zostać zapisana kopia, w polu Nazwa pliku wpisz nazwę kopii lokalnej, a następnie kliknij przycisk Zapisz.

    Kopia lokalna zostanie zapisana i otwarta przez program Access, a następnie zostanie wyświetlone okno dialogowe Tworzenie widoku programu Access.

  4. W oknie dialogowym Tworzenie widoku programu Access kliknij dwukrotnie typ widoku, który chcesz utworzyć.

    W programie Access zostanie utworzony nowy widok, który następnie zostanie otwarty w widoku układu.

  5. Nowy widok możesz dostosować w widoku układu. Możesz także przejść do widoku projektu.

    W widoku układu można zmieniać rozmiar i rozmieszczenie formantów (takich jak etykiety i pola), ale nie można dodawać następnych formantów do widoku. Widok układu zawiera podgląd danych, co pozwala przejrzeć wygląd zmian w gotowym widoku.

    W widoku projektu można zmieniać rozmiar i rozmieszczenie formantów, a także dodawać kolejne formanty do widoku. Jednak widok projektu nie pozwala na podgląd danych.

    Między widokiem projektu a widokiem układu można przełączać się dowolną liczbę razy. Po dodaniu formantów do widoku za pomocą widoku projektu można przełączyć się do widoku układu i rozmieścić te formanty w widoku, wyświetlając przy tym podgląd danych.

  6. Po wprowadzeniu dostosowań kliknij przycisk Opublikuj w witrynie programu SharePoint na pasku komunikatów.

    Pasek narzędzi

    Zostanie wyświetlone okno dialogowe Publikowanie na serwerze sieci Web.

    Jeśli pasek komunikatów nie będzie widoczny, należy go wyświetlić, wykonując następujące czynności:

    • Na karcie Narzędzia bazy danych w grupie Pokazywanie/ukrywanie kliknij przycisk Pasek komunikatów.

  7. Domyślnie widok jest zapisywany przez program Access w pliku bazy danych znajdującym się w bibliotece Dokumenty udostępnione w witrynie programu SharePoint — zawiera ona listę, na podstawie której utworzono widok. Jest to zapewne pożądane w większości przypadków, ale bibliotekę dokumentów do przechowywania bazy danych można zmienić, wybierając inną w polu Zapisz w okna dialogowego Publikowanie na serwerze sieci Web. Można to zrobić, aby dokładniej kontrolować dostęp do widoku i określać, czy użytkownicy mogą otwierać widok w trybie tylko do odczytu czy w trybie edycji. Witryna programu SharePoint może także mieć skonfigurowane specjalne biblioteki do publikowania widoków programu Access. W takim przypadku może być konieczna zmiana lokalizacji w polu Zapisz w, aby wskazywała ona poprawną bibliotekę.

    Administrator witryny programu SharePoint może pomóc w wyborze poprawnej biblioteki.

  8. Program Access proponuje nazwę bazy danych w polu Nazwa pliku okna dialogowego Publikowanie na serwerze sieci Web. Ta nazwa odpowiada nazwie bazy danych zapisanej jako kopia lokalna. Można ją zmienić, lecz w większości przypadków należy ją zaakceptować — ułatwi to zapamiętanie, która lokalna baza danych odpowiada bazie danych opublikowanej w witrynie programu SharePoint.

  9. Kliknij przycisk Publikuj, aby zapisać bazę danych w witrynie programu SharePoint.

Początek strony

Dostępu do widok domyślny dla listy programu SharePoint

Po wprowadzeniu programu Access dla listy programu SharePoint widok domyślny widok programu Access zostanie otwarty automatycznie po otwarciu listy, jeśli ci użytkownicy mają dostęp na swoich komputerach.

Ważne : Jeśli wprowadzisz widoku domyślnego widoku listy odwiedzający, którzy nie mają zainstalowanego programu Access 2007 nie będzie mógł korzystać z listy.

  1. Z listy programu SharePoint jest otwarta, w menu Ustawienia kliknij przycisk Ustawienia listy.

  2. Na stronie Ustawienia listy w obszarze Widoki, kliknij nazwę widoku programu Access, który chcesz ustawić jako widok domyślny.

  3. Na stronie Edytowanie widoku wybierz pozycję Ustaw ten widok domyślny, a następnie kliknij przycisk OK.

Początek strony

Używanie widoku listy programu SharePoint w programie Access

Aby użyć widoku listy programu SharePoint w programie Access, należy wybrać widok programu Access z menu Widok listy.

  • W menu Widok Menu rozwijane kliknij nazwę widoku programu Access. Zostanie uruchomiony program Access, a następnie zostanie wyświetlony widok w trybie tylko do odczytu.

    W trybie tylko do odczytu można zmieniać dane w widoku oraz drukować widok, ale nie można zmieniać jego projektu. Aby zmienić projekt widoku, należy zapoznać się z następną sekcją tego artykułu (Modyfikowanie widoku listy programu SharePoint w programie Access).

Początek strony

Modyfikowanie widoku listy programu SharePoint w programie Access

Aby zmodyfikować projekt widoku programu Access, należy zapisać kopię lokalną bazy danych zawierającej ten widok i wprowadzić odpowiednie zmiany. Następnie można używać kopii lokalnej widoku lub, jeśli użytkownik ma odpowiednie uprawnienia w witrynie programu SharePoint, opublikować nowy widok.

Uwaga : Kopię lokalną można modyfikować w widoku programu Access niezależnie od posiadanego poziomu uprawnień w programie Windows SharePoint Services. Jednak aby opublikować zmodyfikowany widok w witrynie programu SharePoint, należy mieć uprawnienie Zarządzanie listami programu Windows SharePoint Services, które domyślnie jest zawarte w poziomie uprawnień Projektowanie. Jeśli użytkownik utworzył widok programu Access, powinien już mieć uprawnienie Zarządzanie listami. W przypadku braku pewności należy skontaktować się z administratorem witryny programu SharePoint w celu określenia, czy bieżące uprawnienia są odpowiednie.

  1. Po otwarciu widoku programu Access na pasku komunikatów kliknij przycisk Zapisz jako.

    Przycisk Zapisz jako na pasku komunikatów

    Uwaga : Jeśli pasek komunikatów nie będzie widoczny, należy go wyświetlić, wykonując następujące czynności:

    • Na karcie Narzędzia bazy danych w grupie Pokazywanie/ukrywanie kliknij przycisk Pasek komunikatów.

  2. Gdy w programie Access zostanie wyświetlony monit o zamknięcie widoku i wszystkich pozostałych otwartych obiektów, kliknij przycisk Tak.

    Zostanie wyświetlone okno dialogowe Zapisywanie jako.

  3. W polu Zapisz w określ lokalizację, w której chcesz zapisać kopię lokalną, wpisz nazwę tej kopii w polu Nazwa pliku, a następnie kliknij przycisk Zapisz.

    Kopia lokalna bazy danych zostanie zapisana, a następnie otwarta w programie Access.

  4. Wykonaj jedną z następujących czynności: 

    • Aby zmienić układ widoku bez dodawania nowych formantów, w okienku nawigacji kliknij prawym przyciskiem myszy widok, a następnie w menu skrótów kliknij polecenie Widok układu.

      W widoku układu można zmieniać rozmiar i rozmieszczenie formantów (takich jak etykiety i pola), ale nie można dodawać następnych formantów do widoku. Widok układu zawiera podgląd danych, co pozwala przejrzeć wygląd zmian w gotowym widoku.

    • Aby dodać formanty (takie jak etykiety i pola) lub usunąć je z widoku, w okienku nawigacji kliknij prawym przyciskiem myszy widok, a następnie w menu skrótów kliknij polecenie Widok projektu.

      W widoku projektu można zmieniać rozmiar i rozmieszczenie formantów, a także dodawać kolejne formanty do widoku. Jednak widok projektu nie pozwala na podgląd danych.

      Uwaga : Jeśli wybrano opcję edytowania widoku w widoku projektu i jest planowane opublikowanie zmodyfikowanego widoku w witrynie programu SharePoint, nie należy dodawać do widoku żadnych pól, które nie wchodzą w skład listy programu SharePoint.

  5. Między widokiem projektu a widokiem układu można przełączać się dowolną liczbę razy. Po dodaniu formantów do widoku za pomocą widoku projektu można przełączyć się do widoku układu i rozmieścić te formanty w widoku, wyświetlając przy tym podgląd danych.

Publikowanie zmodyfikowanego widoku programu Access w witrynie programu SharePoint

Po zakończeniu modyfikowania widoku, jeśli użytkownik ma uprawnienie Zarządzanie listami w witrynie programu SharePoint, można opublikować zmodyfikowany widok, wykonując następującą procedurę.

W celu uzyskania uprawnienia Zarządzanie listami należy skontaktować się z administratorem witryny programu SharePoint.

  1. Zapisz widok w lokalnej kopii bazy danych.

  2. Na pasku komunikatów kliknij przycisk Opublikuj w witrynie programu SharePoint.

    Pasek narzędzi

    Uwaga : W przypadku braku uprawnienia Zarządzanie listami na pasku komunikatów nie zostanie wyświetlony przycisk Opublikuj w witrynie programu SharePoint. Jeśli pasek komunikatów nie będzie widoczny, należy go wyświetlić, wykonując następujące czynności:

    • Na karcie Narzędzia bazy danych w grupie Pokazywanie/ukrywanie kliknij przycisk Pasek komunikatów.

  3. W oknie dialogowym Publikowanie na serwerze sieci Web kliknij przycisk Publikuj.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×