Tworzenie formuł warunkowych

Testowanie, czy określone warunki są spełnione, i logiczne porównywanie wyrażeń to operacje typowe dla wielu zadań. Do tworzenia formuł warunkowych służą funkcje ORAZ, LUB, NIE i JEŻELI.

Na przykład w przypadku funkcji JEŻELI są stosowane następujące argumenty:

formuła zawierająca funkcję JEŻELI

Formuła z użyciem funkcji JEŻELI

Obraz przycisku  test_logiczny: warunek, który ma zostać sprawdzony.

Objaśnienie 2  wartość_jeżeli_prawda: wartość, jaka ma zostać zwrócona, jeśli warunek okaże się prawdziwy.

Obraz przycisku  wartość_jeżeli_fałsz: wartość, jaka ma zostać zwrócona, jeśli warunek okaże się fałszywy.

Aby uzyskać więcej informacji na temat sposobów tworzenia formuł, zobacz Tworzenie lub usuwanie formuły.

Co chcesz zrobić?

Tworzenie formuł warunkowych zwracających wartość logiczną (PRAWDA lub FAŁSZ)

Tworzenie formuł warunkowych, których wynikiem są obliczenia lub wartości inne niż PRAWDA i FAŁSZ

Tworzenie formuł warunkowych zwracających wartość logiczną (PRAWDA lub FAŁSZ)

Do wykonania tego zadania należy użyć funkcji ORAZ, LUB i NIE, a także operatorów, tak jak to pokazano w poniższym przykładzie.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak skopiować przykład?

  1. Zaznacz przykład w tym artykule.

    Ważne : Nie zaznaczaj nagłówków wierszy ani kolumn.

    Zaznaczanie przykładu w Pomocy programu Excel 2013 dla systemu Windows

    Zaznaczanie przykładu w Pomocy

  2. Naciśnij klawisze CTRL+C.

  3. W programie Excel utwórz pusty skoroszyt lub arkusz.

  4. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.

Ważne : Aby przykład działał poprawnie, musi zostać wklejony do komórki A1 w arkuszu.

  1. Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

Po skopiowaniu przykładu do pustego arkusza można dopasować go do własnych potrzeb.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Dane

15

9

8

Zębatki

Wihajstry

Formuła

Opis (wynik)

=ORAZ(A2>A3; A2<A4)

Określa, czy wartość w komórce A2 jest większa niż wartość w komórce A3 i mniejsza niż wartość w komórce A4. (FAŁSZ)

=LUB(A2>A3; A2<A4)

Określa, czy wartość w komórce A2 jest większa niż wartość w komórce A3 lub mniejsza niż wartość w komórce A4. (PRAWDA)

=NIE(A2+A3=24)

Określa, czy suma wartości w komórkach A2 i A3 jest różna od 24. (FAŁSZ)

=NIE(A5="Zębatki")

Określa, czy wartość w komórce A5 jest różna niż tekst „Zębatki”. (FAŁSZ)

=LUB(A5<>"Zębatki";A6 = "Wihajstry")

Określa, czy wartość w komórce A5 jest różna niż tekst „Zębatki” lub równa tekstowi „Wihajstry”. (PRAWDA)

Aby uzyskać więcej informacji, zobacz tematy dotyczące funkcji ORAZ, LUB i NIE.

Początek strony

Tworzenie formuł warunkowych, których wynikiem są obliczenia lub wartości inne niż PRAWDA i FAŁSZ

Do wykonania tego zadania należy użyć funkcji JEŻELI, ORAZ i LUB oraz operatorów, tak jak to pokazano w poniższym przykładzie.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak skopiować przykład?

  1. Zaznacz przykład w tym artykule.

Ważne : Nie zaznaczaj nagłówków wierszy ani kolumn.

Zaznaczanie przykładu w Pomocy programu Excel 2013 dla systemu Windows

Zaznaczanie przykładu w Pomocy

  1. Naciśnij klawisze CTRL+C.

  2. W programie Excel utwórz pusty skoroszyt lub arkusz.

  3. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.

Ważne : Aby przykład działał poprawnie, musi zostać wklejony do komórki A1 w arkuszu.

  1. Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

Po skopiowaniu przykładu do pustego arkusza można dopasować go do własnych potrzeb.

1

2

3

4

5

6

7


8



9



10



11




12



13



14




15



16

A

B

Dane

15

9

8

Zębatki

Wihajstry

Formuła

Opis (wynik)

=JEŻELI(A2=15;"OK";"Nie OK")

Jeśli wartość w komórce A2 jest równa 15, zwracany jest tekst „OK”. W przeciwnym razie zwracany jest tekst „Nie OK”. (OK)

=JEŻELI(A2<>15;"OK";"Nie OK")

Jeśli wartość w komórce A2 jest różna niż 15, zwracany jest tekst „OK”. W przeciwnym razie zwracany jest tekst „Nie OK”. (Nie OK)

=JEŻELI(NIE(A2<=15);"OK";"Nie OK")

Jeśli wartość w komórce A2 nie jest mniejsza niż ani równa 15, zwracany jest tekst „OK”. W przeciwnym razie zwracany jest tekst „Nie OK”. (Nie OK)

=JEŻELI(A5<>"ZĘBATKI";"OK";"Nie OK")

Jeśli wartość w komórce A5 jest różna niż tekst „ZĘBATKI”, zwracany jest tekst „OK”. W przeciwnym razie zwracany jest tekst „Nie OK”. (Nie OK)

=JEŻELI(ORAZ(A2>A3;A2<A4);"OK";"Nie OK")

Jeśli wartość w komórce A2 jest większa niż wartość w komórce A3 i mniejsza niż wartość w komórce A4, zwracany jest tekst „OK”. W przeciwnym razie zwracany jest tekst „Nie OK”. (Nie OK)

=JEŻELI(ORAZ(A2<>A3;A2<>A4);"OK";"Nie OK")

Jeśli wartość w komórce A2 jest różna niż wartość w komórce A3 i różna niż wartość w komórce A4, zwracany jest tekst „OK”. W przeciwnym razie zwracany jest tekst „Nie OK”. (OK)

=JEŻELI(LUB(A2>A3;A2<A4);"OK";"Nie OK")

Jeśli wartość w komórce A2 jest większa niż wartość w komórce A3 lub mniejsza niż wartość w komórce A4, zwracany jest tekst „OK”. W przeciwnym razie zwracany jest tekst „Nie OK”. (OK)

=JEŻELI(LUB(A5<>"Zębatki"; A6<>"Wihajstry"); "OK"; "Nie OK")

Jeśli wartość w komórce A5 jest różna niż tekst „Zębatki” lub wartość w komórce A6 jest różna niż tekst „Wihajstry”, zwracany jest tekst „OK”. W przeciwnym razie zwracany jest tekst „Nie OK”. (Nie OK)

=JEŻELI(LUB(A2<>A3lA2<>A4);"OK";"Nie OK")

Jeśli wartość w komórce A2 jest różna niż wartość w komórce A3 lub różna niż wartość w komórce A4, zwracany jest tekst „OK”. W przeciwnym razie zwracany jest tekst „Nie OK”. (OK)

Aby uzyskać więcej informacji, zobacz tematy dotyczące funkcji JEŻELI, ORAZ i LUB.

Początek strony

Czy te informacje były pomocne?

Jak możemy to poprawić?

Jak możemy to poprawić?

Aby chronić swoją prywatność, nie dołączaj do opinii informacji o kontakcie. Przejrzyj nasze zasady zachowania poufności informacji.

Dziękujemy za opinię!