Tworzenie diagramu wdrożenia UML

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Możesz utworzyć diagram wdrożenia UML pokazanie architektura wdrażania artefaktów oprogramowania do węzłów. Najpierw otwórz szablon Wdrożenia UML i wybierz jedną z opcji cztery szablonu. Następnie wzornika Diagram wdrożenia UML pojawi się wraz z kształtów, które są zgodne z 2,5 UML standardowy.

Diagram wdrożenia UML wzornika przykład kształty na stronie

Uwaga : Wzornik Wdrożenia UML jest dostępna tylko w przypadku subskrybentów Program Visio Pro dla Office 365 . Jeśli masz subskrypcję, Upewnij się, że masz najnowszą wersję programu Visio.

  1. Uruchom program Visio. Lub jeśli masz już otwarciu pliku, kliknij pozycję plik > Nowy.

  2. Przejdź do kategorii > oprogramowania i baz danych > wdrożenia UML.

  3. Wybierz pusty szablon lub lub diagramy startowe trzy z nich. Po wybraniu szablonu, który ma, kliknij przycisk Utwórz.

  4. Powinien zostać wyświetlony okna Kształty obok diagramu. Jeśli nie widzisz, przejdź do pozycji Widok > Okienka zadań i upewnij się, że jest zaznaczony kształt. Jeśli nadal nie widać, kliknij przycisk Rozwiń okno kształty Okno Kształty przycisk Rozwiń po lewej stronie.

  5. Na karcie Widok upewnij się, że jest zaznaczone pole wyboru obok Punkty połączeń. Spowoduje to połączenie, którego punkty są wyświetlane po uruchomieniu łączenie kształtów.

  6. Teraz przeciągnij kształty, które chcesz uwzględnić na diagramie z okna Kształty na stronę. Aby zmienić tekst etykiet, kliknij dwukrotnie etykiet.

Kiedy należy używać

  1. Jeśli chcesz określić wystąpienie urządzenia obliczeniowy lub fizyczny wykonywalna za pomocą kształtów Wystąpienie węzła.

  2. Umieszczanie kształtów Wystąpienie artefaktu wewnątrz kształtów wystąpienie węzeł wdrożenia artefakty.

1 wskazujący na wystąpienie węzła kształtu "<< w chmurze maszyn wirtualnych >>: MachineInstance"; 2 wskazująca kształtu artefaktu: "<< artefaktu >> liczbę Cruncher.py"

Krok 1

Przeciągnij na stronę kształtu Wystąpienie węzła najpierw, a następnie go powiększyć, przeciągając uchwyty kształtu.

Kształt wystąpienie węzła zmieniony na większym

Krok 2

Przeciągnij kształt Wystąpienia artefaktu i umieść go wewnątrz większy kształt węzła. Gdy zostanie wyświetlony zielone wyróżnienie, oznacza to, że mniejszym kształtem będzie zawierać większy kształt węzła. Od tego momentu gdy zostanie przeniesiony kształt węzła, artefaktu wewnątrz spowoduje przeniesienie także.

Przeciąganie kształtu artefaktu u góry wystąpienie węzła kształt, zielone wyróżnienie

Istnieją inne kształty kontenera we wzorniku Wdrożenia UML. Zachowują się jak kształt wystąpienie węzła. Oznacza to, że po upuszczeniu kształty na ich kształty są przyklejone a spowoduje przeniesienie z tym kontenerem. Oto niektóre z najbardziej popularne kształty kontenera diagramy wdrożenia:

Węzły hierarchii

Kształty węzeł zagnieżdżone wewnątrz po mają być wyświetlane ich hierarchicznie.

Węzła UserClient, zawierającego węzeł przeglądarki, który zawiera artefaktu HTML5

Kształty pakietu

Kształty pakietu, gdy trzeba reprezentują zawierające elementy, takie jak folder.

Kształt pakiet zawierający inne kształty wystąpienie i artefaktu węzeł

Omówienie diagramu

Użyj kształtu Omówienie Diagram, należy ująć wszystkie kształty z ramką.

Diagram omówienie kształt zawierający inne kształty wystąpienie i artefaktu węzeł

Wyprostować łączniki

Jeśli łącznik trwa zbyt wiele zmieni się, kliknij go prawym przyciskiem myszy, a następnie kliknij r Może połączyć się proste.

Pokazywanie liczebność

W razie potrzeby kliknij łącznik prawym przyciskiem myszy i wybierz pozycję Pokaż liczebność. Po wykonaniu tych są wyświetlane czterema polami tekstowymi, miejsce, w którym można dodać szczegóły. Jeśli nie potrzebujesz wszystkich pól tekstowych, należy usunąć te, których nie potrzebujesz.

Zmiana typu łącznika

Możesz zmienić typ łącznika. Możesz na przykład zmienić z skojarzenia do skojarzenia przekierowanie. Kliknij prawym przyciskiem myszy łącznik, a następnie kliknij polecenie Ustaw typ łącznika.

Nawiązywanie połączenia dynamiczne zamiast punktu połączenia

Jeśli przewidujesz wiele przenoszenie kształtów, należy rozważyć, czy połączenie dynamiczne zamiast punkt połączenia.

Przenoszenie lub obracanie tekstu na łączników

Prawdopodobnie musisz obracanie i przenoszenie tekstu na swojej linie łączników. Oto jak to zrobić:

  1. Kliknij pusty obszar strony, aby usunąć zaznaczenie nic może być zaznaczony.

  2. Na karcie Narzędzia główne w grupie Narzędzia kliknij Narzędzie blok tekstu Przycisk bloku tekstu

  3. Kliknij łącznik, który zawiera tekst, którą chcesz obrócić lub przenieść.

  4. Przeciągnij blok tekstu, aby go przenieść, lub obracanie go przy użyciu Uchwyt obrotu Uchwyt obrotu podczas przeciągania

  5. Gdy skończysz, kliknij przycisk Wskaźnik — narzędzie Przycisk wskaźnika

    Po przełączeniu się do przycisk Wskaźnik — narzędzie Przycisk wskaźnika tekst pozwala na tej samej pozycji względem kształtu. Jeśli przeciągnij wskaźnik nad tekstem za pomocą Narzędzia wskaźnik Przycisk wskaźnika kształt będzie również przenieść. Aby przenieść tekst niezależnie od kształtu, wróć do Narzędzia blok tekstu Przycisk bloku tekstu .

Kiedy należy używać

Kształty składnika dla każdej jednostki funkcjonalności systemu lub w aplikacji.

Kształt składnik "Store"

Pokazywanie lub ukrywanie stereotypu

Kliknij prawym przyciskiem myszy kształt, który chcesz pokazać lub ukryć etykiety stereotyp.

Kliknij prawym przyciskiem myszy, polecenie Pokaż stereotyp, << składnik >> Tekst etykiety

Kiedy należy używać

  1. Kształt Interfejsu opisane jest chcesz określić realizacji interfejs klasy.

  2. Za pomocą Interfejsu wymagane chcesz określić zależność klasy-interfejsu.

Połączenie dwóch interfejsów, 1: kształt podany interfejs kończące się literami okrąg, 2: kształt wymagany interfejs kończące się literami socket

Krok 1

Przeciągnij kształt Podany interfejs do strony, a wyrównać ramka portu z punktu połączenia. Pamiętaj, że jest podłączone po wyświetleniu zielone wyróżnienie wokół punktu połączenia.

Opisane kształt interfejs przyklejony do kształtu składnik

Krok 2

Przeciągnij kształt Wymagany interfejs do strony, a wyrównać kwadrat portu z punktu połączenia, a także. Pamiętaj, że jest podłączone po wyświetleniu zielone wyróżnienie wokół punktu połączenia.

Wymagane kształt interfejs przyklejony do kształtu składnik

Krok 3

Aby połączyć oba interfejsem dostarczonych i wymagane razem, najpierw zaznacz kształt wymagane interfejsu. Następnie znajdź żółty uchwyt.

Żółty uchwyt dla kształtu interfejs wymagane

Krok 4

Przeciągnij żółty uchwyt, aby połączyć się z interfejsu opisane.

Wymagane kształt interfejs połączony z udostępnionej interfejsu

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Zobacz też

Diagramy UML w programie Visio

Tworzenie diagramu składników UML

Tworzenie diagramu UML komunikacji

Tworzenie diagramu sekwencji UML

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×