Tworzenie diagramu UML komunikacji

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Możesz utworzyć diagramu UML komunikacji, aby pokazywać interakcje między linie życia korzystające sekwencjonowanej wiadomości w układzie dowolnych. Najpierw otwórz szablon UML komunikacji i wybierz jedną z opcji cztery szablonu. Następnie wzornika UML komunikacji pojawi się wraz z kształtów, które są zgodne z 2,5 UML standardowy.

Komunikacja UML wzornik, przykład kształty na stronie

Uwaga : Wzornik Komunikacji UML jest dostępna tylko w przypadku subskrybentów Program Visio Pro dla Office 365 . Jeśli masz subskrypcję, Upewnij się, że masz najnowszą wersję programu Visio.

  1. Uruchom program Visio. Lub jeśli masz już otwarciu pliku, kliknij pozycję plik > Nowy.

  2. Przejdź do kategorii > oprogramowania i baz danych > komunikacji UML.

  3. Wybierz pusty szablon lub lub diagramy startowe trzy z nich. Jeśli ma reprezentować współpracy linii życia, wyświetlając interakcje między linie życia, upewnij się wybrać starter diagram w lewym dolnym rogu.

  4. Kliknij przycisk Utwórz.

  5. Powinien zostać wyświetlony okna Kształty obok diagramu. Jeśli nie widzisz, przejdź do pozycji Widok > Okienka zadań i upewnij się, że jest zaznaczony kształt. Jeśli nadal nie widać, kliknij przycisk Rozwiń okno kształty Okno Kształty przycisk Rozwiń po lewej stronie.

  6. Na karcie Widok upewnij się, że jest zaznaczone pole wyboru obok Punkty połączeń. Spowoduje to połączenie, którego punkty są wyświetlane po uruchomieniu łączenie kształtów.

  7. Teraz przeciągnij kształty, które chcesz uwzględnić na diagramie z okna Kształty na stronę. Aby zmienić tekst etykiet, kliknij dwukrotnie etykiet.

Kiedy należy używać

  1. Przeciągnij kształt Aktor na stronę, aby oznaczyć roli użytkownika lub systemu zewnętrznego.

  2. Przeciągnij kształt linii życia na stronę dla każdego nazwanego elementu, który przedstawia uczestnika.

1: Aktor kształt z "Ktoś" tekst 2: kształt linia życia z ": dywidendy" tekstu

Krok 1

Przeciągnij na stronę kształt komunikatu i przyklej jeden z punktów końcowych do punktu połączenia na innym kształcie. Wiadomo, że jest przyklejony po zielony kwadrat wokół punktu połączenia.

Kształt wiadomości z jednym końcu podświetlone na zielono i połączony z kształtem Linia życia

Krok 2

Wykonaj tę samą na koniec wiadomości, tak aby również jest przyklejony do punktu połączenia. Wiadomo, że jest przyklejony po zielone wyróżnienie wokół punktu.

Kształt wiadomości z zakończenia podświetlone na zielono i podłączony do innego kształtu Linia życia

Krok 3

Jeśli chcesz asynchroniczne wiadomość, kliknij prawym przyciskiem myszy i umożliwia wybór trybu. Które zmieni zamknięty grotu Otwórz jeden.

Komunikat kształtu, kliknij prawym przyciskiem myszy menu, wybrane polecenie asynchroniczne

Omówienie

  1. Najpierw połączyć linie życia za pomocą narzędzia Łącznik.

  2. Następnie skorzystaj z kształtów wiadomość i Powrócić do wiadomości, aby pokazywać interakcje między linie życia.

1 wskazująca linii łącznika szarym 2 wskazująca wiersz wiadomości z tekstem "4: Execute()"

Krok 1

Na karcie Narzędzia główne kliknij pozycję narzędzia Łącznik (1). Umieść wskaźnik myszy nad jednym z punktów połączeń kształtu Linia życia, aż zobaczysz zielone Wyróżnienie (2).

1 wskazująca narzędzia Łącznik 2 wskazująca kursor umieszczenie wskaźnika myszy na zielono wyróżniony punkt połączenia kształtu Linia życia

Krok 2

Kliknij i przeciągnij z zielone wyróżnienie do punktu połączenia na innym kształcie linii życia do momentu wyświetlenia wyróżnienie, tak jak poniżej.

Koniec linii łącznika przeciąganie do innego kształtu Linia życia z zielone wyróżnienie wokół punktu połączenia

Krok 3

Gdy skończysz, kliknij narzędzie wskaźnik łączących kształty linia życia.

"Kliknij tutaj po zakończeniu" wskaż polecenie wskaźnik — narzędzie

Krok 4

Przeciągnij inny kształt wiadomości, tak aby była równoległa do innych linii.

Kursor położenie kształtu komunikat na miejsce obok linii łącznika

Wyprostować łączniki

Jeśli łącznik trwa zbyt wiele zmieni się, kliknij go prawym przyciskiem myszy, a następnie kliknij r Może połączyć się proste.

Zmiana typu łącznika

Możesz zmienić typ łącznika. Możesz na przykład zmienić z skojarzenia do skojarzenia przekierowanie. Kliknij prawym przyciskiem myszy łącznik, a następnie kliknij polecenie Ustaw typ łącznika.

Nawiązywanie połączenia dynamiczne zamiast punktu połączenia

Jeśli przewidujesz wiele przenoszenie kształtów, należy rozważyć, czy połączenie dynamiczne zamiast punkt połączenia.

Przenoszenie lub obracanie tekstu na łączników

Prawdopodobnie musisz obracanie i przenoszenie tekstu na swojej linie łączników. Oto jak to zrobić:

  1. Kliknij pusty obszar strony, aby usunąć zaznaczenie nic może być zaznaczony.

  2. Na karcie Narzędzia główne w grupie Narzędzia kliknij Narzędzie blok tekstu Przycisk bloku tekstu

  3. Kliknij łącznik, który zawiera tekst, którą chcesz obrócić lub przenieść.

  4. Przeciągnij blok tekstu, aby go przenieść, lub obracanie go przy użyciu Uchwyt obrotu Uchwyt obrotu podczas przeciągania

  5. Gdy skończysz, kliknij przycisk Wskaźnik — narzędzie Przycisk wskaźnika

    Po przełączeniu się do przycisk Wskaźnik — narzędzie Przycisk wskaźnika tekst pozwala na tej samej pozycji względem kształtu. Jeśli przeciągnij wskaźnik nad tekstem za pomocą Narzędzia wskaźnik Przycisk wskaźnika kształt będzie również przenieść. Aby przenieść tekst niezależnie od kształtu, wróć do Narzędzia blok tekstu Przycisk bloku tekstu .

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Zobacz też

Diagramy UML w programie Visio

Tworzenie diagramu składników UML

Tworzenie diagramu wdrożenia UML

Tworzenie diagramu sekwencji UML

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×