Tworzenie diagramu ORM

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Szablon Diagram ORM programu Microsoft Office Visio zawiera wszystkie kształty niezbędne do przedstawiania reguł biznesowych i projektowania baz danych za pomocą metody ORM (Object Role Modeling). Jest to semantyczna metoda modelowania, w której świat jest opisywany przez obiekty i pełnione przez nie role.

Przykład diagramu ORM

  1. W menu Plik wskaż polecenie Nowy, wskaż polecenie Oprogramowanie i baza danych, a następnie kliknij polecenie Diagram ORM.

    Porada : Przed utworzeniem diagramu ORM należy wynotować, jakie informacje mają się znaleźć w bazie danych. W kilku krótkich zdaniach należy opisać istniejące obiekty, sposób ich identyfikacji i pełnione przez nie role.

  2. Dodaj typ obiektu (encja) i określ jego nazwę:

    1. Przeciągnij kształt Encja (symbolizujący typ obiektu) z wzornika Diagram ORM na stronę rysunku.

    2. Gdy kształt jest zaznaczony, wpisz nazwę typu encji.

    3. Naciśnij klawisz ENTER, a następnie wpisz w nawiasach tryb odwołania encji.

  3. Dodaj typ wartości i określ jego nazwę:

    1. Przeciągnij kształt Wartość z wzornika Diagram ORM na stronę rysunku.

    2. Gdy kształt jest zaznaczony, wpisz nazwę typu wartości.

  4. Wskaż podtyp:

    1. Przeciągnij kształt Łącznik podtypu z wzornika Diagram ORM na stronę rysunku.

    2. Przyklej punkt końcowy Obraz punktu końcowego — zielony kwadrat ze znakiem plus do punktu połączenia Obraz punktu połączenia — niebieski znak X kształtu obiektu podtypu.

      Punkt końcowy zmieni kolor na czerwony, co oznacza przyklejenie łącznika do kształtu. Sklejone kształty można przenosić bez przerywania połączenia.

    3. Przyklej początkowego punktu Obraz punktu początkowego — zielony kwadrat ze znakiem X w środku (koniec strzałki) do punktu połączenia Obraz punktu połączenia — niebieski znak X na inny typ obiektu.

  5. Wykonaj jedną z następujących czynności:

    1. Wskaż relację, rolę lub fakt między typami obiektów:

      1. Przeciągnij kształt predykatu (Jednoelementowy, Dwuelementowy, Dwuelementowy pionowy, Trzyelementowy lub Czteroelementowy) z wzornika Diagram ORM na stronę rysunku.

        Użyj kształtu predykatu, który zawiera wystarczającą liczbę pól roli do połączenia z typami wszystkich obiektów (kształtów encji) uczestniczących w relacji. Użyj na przykład kształtu Trzyelementowy, aby określić relacje między trzema encjami.

      2. Przeciągnij kształt Łącznik roli z wzornika Diagram ORM na stronę rysunku.

      3. Przyklej punkt początkowy Obraz punktu początkowego — zielony kwadrat ze znakiem X w środku Łącznik roli kształtu do punktu połączenia Obraz punktu połączenia — niebieski znak X typu obiektu (kształtu Encja), dla którego chcesz zdefiniować relację.

        Punkt początkowy zmieni kolor na czerwony, co oznacza przyklejenie łącznika do kształtu. Sklejone kształty można przenosić bez przerywania połączenia.

      4. Przyklej punkt końcowy Obraz punktu końcowego — zielony kwadrat ze znakiem plus kształtu Łącznik roli do odpowiedniego pola roli kształtu predykatu (z kroku 1).

      5. Kliknij dwukrotnie kształt predykatu. Umieść punkt wstawiania między elipsami (lub symbolami zastępczymi), a następnie wpisz nazwę roli pełnionej przez typ encji.

      6. Powtórz kroki 2–5 dla każdej encji, dla której chcesz zdefiniować relację.

    2. Wskaż relację, rolę lub odwołanie między encją a wartością:

      1. Przeciągnij kształt Łącznik roli z wzornika Diagram ORM na stronę rysunku.

      2. Przyklej punkt początkowy Obraz punktu początkowego — zielony kwadrat ze znakiem X w środku Łącznik roli kształtu do punktu połączenia Obraz punktu połączenia — niebieski znak X typu jednostki (jednostki kształtu), dla którego chcesz zdefiniować relację.

        Punkt początkowy zmieni kolor na czerwony, co oznacza przyklejenie łącznika do kształtu. Sklejone kształty można przenosić bez przerywania połączenia.

      3. Przeciągnij kształt Dwuelementowy lub Dwuelementowy pionowy z wzornika Diagram ORM na stronę rysunku.

      4. Przyklej punkt końcowy Obraz punktu końcowego — zielony kwadrat ze znakiem plus kształtu Łącznik roli na końcu kształtu binarny lub Binarny pionowy.

      5. Aby edytować tekst, kliknij dwukrotnie kształt Dwuelementowy. Umieść punkt wstawiania między elipsami lub symbolami zastępczymi, a następnie wpisz nazwę roli encji.

        Porada : Aby przenieść elipsy i nazwy na drugą stronę kształtu Dwuelementowy pionowy, należy kliknąć kształt prawym przyciskiem myszy, wskazać polecenie Kształt w menu skrótów, a następnie kliknąć polecenie Przerzuć w poziomie.

  6. Wyświetl obiekt zagnieżdżony, tworząc predykat obiektowy:

    1. Kliknij przycisk Narzędzia do rysowania Obraz przycisku w celu wyświetlenia paska narzędzi Narzędzia do rysowania, a następnie kliknij narzędzie Obraz przycisku prostokąt

    2. Narysuj prostokąt wokół kształtu predykatu (Jednoelementowy, Dwuelementowy, Dwuelementowy pionowy, Trzyelementowy lub Czteroelementowy), który chcesz określić jako predykat obiektowy.

    3. Kliknij prostokąt prawym przyciskiem myszy, wskaż polecenie Kształt w menu skrótów, a następnie kliknij polecenie Przesuń na spód.

    4. W menu Format (prostokąt ma być wciąż zaznaczony) kliknij polecenie Zaokrąglanie rogów, kliknij trzecią opcję w górnym wierszu, a następnie kliknij przycisk OK.

  7. Wykonaj jedną z następujących czynności:

    1. Wskaż ograniczenie roli obowiązkowej:

      1. Przeciągnij kształt Łącznik roli obowiązkowej z wzornika Diagram ORM na stronę rysunku.

      2. Przyklej punkt początkowy oznaczony czarnym kołem Obraz punktu początkowego — zielony kwadrat ze znakiem X w środku do punktu połączenia Obraz punktu połączenia — niebieski znak X obiektu (kształtu obiektu).

        Punkt początkowy zmieni kolor na czerwony, co oznacza przyklejenie łącznika do kształtu. Sklejone kształty można przenosić bez przerywania połączenia.

      3. Przyklej punkt końcowy Obraz punktu końcowego — zielony kwadrat ze znakiem plus o obowiązkowe. Łącznik roli kształtu na kształt predykatu (jednoargumentowy, binarne, Binarny pionowy, Trzyelementowy lub Czteroelementowy ).

    2. Wskaż ograniczenie unikatowości:

      1. Przeciągnij na stronę rysunku kształt Ograniczenie unikatowości z wzornika Diagram ORM.

      2. Umieść kształt bezpośrednio nad lub pod kształtem predykatu (Jednoelementowy, Dwuelementowy, Dwuelementowy pionowy, Trzyelementowy lub Czteroelementowy), którego ma dotyczyć ograniczenie.

      3. Przeciągnij jeden z punktów końcowych ( Obraz punktu początkowego — zielony kwadrat ze znakiem X w środku lub Obraz punktu końcowego — zielony kwadrat ze znakiem plus ), tak aby rozciągnąć strzałkę nad odpowiedniego pola roli kształtu predykatu.

    3. Wskaż ograniczenie częstotliwości:

      1. Przeciągnij kształt Ograniczenie częstotliwości z wzornika Diagram ORM na stronę rysunku.

      2. Umieść kształt w pobliżu kształtu predykatu (Jednoelementowy, Dwuelementowy, Dwuelementowy pionowy, Trzyelementowy lub Czteroelementowy), którego ma dotyczyć ograniczenie.

      3. Po zaznaczeniu kształtu wpisz odpowiednią częstotliwość.

    4. Wskaż ograniczenie porównania zbioru lub równości:

      1. Przeciągnij na stronę rysunku kształt Ograniczenie podzbioru lub Ograniczenie równości z wzornika Diagram ORM.

      2. Umieść kształt między kształtami predykatów (Jednoelementowy, Dwuelementowy, Dwuelementowy pionowy, Trzyelementowy lub Czteroelementowy) z rolami, których ma dotyczyć ograniczenie.

      3. Przyklej punkt początkowy Obraz punktu początkowego — zielony kwadrat ze znakiem X w środku Ograniczenie równości lub Podzbioru kształtu do punktu połączenia Obraz punktu połączenia — niebieski znak X na odpowiedniego pola roli kształtu predykatu.

        Punkt początkowy zmieni kolor na czerwony, co oznacza przyklejenie łącznika do kształtu. Sklejone kształty można przenosić bez przerywania połączenia.

      4. Przyklej punkt końcowy Obraz punktu końcowego — zielony kwadrat ze znakiem plus Ograniczenie równości lub Podzbioru kształtu do odpowiedniego pola roli drugiego kształtu predykatu.

    5. Wskaż ograniczenie pierścieniowe:

      1. Przeciągnij kształt Ograniczenie pierścieniowe z wzornika Diagram ORM na stronę rysunku.

      2. Umieść kształt w pobliżu kształtu predykatu (Jednoelementowy, Dwuelementowy, Dwuelementowy pionowy, Trzyelementowy lub Czteroelementowy) zawierającego dwie role, których ma dotyczyć ograniczenie.

      3. Wykonaj jedną z następujących czynności:

        • Jeśli obie role są częścią dłuższego predykatu, przyklej każdy punkt końcowy ( Obraz punktu początkowego — zielony kwadrat ze znakiem X w środku i Obraz punktu końcowego — zielony kwadrat ze znakiem plus ) kształtu Ograniczenie pierścieniowe do jednej z ról kształtu predykatu.

        • Jeśli obie role tworzą predykat dwuelementowy, zaznacz kształt Ograniczenie pierścieniowe, a następnie w menu Format kliknij polecenie Linia, z listy Deseń wybierz pozycję Brak i kliknij przycisk OK.

      4. Kliknij prawym przyciskiem myszy kształt Ograniczenie pierścieniowe, a następnie kliknij odpowiedni typ ograniczenia pierścieniowego w menu skrótów.

    6. Wskaż ograniczenie zewnętrzne:

      1. Przeciągnij kształt ograniczenia zewnętrznego (Zewnętrzne ograniczenie częstotliwości, Zewnętrzne podstawowe ograniczenie odwołania, Zewnętrzne ograniczenie obowiązkowe lub Zewnętrzne ograniczenie unikatowości) z wzornika Diagram ORM na stronę rysunku.

      2. Umieść kształt w pobliżu kształtów predykatów przedstawiających role, których ma dotyczyć ograniczenie.

      3. Przeciągnij kształt Łącznik ograniczenia z wzornika Diagram ORM na stronę rysunku.

      4. Przyklej punkt początkowy Obraz punktu początkowego — zielony kwadrat ze znakiem X w środku kształtu łącznika ograniczenia do punktu połączenia Obraz punktu połączenia — niebieski znak X kształtu ograniczenia zewnętrznego.

        Punkt początkowy zmieni kolor na czerwony, co oznacza przyklejenie łącznika do kształtu. Sklejone kształty można przenosić bez przerywania połączenia.

      5. Przyklej punkt końcowy Obraz punktu końcowego — zielony kwadrat ze znakiem plus kształtu łącznika ograniczenia do odpowiedniego pola roli kształtu predykatu (jednoargumentowy, binarne, Binarny pionowy, Trzyelementowy lub Czteroelementowy ).

      6. Aby zmienić częstotliwość dla kształtu ograniczenia zewnętrznego (Zewnętrzne ograniczenie częstotliwości, Zewnętrzne podstawowe ograniczenie odwołania, Zewnętrzne ograniczenie obowiązkowe lub Zewnętrzne ograniczenie unikatowości), zaznacz kształt, a następnie wpisz odpowiednią częstotliwość.

  8. Zapisz diagram.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×