Szacowanie formuły zagnieżdżonej krok po kroku

Ważne: Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Czasami opis jak zagnieżdżone formuła oblicza wynik końcowy jest trudne, ponieważ istnieje kilka obliczeń pośrednich i testów logicznych. Jednak za pomocą okna dialogowego Szacuj formułę, można wyświetlić różne części formuły zagnieżdżonej szacowane w kolejności, gdy formuła jest obliczana. Na przykład formuła =Jeżeli(średnia(F2:F5) > 50,SUM(G2:G5),0) jest łatwiejszy do zrozumienia, po wyświetleniu pośrednie następujące wyniki:

Kroki przedstawione w oknie dialogowym

Opis

=JEŻELI(ŚREDNIA(F2:F5)>50;SUMA(G2:G5);0)

Początkowo jest wyświetlana formuła zagnieżdżona. Funkcje ŚREDNIA i SUMA są zagnieżdżone w funkcji JEŻELI.

=JEŻELI(40>50;SUMA(G2:G5);0)

Zakres komórek F2: F5 zawiera wartości 55, 35, 45 i 25, i dlatego wynikiem funkcji ŚREDNIA(F2:F5) jest 40.

=JEŻELI(Fałsz;SUMA(G2:G5);0)

40 nie jest większa niż 50, więc wyrażenie w pierwszym argumencie funkcji Jeżeli (test_logiczny) ma wartość false.

0

Funkcja Jeżeli zwraca wartość trzeciego argumentu (argument wartość_jeżeli_fałsz). Funkcja suma nie jest obliczana, ponieważ jest drugim argumentem funkcji Jeżeli (argument wartość_jeżeli_prawda jest średnik) i zwracany jest tylko wtedy, gdy wyrażenie ma wartość PRAWDA.

  1. Zaznacz komórkę, którą chcesz oszacować. Nie można szacować kilku komórek równocześnie.

  2. Na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Szacuj formułę.

    Grupa Inspekcja formuł na karcie Formuły

  3. Kliknij przycisk Szacuj, aby zbadać wartość podkreślonego odwołania. Wynik szacowania zostanie wyświetlony kursywą.

    Jeśli podkreślona część formuły stanowi odwołanie do innej formuły, kliknij przycisk Wkrocz, aby wyświetlić drugą formułę w polu Oszacowanie. Kliknij przycisk Wyjdź, aby powrócić do poprzedniej komórki i formuły.

    Uwaga: Przycisk Wkrocz jest niedostępny dla odwołania w przypadku drugiego wystąpienia tego odwołania w formule lub gdy formuła odwołuje się do komórki w innym skoroszycie.

  4. Kontynuuj, aż każda z części formuły zostanie oszacowana.

  5. Aby ponownie wyświetlić oszacowanie, kliknij przycisk Wznów.

    Aby zakończyć oszacowanie, kliknij przycisk Zamknij.

    Uwagi: 

    • Niektóre części formuł, które należy użyć funkcji jeżeli i wybierz pozycję Funkcje nie są obliczane, a w polu oszacowanie jest wyświetlany # n/d!.

    • Jeśli odwołanie jest puste, w polu Oszacowanie jest wyświetlana wartość zero (0).

    • Następujące funkcje są obliczane ponownie każdej zmianie arkusza kalkulacyjnego i mogą spowodować Szacuj formułę nadać wyniki inne niż wyświetlane w komórce: LOS, przesunięcie, komórka, pośrednie, teraz, dzisiaj, LOS.ZAKR.

Uwaga: Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×