Szacowanie formuły zagnieżdżonej krok po kroku

Czasami trudno jest zrozumieć, jak formuła zagnieżdżona oblicza ostateczny wynik, ponieważ istnieje kilka obliczeń pośrednich i testów logicznych. Jednak za pomocą okna dialogowego Szacowanie formuły można wyświetlić różne części formuły zagnieżdżonej, szacowane w kolejności zgodnej z obliczaniem formuły. Na przykład formuła = jeżeli (średnia (F2: F5) >50, suma (G2: G5), 0) jest bardziej zrozumiała, gdy są wyświetlane następujące wyniki pośrednie:

Kroki przedstawione w oknie dialogowym

Opis

=JEŻELI(ŚREDNIA(F2:F5)>50;SUMA(G2:G5);0)

Początkowo jest wyświetlana formuła zagnieżdżona. Funkcje ŚREDNIA i SUMA są zagnieżdżone w funkcji JEŻELI.

=JEŻELI(40>50;SUMA(G2:G5);0)

Zakres komórek F2:F5 zawiera wartości 55, 35, 45 i 25, dlatego wynikiem funkcji ŚREDNIA(F2:F5) jest 40.

=JEŻELI(Fałsz;SUMA(G2:G5);0)

40 nie jest większe niż 50, więc wyrażenie w pierwszym argumencie funkcji jeżeli (argument test_logiczny) ma wartość FAŁSZ.

0

Funkcja JEŻELI zwraca wartość trzeciego argumentu (wartość_jeżeli_fałsz). Funkcja suma nie jest szacowana, ponieważ jest to drugi argument funkcji jeżeli (argument wartość_jeżeli_prawda) i jest zwracany tylko wtedy, gdy wyrażenie jest prawdziwe.

  1. Zaznacz komórkę, którą chcesz oszacować. Nie można szacować kilku komórek równocześnie.

  2. Na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Szacuj formułę.

    Grupa Inspekcja formuł na karcie Formuły

  3. Kliknij przycisk Szacuj, aby zbadać wartość podkreślonego odwołania. Wynik szacowania zostanie wyświetlony kursywą.

    Jeśli podkreślona część formuły stanowi odwołanie do innej formuły, kliknij przycisk Wkrocz, aby wyświetlić drugą formułę w polu Oszacowanie. Kliknij przycisk Wyjdź, aby powrócić do poprzedniej komórki i formuły.

    Uwaga: Przycisk Wkrocz jest niedostępny dla odwołania w przypadku drugiego wystąpienia tego odwołania w formule lub gdy formuła odwołuje się do komórki w innym skoroszycie.

  4. Kontynuuj, aż każda z części formuły zostanie oszacowana.

  5. Aby ponownie wyświetlić oszacowanie, kliknij przycisk Wznów.

    Aby zakończyć oszacowanie, kliknij przycisk Zamknij.

    Uwagi: 

    • Niektóre części formuł używające funkcji jeżeli i wybierz nie są szacowane, a w polu szacowanie jest wyświetlany #N/a.

    • Jeśli odwołanie jest puste, w polu Oszacowanie jest wyświetlana wartość zero (0).

    • Formuły z odwołaniami cyklicznymi mogą nie być sprawdzane w oczekiwany sposób. Jeśli odwołania cykliczne są odpowiednie, można włączyć obliczanie iteracyjne.

    • Poniższe funkcje są obliczane ponownie za każdym razem, gdy arkusz ulegnie zmianie, i może spowodować, że narzędzie Oceń formułę będzie dawać wyniki inne niż wyświetlane w komórce: Los, przesunięcie, komórka, pośredni, teraz, dziś, zakr, info i suma (w kilku scenariusze).

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Zobacz też

Jak unikać niepoprawnych formuł

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×