Sumowanie wartości na podstawie wielu warunków

Sumowanie wartości na podstawie wielu warunków

Chcesz zsumować wartości na podstawie więcej niż jednego warunku, na przykład uzyskać sumę sprzedaży określonego produktu w danym regionie. W takiej sytuacji użyj funkcji SUMA.WARUNKÓW w formule.

Oto przykład zastosowania dwóch warunków: potrzebna jest suma sprzedaży produktu Mięso (z kolumny C) w regionie Południe (z kolumny A).

Dane w arkuszu programu Excel

Oto formuła do użycia:

=SUMA.WARUNKÓW(D2:D11;A2:A11;”Południe”;C2:C11;”Mięso”)Wynikiem jest liczba 14719. Oto jak działa ta formuła.

Formuła =SUMA.WARUNKÓW jest formułą arytmetyczną. Umożliwia obliczanie liczb, jak w przypadku kolumny D. Zacznijmy więc od pokazania w formule, gdzie te liczby są:

  • =SUMA.WARUNKÓW(D2:D11;

Innymi słowy chcesz zsumować liczby znajdujące się w tej kolumnie, jeśli spełnią określone warunki. Ten zakres komórek jest pierwszym argumentem (argumenty to części danych potrzebne do uruchomienia funkcji).

Następnie chcesz znaleźć dane spełniające dwa warunki, więc wprowadzasz pierwszy warunek, pokazując w formule, gdzie te dane się znajdują (A2:A11) i gdzie jest warunek, to znaczy „Południe”. Zwróć uwagę na średniki oddzielające argumenty.

  • =SUMA.WARUNKÓW(D2:D11;A2:A11;”Południe”;

Ujęcie wyrazu „Południe” w cudzysłowy jest informacją dla programu Excel, że korzysta z danych tekstowych.

Na końcu wprowadzasz argumenty dotyczące drugiego warunku — zakresu komórek (C2:C11) zawierającego wyraz „mięso” oraz sam wyraz (ujęty w cudzysłowy), aby mógł zostać dopasowany. Zakończ formułę nawiasem zamykającym ), a następnie naciśnij klawisz Enter, aby uzyskać wynik: 14719.

  • =SUMA.WARUNKÓW(D2:D11;A2:A11;”Południe”;C2:C11;”Mięso”)

Jeśli podczas wpisywania funkcji SUMA.WARUNKÓW w programie Excel zapomnisz argumentów, nic nie szkodzi. Po wpisaniu ciągu =SUMA.WARUNKÓW( pod formułą zostanie wyświetlone okno funkcji Autouzupełnianie formuł z listą argumentów we właściwej kolejności.

Przyjrzyjmy się obrazowi okna Autouzupełnianie formuł i liście argumentów. W naszym przykładzie suma_zakres to zakres D2:D11 — kolumna liczb, które chcesz zsumować, a kryteria_zakres1 to zakres A2:A11 — kolumna danych, w której znajduje się wyraz „Południe” (kryteria1).

Wprowadzanie funkcji SUMA.WARUNKÓW przy użyciu funkcji Autouzupełnianie formuł

Podczas wpisywania reszta argumentów pojawi się w oknie Autouzupełnianie formuł (tutaj niewidoczne): kryteria_zakres2 to zakres C2:C11 — kolumna danych, w której znajduje się wyraz „Mięso” (kryteria2).

Jeśli klikniesz pozycję SUMA.WARUNKÓW w oknie Autouzupełnianie formuł, zostanie otworzony artykuł oferujący więcej pomocy.

Spróbuj użyć tej funkcji

Jeśli chcesz poeksperymentować z funkcją SUMA.WARUNKÓW, oto kilka przykładowych danych i formuła z zastosowaniem tej funkcji.

Z przykładowymi danymi i formułami możesz pracować tutaj, w tym skoroszycie aplikacji Excel Online. Zmień wartości i formuły lub dodaj swoje własne wartości i formuły i obserwuj, jak zmieniają się wyniki na żywo.

Skopiuj wszystkie komórki w poniższej tabeli i wklej je w komórce A1 nowego arkusza w programie Excel. Być może trzeba będzie dopasować szerokości kolumn, aby formuły były lepiej widoczne.

Region

Sprzedawca

Typ

Sprzedaż

Południe

Czernek

Napoje

3571

Zachód

Maśliński

Nabiał

3338

Wschód

Misiec

Napoje

5122

Północ

Misiec

Nabiał

6239

Południe

Karwat

Warzywa

8677

Południe

Maśliński

Mięso

450

Południe

Maśliński

Mięso

7673

Wschód

Misiec

Warzywa

664

Północ

Maśliński

Warzywa

1500

Południe

Karwat

Mięso

6596

Formuła

 

Opis

Wynik

'=SUMA.WARUNKÓW(D2:D11;A2:A11;
"Płd."; C2:C11;"Mięso")

Sumuje sprzedaż mięsa w
kolumnie C w regionie Płd.
w kolumnie A (wynik to 14719).

=SUMA.WARUNKÓW(D2:D11;A2:A11;
"Płd."; C2:C11;"Mięso")

Uwagi : 

  • Chcesz więcej przykładów? Znajdziesz je w artykule na temat funkcji SUMA.WARUNKÓW.

  • Jeśli chcesz utworzyć łączną wartość tylko jednego zakresu na podstawie wartości w innym zakresie, użyj funkcji SUMA.JEŻELI.

Początek strony

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×