Sprawdzanie pisowni i gramatyki

Część treści tego tematu może nie mieć zastosowania w przypadku niektórych języków.

W miarę zbliżania się terminu zakończenia pracy użytkownik ma zwykle niewiele czasu na sprawdzenie w dokumencie błędów pisowni i gramatyki. Programy pakietu Microsoft Office udostępniają narzędzia przyspieszające poprawianie błędów. Użytkownik może tak skonfigurować program pakietu Microsoft Office, aby potencjalne błędy były widoczne na bieżąco podczas pracy. Jeśli jednak faliste czerwone i zielone linie rozpraszają uwagę, można sprawdzić dokument po zakończeniu pracy.

Co chcesz zrobić?

Automatyczne sprawdzanie pisowni i gramatyki (faliste czerwone, niebieskie i zielone linie)

Zbiorcze sprawdzanie pisowni i gramatyki w całym dokumencie

Rozwiązywanie problemów z modułem sprawdzania pisowni i gramatyki

Automatyczne sprawdzanie pisowni i gramatyki (faliste czerwone, niebieskie i zielone linie)

Czy szukasz sposobu szybszego i łatwiejszego znajdowania i poprawiania błędów w dokumencie? A może nie chcesz oglądać falistych czerwonych linii wyświetlanych w dokumencie przez program pakietu Microsoft Office? W tej sekcji wyjaśniono, w jaki sposób działa automatyczne sprawdzanie pisowni i gramatyki oraz jak je włączać i wyłączać.

Uwagi   

  • Nie ma możliwości sprawdzania pisowni podczas pisania w programach Microsoft Office Access, Microsoft Office Excel ani Microsoft Office Project.

  • Sprawdzanie gramatyki jest dostępne wyłącznie w programach Microsoft Office Outlook i Microsoft Office Word.

Jak działa automatyczne sprawdzanie pisowni

Po włączeniu automatycznego sprawdzania pisowni podczas pisania można mieć większą pewność, że przed przekazaniem dokumentu nie trzeba będzie poprawiać wielu błędów pisowni. W używanym programie pakietu Microsoft Office błędnie napisane wyrazy mogą być oznaczane flagą, co ułatwia ich wykrycie, jak to przedstawiono w następującym przykładzie.

Błędnie napisane wyrazy są wyświetlane z czerwoną linią falistą pod nimi.

Błędnie napisany wyraz można kliknąć prawym przyciskiem myszy, aby wyświetlić sugerowane poprawki.

Kliknij prawym przyciskiem myszy błędnie napisany wyraz, aby wyświetlić sugerowane korekty

W zależności od używanego programu pakietu Microsoft Office po kliknięciu prawym przyciskiem myszy można uzyskać dostęp do innych opcji, takich jak dodanie wyrazu do słownika niestandardowego.

Jak działa automatyczne sprawdzanie gramatyki (tylko w programach Outlook i Word)

Po włączeniu automatycznego sprawdzania gramatyki programy Word i Outlook oznaczają flagą potencjalne błędy gramatyczne i stylistyczne podczas pracy nad dokumentami programu Word i otwartymi elementami programu Outlook (z wyjątkiem notatek), jak to przedstawiono w następującym przykładzie.

Grammar error

Kliknięcie błędu prawym przyciskiem myszy umożliwia uzyskanie dostępu do kolejnych opcji.

Klikanie prawym przyciskiem myszy błędu gramatycznego

Wyświetlone menu może zawierać sugerowaną poprawkę. Można również wybrać opcję zignorowania błędu albo kliknąć opcję Informacje o tym zdaniu, aby sprawdzić, dlaczego program uznaje dany tekst za błędny.

Włączanie lub wyłączanie automatycznego sprawdzania pisowni i gramatyki

W następujących programach pakietu Microsoft Office:

Word

  1. Kliknij przycisk Microsoft Office Obraz przycisku pakietu Office, a następnie kliknij opcję Opcje programu Word.

  2. Kliknij opcję Sprawdzanie.

  3. Aby włączyć lub wyłączyć automatyczne sprawdzanie pisowni i gramatyki w aktualnie otwartym dokumencie, wykonaj następujące czynności:

    1. W obszarze Wyjątki dla kliknij opcję nazwa aktualnie wybranego pliku.

    2. Zaznacz lub wyczyść pola wyboru Ukryj błędy ortograficzne tylko w tym dokumencie i Ukryj błędy gramatyczne tylko w tym dokumencie.

      Aby włączyć lub wyłączyć automatyczne sprawdzanie pisowni i gramatyki we wszystkich dokumentach tworzonych od tej pory, wykonaj następujące czynności:

    3. W obszarze Wyjątki dla kliknij opcję Wszystkie nowe dokumenty.

    4. Zaznacz lub wyczyść pola wyboru Ukryj błędy ortograficzne tylko w tym dokumencie i Ukryj błędy gramatyczne tylko w tym dokumencie.

Ważne   Jeśli automatyczne sprawdzanie pisowni lub gramatyki zostanie wyłączone w dokumencie udostępnianym innym osobom, warto je zawiadomić o poczynionej zmianie.

Outlook

  1. W menu Narzędzia kliknij polecenie Opcje.

  2. Kliknij kartę Pisownia, a następnie kliknij opcję Pisownia i autokorekta.

  3. Zaznacz lub wyczyść pola wyboru Sprawdź pisownię w trakcie pisania i Sprawdź gramatykę w trakcie pisania.

Uwaga   Moduły sprawdzania pisowni i gramatyki są dostępne we wszystkich elementach z wyjątkiem notatek.

Włączanie lub wyłączanie automatycznego sprawdzania pisowni

W następujących programach pakietu Microsoft Office:

PowerPoint

  1. Kliknij przycisk Microsoft Office Obraz przycisku pakietu Office, a następnie kliknij opcję Opcje programu PowerPoint.

  2. Kliknij opcję Sprawdzanie.

  3. Zaznacz lub wyczyść pole wyboru Ukryj błędy pisowni.

    Uwaga   Jeśli chcesz zaznaczyć to pole wyboru, musisz również zaznaczyć pole wyboru Sprawdź pisownię w trakcie pisania.

InfoPath, OneNote, Publisher, SharePoint Designer lub Visio

  1. W menu Narzędzia kliknij polecenie Pisownia, a następnie kliknij opcję Opcje pisowni.

  2. Zaznacz lub wyczyść pole wyboru Ukryj błędy pisowni.

    Uwaga   Jeśli chcesz zaznaczyć to pole wyboru, musisz również zaznaczyć pole wyboru Sprawdź pisownię w trakcie pisania.

Access, Excel lub Project

Ta funkcja jest niedostępna.

Autokorekta

W niektórych programach można użyć funkcji autokorekty do automatycznego poprawiania pisowni w trakcie pisania bez konieczności potwierdzania każdej poprawki. Na przykład po napisaniu wyrazu zdecydować i naciśnięciu spacji lub wstawieniu znaku interpunkcyjnego funkcja autokorekty automatycznie zamieni niepoprawny wyraz na wyraz zdecydować. Aby uzyskać więcej informacji o funkcji autokorekty, zobacz temat Tworzenie lub zmienianie automatycznych poprawek.

Początek strony

Zbiorcze sprawdzanie pisowni i gramatyki w całym dokumencie

Ta metoda jest przydatna, gdy sprawdzanie dokumentu ma nastąpić dopiero po zakończeniu jego edycji. Możliwe błędy pisowni i gramatyki można wyszukać, a następnie potwierdzić każdą poprawkę.

Uwaga   Opcja sprawdzania gramatyki jest dostępna wyłącznie w programach Outlook i Word.

W większości przypadków sprawdzanie pisowni we wszystkich programach pakietu Microsoft Office jest całkiem proste. Wystarczy nacisnąć klawisz F7, a następnie użyć wyświetlonego okna dialogowego lub okienka zadań, aby sprawdzić dany plik lub element. Poniżej przedstawiono szczegółowe instrukcje oraz opis unikatowych opcji dostępnych w każdym z programów pakietu Microsoft Office:

  1. Zaznacz plik, element, fragment tekstu lub dane, których pisownię chcesz sprawdzić.

    Poniżej opisano sposób zaznaczania w programach pakietu Microsoft Office.

    Word, PowerPoint, Project, Publisher lub SharePoint Designer

    Kliknij wewnątrz pliku. Opcjonalnie w celu sprawdzenia tylko określonego fragmentu tekstu zaznacz tekst, który chcesz sprawdzić.

    Access

    Sprawdzanie pisowni w widoku arkusza danych

    1. Otwórz arkusz danych.

    2. Zaznacz rekordy, kolumny, pola lub tekst, którego pisownię chcesz sprawdzić.

      W poniższej tabeli przedstawiono, w jaki sposób za pomocą myszy można zaznaczyć dane lub rekordy w widoku arkusza danych.

    Aby zaznaczyć

    Kliknij

    Dane w polu

    Miejsce, od którego chcesz zacząć zaznaczenie, po czym przeciągnij wskaźnik przez dane.

    Całe pole

    Lewą krawędź pola w arkuszu danych, gdy wskaźnik przybiera postać Wskaźnik w kształcie plusa.

    Sąsiadujące pola

    Lewą krawędź pola, a następnie przeciągnij wskaźnik, aby rozszerzyć zaznaczenie.

    Można również nacisnąć i przytrzymać klawisz SHIFT, a następnie kliknąć inną komórkę.

    Kolumnę

    Selektor pól.

    Sąsiadujące kolumny

    Nazwę pola u góry kolumny, a następnie przeciągnij wskaźnik, aby rozszerzyć zaznaczenie.

    Rekord

    Selektor rekordów.

    Wiele rekordów

    Selektor pierwszego rekordu, a następnie przeciągnij wskaźnik, aby rozszerzyć zaznaczenie.

    Wszystkie rekordy

    Polecenie Zaznacz wszystkie rekordy w menu Edycja.

    Uwagi   

    1. Jeśli arkusz danych zawiera podarkusze, program Access sprawdza pisownię tylko w arkuszu lub podarkuszu, w którym umieszczono kursor.

    2. Aby anulować zaznaczenie komórek, kliknij dowolną komórkę arkusza.

    Sprawdzanie pisowni danych w widoku formularza

    1. Otwórz formularz w widoku formularza.

    2. Zaznacz pole lub tekst, którego pisownię chcesz sprawdzić.

      Sprawdzanie pisowni danych w obiekcie bazy danych w okienku nawigacji

    3. W okienku nawigacji kliknij tabelę, kwerendę, formularz, widok lub procedurę przechowywaną, której pisownię chcesz sprawdzić.

    Excel

    Kliknij wewnątrz edytowanego arkusza, aby zaznaczyć cały aktywny arkusz, w tym wartości komórek, komentarze do komórek, osadzone wykresy, pola tekstowe, przyciski, nagłówki i stopki. Program Excel nie sprawdza chronionych arkuszy, formuł ani tekstów będących rezultatem formuł. Jeśli podczas sprawdzania pisowni jest aktywny pasek formuły, program Excel sprawdza tylko zawartość paska formuły.

    Opcjonalnie, aby sprawdzić tylko wybrany fragment tekstu, zaznacz tekst, który chcesz sprawdzić.

    Aby zaznaczyć

    Wykonaj następującą czynność

    Zakres komórek

    Kliknij pierwszą komórkę w zakresie, a następnie przeciągnij wskaźnik do ostatniej komórki. Możesz również przytrzymać klawisz SHIFT, jednocześnie naciskając klawisze strzałek w celu rozszerzenia zaznaczenia.

    Można także zaznaczyć pierwszą komórkę w zakresie, a następnie nacisnąć klawisz F8, aby rozszerzyć zaznaczenie za pomocą klawiszy strzałek.

    Duży zakres komórek

    Kliknij pierwszą komórkę w zakresie, a następnie przytrzymaj klawisz SHIFT i kliknij ostatnią komórkę w zakresie. Aby wyświetlić ostatnią komórkę, można przewinąć ekran.

    Wszystkie komórki arkusza

    Kliknij przycisk Zaznacz wszystko.

    Aby zaznaczyć cały arkusz, można również nacisnąć klawisze CTRL+A.

    Uwaga   Jeśli arkusz zawiera dane, naciśnięcie klawiszy CTRL+A powoduje zaznaczenie bieżącego obszaru. Naciśnięcie klawiszy CTRL+A po raz drugi powoduje zaznaczenie całego arkusza.

    Nieprzylegające komórki lub zakresy komórek

    Zaznacz pierwszą komórkę lub zakres komórek, a następnie przytrzymaj klawisz CTRL i zaznacz inne komórki lub zakresy.

    Można również zaznaczyć pierwszą komórkę lub zakres komórek, a następnie nacisnąć klawisze SHIFT+F8, aby dodać do zaznaczenia następną nieprzylegającą komórkę lub zakres komórek.

    Uwaga   Nie można anulować zaznaczenia nieprzylegającej komórki lub zakresu komórek bez anulowania całego zaznaczenia.

    Cały wiersz lub kolumnę

    Kliknij nagłówek wiersza lub kolumny.

    Arkusz przedstawiający nagłówki wierszy i kolumn

    1. Nagłówek wiersza

    2. Nagłówek kolumny

    Można również zaznaczyć komórki w wierszu lub kolumnie, zaznaczając pierwszą komórkę, a następnie naciskając klawisze CTRL+SHIFT+KLAWISZ STRZAŁKI (STRZAŁKA W PRAWO lub STRZAŁKA W LEWO dla wierszy, STRZAŁKA W GÓRĘ lub STRZAŁKA W DÓŁ dla kolumn).

    Uwaga   Jeśli wiersz lub kolumna zawiera dane, naciśnięcie klawiszy CTRL+SHIFT+KLAWISZ STRZAŁKI powoduje zaznaczenie wiersza lub kolumny do ostatniej używanej komórki. Naciśnięcie klawiszy CTRL+SHIFT+KLAWISZ STRZAŁKI po raz drugi powoduje zaznaczenie całego wiersza lub kolumny.

    Przylegające wiersze lub kolumny

    Przeciągnij kursor wzdłuż nagłówków wierszy lub kolumn. Możesz również zaznaczyć pierwszy wiersz lub kolumnę, a następnie przytrzymać klawisz SHIFT i zaznaczyć ostatni wiersz lub kolumnę.

    Nieprzylegające wiersze lub kolumny

    Kliknij nagłówek pierwszego wiersza lub kolumny wybranego obszaru; następnie przytrzymaj klawisz CTRL i kliknij nagłówki innych kolumn lub wierszy, które chcesz dodać do zaznaczenia.

    Więcej lub mniej komórek niż komórki znajdujące się w aktywnym zaznaczeniu

    Przytrzymaj klawisz SHIFT i kliknij ostatnią komórkę, którą chcesz dołączyć do nowego zaznaczenia. Prostokątny obszar między komórka aktywna a komórką klikniętą stanie się nowym zaznaczeniem.

    Uwaga   Aby anulować zaznaczenie komórek, kliknij dowolną komórkę arkusza.

    InfoPath

    Kliknij wewnątrz formularza. Opcjonalnie, aby sprawdzić tylko określony fragment tekstu, zaznacz tekst, który chcesz sprawdzić.

    OneNote

    Kliknij wewnątrz strony, aby sprawdzić pisownię tekstu znajdującego się na aktywnej stronie. Opcjonalnie, aby sprawdzić wyłącznie określony fragment tekstu, zaznacz tekst, który chcesz sprawdzić.

    Outlook

    Kliknij wewnątrz otwartego elementu, takiego jak wiadomość e-mail, aby sprawdzić pisownię zawartego w nim tekstu. Opcjonalnie, aby sprawdzić wyłącznie określony fragment tekstu, zaznacz tekst, który chcesz sprawdzić.

    Uwaga   Moduł sprawdzania pisowni jest dostępny dla wszystkich elementów z wyjątkiem notatek.

    Visio

    Kliknij wewnątrz pliku. Opcjonalnie, aby sprawdzić wyłącznie określony fragment tekstu, można albo kliknąć wewnątrz obiektu tekstowego, aby sprawdzić pisownię całego tekstu zawartego w tym obiekcie, albo zaznaczyć tekst w tym obiekcie.

  2. Wykonaj jedną z następujących czynności:

    1. Naciśnij klawisz F7.

    2. Użyj myszy w jednym z następujących programów pakietu Microsoft Office:

      Word, Excel lub PowerPoint

      Na karcie Przegląd w grupie Sprawdzanie kliknij opcję Pisownia (w programie Word kliknij opcję Pisownia i gramatyka).

      Outlook

      Utwórz lub otwórz element, taki jak wiadomość e-mail, termin lub kontakt, a następnie na karcie Zapisywanie w grupie Sprawdzanie kliknij opcję Pisownia i gramatyka.

      Access

      Na karcie Narzędzia główne w grupie Rekordy kliknij opcję Pisownia.

      InfoPath, OneNote, Publisher, SharePoint Designer lub Visio

      W menu Narzędzia wskaż polecenie Pisownia, a następnie kliknij polecenie Pisownia.

  3. Jedynie w przypadku programów Outlook i Word istnieje możliwość sprawdzenia gramatyki — w tym celu należy zaznaczyć pole wyboru Sprawdź gramatykę.

  4. W przypadku znalezienia przez program błędów pisowni zostanie wyświetlone okno dialogowe lub okienko zadań, a pierwszy błędnie napisany wyraz znaleziony przez moduł sprawdzania pisowni zostanie zaznaczony. Użytkownik decyduje o sposobie postępowania z każdym błędem znalezionym przez program. Poniżej przedstawiono instrukcje postępowania w przypadku błędnie napisanego wyrazu:

    Chcę naprawić błąd, wybierając jeden z sugerowanych wyrazów

    Wybierz wyraz z listy Sugestie, a następnie kliknij przycisk Zmień.

    Chcę naprawić błąd, zmieniając wyraz własnoręcznie

    Outlook, Word, PowerPoint, InfoPath i OneNote

    1. Kliknij wyraz w dokumencie i dokonaj jego edycji, aby skorygować błąd.

    2. Po poprawieniu błędnie napisanego wyrazu kliknij przycisk Wznów, Znajdź następny (w programie InfoPath) lub Rozpocznij sprawdzanie pisowni (w programie OneNote).

      Access, Excel i Publisher

    3. Kliknij pole Nie ma w słowniku.

    4. Dokonaj edycji wyrazu.

    5. Kliknij przycisk Zmień.

      SharePoint Designer lub Visio

    6. Kliknij pole Zmień na.

    7. Dokonaj edycji wyrazu.

    8. Kliknij przycisk Zmień.

    Wyraz o błędnej pisowni został użyty celowo. Chcę, aby programy pakietu Microsoft Office rozpoznawały ten wyraz i nie uznawały go za błąd

    1. Kliknij przycisk Dodaj lub Dodaj do słownika.

    Chcę zignorować ten błędnie napisany wyraz i przejść do następnego

    Excel, Outlook, PowerPoint lub Word

    1. Kliknij przycisk Ignoruj raz.

      Ważne   Kliknięcie przycisku Ignoruj raz w programach Outlook, PowerPoint i Word powoduje, że moduł sprawdzania pisowni będzie stale ignorował to wystąpienie danego wyrazu. W przypadku programów Outlook i Word można użyć opcji ponownego znajdowania zignorowanych wyrazów. W programie PowerPoint nie ma możliwości ponownego znalezienia wystąpienia wyrazu po zignorowaniu go.

      Access, OneNote, Publisher, SharePoint Designer lub Visio

    2. Kliknij przycisk Ignoruj raz.

      Ważne   Kliknięcie przycisku Ignoruj raz w programie OneNote powoduje, że moduł sprawdzania pisowni będzie stale ignorował ten wyraz. Nie ma możliwości, aby w programie OneNote ponownie znaleźć wystąpienie takiego wyrazu po kliknięciu przycisku Ignoruj raz dla tego wyrazu.

      InfoPath

    3. Kliknij przycisk Znajdź następny.

    Chcę zignorować wszystkie wystąpienia błędnie napisanego wyrazu i przejść do następnego wyrazu

    Kliknij przycisk Ignoruj wszystkie.

    Ważne   Kliknięcie przycisku Ignoruj wszystkie w programach Outlook, PowerPoint i Word powoduje, że moduł sprawdzania pisowni stale ignoruje wszystkie istniejące wystąpienia danego wyrazu. W przypadku programów Outlook i Word można użyć opcji ponownego znajdowania zignorowanych wyrazów. W programie PowerPoint nie ma możliwości ponownego znalezienia wystąpień błędnie napisanego wyrazu po kliknięciu przycisku Ignoruj wszystkie dla tego wyrazu.

    Często popełniam ten błąd, dlatego chcę, aby program automatycznie poprawiał go przy każdym wystąpieniu

    Access, Excel, Outlook, Word lub PowerPoint

    1. Zaznacz poprawny wyraz na liście Sugestie, a następnie kliknij przycisk Autokorekta.

      OneNote

    2. Kliknij polecenie Opcje autokorekty.

    3. Wpisz błędny wyraz w polu Zamień, a następnie wpisz poprawny wyraz w polu Na.

    4. Kliknij przycisk Dodaj.

      Project, Publisher lub Visio

    5. Najpierw anuluj lub dokończ sprawdzanie pisowni.

    6. W menu Narzędzia wybierz polecenie Opcje autokorekty.

    7. Wpisz błędny wyraz w polu Zamień, a następnie wpisz poprawny wyraz w polu Na.

    8. Kliknij przycisk Dodaj.

      InfoPath i SharePoint Designer

      Ponieważ te programy nie obsługują funkcji autokorekty, nie jest możliwe automatyczne poprawianie błędów podczas pisania.

  5. Po skorygowaniu błędnie napisanego wyrazu program oznacza flagą następny wyraz z błędem, dając użytkownikowi możliwość podjęcia decyzji.

  6. Jedynie w przypadku programów Outlook i Word po zakończeniu oznaczania błędów w pisowni program przystępuje do wyświetlenia błędów gramatycznych. Dla każdego błędu należy wybrać odpowiednią opcję w oknie Pisownia i gramatyka.

Początek strony

Rozwiązywanie problemów z modułem sprawdzania pisowni i gramatyki

W sekcji Zobacz też można znaleźć łącza do informacji dotyczących rozwiązywania problemów ze sprawdzaniem pisowni i gramatyki.

Początek strony

Dotyczy: SharePoint Designer 2007, Office 2010, Visio Standard 2007, OneNote 2007, Excel 2007, Outlook 2007, Project Standard 2007, Project 2007, Word 2007, Visio 2007, PowerPoint 2007, Office 2007, Access 2007, Publisher 2007



Czy te informacje były pomocne?

Tak Nie

Jak możemy to poprawić?

255 pozostało znaków

Aby chronić swoją prywatność, nie dołączaj do opinii informacji o kontakcie. Przejrzyj nasze zasady zachowania poufności informacji.

Dziękujemy za opinię!

Zasoby pomocy technicznej

Zmień język