SUMA.WARUNKÓW, funkcja

Funkcja SUMA.WARUNKÓW, jedna z funkcji matematycznych i trygonometrycznych, dodaje wszystkie argumenty, które spełniają wiele kryteriów. Funkcji SUMA.WARUNKÓW można użyć na przykład do zsumowania sprzedawców w kraju, których (1) adres zamieszkania obejmuje ten sam kod pocztowy oraz (2) których zyski przekraczają określoną wartość w dolarach.

Przeglądarka nie obsługuje klipu wideo. Instalowanie dodatku Microsoft Silverlight, Adobe Flash Player lub programu Internet Explorer 9.

Ten klip wideo jest częścią kursu szkoleniowego zatytułowanego Zaawansowane możliwości funkcji JEŻELI.

Składnia

SUMA.WARUNKÓW(suma_zakres;kryteria_zakres1;kryteria1;[kryteria_zakres2;kryteria2];...)

  • =SUMA.WARUNKÓW(A2:A9,B2:B9;"=J*";C2:C9;"Tomasz")

  • =SUMA.WARUNKÓW(A2:A9,B2:B9;"<>Banany";C2:C9;"Tomasz")

Nazwa argumentu

Opis

Suma_zakres    (wymagany)

Zakres komórek do zsumowania.

Kryteria_zakres1    (wymagany)

Zakres, który jest sprawdzany przy użyciu argumentu kryteria1.

Argumenty kryteria_zakres1 i kryteria1 konfigurują parę wyszukiwania, w której zakres jest przeszukiwany pod kątem konkretnych kryteriów. Jeśli elementy w zakresie zostaną znalezione, odpowiadające im wartości w zakresie suma_zakres zostaną dodane.

Kryteria1    (wymagany)

Kryteria określające, które komórki w zakresie kryteria_zakres1 zostaną dodane. Kryteria można na przykład wprowadzić w następujący sposób: 32, ">32", B4, "jabłka" lub "32".

Kryteria_zakres2;kryteria2;...    (opcjonalny)

Dodatkowe zakresy i skojarzone z nimi kryteria. Maksymalnie można wprowadzić 127 par zakres/kryteria.

Przykłady

Aby użyć tych przykładów w programie Excel, zaznacz przeciągnięciem datę w tabeli, a następnie kliknij prawym przyciskiem myszy to zaznaczenie i wybierz polecenie Kopiuj. W nowym arkuszu kliknij prawym przyciskiem myszy komórkę A1 i wybierz polecenie Uwzględnij formatowanie docelowe w obszarze Opcje wklejania.

Wielkość sprzedaży

Produkt

Sprzedawca

5

Jabłka

Tomasz

4

Jabłka

Aneta

15

Jeżyny

Tomasz

3

Jeżyny

Aneta

22

Banany

Tomasz

12

Banany

Aneta

10

Marchew

Tomasz

33

Marchew

Aneta

Formuła

Opis

=SUMA.WARUNKÓW(A2:A9;B2:B9;"=J*";C2:C9;"Tomasz")

Dodaje liczbę produktów, których nazwa zaczyna się od litery J i które zostały sprzedane przez Tomasza. W przykładzie użyto symbolu wieloznacznego * w argumencie kryteria1;"=J*" w celu wyszukania pasujących nazw produktów w zakresie kryteria_zakres1 B2:B9. W przykładzie wyszukiwana jest też nazwa "Tomasz" w zakresie kryteria_zakres2 C2:C9. Funkcja następnie dodaje liczby w zakresie suma_zakres A2:A9, które spełniają oba warunki. Wynik to 20.

=SUMA.WARUNKÓW(A2:A9;B2:B9;"<>Banany";C2:C9;"Tomasz")

Dodaje liczbę produktów, które nie są bananami i które zostały sprzedane przez Tomasza. W funkcji wykluczono banany przy użyciu znaków <> w argumencie kryteria1: "<>banany" i przeprowadzono wyszukiwanie nazwy "Tomasz" w zakresie kryteria_zakres2 C2:C9. Funkcja następnie dodaje liczby w zakresie suma_zakres A2:A9, które spełniają oba warunki. Wynik to 30.

Typowe problemy

Problem

Opis

Zamiast oczekiwanych wyników wyświetlana jest wartość 0 (zero).

Upewnij się, że argumenty kryteria1,2 są ujęte w znaki cudzysłowu, jeśli testujesz wartości tekstowe, takie jak imię i nazwisko osoby.

Wynik jest nieprawidłowy, kiedy zakres suma_zakres zawiera wartości PRAWDA lub FAŁSZ.

Wartości PRAWDA i FAŁSZ dla zakresu suma_zakres są obliczane w inny sposób, co może powodować nieoczekiwane wyniki, gdy są one dodawane.

Komórki w zakresie suma_zakres zawierające wartość PRAWDA są interpretowane jako 1. Komórki zawierające wartość FAŁSZ są interpretowane jako 0 (zero).

Najważniejsze wskazówki

Czynność

Opis

Używaj symboli wieloznacznych.

Używanie symboli wieloznacznych, takich jak znak zapytania (?) i gwiazdki (*), w argumentach kryteria1,2 może pomóc w znalezieniu zgodnych elementów, które są podobne, ale nie identyczne.

Znak zapytania odpowiada dowolnemu pojedynczemu znakowi. Gwiazdka odpowiada dowolnej sekwencji znaków. Jeśli chcesz znaleźć rzeczywisty znak zapytania lub gwiazdkę, wpisz tyldę (~) przed znakiem zapytania.

Na przykład funkcja =SUMA.WARUNKÓW(A2:A9;B2:B9;"=J*";C2:C9;"Tomas?") spowoduje dodanie wszystkich wystąpień o nazwie zaczynającej się od „Tomas” i kończącej się dowolną ostatnią literą.

Opis różnic między funkcjami SUMA.JEŻELI i SUMA.WARUNKÓW.

Kolejność argumentów w funkcjach SUMA.JEŻELI i SUMA.WARUNKÓW jest inna. Na przykład argument suma_zakres jest pierwszym argumentem funkcji SUMA.WARUNKÓW, ale jest trzecim argumentem funkcji SUMA.JEŻELI. Jest to częstym źródłem problemów podczas korzystania z tych funkcji.

Jeśli kopiujesz lub edytujesz te podobne funkcje, upewnij się, że argumenty umieszczasz w poprawnej kolejności.

W argumentach zakresu używaj takiej samej liczby wierszy i kolumn.

Argument kryteria_zakres musi zawierać taką samą liczbę wierszy i kolumn co argument suma_zakres.

Początek strony

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Zobacz klip wideo na temat korzystania z zaawansowanych funkcji JEŻELI, na przykład z funkcji SUMA.WARUNKÓW

Funkcja SUMA.JEŻELI sumuje tylko wartości spełniające pojedyncze kryterium

Funkcja SUMA.KWADRATÓW sumuje wartości po wykonaniu operacji matematycznej podniesienia każdej z nich do kwadratu

Funkcja LICZ.JEŻELI zlicza tylko wartości spełniające pojedyncze kryterium

Funkcja LICZ.WARUNKI zlicza tylko wartości, które spełniają wiele kryteriów

Funkcja WARUNKI (usługa Office 365, program Excel 2016 lub nowszy)

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Poprawianie typowych błędów w formułach przy użyciu funkcji sprawdzania błędów

Funkcje matematyczne i trygonometryczne

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×