SUMA.JEŻELI, funkcja

Funkcja SUMA.JEŻELI służy do sumowania wartości z zakresu spełniającego kryteria określone przez użytkownika. Załóżmy na przykład, że mają zostać zsumowane liczby z danej kolumny, które są większe od 5. W tym celu można zastosować następującą formułę: =SUMA.JEŻELI(B2:B25;">5")

Przeglądarka nie obsługuje klipu wideo. Instalowanie dodatku Microsoft Silverlight, Adobe Flash Player lub programu Internet Explorer 9.

Ten klip wideo jest częścią kursu szkoleniowego zatytułowanego Dodawanie liczb w programie Excel 2013.

Porady : 

  • Kryteria można też zastosować do jednego zakresu i zsumować odpowiednie wartości należące do innego zakresu. Na przykład formuła =SUMA.JEŻELI(B2:B5;"Jan";C2:C5) zsumuje wartości z zakresu C2:C5, dla których zawartość odpowiadających im komórek z zakresu B2:B5 jest równa „Jan”.

  • Aby uzyskać informacje o sumowaniu zawartości komórek na podstawie wielu kryteriów, zobacz SUMA.WARUNKÓW, funkcja.

Składnia

SUMA.JEŻELI(zakres;kryteria;[suma_zakres])

W składni funkcji SUMA.JEŻELI występują następujące argumenty:

  • zakres    Argument wymagany. Jest to zakres komórek, do których zostaną zastosowane kryteria. Komórki w każdym zakresie muszą być liczbami lub nazwami, tablicami albo odwołaniami zawierającymi liczby. Wartości puste i wartości tekstowe są ignorowane. Wybrany zakres może zawierać daty w standardowym formacie programu Excel (przykłady poniżej).

  • kryteria    Argument wymagany. Są to kryteria w postaci liczby, wyrażenia, odwołania do komórki, tekstu lub funkcji określającej, które komórki będą dodawane. Kryteria można wyrazić na przykład jako 32, ">32", B5, "32", "jabłka" lub DZIŚ().

    Ważne : Wszelkie kryteria tekstowe oraz zawierające symbole matematyczne lub logiczne należy ująć w podwójny cudzysłów ("). Kryteria liczbowe nie wymagają cudzysłowów.

  • suma_zakres    Argument opcjonalny. Są to rzeczywiste komórki, które podlegają sumowaniu w przypadku, gdy należy zsumować komórki inne niż określone w argumencie zakres. Jeśli argument suma_zakres zostanie pominięty, program Excel zsumuje komórki wyznaczone przez argument zakres (te same, do których mają zastosowanie kryteria).

  • Przy określaniu argumentu kryteria można używać symboli wieloznacznych — znaku zapytania (?) i gwiazdki (*). Znak zapytania zastępuje dowolny pojedynczy znak, a gwiazdka zastępuje dowolną sekwencję znaków. Aby znaleźć znak zapytania lub gwiazdkę, przed szukanym znakiem należy wpisać tyldę (~). 

Spostrzeżenia

  • Funkcja SUMA.JEŻELI zwraca niepoprawne wyniki w razie użycia jej do dopasowania ciągów mających więcej niż 255 znaków lub do ciągu #ARG!.

  • Argument suma_zakres nie musi mieć takiego samego rozmiaru i kształtu jak argument zakres. Podczas określania rzeczywistych komórek do zsumowania lewa górna komórka argumentu suma_zakres jest traktowana jako początek zakresu, do którego są następnie dołączane komórki odpowiadające rozmiarem i kształtem argumentowi zakres. Przykład:

Argument zakres

Argument suma_zakres

Rzeczywiste komórki

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Jeśli jednak argumenty zakres i suma_zakres w funkcji SUMA.JEŻELI nie zawierają tej samej liczby komórek, ponowne obliczanie arkusza może trwać dłużej, niż oczekiwano.

Przykłady

Przykład 1

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

Wartość nieruchomości

Prowizja

Dane

100 000 zł

7 000 zł

250 000 zł

200 000 zł

14 000 zł

300 000 zł

21 000 zł

400 000 zł

28 000 zł

Formuła

Opis

Wynik

=SUMA.JEŻELI(A2:A5;">160000";B2:B5)

Suma prowizji dla wartości nieruchomości powyżej 160 000 zł.

63 000 zł

=SUMA.JEŻELI(A2:A5;">160000")

Suma wartości nieruchomości powyżej 160 000 zł.

900 000 zł

=SUMA.JEŻELI(A2:A5;300000;B2:B5)

Suma prowizji dla wartości nieruchomości równych 300 000 zł.

21 000 zł

=SUMA.JEŻELI(A2:A5;">" &C2;B2:B5)

Suma prowizji dla wartości nieruchomości powyżej kwoty zawartej w komórce C2.

49 000 zł

Przykład 2

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

Kategoria

Żywność

Sprzedaż

Warzywa

Pomidory

2 300 zł

Warzywa

Brokuły

5 500 zł

Owoce

Pomarańcze

800 zł

Masło

400 zł

Warzywa

Marchew

4 200 zł

Owoce

Jabłka

1 200 zł

Formuła

Opis

Wynik

=SUMA.JEŻELI(A2:A7;"Owoce";C2:C7)

Łączna wartość sprzedaży produktów żywnościowych w kategorii „Owoce”.

2 000 zł

=SUMA.JEŻELI(A2:A7;"Warzywa";C2:C7)

Łączna wartość sprzedaży produktów żywnościowych w kategorii „Warzywa”.

12 000 zł

=SUMA.JEŻELI(B2:B7;"*y";C2:C7)

Łączna wartość sprzedaży produktów żywnościowych, których nazwy kończą się literą „y” (pomidory i brokuły).

4 300

=SUMA.JEŻELI(A2:A7;"";C2:C7)

Łączna wartość sprzedaży produktów żywnościowych niezakwalifikowanych do żadnej kategorii.

400 zł

Początek strony

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Funkcja SUMA.WARUNKÓW sumuje wszystkie argumenty, które spełniają wiele kryteriów

Funkcja SUMA.KWADRATÓW sumuje wartości po wykonaniu operacji matematycznej podniesienia każdej z nich do kwadratu

Funkcja SUMA.JEŻELI dodaje tylko wartości spełniające pojedyncze kryterium

Funkcja LICZ.WARUNKI zlicza tylko wartości, które spełniają wiele kryteriów

Funkcja WARUNKI (usługa Office 365, program Excel 2016 lub nowszy)

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach przy użyciu opcji sprawdzania błędów

Funkcje matematyczne i trygonometryczne

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×