Rozpoczynanie pracy z programem Access 2007

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Pracę z programem Microsoft Office Access 2007 można rozpoczynać na kilka sposobów, zależnie od tego, czy użytkownik korzysta z programu Access po raz pierwszy, czy przenosi do programu Access dane z innego programu baz danych lub arkuszy kalkulacyjnych, czy uaktualnia z poprzedniej wersji programu Access. W tym artykule omówiono pytania, które mogą się pojawić w każdej z tych sytuacji.

Co chcesz zrobić?

Rozpoczynanie korzystania z programu Access po raz pierwszy

Importowanie danych z arkusza kalkulacyjnego lub innego programu

Używanie wcześniejszej wersji bazy danych w kilku wersjach programu Access

Korzystanie z programu Access po raz pierwszy

W programie Office Access 2007 wprowadzono szereg udoskonaleń, które ułatwiają tworzenie bazy danych. Użytkownicy, którzy już tworzyli bazy danych w programie Access, docenią szybkość tworzenia, jaką zapewniają te nowe i udoskonalone funkcje.

Pierwszy ekran, który pojawia się po uruchomieniu programu Office Access 2007, to strona Wprowadzenie do programu Microsoft Office Access (o ile program Access nie zostanie uruchomiony przez dwukrotnie kliknięcie określonego pliku bazy danych programu Access, co spowoduje jej otwarcie). Strona Wprowadzenie do programu Microsoft Office Access umożliwia rozpoczęcie pracy przez utworzenie nowej bazy danych, otwarcie istniejącej bazy danych lub wyświetlenie proponowanej zawartości witryny Microsoft Office Online.

Tworzenie bazy danych przy użyciu szablonu

Pobieranie szablonu z witryny Microsoft Office Online

Tworzenie bazy danych od podstaw

Tworzenie pustej bazy danych

Dodawanie tabeli

Wklejanie danych z innego źródła do tabeli programu Access

Importowanie danych z innego źródła

Otwieranie istniejącej bazy danych programu Access

Program Access 2010 ma zaawansowanych narzędzi, które ułatwiają śledzenie raportu i udostępniać dane.

Tworzenie bazy danych przy użyciu szablonu

Program Access udostępnia szeroką gamę szablonów, których można użyć do szybszego utworzenia własnej bazy danych. Szablon jest gotową do użycia bazą danych, która zawiera wszystkie tabele, kwerendy, formularze i raporty potrzebne do określonego zadania. Istnieją na przykład szablony, które mogą służyć do śledzenia problemów, zarządzania kontaktami lub rejestrowania wydatków. Niektóre szablony zawierają kilka przykładowych rekordów prezentujących ich zastosowanie. Szablony baz danych można stosować w niezmienionej postaci lub dostosowywać do własnych potrzeb.

  1. Jeśli program Access nie jest uruchomiony, uruchom go.

    Jeśli baza danych jest już otwarta, wykonaj następujące czynności, aby wyświetlić stronę Wprowadzenie do programu Microsoft Office Access:

    • Kliknij Przycisk Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Zamknij bazę danych. Obraz przycisku

      Strona Wprowadzenie do programu Microsoft Office Access

  2. Kilka szablonów są wyświetlane w obszarze Polecane szablony Online na stronie Wprowadzenie do programu Microsoft Office Access, a kolejne staną się dostępne po kliknięciu jednej z kategorii w obszarze Kategorie szablonów w lewej części Okna programu Access. Kolejne można pobrać z witryny Microsoft Office w sieci Web (zobacz następną sekcję, Pobieranie szablonu z witryny Microsoft Office Online, aby uzyskać szczegółowe informacje).

  3. Kliknij szablon, którego chcesz użyć.

  4. W okienku z prawej strony okna programu Access w polu Nazwa pliku znajduje się propozycja nazwy pliku bazy danych. Można edytować nazwę pliku i określić inny folder. Opcjonalnie można utworzyć bazę danych i połączyć ją z witryną programu Windows SharePoint Services 3.0.

  5. Kliknij przycisk Utwórz (lub kliknij przycisk Pobierz w przypadku szablonu z witryny Office Online).

    Program Access utworzy bazę danych i otworzy ją. Zostanie wyświetlony formularz, w którym można rozpocząć wprowadzanie danych.

    Jeśli szablon zawiera przykładowe dane, można usunąć każdy rekord w następujący sposób:

    • Kliknij nagłówek wiersza rekordu, który chcesz usunąć. (Nagłówek wiersza to pole lub pasek z lewej strony tuż obok rekordu).

    • Na karcie Narzędzia główne w grupie Rekordy kliknij przycisk Usuń. Obraz przycisku

  6. Aby rozpocząć wprowadzanie danych, kliknij wewnątrz pierwszej pustej komórki formularza, a następnie zacznij pisać. Po wprowadzeniu kilku rekordów można użyć okienka nawigacji, aby sprawdzić, czy istnieją inne formularze lub raporty do zastosowania.

Pobieranie szablonu z witryny Microsoft Office Online

Jeśli na stronie Wprowadzenie do programu Microsoft Office Access nie ma szablonu odpowiadającego potrzebom użytkownika, można skorzystać z witryny sieci Web Office Online, która oferuje większy wybór szablonów.

  1. Jeśli program Access nie jest uruchomiony, uruchom go.

    Jeśli baza danych jest już otwarta, wykonaj następujące czynności, aby wyświetlić stronę Wprowadzenie do programu Microsoft Office Access:

    • Kliknij Przycisk Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Zamknij bazę danych. Obraz przycisku

  2. U dołu strony Wprowadzenie do programu Microsoft Office Access w obszarze Więcej w witrynie Office Online kliknij pozycję Szablony.

    W nowym oknie przeglądarki zostanie wyświetlona witryna Office Online.

  3. Użyj narzędzi wyszukiwania witryny Office Online, aby znaleźć i pobrać odpowiedni szablon.

  4. Gdy zostanie pobrany szablon, nowa baza danych zostanie zapisana w jednym z następujących folderów:

    • Windows Vista    c:\Users\user name\Documents

    • Microsoft Windows Server 2003 lub Microsoft Windows XP    c:\Documents and Settings\nazwa name\My dokumentów

      Aby później podjąć pracę z tą bazą danych, należy użyć programu Access lub Eksploratora Windows w celu jej otwarcia z tej lokalizacji.

Powrót do początku sekcji

Tworzenie bazy danych od podstaw

Jeśli żaden z szablonów nie odpowiada potrzebom użytkownika lub dysponuje on danymi w innym programie, które chce zaimportować do programu Access, może się okazać, że lepszym wyjściem jest utworzenie bazy danych od podstaw. W większości przypadków oznacza to wykonanie jednej z poniższych czynności lub ich obu:

  • Utworzenie nowych tabel, a następnie wprowadzenie, wklejenie lub zaimportowanie danych do tych tabel.

  • Zaimportowanie danych z innych źródeł, czemu towarzyszy utworzenie nowych tabel.

Aby dowiedzieć się więcej na temat planowania i projektowania bazy danych lub tworzenia relacji, formularzy, raportów i kwerend, skorzystaj z łączy w sekcji Zobacz też tego artykułu.

Tworzenie pustej bazy danych

  1. Uruchom program Access.

  2. Na stronie Wprowadzenie do programu Microsoft Office Access kliknij przycisk Pusta baza danych.

    Przycisk Pusta baza danych

  3. W okienku Pusta baza danych wpisz nazwę pliku w polu Nazwa pliku. Jeśli rozszerzenie pliku nie zostanie podane, program Access doda je. Plik zostanie domyślnie umieszczony w jednej z poniższych lokalizacji:

    • Windows Vista    c:\Users\user name\Documents

    • Microsoft Windows Server 2003 lub Microsoft Windows XP    c:\Documents and Settings\nazwa name\My dokumentów

      Aby zmienić lokalizację pliku, kliknij przycisk Przeglądaj Obraz przycisku obok pola Nazwa pliku, przejdź do i wybierz nową lokalizację, a następnie kliknij przycisk OK.

  4. Kliknij przycisk Utwórz.

    Program Access utworzy bazę danych, a następnie otworzy pustą tabelę (o nazwie Tabela1) w widok arkusza danych.

  5. Kursor zostanie umieszczony w pierwszej pustej komórce w kolumnie Dodaj nowe pole.

    Nowa pusta tabela w nowej bazie danych

    Aby dodać dane, zacznij wpisywać — też wkleić dane z innego źródła, zgodnie z opisem w sekcji Wklejanie danych z innego źródła do tabeli programu Access, w dalszej części tego artykułu.

    Uwagi : 

    • Wprowadzanie danych w widoku arkusza danych zaprojektowano w sposób bardzo podobny do wprowadzania danych w arkuszu programu Excel. Główne ograniczenie polega na tym, że dane muszą być wprowadzane w przyległych wierszach i kolumnach, począwszy od lewego górnego rogu arkusza danych. Nie należy próbować formatować danych, ponieważ spowoduje to utratę miejsca w tabeli. Tabela tylko zawiera dane. Do wizualnej prezentacji danych posłużą formularze i raporty, które zostaną zaprojektowane później.

    • Struktura tabeli jest tworzona podczas wprowadzania danych. Ilekroć do tabeli jest dodawana nowa kolumna, jest definiowane nowe pole. Program Access ustala typ danych pola na podstawie typu wprowadzanych danych. Jeśli na przykład istnieje kolumna, w której wprowadzono tylko wartości dat, program Access określi typ danych tego pola jako Data/Godzina. W przypadku późniejszej próby wprowadzenia w tym polu wartości niebędącej datą (na przykład nazwiska lub numeru telefonu) program Access wyświetli komunikat z informacją, że wartość nie pasuje do typu danych tej kolumny. O ile to możliwe, należy planować tabelę w taki sposób, aby każda kolumna zawierała dane tego samego typu, na przykład tekst, daty, liczby itd. Ułatwia to tworzenie kwerend, formularzy i raportów, które wybierają tylko odpowiednie dane.

    • Aby uzyskać więcej informacji na temat pracy z arkuszy danych zobacz artykuł Otwieranie pustego arkusza danych.

Jeśli interesuje Cię nie wprowadzania danych w tej chwili, kliknij przycisk Zamknij Obraz przycisku .

Dodawanie tabeli

Nową tabelę można dodać do istniejącej bazy danych za pomocą narzędzi w grupie Tabele na karcie Tworzenie.

Obraz wstążki programu Access

Aby utworzyć pustą tabelę w widoku arkusza danych, należy kliknąć przycisk Tabela. Wprowadzanie danych można rozpocząć bezpośrednio w widoku arkusza danych. W takim przypadku program Access utworzy strukturę tabeli podczas wprowadzania danych. Można też użyć widok projektu i najpierw utworzyć strukturę tabeli, a potem wrócić do widoku arkusza danych i wprowadzić dane. Niezależnie od tego, w którym widoku zostanie rozpoczęta praca, zawsze można przejść do drugiego widoku za pomocą przycisków widoków na pasku stanu okna programu Access.

Wstawianie tabeli przy użyciu widoku arkusza danych    W widoku arkusza danych można wprowadzać dane bezpośrednio. Program Access utworzy strukturę tabeli w tle. Przypisywane nazwy pól zawierają liczby (Pole1, Pole2 itd.), a typ danych pola jest określany na podstawie typu wprowadzanych danych.

  1. Na karcie Tworzenie w grupie Tabele kliknij pozycję Tabela. Obraz przycisku

  2. Program Access tworzy tabelę, a następnie umieszcza kursor w pierwszej pustej komórce w kolumnie Dodaj nowe pole.

    Uwaga : Jeśli kolumna o nazwie Dodaj nowe pole nie jest wyświetlana, być może jest otwarty widok projektu, a nie widok arkusza danych. Aby przełączyć do widoku arkusza danych, kliknij dwukrotnie tabelę w okienku nawigacji. Program Access wyświetli monit o podanie nazwy nowej tabeli, a następnie przełączy się do widoku arkusza danych.

  3. Na karcie Arkusz danych w grupie Pola i kolumny kliknij przycisk Nowe pole. Obraz przycisku

    W programie Access zostanie wyświetlone okienko Szablony pól, które zawiera listę często używanych typów pól. Przeciągnięcie jednego z tych pól do arkusza danych spowoduje dodanie pola o odpowiedniej nazwie i ustawienie jego właściwości na wartość odpowiednią dla typu pola. Te właściwości można później zmienić. Pole należy przeciągnąć do obszaru arkusza danych, który zawiera dane. Zostanie wyświetlony pionowy pasek wstawiania, pokazujący położenie pola.

  4. Aby dodać dane, zacznij pisać w pierwszej pustej komórce — możesz także wkleić dane z innego źródła w sposób opisany w dalszej części tego artykułu.

    • Aby zmienić nazwę kolumny (pola), kliknij dwukrotnie nagłówek kolumny, a następnie wpisz nową nazwę. Warto stosować opisowe nazwy pól, ponieważ ułatwia to określanie zawartości pól wyświetlanych w okienku Lista pól.

    • Aby przenieść kolumnę, zaznacz ją, klikając nagłówek kolumny, a następnie przeciągnij w odpowiednie miejsce. Można zaznaczyć kilka przyległych kolumn i przeciągnąć je wszystkie razem w nowe miejsce.

Wstawianie tabeli przy użyciu widoku projektu    W widoku projektu użytkownik najpierw tworzy strukturę nowej tabeli. Następnie przełącza do widoku arkusza danych i wprowadza dane, używając innej metody, na przykład wklejania lub dołączania.

  1. Na karcie Tworzenie w grupie Tabele kliknij pozycję Projekt tabeli. Obraz przycisku

  2. Dla każdego pola tabeli wpisz nazwę w kolumnie Nazwa pola, a następnie wybierz typ danych z listy Typ danych.

    Uwaga : Jeśli kolumny Nazwa pola i Typ danych nie są wyświetlane, być może otwarty jest widok arkusza danych, a nie widok projektu. Aby przełączyć do widoku projektu, należy kliknąć przycisk Widok projektu na pasku stanu okna programu Access. Program Access wyświetli monit o podanie nazwy nowej tabeli, a następnie przełączy do widoku projektu.

  3. W razie potrzeby można w kolumnie Opis wprowadzić opis każdego pola. Wprowadzony opis jest wyświetlany na pasku stanu, gdy punkt wstawiania znajduje się w danym polu, i jest używany jako tekst paska stanu dla wszystkich formantów utworzonych przez przeciągnięcie tego pola z okienka Lista pól do formularza lub raportu i wszystkich formantów utworzonych dla tego pola za pomocą Kreatora formularzy lub Kreatora raportów.

  4. Po dodaniu wszystkich pól zapisz tabelę:

    • Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Zapisz. Możesz także nacisnąć klawisze CTRL+S.

  5. Wprowadzanie danych do tabeli można rozpocząć w dowolnej chwili przez przełączenie do widoku arkusza danych, kliknięcie pierwszej pustej komórki i pisanie. Można też wkleić dane z innego źródła w sposób opisany w następnej sekcji.

Aby po wprowadzeniu danych dodać do tabeli jedno lub większą liczbę pól, można zacząć pisać w kolumnie Dodaj nowe pole w widoku arkusza danych lub dodać nowe pola przy użyciu poleceń w grupie Pola i kolumny na karcie Arkusz danych.

Aby uzyskać więcej informacji o tworzeniu tabel, łącznie z użyciem Szablony tabel zobacz artykuł Tworzenie tabel bazy danych.

Powrót do początku sekcji

Wklejanie danych z innego źródła do tabeli programu Access

Jeśli dane są zapisane w innym programie, na przykład w programie Office Excel 2007, można je skopiować i wkleić do tabeli programu Access. Zazwyczaj ten sposób sprawdza się najlepiej, jeśli dane są już podzielone na kolumny, tak jak w arkuszu programu Excel. Jeśli dane znajdują się w edytorze tekstów, przed ich skopiowaniem najlepiej jest rozdzielić kolumny danych przy użyciu znaków tabulacji lub przekonwertować dane na tabelę w edytorze tekstów. Jeśli dane wymagają edycji lub manipulowania (na przykład rozdzielenia imion i nazwisk), warto wprowadzić odpowiednie zmiany przed skopiowaniem danych i wklejeniem ich do tabeli programu Access, szczególnie jeśli użytkownik nie ma doświadczenia w pracy z programem Access.

Podczas wklejania danych do pustej tabeli program Access ustawia typ danych każdego pola według rodzaju danych, które w nim znajdzie. Jeśli na przykład wklejane pole zawiera tylko daty, program Access stosuje do tego pola typ danych Data/Godzina. Jeśli pole zawiera tylko wyrazy „tak” lub „nie”, program Access stosuje do tego pola typ danych Tak/Nie.

Nazwy pól zostają nadane zależnie od zawartości pierwszego wiersza wklejanych danych. Jeśli pierwszy wiersz wklejanych danych jest podobnego typu jak dalsze wiersze, program Access uzna, że pierwszy wiersz stanowi część danych i przydzieli polom nazwy ogólne (F1, F2 itd.). Jeśli pierwszy wiersz wklejanych danych nie jest podobny do następnych wierszy, program Access uzna, że pierwszy wiersz zawiera nazwy pól i nada polom odpowiednie nazwy oraz nie uwzględni pierwszego wiersza w danych.

Jeśli zostaną nadane nazwy ogólne, warto je jak najszybciej zmienić, aby uniknąć pomyłek. Należy postępować zgodnie z poniższą procedurą:

  1. Zapisz tabelę.

    • Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij pozycję Zapisz. Możesz także nacisnąć klawisze CTRL+S.

  2. W widoku arkusza danych kliknij dwukrotnie nagłówek każdej kolumny i wpisz odpowiednią nazwę pola dla każdej kolumny. Może to wyglądać jak zastępowanie danych, jednak wiersz nagłówków kolumn zawiera nazwy pól, a nie dane.

  3. Ponownie zapisz tabelę.

Uwaga : Nazwy pól można też zmienić przez przełączenie do widoku projektu, a następnie edytowanie w nim nazw pól. Aby przełączyć do widoku projektu, należy kliknąć prawym przyciskiem myszy tabelę w okienku nawigacji, a następnie kliknąć polecenie Widok projektu. Aby przełączyć z powrotem do widoku arkusza danych, należy kliknąć dwukrotnie tabelę w okienku nawigacji.

Powrót do początku sekcji

Importowanie danych z innego źródła

Użytkownik może mieć zapisane w innym programie dane, które chce zaimportować do programu Access. Możliwa jest też sytuacja, w której użytkownik współpracuje z osobami zapisującymi dane w innych programach, a sam chce pracować z tymi danymi w programie Access. W każdym przypadku program Access ułatwia importowanie danych z innych programów. Dane można importować z arkusza programu Excel, z tabeli w innej bazie danych programu Access, z listy programu SharePoint oraz z wielu innych źródeł. Proces różni się nieco w przypadku różnych źródeł, ale należy zacząć od wykonania następujących instrukcji:

  1. Na karcie Dane zewnętrzne w grupie Importowanie kliknij polecenie odpowiednie do typu importowanego pliku.

    Obraz wstążki programu Access

    Na przykład w przypadku importowania danych z arkusza programu Excel należy kliknąć przycisk Excel. Jeśli odpowiedni typu programu nie jest wyświetlany, należy kliknąć przycisk Więcej.

    Uwaga : Jeśli nie można znaleźć odpowiedniego typu formatu w grupie Importowanie, może być konieczne uruchomienie programu, w którym utworzono dane, a następnie zapisanie danych w powszechnie stosowanym formacie pliku (takim jak rozdzielany plik tekstowy), co umożliwi zaimportowanie danych do programu Access.

  2. W oknie dialogowym Pobieranie danych zewnętrznych kliknij przycisk Przeglądaj, aby przejść do pliku danych źródłowych, lub wpisz pełną ścieżkę do pliku danych źródłowych w polu Nazwa pliku.

  3. Kliknij odpowiednią opcję w obszarze Określ sposób i miejsce przechowywania danych w bieżącej bazie danych. Możesz utworzyć nową tabelę z importowanymi danymi, dołączyć dane do istniejącej tabeli lub utworzyć tabelę połączoną, a w niej łącze do źródła danych.

  4. Kliknij przycisk OK.

    Program Access uruchomi Kreatora importu.

  5. Postępuj zgodnie z instrukcjami Kreatora importu. Dokładna procedura do wykonania zależy od wybranej opcji importowania lub łączenia.

  6. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

    W programie Access zostanie wyświetlone pytanie, czy chcesz zapisać szczegóły właśnie zakończonej operacji importowania.

    • Jeśli ta sama operacja importowania będzie prawdopodobnie wykonywana ponownie, kliknij pole wyboru Zapisz kroki importowania i wprowadź szczegółowe informacje.

      Można łatwo powtórzyć operację importowania, klikając przycisk Zapis. dane importu w grupie Importowanie na karcie Dane zewnętrzne, klikając specyfikację importowania, a następnie klikając przycisk Uruchom.

    • Jeśli szczegółowe informacje na temat operacji nie mają zostać zapisane, należy kliknąć przycisk Zamknij.

Program Access zaimportuje dane do nowej tabeli, a następnie tabela ta zostanie wyświetlona w obszarze Tabele w okienku nawigacji.

Aby uzyskać więcej informacji na temat importowania danych do programu Access, skorzystaj z łączy w sekcji Zobacz też w tym artykule.

Powrót do początku sekcji

Otwieranie istniejącej bazy danych programu Access

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Otwórz.

  2. Kliknij skrót w oknie dialogowym Otwieranie albo kliknij dysk lub folder zawierający bazę danych programu Access na liście w polu Szukaj w .

  3. Na liście folderów klikaj dwukrotnie kolejne foldery, aż zostanie otwarty folder zawierający szukaną bazę danych.

  4. Znalazłszy bazę danych, wykonaj jedną z następujących czynności:

    • Aby otworzyć bazę danych w domyślnym trybie otwierania, kliknij ją dwukrotnie.

    • Aby otworzyć bazę danych do udostępnionego w środowisku, tak aby Ty i inni użytkownicy mogli czytać i zapisywać w bazie danych, w tym samym czasie, kliknij przycisk Otwórz.

    • Aby otworzyć bazę danych w trybie tylko do odczytu, tak aby można było oglądać bazę danych, ale nie można było jej edytować, kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz tylko do odczytu.

    • Aby otworzyć bazę danych do wyłącznego dostępu, tak aby inni użytkownicy nie mogli jej otworzyć, kiedy będzie otwarta, kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz z wyłącznością.

    • Aby otworzyć bazę danych w trybie dostępu tylko do odczytu, kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz z wyłącznością tylko do odczytu. Inni użytkownicy będą mogli otwierać bazę danych, ale będą mieli do niej dostęp w trybie tylko do odczytu.

Postępowanie w sytuacji, gdy nie można znaleźć bazy danych    

  1. W oknie dialogowym Otwieranie kliknij skrót Mój komputer lub w polu Szukaj w kliknij pozycję Mój komputer.

  2. Na liście dysków kliknij prawym przyciskiem myszy dysk, na którym może się znajdować szukana baza danych, a następnie kliknij polecenie Wyszukaj.

  3. Wprowadź kryteria wyszukiwania, a następnie naciśnij klawisz ENTER, aby wyszukać bazę danych.

  4. Jeśli baza danych zostanie znaleziona, otwórz ją, klikając ją dwukrotnie w oknie dialogowym Wyniki wyszukiwania.

  5. Ponieważ wyszukiwanie zostało zainicjowane w oknie dialogowym Otwieranie, trzeba kliknąć w nim przycisk Anuluj, aby umożliwić otwarcie bazy danych.

Uwaga : Istnieje możliwość bezpośredniego otwarcia pliku danych w zewnętrznym formacie pliku (na przykład dBASE, Paradox, Microsoft Exchange lub Excel). Można także otworzyć bezpośrednio dowolne źródło danych ODBC, na przykład źródło danych programu Microsoft SQL Server lub Microsoft FoxPro. W programie Access jest automatycznie tworzona nowa baza danych programu Access w folderze, w którym znajduje się plik danych, a także dodawane są łącza do każdej tabeli w zewnętrznej bazie danych.

Porady

  • Aby otworzyć jedną z kilku ostatnio otwieranych baz danych, kliknij nazwę pliku na liście Otwórz ostatnio używane bazy danych na stronie Wprowadzenie do programu Microsoft Office Access. Program Access otworzy bazę danych, stosując te same ustawienia opcji sformatowanych za pomocą bazy danych podczas ostatniego, który został otwarty. Jeśli na liście ostatnio używanych plików nie jest wyświetlana, kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij Opcje programu Access. Zostanie wyświetlone okno dialogowe Opcje programu Access. Kliknij kategorię Zaawansowane, a następnie w obszarze w sekcji Wyświetlanie zaznacz pole wyboru Niedawno używane pliki. (Możesz też określić liczbę ostatnio używanych plików, które mają zostać wyświetlone na liście maksymalnie 9).

  • Podczas otwierania bazy danych, klikając Przycisk Microsoft Office Obraz przycisku pakietu Office i za pomocą polecenia Otwórz, możesz wyświetlić listę skrótów do bazy danych, które były wcześniej otwierane, klikając pozycję Moje ostatnie dokumenty w Otwórz okno dialogowe.

Powrót do początku sekcji

Początek strony

Importowanie danych z arkusza kalkulacyjnego lub innego programu

Jeżeli masz doświadczenie z innymi programami bazy danych lub arkusz kalkulacyjny, prawdopodobnie wiesz, jak działają te aplikacje i do czego służą bazy danych dla. Umożliwia tworzenie relacyjnych baz danych programu Access różni się od wielu innych aplikacji bazy danych. Program Access udostępnia również wiele opcji ułatwiających pracę z innymi programami bazy danych, na przykład programu SQL Server.

W tej sekcji

Importowanie arkusza programu Excel do programu Access.

Importowanie arkusza programu Excel jako tabeli w nowej bazie danych pakietu Office Access 2007

Organizowanie danych przy użyciu Kreatora analizatora tabel

Praca z danymi z innych programów

Importowanie arkusza programu Excel do programu Access

W przypadku wielu użytkowników pracę z programem Access poprzedza utworzenie listy w programie Excel. Program Excel jest doskonałym miejscem na rozpoczęcie listy, ale w miarę jej rozrastania się coraz trudniej jest tę listę organizować i aktualizować. Kolejnym logicznym krokiem jest przeniesienie listy do programu Access.

Tabela bazy danych przypomina w strukturze do arkusza, w którym dane są przechowywane w wierszach i kolumnach. W wyniku jest zazwyczaj można z łatwością importować arkusz do tabeli bazy danych. Główna różnica pomiędzy magazynowaniem danych w arkuszu i przechowywaniu go w bazie danych znajduje się w sposób organizowania danych. Po prostu Importowanie całego arkusza jako nowej tabeli w bazie danych nie rozwiąże problemów związanych z organizowanie i aktualizowanie danych, szczególnie jeśli arkusz zawiera powtarzających się danych. Aby rozwiązać te problemy, należy podzielić dane z arkusza kalkulacyjnego na osobne tabele, każdy z nich zawiera dane pokrewne. Aby uzyskać więcej informacji o rozmieszczaniu danych w tabelach, zobacz artykuł podstawowe informacje o projekcie bazy danych.

Program Access udostępnia Kreatora analizatora tabel, który ułatwia wykonanie tego procesu. Po zaimportowaniu danych do tabeli przez użytkownika kreator umożliwia podzielenie tabeli na osobne tabele zawierające dane, które nie są zduplikowane w żadnej z pozostałych tabel. Kreator umożliwia również tworzenie niezbędnych relacji między tabelami.

Importowanie arkusza programu Excel jako tabeli nowej bazy danych programu Office Access 2007

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Nowe.

  2. Wpisz nazwę nowej bazy danych w polu Nazwa pliku, a następnie kliknij przycisk Utwórz.

  3. Zamknij tabelę Tabela1.

    Gdy zostanie wyświetlony monit o zapisanie zmian w projekcie tabeli Tabela1, kliknij przycisk Nie.

  4. Na karcie Dane zewnętrzne w grupie Importowanie kliknij programu Excel. Obraz przycisku

  5. W oknie dialogowym Pobieranie danych zewnętrznych kliknij przycisk Przeglądaj.

  6. Zlokalizuj swój plik przy użyciu okna dialogowego Otwieranie pliku.

  7. Zaznacz plik i kliknij przycisk Otwórz.

  8. W oknie dialogowym Pobieranie danych zewnętrznych upewnij się, że jest zaznaczona opcja Importuj dane źródłowe do nowej tabeli w bieżącej bazie danych.

  9. Kliknij przycisk OK.

    Zostanie uruchomiony Kreator importu arkuszy, który zada kilka pytań na temat danych.

  10. Postępuj zgodnie z instrukcjami, klikając przyciski Dalej lub Wstecz, aby przechodzić między stronami. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

    Uwaga : W programie Access zostanie wyświetlone pytanie, czy chcesz zapisać szczegóły właśnie zakończonej operacji importowania. Jeśli ta sama operacja importowania będzie prawdopodobnie wykonywana ponownie, należy kliknąć przycisk Tak i wprowadzić szczegółowe informacje. Ułatwi to powtarzanie operacji importowania przez kliknięcie przycisku Zapis. dane importu w grupie Importowanie na karcie Dane zewnętrzne. Aby nie zapisywać szczegółowych informacji na temat operacji, należy kliknąć przycisk Zamknij.

Program Access zaimportuje dane do nowej tabeli, a następnie tabela zostanie wyświetlona w obszarze Wszystkie tabele w okienku nawigacji.

Organizowanie danych przy użyciu Kreatora analizatora tabel

Po zaimportowaniu danych do tabeli programu Access można użyć Kreatora analizatora tabel w celu szybkiego zidentyfikowania powtarzających się danych. Kreator ułatwia organizowanie powtarzających się danych w osobnych tabelach, tak aby dane były przechowywane najefektywniej. Program Access zachowa oryginalną tabelę jako kopię zapasową, a następnie utworzy nowe tabele i użyje ich jako podstawowych tabel w aplikacji bazy danych.

  1. Otwórz bazę danych programu Access zawierającą tabelę, którą chcesz przeanalizować.

  2. Na karcie Narzędzia bazy danych w grupie Analiza kliknij przycisk Analizuj tabelę.

    Zostanie uruchomiony Kreator analizatora tabel.

    Z myślą o użytkownikach nieznających koncepcji normalizacji na dwóch stronach wprowadzenia kreatora zamieszczono krótki samouczek — zawiera on przyciski, których kliknięcie powoduje wyświetlenie przykładów. Jeśli te strony nie są wyświetlane, lecz jest tylko dostępne pole wyboru Czy pokazać strony wprowadzenia?, zaznacz to pole wyboru, a następnie dwa razy kliknij przycisk Wstecz, aby zobaczyć wprowadzenie. Jeśli nie chcesz wyświetlać stron wprowadzenia ponownie po przeczytaniu wprowadzenia, możesz wyczyścić to pole wyboru.

  3. Na stronie rozpoczynającej się od zdania Która tabela zawiera pola zawierające powtarzające się dane w wielu rekordach? zaznacz tabelę, którą chcesz przeanalizować, a następnie kliknij przycisk Dalej.

  4. Możesz zezwolić, aby to kreator zadecydował, które pola zostaną umieszczone w których tabelach, lub zadecydować o tym samodzielnie. Nawet po przyjęciu sugestii kreatora można wprowadzić zmiany do układu tabeli na następnej stronie kreatora.

    Uwaga : Pozostawiając kreatorowi decyzję o tym, które pola zostaną umieszczone w których tabelach, trzeba pamiętać, że wybory kreatora mogą nie być właściwe dla danych, szczególnie jeśli nie jest ich zbyt wiele. Wyniki kreatora należy dokładnie sprawdzić. Z drugiej strony kreator może zaproponować efektywniejszą organizację niż sam użytkownik, warto więc chociaż raz spróbować zastosować decyzje kreatora. Jeśli propozycje kreatora nie będą trafne, można ręcznie zmienić rozmieszczenie pól albo kliknąć przycisk Wstecz i zorganizować wszystkie pola samodzielnie.

  5. Kliknij przycisk Dalej. Na tej stronie należy określić, które tabele mają zawierać które pola. Jeśli zadecydował o tym kreator, powinny być widoczne liczne tabele połączone liniami relacji. Program Access może też utworzyć tylko jedną tabelę zawierającą wszystkie pola. W obu przypadkach na tej stronie można wprowadzać zmiany.

    • Można przeciągać pola z tabeli do pustego obszaru strony, aby utworzyć nową tabelę zawierającą te pola. Program Access wyświetli monit o określenie nazwy tabeli.

    • Można przeciągać pola z jednej tabeli do drugiej, jeśli zdaniem użytkownika takie ich przechowywanie będzie efektywniejsze.

    • Większość tabel otrzyma pole Identyfikator lub pole Wygenerowany unikatowy ID. Aby uzyskać więcej informacji na temat pól identyfikatorów, kliknij łącze Porady w prawym górnym rogu kreatora.

    • Aby cofnąć zmianę, kliknij przycisk Cofnij.

    • Aby zmienić nazwę tabeli, kliknij dwukrotnie jej pasek tytułu, wpisz nową nazwę, a następnie kliknij przycisk OK.

  6. Po ustawieniu pól w odpowiedni sposób kliknij przycisk Dalej.

  7. Jeśli kreator znajdzie rekordy z bardzo podobnymi wartościami, zidentyfikuje te wartości jako prawdopodobne błędy pisowni i wyświetli ekran, na którym można zdecydować, jak wartości te mają być traktowane. Przewiń listę, aby znaleźć te wartości w kolumnie Poprawka, a następnie kliknij odpowiednią pozycję na liście rozwijanej. Wybierz pozycję (Pozostaw bez zmian), aby kreator nie wprowadzał żadnych zmian w tych wartościach. Na koniec kliknij przycisk Dalej.

  8. Kreator zapyta, czy chcesz utworzyć kwerendę podobną do pierwotnej tabeli. Jeśli formularze i raporty oparte na pierwotnej tabeli już zostały utworzone, utworzenie takiej kwerendy jest dobrym pomysłem. Jeśli wybierzesz przycisk Tak, utwórz kwerendę, kreator zmieni nazwę pierwotnej tabeli, dodając do nazwy tabeli „_OLD”, a następnie użyje pierwszej nazwy pierwotnej tabeli jako nazwy nowej kwerendy. Formularze i raporty oparte na tabeli użyją teraz danych z kwerendy i będą działać tak jak wcześniej.

  9. Kliknij przycisk Zakończ.

    Kreator utworzy nowe tabele zgodnie z wybranymi opcjami, a następnie otworzy je. Po zakończeniu sprawdzania wyników zamknij te tabele.

Powrót do początku sekcji

Praca z danymi z innych programów

Program Office Access 2007 udostępnia funkcje pracy z danymi przechowywanymi w innych programach.

  • Tworzenie nowej bazy danych programu Access z połączeniem do danych w innym formacie pliku    Program Access pozwala otworzyć plik w innym formacie, na przykład plik tekstowy, plik bazy danych dBASE czy plik arkusza kalkulacyjnego. Program Access automatycznie utworzy bazę danych i połączy z nią wskazany plik.

    1. Uruchom program Access.

    2. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Otwórz.

    3. W oknie dialogowym Otwieranie kliknij typ pliku, który chcesz otworzyć. Jeśli nie masz pewności co do typu pliku, kliknij pozycję Wszystkie pliki (*.*).

    4. W razie potrzeby przejdź do folderu zawierającego plik, który chcesz otworzyć. Znalazłszy plik, kliknij go dwukrotnie, aby go otworzyć.

    5. Postępuj zgodnie z instrukcjami kreatora. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

  • Importowanie danych lub tworzenie łącza do istniejącej bazy danych programu Access    Dane z innych źródeł i programów można importować do tabel programu Access, aby dane te znalazły się w pliku programu Access. Można też tworzyć w programie Access łącza do tych danych, aby pozostały w pierwotnym pliku (poza plikiem programu Access).

    Importowanie i łączenie danych

    1. Na karcie Dane zewnętrzne w grupie Importowanie kliknij format, w którym są przechowywane dane.

      Można importować lub łączyć dane w następujących formatach:

      • Microsoft Office Access

      • Microsoft Office Excel

      • Microsoft Windows SharePoint Services

      • Pliki tekstowe

      • Pliki XML

      • Bazy danych ODBC

      • Dokumenty HTML

      • Microsoft Office Outlook

      • dBase

      • Paradox

      • Lotus 1-2-3

        Zostanie wyświetlone okno dialogowe Pobieranie danych zewnętrznych.

    2. Postępuj zgodnie z instrukcjami wyświetlanymi w oknie dialogowym.

      Program Access zaimportuje dane do bazy danych lub połączy je z bazą danych. Większość formatów wymaga określenia lokalizacji danych, a następnie wybrania sposobu przechowywania danych w bazie danych.

Powrót do początku sekcji

Początek strony

Używanie wcześniejszej wersji bazy danych w kilku wersjach programu Access

Jeśli baza danych programu Access lub projekt programu Access zostały utworzone w programie Access 2000 lub nowszym, można użyć tej bazy danych lub projektu w wersji programu Access, w której zostały utworzone, lub w dowolnej nowszej wersji — nawet przy włączonych zabezpieczeniach pliku. Plików programu Access 2000 można na przykład używać w programie w wersji od Access 2000 do Office Access 2007, a plików programu Access 2002–2003 można używać w programie w wersji od Access 2002–2003 do Office Access 2007.

Może zaistnieć sytuacja, w której dane są przechowywane we wcześniejszej wersji programu Access, ale niektórzy użytkownicy mają nowszą wersję programu Access i chcą nawiązać połączenie z danymi, korzystając jednocześnie z niektórych funkcji nowszej wersji programu. Odpowiednim rozwiązaniem jest utworzenie nowej „zewnętrznej” bazy danych w nowszej wersji (zawierającej formularze, raporty, kwerendy, makra, ale nie tabele) i połączenie jej z tabelami we wcześniejszej wersji pliku. W zależności od tego, czy baza danych jest zawarta w jednym pliku, czy jest podzielona na aplikacja zewnętrzna/wewnętrzna, należy zastosować jedną z poniższych procedur.

Używanie jednego pliku bazy danych programu Access w kilku wersjach programu Access

Używanie aplikacji zewnętrznej/wewnętrznej w kilku wersjach programu Access

Używanie jednoplikowej bazy danych programu Access w kilku wersjach programu Access

Jeśli wszystkie tabele, formularze i inne obiekty bazy danych programu Access są zawarte w jednym pliku mdb i baza danych ma być używana w kilku wersjach programu Access, można utworzyć nową zewnętrzną bazę danych w nowszej wersji i połączyć ją z plikiem oryginalnym. Użytkownicy dysponujący starszą wersją programu Access będą mogli nadal używać oryginalnej bazy danych. Użytkownicy dysponujący nowszą wersją będą mogli używać nowej zewnętrznej bazy danych, aby nawiązywać połączenie z tymi samymi danymi.

  1. Za pomocą poniższej procedury przekonwertuj bazę danych na jeden z trzech najnowszych formatów: Access 2000, Access 2002–2003 lub Access 2007. To polecenie zachowa bazę danych w jej pierwotnym formacie i utworzy jej kopię w wybranym formacie.

    • Zamknij plik programu Access. Jeśli plik jest bazą danych programu Access z dostępem wielu użytkowników znajdującą się na serwerze lub w folderze udostępnionym, upewnij się, że nie został otwarty przez innego użytkownika.

    • Uruchom program Access 2007.

    • Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Otwórz.

    • Przejdź do lokalizacji pliku do przekonwertowania i kliknij go dwukrotnie, aby go otworzyć.

      Jeśli zostanie otwarte okno dialogowe Ostatnio używane pliki z pytaniem, czy chcesz rozszerzyć bazę danych, kliknij przycisk Nie.

    • Jeśli po uruchomieniu bazy danych zostanie otwarty formularz, zamknij go.

    • Kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , wskaż polecenie Zapisz jako, a następnie w obszarze Zapisz bazę danych w innym formacie, kliknij format pliku, do którego chcesz przekonwertować.

    • W oknie dialogowym Zapisywanie jako wpisz nazwę nowej bazy danych.

      Uwaga : Jeśli nowa baza danych nie jest zapisywana w innej lokalizacji, jej nazwa musi być inna niż nazwa pierwotnej bazy danych. W obu przypadkach najlepiej użyć innej nazwy, aby z łatwością odróżniać wewnętrzną i zewnętrzną bazę danych. Jeśli jednak baza danych jest konwertowana na format programu Access 2007, rozszerzenie nazwy pliku zmieni się z mdb na accdb, można więc użyć tej samej nazwy pliku.

    • Kliknij przycisk Zapisz.

  2. Za pomocą poniższej procedury podziel przekonwertowaną bazę danych na aplikację zewnętrzną/wewnętrzną:

    • Na karcie Narzędzia bazy danych w grupie Przenoszenie danych kliknij Bazę danych programu Access. Obraz przycisku

    • W oknie dialogowym Rozdzielacz bazy danych kliknij przycisk Podziel bazę danych.

    • Wpisz nazwę wewnętrznej bazy danych, a następnie kliknij przycisk Podziel.

  3. Usuń wewnętrzną bazę danych utworzoną przez narzędzie Rozdzielacz bazy danych — uważaj, aby nie usunąć pierwotnej bazy danych.

  4. Połącz nową zewnętrzną bazę danych z tabelami w pierwotnej bazy danych: na karcie Narzędzia bazy danych w grupie Narzędzia bazy danych kliknij pozycję Menedżer tabel połączonych. Obraz przycisku

  5. Kliknij przycisk Zaznacz wszystko, a następnie zaznacz pole wyboru Zawsze monituj o nową lokalizację.

  6. Kliknij przycisk OK, przejdź do bazy danych w starszej wersji, a następnie kliknij ją dwukrotnie.

    Jeśli nie wystąpią problemy, w programie Access zostanie wyświetlony komunikat informujący, że wszystkie zaznaczone tabele połączone zostały pomyślnie odświeżone.

    Następnie można rozszerzyć nową zewnętrzną bazę danych o obsługę nowych funkcji dla użytkowników, którzy dokonali uaktualnienia do programu Access 2000, Access 2002–2003 lub Access 2007. Użytkownicy dysponujący starszymi wersjami mogą nadal używać starszej wersji bazy danych.

    Można również konwertować nową zewnętrzną bazę danych do jeszcze innej wersji. Jeśli na przykład oryginalna baza danych miała format programu Access 2000, można utworzyć zewnętrzną bazę danych w formacie programu Access 2002–2003 dla osób używających tej wersji programu, a także zewnętrzną bazę danych w formacie programu Access 2007 dla użytkowników mających taką wersję. Obie wersje zewnętrznej bazy danych będą w takim przypadku połączone z plikiem w formacie programu Access 2000.

Powrót do początku sekcji

Używanie aplikacji zewnętrznej/wewnętrznej w kilku różnych wersjach programu Access

Jeśli baza danych programu Access ma już postać aplikacja zewnętrzna/wewnętrzna, trzeba tylko przekonwertować zewnętrzną bazę danych na format pliku programu Access 2000, Access 2002–2003 lub Access 2007. Wewnętrzna baza danych nie wymaga żadnych zmian.

W poniższej procedurze pokazano, jak za pomocą polecenia Zapisz bazę danych jako przekonwertować zewnętrzną bazę danych na jeden z trzech najnowszych formatów: programu Access 2000, Access 2002–2003 lub Access 2007. To polecenie zachowa bazę danych w jej pierwotnym formacie i utworzy jej kopię w wybranym formacie.

  1. Zamknij zewnętrzną bazę danych. Jeśli plik jest współużytkowaną bazą danych programu Access, która znajduje się na serwerze lub w folderze udostępnionym, upewnij się, że ten plik nie został otwarty przez innego użytkownika.

  2. Uruchom program Access 2007.

  3. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Otwórz.

  4. Przejdź do lokalizacji zewnętrznej bazy danych, a następnie kliknij ją dwukrotnie, aby ją otworzyć.

    Jeśli zostanie otwarte okno dialogowe Ostatnio używane pliki z pytaniem, czy chcesz rozszerzyć bazę danych, kliknij przycisk Nie.

  5. Jeśli po otwarciu bazy danych zostanie wyświetlony formularz, zamknij go.

  6. Kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , wskaż polecenie Zapisz jako, a następnie w obszarze Zapisz bazę danych w innym formacie, kliknij format pliku, do którego chcesz przekonwertować.

  7. W oknie dialogowym Zapisywanie jako wpisz nazwę nowej bazy danych.

  8. Kliknij przycisk Zapisz.

Teraz możesz rozszerzyć nową zewnętrzną bazę danych o obsługę nowych funkcji dla użytkowników, którzy dokonali uaktualnienia do programu Access 2000, Access 2002–2003 lub Access 2007.

Powrót do początku sekcji

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×