Rozpoczynanie pracy: tworzenie spotkania Uwaga systemu przy użyciu programu InfoPath i SharePoint

Ważne: Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Modyfikując w niewielkim stopniu przykładowy szablon formularza programu Microsoft Office InfoPath 2007 i tworząc bibliotekę dokumentów w witrynie programu Windows SharePoint Services 3.0, można zaimplementować system służący do spójnego sporządzania notatek ze spotkań, wysyłania ich do wszystkich uczestników spotkań i zapisywania ich w bibliotece dokumentów programu SharePoint Services. W tym artykule wyjaśniono, jak utworzyć ten system.

W tym artykule

Omówienie

Przed rozpoczęciem

Tworzenie nowego systemu notatek ze spotkań

Aktualizowanie szablonu formularza

Omówienie

Do programu InfoPath dołączono przykładowy szablon formularza, który zaprojektowano specjalnie do zbierania typowych danych dotyczących spotkań, takich jak informacje o planach spotkań, uczestnikach, zagadnieniach do omówienia i czynnościach do wykonania. Ten przykładowy szablon formularza jest tak skonfigurowany, że można wysłać kopię formularza opartego na tym szablonie pocztą e-mail do każdego uczestnika spotkania.

Przykładowy szablon formularza skonfigurowano w celu ułatwienia osobie sporządzającej notatki zbierania danych rejestrowanych zwykle w trakcie spotkania. Formanty rozmieszczono w sekcjach logicznych, dzięki czemu osoba sporządzająca notatki może łatwo wprowadzać odpowiednie dane i jednocześnie nie musi wprowadzać danych, które mogą zostać wygenerowane automatycznie. Ponadto układ formantów zapewnia spójną strukturę, więc osoba sporządzająca notatki nie musi pamiętać, jakie dane trzeba zebrać — wystarczy, że w trakcie spotkania będzie wypełniać udostępnione puste pola.

Szablon formularza można zmodyfikować, umożliwiając zbieranie dodatkowych danych, jednak zaleca się korzystanie z istniejącego szablonu formularza w jego pierwotnej postaci i wprowadzenie jednej modyfikacji, która umożliwi zapisywanie wypełnionych formularzy w bibliotece dokumentów programu SharePoint. Następnie można przetestować skuteczność tego systemu i wykorzystać wiedzę uzyskaną w trakcie testowania do zmodyfikowania szablonu formularza w celu dostosowania go do potrzeb grupy.

Ten przykładowy szablon formularza można zastosować w tworzonym systemie, publikując go najpierw w nowej bibliotece dokumentów w witrynie programu SharePoint. Nowa biblioteka dokumentów zostanie utworzona przez użytkownika w ramach procesu publikowania. Po opublikowaniu szablonu formularza i utworzeniu nowej biblioteki dokumentów użytkownik zmodyfikuje szablon formularza, tak aby wypełniony formularz był zapisywany w nowej bibliotece dokumentów, a jego kopie były wysyłane do uczestników spotkania.

Aby skorzystać z tego systemu, osoba sporządzająca notatki przechodzi do biblioteki dokumentów i tworzy nowy formularz oparty na tym szablonie formularza. Podczas spotkania wypełnia odpowiednie formanty w formularzu danymi. Na końcu spotkania przesyła formularz do biblioteki dokumentów, a kopie formularza są wysyłane do każdego uczestnika spotkania. Osoby, które nie uczestniczyły w spotkaniu, mogą przeczytać notatki, przechodząc do biblioteki dokumentów i otwierając ten formularz w programie InfoPath.

Przykładowy szablon formularza zawiera następujące sekcje:

Szablon formularza planu spotkania z czterema sekcjami

1. sekcja tytuł zawiera kontrolki dla nazwy, przeznaczenie, lokalizację, a spotkanie daty i godziny. Kontrola daty automatycznie wyświetlana jest data utworzenia formularza. Domyślnie Czas zakończenia w polu tekstowym automatycznie wyświetla godzinę czyli godzinę później niż godziny wprowadzone w polu tekstowym Czas rozpoczęcia.

2. uczestników powtarzających się, że sekcja zawiera kontrolki dla nazwy i adresy e-mail wszystkich uczestników spotkania. Jeśli zabezpieczenie notatki prześle wypełniony formularz, każdego uczestnika wymienionych w tej sekcji, otrzymuje kopię wypełniony formularz.

3. element dyskusji sekcji powtarzającej się zawiera kontrolki dla każdej osoby prowadzącej (uczestnika, który prowadzi dyskusji) i notatki dotyczące poszczególnych dyskusji. Formant pola listy rozwijanej prezentera zawiera nazwy z sekcji uczestników.

4. czynność do wykonania sekcji powtarzającej się zawiera kontrolki nazwisko, przydział i ukończenia daty dla każdego elementu akcji. Formant pola listy rozwijanej przydziału zawiera nazwy z sekcji uczestników.

Nowi użytkownicy programu InfoPath powinni zapoznać się z poniższymi artykułami, które ułatwiają zrozumienie ważnych pojęć i okoliczności wykonywania poszczególnych zadań opisanych w tym artykule. Jeśli w trakcie wykonywania zadania będą potrzebne dodatkowe informacje, można skorzystać z łączy do tych artykułów, które są również dostępne w odpowiednich sekcjach tego artykułu.

Początek strony

Przed rozpoczęciem

Będzie potrzebny Uniform Resource Locator (URL) i, co najmniej uprawnienia do zbioru witryn, witryny programu SharePoint, który będzie używany dla systemu projektowanie. Jeśli tworzysz biblioteki dokumentów w zbiorze witryn, dysponuje się odpowiednimi uprawnieniami. Osoby, które muszą być widoczne notatki ze spotkań będą potrzebne uprawnienia do odczytu w zbiorze witryn. Jeśli potrzebne są uprawnienia do tworzenia biblioteki dokumentów lub ustawianie uprawnień do odczytu do zbioru witryn dla użytkowników formularza, skontaktuj się z administratorem zbioru witryn.

Ponadto potrzebny jest co najmniej jeden adres e-mail, na który można wysłać kopię wypełnionego formularza, oraz klient poczty e-mail (na przykład program Microsoft Office Outlook 2007) skonfigurowany do odbierania wiadomości w celu przetestowania działania szablonu formularza.

W tym artykule przyjęto, że jest używana domyślna konfiguracja programu SharePoint Services.

Początek strony

Tworzenie nowego systemu notatek ze spotkań

Aby utworzyć ten system, należy wykonać następujące zadania:

  1. Otwarcie i zapisanie przykładowego szablonu formularza.

  2. Opublikowanie tego przykładowego szablonu formularza w celu utworzenia nowej biblioteki dokumentów dla notatek ze spotkań.

  3. Zmodyfikowanie tego przykładowego szablonu formularza w celu zapisywania wypełnionych formularzy w nowej bibliotece dokumentów i wysyłania kopii do każdego uczestnika.

  4. Opublikowanie zmodyfikowanego szablonu formularza.

  5. Przetestowanie zmodyfikowanego szablonu formularza i nowej biblioteki dokumentów przez tworzenie i przesyłanie formularzy testowych opartych na tym szablonie formularza.

Otwieranie i zapisywanie szablonu formularza

  1. W menu Plik kliknij polecenie Projektuj szablon formularza.

  2. W obszarze Otwórz szablon formularza kliknij łącze Dostosuj przykład.

  3. W obszarze Dostosowywanie przykładu kliknij dwukrotnie pozycję Plan spotkania — przykład.

  4. W menu Plik kliknij polecenie Zapisz.

  5. Jeśli w programie InfoPath zostanie wyświetlony komunikat o publikowaniu szablonu formularza, kliknij przycisk OK.

  6. W oknie dialogowym Zapisywanie jako określ lokalizację, w której chcesz zapisać szablon formularza.

  7. W polu Nazwa pliku wpisz nazwę szablonu formularza.

  8. Na liście Zapisz jako typ kliknij pozycję Formularz programu InfoPath, a następnie kliknij przycisk Zapisz.

Publikowanie szablonu formularza

W ramach procesu publikowania zostanie utworzona nowa biblioteka dokumentów.

Aby dowiedzieć się więcej na temat publikowania szablonu formularza, zobacz artykuł Wprowadzenie do publikowania szablonu formularza.

  1. W menu plik kliknij pozycję Publikuj.

  2. Na pierwszej stronie Kreatora publikowania kliknij pozycję Serwer programu SharePoint z usługami InfoPath Forms Services lub bez nich, a następnie kliknij przycisk Dalej.

  3. Na następnej stronie kreatora w polu Wprowadź lokalizację witryny programu SharePoint lub witryny usług InfoPath Forms Services wpisz adres URL zbioru witryn witryny programu SharePoint, a następnie kliknij przycisk Dalej. Aby na przykład użyć zbioru witryn o adresie URL http://www.adventureworks.com/TylkoPracownicy, wpisz w tym polu ciąg http://www.adventureworks.com/TylkoPracownicy.

  4. Na następnej stronie kliknij pozycję Biblioteka dokumentów, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kliknij pozycję Utwórz nową bibliotekę dokumentów, a następnie kliknij przycisk Dalej.

  6. Na następnej stronie wpisz nazwę i opis nowej biblioteki dokumentów, a następnie kliknij przycisk Dalej.

  7. Zaakceptuj sugerowane kolumny i kliknij przycisk Dalej.

  8. Na ostatniej stronie kreatora sprawdź, czy wyświetlone informacje są poprawne, a następnie kliknij przycisk Publikuj.

  9. Kliknij przycisk Zamknij.

    Po pomyślnym opublikowaniu szablonu formularza na ostatniej stronie kreatora zostanie wyświetlone potwierdzenie.

Należy zanotować adres URL nowej biblioteki dokumentów, ponieważ będzie on potrzebny w dalszej części tego artykułu. Adres URL nowej biblioteki dokumentów będzie składać się z adresu URL zbioru witryn, ukośnika (/) i nazwy biblioteki dokumentów. Jeśli na przykład utworzono nową bibliotekę dokumentów o nazwie SpotkaniaNotatki w zbiorze witryn o adresie URL http://www.adventureworks.com/TylkoPracownicy, adres URL nowej biblioteki dokumentów będzie mieć postać http://www.adventureworks.com/TylkoPracownicy/SpotkaniaNotatki.

Modyfikowanie szablonu formularza

W tej sekcji przedstawiono sposób wykonywania następujących zadań:

  • Dodawanie nowego połączenia do przesyłania danych w celu zapisywania wypełnionego formularza w nowej bibliotece dokumentów.

    Aby dowiedzieć się więcej na temat przesyłania połączenia danych, zobacz Wprowadzenie do połączeń danych.

  • Zmienianie opcji połączenia danych, tak aby wypełniony formularz był zapisywany w bibliotece dokumentów, a jego kopia była wysyłana do każdego uczestnika spotkania.

  • Konfigurowanie szablonu formularza do zamykania formularza po przesłaniu danych.

Aby dowiedzieć się więcej o przesyłaniu formularza opartego na szablonie formularza, zobacz artykuł Wprowadzenie do przesyłania danych formularza.

Dodawanie nowego połączenia do przesyłania danych

W tej sekcji zostanie utworzone nowe połączenie do przesyłania danych do nowej biblioteki dokumentów, a następnie zostanie ono skonfigurowane w celu zapisywania formularza pod unikatową nazwą. Nazwa formularza będzie kombinacją tytułu spotkania i daty utworzenia formularza.

Rozpoczęcie tworzenia połączenia danych
  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Utwórz nowe połączenie z, kliknij opcję Prześlij dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij w bibliotece dokumentów w witrynie programu SharePoint, a następnie kliknij przycisk Dalej. Wybieranie miejsca docelowego przesyłanych danych w Kreatorze połączenia danych

  5. Na następnej stronie kreatora w polu Biblioteka dokumentów wpisz adres URL biblioteki dokumentów utworzonej w poprzedniej sekcji. Aby na przykład użyć biblioteki dokumentów o adresie URL http://www.adventureworks.com/TylkoPracownicy/SpotkaniaNotatki, w polu Biblioteka dokumentów wpisz ciąg http://www.adventureworks.com/TylkoPracownicy/SpotkaniaNotatki.

    W następnej sekcji opisano proces definiowania unikatowej nazwy formularza, co wymaga pozostania na tej stronie kreatora. Nie klikaj jeszcze przycisku Dalej.

Definiowanie unikatowej nazwy formularza

Szablon formularza zapisuje formularz w bibliotece dokumentów pod nazwą domyślną. W przypadku używania tej nazwy domyślnej nowa biblioteka dokumentów będzie zawierać tylko jeden wypełniony formularz. W tej sekcji połączenie danych zostanie tak skonfigurowane, aby formularze oparte na tym szablonie formularza były zapisywane pod nazwami składającymi się z tytułu i daty spotkania. W tym celu należy utworzyć formułę z zastosowaniem funkcji XPath.

Aby dowiedzieć się więcej na temat formuł i funkcji, zobacz Dodawanie formuły do formantu.

  1. Kliknij przycisk Wstaw formułę Obraz przycisku .

  2. W oknie dialogowym Wstawianie formuły kliknij przycisk Wstaw funkcję.

  3. Na liście Kategorie w oknie dialogowym Wstawianie funkcji kliknij pozycję Tekst.

  4. Na liście Funkcje kliknij pozycję concat, a następnie kliknij przycisk OK.

  5. W polu Formuła kliknij dwukrotnie pierwsze wystąpienie ciągu kliknij dwukrotnie, aby wstawić pole.

    Dwukrotne kliknięcie w celu wstawienia pierwszego pola, które ma zostać użyte jako część nazwy formularza

  6. W oknie dialogowym Wybieranie pola lub grupy otwórz pozycję meeting (spotkanie), kliknij pozycję meetingTitle (tytuł spotkania), a następnie kliknij przycisk OK.

    Wybieranie pola meetingTitle w oknie dialogowym Wybieranie pola lub grupy

  7. W polu Formuła kliknij drugie wystąpienie ciągu kliknij dwukrotnie, aby wstawić pole, aby je zaznaczyć (nie klikaj go dwukrotnie).

    Dwukrotne kliknięcie w celu wstawienia znaku łącznika jako części nazwy formularza

  8. Wpisz podwójny cudzysłów ("), łącznik (-) i kolejny podwójny cudzysłów.

    Wstawianie znaku łącznika jako części nazwy formularza

  9. Kliknij dwukrotnie trzecie wystąpienie ciągu kliknij dwukrotnie, aby wstawić pole.

    Dwukrotne kliknięcie w celu wstawienia kolejnego pola, które ma zostać użyte jako część nazwy formularza

  10. W oknie dialogowym Wybieranie pola lub grupy otwórz pozycję meeting (spotkanie), kliknij pozycję meetingDate (data spotkania), a następnie kliknij przycisk OK.

    Wybieranie pola meetingDate w oknie dialogowym Wybieranie pola lub grupy

    Okno dialogowe Wstawianie formuły powinno wyglądać następująco:

    Ukończona formuła konstruująca nazwę formularza w oknie dialogowym Wstawianie formuły

  11. Aby sprawdzić, czy formuła ma poprawną składnię, kliknij przycisk Weryfikuj formułę w oknie dialogowym Wstawianie formuły.

  12. Jeśli formuła nie zawiera żadnych błędów, kliknij przycisk OK, aby zamknąć okno dialogowe.

Kończenie konfigurowania połączenia danych
  1. W kreatorze kliknij przycisk Dalej.

  2. Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz opisową nazwę dla tego przedstawia połączenia danych.

  3. Upewnij się, że informacje w sekcji Podsumowanie są poprawne, a następnie kliknij przycisk Zakończ.

  4. Kliknij przycisk Zamknij.

  5. W menu Plik kliknij polecenie Zapisz.

Zmienianie opcji przesyłania w celu używania obu połączeń do przesyłania danych

  1. W menu Narzędzia kliknij polecenie Opcje przesyłania.

  2. W oknie dialogowym Opcje przesyłania zaznacz pole wyboru Zezwalaj użytkownikom na przesyłanie tego formularza.

  3. Kliknij opcję Wykonaj akcję niestandardową przy użyciu reguł, a następnie kliknij przycisk Reguły.

  4. W oknie dialogowym Reguły przesyłania formularzy kliknij przycisk Dodaj.

  5. Kliknij pozycję Dodaj akcję.

  6. W polu Akcja kliknij pozycję Prześlij, używając połączenia danych.

  7. Na liście Połączenie danych kliknij połączenie danych z biblioteką dokumentów utworzone w poprzedniej sekcji, a następnie kliknij przycisk OK.

  8. Kliknij pozycję Dodaj akcję.

  9. W polu Akcja kliknij pozycję Prześlij, używając połączenia danych.

  10. Na liście Połączenie danych kliknij pozycję Przesyłanie główne, a następnie kliknij przycisk OK.

    Połączenie danych Przesyłanie główne będzie służyć do wysyłania kopii formularza do każdego uczestnika.

  11. W polu Nazwa w oknie dialogowym Reguła wpisz ciąg Reguły przesyłania w celu umożliwienia identyfikacji nowo utworzonej reguły.

  12. Kliknij przycisk OK dwa razy.

Konfigurowanie szablonu formularza do zamykania formularza po przesłaniu danych

  1. W oknie dialogowym Opcje przesyłania kliknij pozycję Zaawansowane.

  2. Na liście Po przesłaniu kliknij pozycję Zamknij formularz.

  3. Kliknij przycisk OK.

  4. W menu Plik kliknij polecenie Zapisz.

Publikowanie szablonu formularza

Po zmodyfikowaniu szablonu formularza należy opublikować go w bibliotece dokumentów w celu wdrożenia modyfikacji.

  1. W menu plik kliknij pozycję Publikuj.

  2. Na pierwszej stronie Kreatora publikowania kliknij pozycję Serwer programu SharePoint z usługami InfoPath Forms Services lub bez nich, a następnie kliknij przycisk Dalej.

  3. Na następnej stronie kreatora w polu Wprowadź lokalizację witryny programu SharePoint lub witryny usług InfoPath Forms Services wpisz lokalizację biblioteki dokumentów w zbiorze witryn witryny programu SharePoint, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kliknij pozycję Biblioteka dokumentów, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kliknij pozycję Aktualizuj szablon formularza w istniejącej bibliotece dokumentów.

  6. Na liście Biblioteka dokumentów do zaktualizowania kliknij odpowiednią bibliotekę dokumentów, a następnie kliknij przycisk Dalej.

  7. Kliknij przycisk Dalej.

  8. Na następnej stronie sprawdź, czy wyświetlone informacje są poprawne, a następnie kliknij przycisk Publikuj.

    Po pomyślnym opublikowaniu szablonu formularza na ostatniej stronie kreatora zostanie wyświetlone potwierdzenie.

Testowanie szablonu formularza i witryny

  1. Na ostatniej stronie Kreatora publikowania kliknij pozycję Otwórz tę bibliotekę dokumentów, a następnie kliknij przycisk Zamknij.

  2. W bibliotece dokumentów kliknij łącze Nowy.

  3. Wypełnij formularz jak podczas sporządzania notatek na spotkaniu. Po wprowadzeniu godziny w formancie pola tekstowego Godzina rozpoczęcia naciśnij klawisz TAB, aby przejść do następnego formantu. Program InfoPath automatycznie wypełni formant pola tekstowego Godzina zakończenia.

  4. Wprowadź adres e-mail uczestnika spotkania w polu Adres e-mail w sekcji Uczestnik. Aby dodać innych uczestników i ich adresy e-mail, kliknij przycisk Dodaj uczestnika.

  5. Na pasku narzędzi programu InfoPath kliknij przycisk Prześlij.

  6. W oknie dialogowym sprawdź, czy wyświetlane adresy e-mail są poprawne.

  7. Kliknij przycisk Wyślij, a następnie kliknij przycisk OK, aby zamknąć okno dialogowe.

Notatki ze spotkania powinny pojawić się w bibliotece dokumentów i zostać dostarczone do skrzynki odbiorczej poczty e-mail jako nowa wiadomość e-mail.

Po przetestowaniu systemu przez utworzenie i przesłanie kilku formularzy opartych na tym szablonie formularza można rozpocząć korzystanie z tego systemu do zapisywania i rozpowszechniania notatek ze spotkań.

Początek strony

Aktualizowanie szablonu formularza

Gdy inne osoby przetestują ten nowy system, tworząc i zapisując notatki ze spotkań, może wystąpić potrzeba wprowadzenia zmian w projekcie szablonu formularza na podstawie opinii użytkowników. Aby wprowadzić zmiany w szablonie formularza, należy wykonać następujące zadania:

  1. Otwarcie szablonu formularza z poziomu biblioteki dokumentów, zmodyfikowanie go według potrzeb i zapisanie zmian.

  2. Zatwierdzenie wprowadzonych zmian w bibliotece dokumentów przez opublikowanie szablonu formularza.

Otwieranie szablonu formularza z poziomu biblioteki dokumentów

  1. Otwórz bibliotekę dokumentów.

  2. Kliknij pozycję Ustawienia, a następnie kliknij pozycję ustawień Biblioteka formularzy.

  3. W obszarze Ustawienia ogólne kliknij pozycję ustawień Zaawansowane.

  4. W obszarze pola Adres URL szablonu w sekcji Szablon dokumentu kliknij pozycję Edytuj szablon.

  5. Jeśli w programie InfoPath zostanie wyświetlony komunikat o publikowaniu szablonu formularza, kliknij przycisk Tak.

Po zmodyfikowaniu szablonu formularza należy go zapisać przed opublikowaniem.

Publikowanie szablonu formularza

Po wprowadzeniu modyfikacji należy opublikować zmodyfikowany szablon formularza w bibliotece dokumentów.

  1. W menu plik kliknij pozycję Publikuj.

  2. Na pierwszej stronie Kreatora publikowania kliknij pozycję Serwer programu SharePoint z usługami InfoPath Forms Services lub bez nich, a następnie kliknij przycisk Dalej.

  3. Na następnej stronie kreatora w polu Wprowadź lokalizację witryny programu SharePoint lub witryny usług InfoPath Forms Services wpisz lokalizację biblioteki dokumentów w zbiorze witryn witryny programu SharePoint, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kliknij pozycję Biblioteka dokumentów, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kliknij pozycję Aktualizuj szablon formularza w istniejącej bibliotece dokumentów.

  6. Na liście Biblioteka dokumentów do zaktualizowania kliknij odpowiednią bibliotekę dokumentów, a następnie kliknij przycisk Dalej.

  7. Kliknij przycisk Dalej.

  8. Na następnej stronie sprawdź, czy wyświetlone informacje są poprawne, a następnie kliknij przycisk Publikuj.

  9. Kliknij przycisk Zamknij.

    Po pomyślnym opublikowaniu szablonu formularza na ostatniej stronie kreatora zostanie wyświetlone potwierdzenie.

Początek strony

Uwaga: Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×