Publikowanie bazy danych w witrynie programu SharePoint

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Opublikowanie bazy danych programu Microsoft Office Access 2007 w witrynie programu Windows SharePoint Services 3.0 umożliwia pozostałym członkom organizacji pracę z tą bazą.

W tym artykule

Omówienie

Publikowanie bazy danych w witrynie programu SharePoint

Ponowne publikowanie bazy danych w witrynie programu SharePoint

Omówienie

Opublikowanie bazy danych w witrynie programu SharePoint umożliwia udostępnianie danych innym osobom używającym witryny programu SharePoint, gdy użytkownik stosuje program Access jako fronton dla formularzy, raportów i kwerend w bazie danych.

Z opublikowaną bazą danych można pracować na dwa sposoby. Projektanci baz danych mogą tworzyć kwerendy, formularze i raporty, które używają danych z witryny programu SharePoint. Użytkownicy baz danych mogą za pomocą programu Access wprowadzać, wyświetlać i analizować dane z witryny programu SharePoint.

Istnieje możliwość opublikowania utworzonej przez użytkownika bazy danych lub skonstruowania bazy danych na podstawie jednej lub kilku tabel połączonych z listami albo bibliotekami programu SharePoint. Po połączeniu danych z listy lub biblioteki programu SharePoint z tabelą programu Access użytkownik może przy użyciu programu Access tworzyć widoki dla tych list lub bibliotek na podstawie formularzy, kwerend i raportów. Dzięki temu można opracowywać aplikacje programu Access śledzące dane w witrynie programu SharePoint.

Na przykład jeśli Twoja witryna programu SharePoint zawiera list śledzenia problemy dotyczące obsługi klientów i przechowywane informacje o pracownikach, można utworzyć bazy danych w programie Access jako fronton dla tych list. Można tworzyć kwerendy programu Access, aby przeprowadzić analizę tych problemów i raporty programu Access, aby formatować i publikować pisanych raportów dla zespołu spotkanie dotyczące stanu. Jeśli osoby mają dostęp na swoich komputerach, kwerendy programu Access i raporty stanie się dostępna w menu Widok Menu Widok listy programu SharePoint. Podczas wyświetlania listy w witrynie programu SharePoint, mogą Znajdź i otwórz kwerendy, raporty i inne obiekty programu Access, klikając menu Widok.

W przypadku publikowania bazy danych w witrynie programu SharePoint po raz pierwszy program Access udostępnia listę serwerów sieci Web, co ułatwia przejście do lokalizacji, w której ma zostać opublikowana baza danych (na przykład biblioteki dokumentów). Po opublikowaniu bazy danych lokalizacja zostaje zapamiętana w programie Access, dzięki czemu użytkownik nie musi ponownie wyszukiwać serwera podczas publikowania zmian.

Publikowanie baz danych w witrynie programu SharePoint jest dostępne tylko w przypadku plików baz danych zapisanych w formacie programu Office Access 2007.

Praca z danymi w witrynie programu SharePoint

Jeśli chcesz utworzyć bazę danych oparty na listy programu SharePoint, możesz zacząć od listy programu SharePoint. Czy kliknij polecenie Otwórz w programie Microsoft Access w menu Akcje Obraz menu listy programu SharePoint, a następnie wybierz pozycję utworzyć łącze do danych w witrynie programu SharePoint. Następnie można utworzyć formularze, raporty i kwerendy dla danych, a także inne listy dodane do bazy danych.

Po opublikowaniu bazy danych w bibliotece witryny programu SharePoint obiekty utworzone w programie Access są dostępne dla innych użytkowników w menu Widok listy programu SharePoint. Kiedy użytkownicy otwierają widoki, obiekty programu Access są dostępne jako tylko do odczytu. Aby zaktualizować widoki, można przeprowadzić aktualizację odpowiednich obiektów, edytując opublikowaną bazę danych.

Podczas pracy z opublikowaną bazą danych jest wyświetlany monit o zapisanie kopii lokalnej. Zmiany są przechowywane lokalnie do momentu ich opublikowania. Zazwyczaj zwiększa to wydajność oraz ułatwia odzyskiwanie danych w przypadku wystąpienia błędu sieciowego. W przypadku wprowadzenia zmian w danych lub obiektach należy ponownie opublikować bazę danych, aby zmiany stały się dostępne dla innych osób.

Program Access zawiera kilka przycisków ułatwiających pracę z danymi list programu SharePoint, na przykład przyciski służące do tworzenia alertów i modyfikowania kolumn list. W przypadku edytowania tabel połączonych z listami programu SharePoint w opublikowanej bazie danych za pomocą programu Access przyciski są dostępne w grupie Lista programu SharePoint na karcie Arkusz danych.

Baza danych opublikowana w witrynie programu SharePoint staje się dostępna dla osób z uprawnieniami do pracy z witryną. Użytkownicy mający uprawnienia do modyfikowania list znajdujących się w lokalizacji, w której opublikowano bazę danych (na przykład w bibliotece dokumentów), mogą aktualizować bazę danych. Użytkownicy z uprawnieniami do współtworzenia list znajdujących się w witrynie programu SharePoint mogą dodawać dane do bazy. Użytkownicy uprawnieni do wyświetlania list mogą wyświetlać dane znajdujące się w bazie danych.

Ponowne publikowanie bazy danych

Jeśli po opublikowaniu bazy danych w witrynie programu SharePoint wprowadzono zmiany w znajdujących się w niej danych, należy ponownie opublikować bazę danych w celu zapisania najnowszych zmian. Ponownie opublikowana baza danych zostanie wyświetlona jako dostępna po następnym uruchomieniu programu Access.

Początek strony

Publikowanie bazy danych w witrynie programu SharePoint

Publikowanie bazy danych można zacząć od istniejącej bazy danych lub od utworzenia bazy danych przy użyciu list w witrynie programu SharePoint.

  1. Kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , wskaż polecenie Publikuj , a następnie kliknij Serwera zarządzania dokumentami.

  2. Wpisz adres URL witryny programu SharePoint, w której ma zostać opublikowana baza danych.

    Jeśli przy poprzednim uruchomieniu programu Access użyto tej samej lokalizacji, baza danych zostanie wyświetlona w oknie dialogowym Publikowanie na serwerze sieci Web.

    Uwaga : Ta opcja jest dostępna tylko w przypadku baz danych zapisanych w formacie programu Office Access 2007.

  3. Zaznacz bibliotekę (na przykład bibliotekę dokumentów), w której ma zostać opublikowana baza danych, a następnie kliknij przycisk Otwórz.

  4. W polu Nazwa wpisz nazwę pliku bazy danych.

  5. Kliknij przycisk Opublikuj.

Uwaga : Po otwarciu bazy danych w witrynie programu SharePoint zostanie wyświetlony monit o zapisane kopii lokalnej.

Początek strony

Ponowne publikowanie bazy danych w witrynie programu SharePoint

Po wprowadzeniu zmian w danych lub projekcie bazy danych, należy ją ponownie opublikować w witrynie programu SharePoint. Przy ponownym publikowania bazy danych program Access pamięta lokalizację, dzięki czemu nie trzeba do niej ponownie przechodzić.

Po otwarciu do edycji bazy danych opublikowanej w bibliotece programu SharePoint w górnej części bazy danych zostanie wyświetlony pasek komunikatów z przyciskiem Publikuj w witrynie programu SharePoint. Jeśli pasek komunikatów jest niedostępny — na przykład na skutek zamknięcia go podczas pracy — można użyć poleceń publikowania w menu przycisku pakietu Microsoft Office.

  1. Na pasku komunikatów kliknij przycisk Publikuj w witrynie programu SharePoint.

    Uwaga : Jeśli pasek komunikatów z przycisku Publikuj w witrynie programu SharePoint nie jest widoczna, kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , wskaż polecenie Publikuj , a następnie kliknij Serwera zarządzania dokumentami.

  2. W oknie dialogowym Publikowanie na serwerze sieci Web potwierdź, że wybrana biblioteka jest lokalizacją, w której baza danych ma zostać ponownie opublikowana.

  3. Kliknij przycisk Opublikuj.

  4. Po wyświetleniu monitu o zastąpienie kopii bazy danych w witrynie kliknij przycisk Tak.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×