Przygotowywanie, publikowanie i obsługiwanie witryny sieci Web w programie Publisher

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Uwaga : Publikacji w sieci Web są tylko dostępne w programie Publisher 2007 lub nowszy. Aby uzyskać informacje na temat aktualizowania istniejących publikacji w sieci Web w programie Publisher 2010 zobacz Funkcje sieci Web.

Po planowanie i tworzenie publikacji w sieci Web w Microsoft Office Publisher 2007, możesz opublikować go do sieci web, serwerze sieciowym lub folderu udostępnionego na swoim komputerze. Niezależnie od miejsca docelowego, program Publisher tworzy filtrowane pliki HTML z publikacji w sieci Web. Można otwierać i odczytywać te pliki HTML w dowolnej przeglądarki sieci Web, takie jak Windows Internet Explorer.

Publikowanie witryny sieci Web

W tym artykule

W tym artykule opisano procedury tworzenia i publikowania publikacji w sieci Web jako pliki HTML oraz w celu zaktualizowania witryny sieci Web przez edytowanie publikacji w sieci Web i opublikowanie go.

Przygotowywanie witryny sieci Web

Publikowanie witryny sieci Web

Zachowywanie witryny sieci Web

Przygotowywanie witryny sieci Web

Witryny sieci Web jest rozszerzeniem, firmy i znakowaniu firm. Przed utworzeniem witryny sieci Web, planowanie go. Aby uzyskać pomoc dotyczącą zrobić zobacz artykuł Planowanie witryny sieci Web.

Co to jest odpowiedniego narzędzia?

Podczas planowania witryny i informacji, jakie będzie udostępniać, należy rozważyć, jakie narzędzie jest odpowiednio do potrzeb. Office Publisher 2007 jest doskonałym narzędziem do używać, gdy chcesz szybko utworzyć, publikowanie i zarządzanie prosty, statyczny witrynami sieci Web pasujących marki firm i wymagają poprawki tylko tekstu i grafiki. Office Publisher 2007 nie jest odpowiednie narzędzie w następujących przypadkach:

  • Jeśli witryny sieci Web wymaga interakcji lub zawartości opartej na bazie danych, dzięki czemu odwiedzający mogą odpowiadać w sieci Web logowania (blog) lub zakup elementów w koszyku

  • Jeśli witryny sieci Web wymaga sprawdzania poprawności danych, takie jak sprawdzanie kredytowej karty liczb

  • Jeśli chcesz później zmienić nieprzetworzonych kod HTML w edytorze HTML po utworzeniu witryny sieci Web w Office Publisher 2007, która łączy kod HTML, XML i VML da witryn sieci Web

Tworzenie witryny sieci Web

Możesz utworzyć nowej publikacji w sieci Web w Office Publisher 2007. Jeśli chcesz pracować nad istniejącą witrynę sieci Web, do którego masz nie publikacji w sieci Web, możesz skopiować i wkleić zawartość z opublikowanych stron sieci Web do nowej publikacji w sieci Web, polegające na witrynę sieci Web jako publikacji w sieci Web, lub można użyć narzędzia do edycji HTML.

  1. W menu Plik kliknij polecenie Nowy.

  2. Na liście Typów publikacji kliknij witryn sieci Web.

  3. Wykonaj jedną z następujących czynności:

    • Aby utworzyć niestandardowe witryny sieci Web opartej na cele witryny, upewnij się, że Użyj Kreatora łatwe w sieci Web, w okienku zadań opcji jest zaznaczone, a następnie kliknij projekt, który ma być.

    • Aby utworzyć witrynę sieci Web od podstaw, w obszarze witryn sieci Web, kliknij pozycję Rozmiary pustych stron, a następnie kliknij odpowiedni rozmiar.

  4. Kliknij przycisk Utwórz.

  5. Jeśli zdecydujesz się za pomocą Kreatora łatwy w sieci Web, wybierz odpowiednie opcje w oknie dialogowym Konstruktor witryn sieci Web, a następnie kliknij przycisk OK.

  6. Dodawanie zawartości do publikacji i wprowadź odpowiednie zmiany.

    Porada : Unikaj umieszczania obiekty na stronach wzorcowych publikacji w sieci Web. Obiekty, które są umieszczane na stronach wzorcowych Office Publisher 2007 nie są wyświetlane poprawnie, gdy są one wyświetlane w niektórych przeglądarkach sieci Web.

Sprawdzanie publikacji w sieci Web

Upewnij się, że witryna działa zgodnie z oczekiwaniami, oraz usunąć wszystkich możliwych problemów, które mogą pojawić się przed opublikowaniem witryny sieci Web.

Możesz wyszukiwać problemy przy użyciu modułu sprawdzania projektu i wyświetlanie podglądu witryny.

Znajdowanie i usuwanie potencjalnych problemów za pomoca modulu sprawdzania projektu

Modul sprawdzania projektu jest zaawansowanym narzedziem do znajdowania potencjalnych problemów. Wiele przeprowadzanych przez niego testów dotyczy podstawowych problemów zwiazanych z formatowaniem. Zawiera on tez jednak testy przygotowane specjalnie na potrzeby publikacji w sieci Web. Aby uruchomic modul sprawdzania projektu, wykonaj nastepujace czynnosci:

  1. W menu Narzedzia kliknij polecenie Sprawdzanie projektu.

  2. W okienku zadań Sprawdzanie projektu zaznacz pole wyboru Uruchom ogólne testy projektu i Uruchom testy witryny sieci web.

    Uwaga : Upewnij się, że nie jest zaznaczone pole wyboru Uruchom testy drukowania komercyjnego.

  3. W okienku zadań Sprawdzanie projektu w obszarze Wybierz element do naprawienia kliknij strzałkę obok elementu, który chcesz naprawić, a następnie wykonaj jedną z następujących czynności:

    • Kliknij przycisk Poprawka automatyczna, aby automatycznie rozwiązać ten problem z elementem.

      Poprawka automatyczna różnią się w zależności od tego problemu. W większości przypadków taka możliwość nie jest dostępna.

    • Kliknij przycisk Przejdź do tego elementu, aby przejść do strony, w której znajduje się element wybranego problemu.

      Następnie można rozwiązać problem, wprowadzając niezbędne zmiany.

    • Kliknij pozycję Wyjaśnij, aby otworzyć temat Pomocy z szerszym objaśnieniem problemu i sugestiami dotyczącymi jego usunięcia.

    • Kliknij pozycję nigdy nie to sprawdzić ponownie uruchom, aby wyłączyć sprawdzanie.

      Kliknięcie tej opcji ma wpływ na wszystkie wystąpienia problemu.

Wyświetlanie podglądu witryny sieci Web

  • W menu Plik kliknij polecenie Podglad strony sieci Web.

Witryny sieci Web zostanie wyświetlona w domyślnej przeglądarce. Sprawdź następujące rzeczy:

  • Otwieranie witryny i wszystkie strony są dostępne.

  • Poprawne dzialanie wszystkich hiperlaczy

  • Poprawne dzialanie formantów nawigacyjnych

  • Obecnosc wszystkich wymaganych elementów

  • Odtwarzanie dzwieków w tle

Znajdowanie hosta usługi sieci Web

Aby można było opublikować witryny sieci Web w sieci web, musisz subskrybować usługę, że pochodzi od usługodawcy internetowego (ISP) hostingu. Ta usługa umożliwi dostęp do Internetu, ilości miejsca do magazynowania na serwerze sieci web i Uniform Resource Locator (URL), osoby można uzyskać dostęp do swojej witryny sieci Web. Przed opublikowaniem witryny sieci Web, skontaktuj się z usługodawcą Internetowym lub administratorem systemu, aby uzyskać informacje potrzebne i adres URL witryny sieci Web lub adres witryny FTP miejsce, w którym można zapisywać pliki.

W obszarze są prawdopodobnie dostępne kilku usługodawców internetowych. Upewnij się, że usługodawca Internetowy zasubskrybowanego oferuje rodzaju pomocy technicznej, który ma. Jeśli masz małym doświadczeniu w publikowania w sieci web może być usługodawcy internetowego, które mogą ułatwić za pośrednictwem potencjalne problemy.

Początek strony

Publikowanie witryny sieci Web

Sprawdzanie i Wyświetl podgląd publikacji w sieci Web, a zasubskrybuj usługę hostingu, możesz przystąpić do opublikowania witryny sieci Web.

Witryny sieci Web można publikować w serwer sieci Web, serwerze sieciowym, serwerze File Transfer Protocol (FTP) lub folderu na komputerze.

Publikowanie witryny w lokalizacji na komputerze może służyć kilku celów:

  • Korzystanie z opublikowanych plików, aby przetestować witryny sieci Web przed udostępnieniem pliku w sieci web.

  • Narzędzia FTP umożliwia publikowanie plików w sieci web, przekazując je z lokalizacji pliku na komputerze.

  • Zachowaj kopię lokalną plików HTML, a także publikacji w sieci Web.

Usługodawcy internetowego zapewnia, że informacje, które mogą pomóc zdecydujesz publikowania metodę, która jest zalecane dla Ciebie.

Czy można opublikować w sieci Web lub do komputera, Office Publisher 2007 zbierane wszystkich powiązanych plików, które tworzy się w jednym folderze. Tworzy tego Office Publisher 2007 pliki mogą być innych stron HTML, które składają się witryny, GIF i JPEG grafiki, która jest używana na stronach oraz pliki dźwiękowe.

Można ustawić Office Publisher 2007 organizowanie tych plików w folderze, gdzie można opublikować witryny sieci Web w jeden z dwóch sposobów. Domyślnie Office Publisher 2007 tworzy pojedynczą stronę główną i podfolder zawierający wszystkie pliki pomocnicze, potrzebne do witryny sieci Web. Lub z wszystkie pliki pomocnicze można uporządkować strony głównej witryny sieci Web w jednym folderze.

Jak kontrolować, gdzie Office Publisher 2007 są rozmieszczone witryny sieci Web publikowania plików?

W menu Narzędzia kliknij polecenie Opcje, kliknij kartę sieci Web, a następnie wykonaj jedną z następujących czynności:

  • Aby rozdzielić strona główna z pliki pomocnicze, zaznacz pole wyboru Organizuj pliki obsługi w folderze.

  • Aby pogrupować stronę główną i wszystkie pliki pomocnicze w tym samym folderze, wyczyść pole wyboru Organizuj pliki obsługi w folderze.

Po opublikowaniu publikacji w sieci web, Office Publisher 2007 tworzy filtrowane pliki HTML, które propagowanie szybciej niż niefiltrowanym pliki HTML w sieci Web. Ponieważ tej Office Publisher 2007 pliki filtrowanego HTML tworzy zawierają znaczniki nie specyficzne dla programu Microsoft Office, nie można otworzyć plików HTML w Office Publisher 2007 i ich edytować. Należy wprowadzić zmiany do witryny sieci Web w publikacji w sieci Web, a następnie ponowne publikowanie witryny sieci web.

Publikowanie witryny sieci Web do lokalizacji w Internecie lub w sieci

Przed rozpoczęciem tej procedury, skontaktuj się z usługodawcą Internetowym lub administratorem systemu, aby uzyskać informacje potrzebne do publikowania i adres URL witryny sieci Web, w którym można zapisywać pliki.

  1. W menu Plik kliknij polecenie Opublikuj w sieci Web.

  2. W oknie dialogowym Publikowanie w sieci Web, w polu Nazwa pliku wpisz adres URL witryny sieci web lub serwera, na którym chcesz zapisać witryny sieci Web. Na przykład wpisz http://www.northwindtraders.com.

  3. Kliknij przycisk Zapisz.

  4. Jesli zostanie wyswietlony monit, wpisz nazwe uzytkownika i haslo, a nastepnie kliknij przycisk OK.

    Katalog, który jest skojarzony z adresu URL pojawi się w oknie dialogowym Publikowanie w sieci Web.

  5. Kliknij dwukrotnie folder, w którym chcesz zapisać witryny sieci Web.

  6. W polu Nazwa pliku wybierz pozycję index jako domyślną nazwę strony głównej, a następnie kliknij przycisk Zapisz.

    Index.htm to ustawienie domyślne. Wybranie indeksu jako nazwę strony głównej ułatwia dostępu i uniemożliwia użytkownikom przeglądanie listy plików, które składają się na swojej witryny sieci Web.

  7. Po wyswietleniu monitu kliknij przycisk OK.

Publikowanie witryny sieci Web przy użyciu protokołu FTP

Przed rozpoczęciem tej procedury, skontaktuj się z administratorem usługodawcę internetowego lub, aby uzyskać informacje potrzebne do publikowania w witrynie FTP. Masz również utworzyć witrynę FTP w Lokalizacji FTP.

Przed dodaniem witryny FTP do listy lokalizacji FTP, musisz mieć dostęp w Internecie lub intranecie.

  1. W menu Plik kliknij polecenie Opublikuj w sieci Web.

  2. W oknie dialogowym Publikowanie w sieci Web kliknij pozycję Narzędzia, a następnie kliknij przycisk Mapuj dysk sieciowy.

  3. W oknie dialogowym Mapuj dysk sieciowy wykonaj następujące czynności:

    • Na liście dysk kliknij literę. Możesz wybrać dowolną dostępną literę.

    • Aby łączył logowania się do komputera, zaznacz pole wyboru Połącz ponownie przy logowania.

    • Kliknij pozycję Połącz z witryną sieci Web, który służy do przechowywania dokumentów i obrazów.

  4. W Kreatorze dodawania lokalizacji sieci kliknij przycisk Dalej, kliknij Wybierz niestandardową lokalizację sieciową, a następnie kliknij przycisk Dalej.

  5. W polu adres internetowy lub sieciowy wpisz adres witryny FTP (na przykład typ ftp://ftp.microsoft.com), a następnie kliknij przycisk Dalej.

    Uwaga : Jeśli nie możesz połączyć się dysku sieciowym lub folder, komputer może zostać wyłączony lub nie masz odpowiednich uprawnień. Jeśli nie możesz połączyć, skontaktuj się z administratorem sieci lub usługodawcą Internetowym.

  6. Jeśli nie chcesz Zaloguj anonimowo, wyczyść pole wyboru Zaloguj anonimowo, w polu Nazwa użytkownika wpisz nazwę użytkownika, a następnie kliknij przycisk Dalej.

  7. Wpisz nazwę dla tej lokalizacji sieciowej, a następnie kliknij przycisk Dalej.

  8. Kliknij przycisk Zakończ.

  9. W menu Plik kliknij polecenie Opublikuj w sieci Web.

  10. Na liście Zapisz w kliknij Lokalizacje FTP.

  11. Na liście witryn FTP kliknij dwukrotnie witryny, która ma, a następnie kliknij dwukrotnie folder, w którym chcesz opublikować witryny sieci Web.

    Uwaga : Jeśli Usługodawca wymaga korzystania z określonego programu do przekazania witryny sieci Web lub witryny sieci Web jest publikowana w firmowej sieci intranet, może być konieczne zapisywanie wersji witryny sieci Web w formacie pliku określonym HTML i wykonaj inną procedurę do opublikowania witryny sieci Web. Aby uzyskać informacje o zapisywanie i publikowanie witryny sieci Web, poproś usługodawcy internetowego lub administratora systemu.

Publikowanie witryny sieci Web w folderze na komputerze

  1. W menu Plik kliknij polecenie Opublikuj w sieci Web.

  2. Na pasku adresu kliknij dysk lub folder, w którym chcesz opublikować witryny sieci Web, na przykład w folderze dokumenty.

    Jeśli chcesz dodać witryny sieci Web do nowego folderu, kliknij przycisk Nowy Folder na pasku narzędzi, aby utworzyć nowy folder, wpisz nazwę nowego folderu i naciśnij klawisz ENTER.

  3. W polu Nazwa pliku wybierz pozycję index jako domyślną nazwę strony głównej, a następnie kliknij przycisk Zapisz.

    Index.htm to ustawienie domyślne. Wybranie indeksu jako nazwę strony głównej ułatwia dostępu i uniemożliwia użytkownikom przeglądanie listy plików, które składają się na swojej witryny sieci Web.

Zachowywanie witryny sieci Web

Po opublikowaniu witryny sieci Web, można zaktualizować w razie potrzeby w celu uwzględnienia nowych informacji. Jednak nie można otworzyć filtrowane pliki HTML w programie Publisher. Należy otworzyć oryginalny publikacji w sieci Web, wprowadź odpowiednie zmiany, które mają i ponowne publikowanie witryny sieci web.

Uwaga : Nie należy próbować aktualizować filtrowanych plików HTML przy użyciu edytora tekstów, takich jak Notepad lub programu Microsoft WordPad. Mimo że jest możliwe w tym celu, HTML wygenerowany przez program Publisher jest bardzo skomplikowane, a prawdopodobnie ułatwi Edycja ręcznie. Aby uzyskać najlepsze wyniki zawsze aktualizowanie witryny sieci Web programu Publisher przy użyciu publikacji w sieci Web, a następnie ponownie opublikować w sieci Web.

Publikowanie tylko co się zmieniło

W Office Publisher 2007, można publikować aktualizacje do witryny sieci Web opublikowanej szybko przy użyciu przyrostowe publikowania w sieci web, który publikuje tylko te strony, które zostały zaktualizowane. Jeśli zamierzasz często aktualizowanie witryny sieci Web lub jeśli witryny sieci Web jest duży i złożone, przyrostowe publikowania w sieci web może przyspieszyć zadania aktualizacji witryny sieci Web.

Jeśli wprowadzisz zmiany do witryny sieci Web bezpośrednio na serwer sieci Web poza Office Publisher 2007, jednak włączenie przyrostowe publikowania w sieci web mogą uniemożliwić publikowanie dalszych aktualizacji do witryny sieci Web przy użyciu polecenia Publikuj w sieci Web. Jeśli planujesz zarządzanie plikami witryny sieci Web bezpośrednio na serwerze sieci web (takie jak za pomocą programu oddzielnych FTP ), należy wyłączyć przyrostowe publikowania w sieci web.

Uwaga : Publikowanie przyrostowe sieci web jest włączona domyślnie w programie Publisher.

Włącz przyrostowe publikowania w sieci web lub wyłączanie

  1. W menu Narzędzia kliknij polecenie Opcje, a następnie kliknij kartę sieci Web.

  2. W obszarze Zapisywanie wykonaj jedną z następujących czynności:

    • Aby wyłączyć przyrostowe publikowania w sieci web, wyczyść pole wyboru Włącz publikowanie przyrostowe w sieci Web.

    • Aby włączyć przyrostowe publikowania w sieci web, a następnie zaznacz pole wyboru Włącz publikowanie przyrostowe w sieci Web.

Publikowanie zmian do witryny sieci Web

Publikowanie aktualizacji witryny sieci Web jest nieco inaczej niż publikowanie witryny sieci Web po raz pierwszy. Po opublikowaniu witryny sieci Web do lokalizacji w sieci web lub w sieci skrót do serwera sieci web lub serwera sieci pojawia się w folderze Moje miejsca sieciowe.

  1. W menu Plik kliknij polecenie Opublikuj w sieci Web.

  2. W oknie dialogowym Publikowanie w sieci Web, w okienku nawigacji kliknij Ten komputer.

  3. Na liście plików kliknij dwukrotnie skrót do folderu na serwerze sieci web lub serwer sieci, w którym opublikowano witryny sieci Web.

  4. Kliknij dwukrotnie folder, w którym chcesz zapisać plik.

  5. W polu Nazwa pliku wpisz nazwę pliku zaktualizować, a następnie kliknij przycisk Zapisz.

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×