Przesyłanie danych formularza w wiadomości e-mail

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Do szablonu formularza można dodawać pomocnicze połączenia danych do przesyłania, aby umożliwić użytkownikom wysyłanie danych formularza w wiadomości e-mail. Do określania adresów e-mail, do których zostanie wysłany formularz, wiersza tematu wiadomości e-mail i nazwy formularza można używać wartości statystycznych, wartości zależnych od danych w formularzu lub formuły. Można też określać, czy formularz ma być wyświetlany w treści wiadomości czy jako załącznik do wiadomości.

Jeśli szablon formularza zostanie skonfigurowany tak, aby dołączał formularz jako załącznik wiadomości e-mail, do wiadomości będzie można również dołączyć szablon formularza. Dołączając formularz i szablon formularza jako załączniki do wiadomości e-mail, można zagwarantować, że adresaci wiadomości e-mail będą mogli otworzyć formularz w programie Microsoft Office InfoPath, nawet jeśli nie będą mieć szablonu formularza zbuforowanego na swoim komputerze. Aby adresaci mogli otwierać załączniki, muszą mieć zainstalowany program InfoPath.

Kiedy użytkownicy przesyłają dane formularza w wiadomości e-mail, program InfoPath tworzy wiadomość e-mail zawierającą dane formularza i wysyła ją do adresatów poczty e-mail określonych podczas tworzenia połączenia danych. Jeśli osoby odbierające wypełnione formularze używają programu Microsoft Office Outlook 2007, mogą dodać do swojej Skrzynki odbiorczej folder, który będzie zawierał wszystkie odebrane formularze, i skonfigurować ten folder tak, aby wyświetlał dane z formularzy w kolumnach programu Outlook.

Po dodaniu połączenia danych do przesyłania można skonfigurować szablon formularza tak, aby umożliwić użytkownikom przesyłanie danych formularza. Dzięki temu w momencie otwarcia formularza przez użytkowników program InfoPath automatycznie doda przycisk Prześlij do paska narzędzi Standardowy i polecenie Prześlij do menu Plik. Można też dostosować opcje przesyłania szablonu formularza:

  • zmieniając tekst pojawiający się na przycisku Prześlij na pasku narzędzi Standardowy i na poleceniu Prześlij w menu Plik;

  • zmieniając skrót klawiaturowy dotyczący przycisku Prześlij na pasku narzędzi Standardowy i polecenia Prześlij w menu Plik;

  • tworząc niestandardowe komunikaty wyświetlane, gdy użytkownicy przesyłają formularze;

  • określając, czy po przesłaniu formularza ma on pozostać otwarty, zostać zamknięty czy ma zostać otwarty kolejny pusty formularz.

Początek strony

Dodawanie połączenia danych do przesyłania

  1. W menu Narzędzia kliknij polecenie Opcje przesyłania.

  2. W oknie dialogowym Opcje przesyłania zaznacz pole wyboru Zezwalaj użytkownikom na przesyłanie tego formularza.

  3. Kliknij opcję Wysyłaj dane formularza do pojedynczego miejsca docelowego, a następnie kliknij na liście pozycję E-mail.

  4. Kliknij przycisk Dodaj.

  5. W Kreatorze połączenia danych wpisz w odpowiednich polach adresy e-mail adresatów, temat, który ma być wyświetlany w wiadomości e-mail, oraz tekst wprowadzający, a następnie kliknij przycisk Dalej.

    Porada : Można też określić pole lub użyć formuły w celu utworzenia wartości każdego pola oprócz pola Wprowadzenie.

    Jak?

    1. Kliknij przycisk Wstaw formułę Obraz przycisku .

    2. W oknie dialogowym Wstawianie formuły wykonaj jedną z następujących czynności:

      • Aby użyć pola w formule, kliknij przycisk Wstaw pole lub grupę, w oknie dialogowym Wybieranie pola lub grupy kliknij pole, którego chcesz użyć, a następnie kliknij przycisk OK.

      • Aby użyć funkcji w formule, kliknij przycisk Wstaw funkcję, w oknie dialogowym Wstawianie funkcji wybierz funkcję, której chcesz użyć, a następnie kliknij przycisk OK.

        Porada : Jeśli funkcja wymaga parametrów, należy zaznaczyć funkcję w oknie dialogowym Wstawianie funkcji, kliknąć przycisk OK, a następnie w polu Formuła w oknie dialogowym Wstawianie formuły kliknąć dwukrotnie dodaną funkcję i kliknąć pole lub grupę. W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o funkcjach.

      • Aby wstawić wartość lub operator matematyczny w formule, w polu Formuła wpisz wartość lub symbol operacji matematycznej.

    Operacja

    Symbol

    Dodawanie

    +

    Odejmowanie

    -

    Mnożenie

    *

    Dzielenie

    /

    • Uwaga : Jeśli w formule występuje operator dzielenia (/), przed nim i po nim musi wystąpić spacja. W przeciwnym przypadku program InfoPath może zinterpretować symbol „/” jako separator kroków położenia XPath, a nie jako operator dzielenia.

    • Aby sprawdzić, czy formuła ma poprawną składnię, kliknij przycisk Weryfikuj formułę w oknie dialogowym Wstawianie formuły.

      W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o formułach.

  6. Na następnej stronie kreatora wykonaj jedną z następujących czynności:

    1. Aby wyświetlić formularz w treści wiadomości e-mail, kliknij opcję Wyślij tylko aktywny widok formularza bez załącznika.

    2. Aby wysyłać dane formularza jako załącznik do wiadomości e-mail, kliknij opcję Wyślij dane formularza w postaci załącznika, zaznacz pole wyboru Dołącz szablon formularza, aby umożliwić użytkownikom otwieranie formularza, a następnie wpisz nazwę formularza w polu Nazwa załącznika. Aby zagwarantować, że każda nazwa formularza będzie unikatowa, można też określić pole lub użyć formuły.

      Jak?

      1. Kliknij przycisk Wstaw formułę Obraz przycisku .

      2. W oknie dialogowym Wstawianie formuły wykonaj jedną z następujących czynności:

        • Aby użyć pola w formule, kliknij przycisk Wstaw pole lub grupę, w oknie dialogowym Wybieranie pola lub grupy kliknij pole, którego chcesz użyć, a następnie kliknij przycisk OK.

        • Aby użyć funkcji w formule, kliknij przycisk Wstaw funkcję, w oknie dialogowym Wstawianie funkcji wybierz funkcję, której chcesz użyć, a następnie kliknij przycisk OK.

          Porada : Jeśli funkcja wymaga parametrów, należy zaznaczyć funkcję w oknie dialogowym Wstawianie funkcji, kliknąć przycisk OK, a następnie w polu Formuła w oknie dialogowym Wstawianie formuły kliknąć dwukrotnie dodaną funkcję i kliknąć pole lub grupę. W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o funkcjach.

        • Aby wstawić wartość lub operator matematyczny w formule, w polu Formuła wpisz wartość lub symbol operacji matematycznej.

      Operacja

      Symbol

      Dodawanie

      +

      Odejmowanie

      -

      Mnożenie

      *

      Dzielenie

      /

      • Uwaga : Jeśli w formule występuje operator dzielenia (/), przed nim i po nim musi wystąpić spacja. W przeciwnym przypadku program InfoPath może zinterpretować symbol „/” jako separator kroków położenia XPath, a nie jako operator dzielenia.

      • Aby sprawdzić, czy formuła ma poprawną składnię, kliknij przycisk Weryfikuj formułę w oknie dialogowym Wstawianie formuły.

        W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o formułach.

      Uwaga : Osoby, które odbiorą dane formularza w formie załącznika w wiadomości e-mail, muszą mieć zainstalowany program InfoPath, aby móc otworzyć załącznik.

  7. Kliknij przycisk Dalej.

  8. Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz opisową nazwę dla tego przedstawia połączenia danych.

  9. Sprawdź, czy informacje w sekcji Podsumowanie są poprawne, a następnie kliknij przycisk Zakończ.

    1. Aby zmienić nazwę przycisk Prześlij, który pojawia się na pasku narzędzi Standardowy, a polecenie Prześlij, który pojawia się w menu plik, podczas wypełniania formularza, wpisz nową nazwę w polu Podpis w oknie dialogowym Opcje przesyłania.

      Porada : Jeśli chcesz przypisać skrót klawiaturowy do tego przycisku i polecenia, wpisz handlowe "i" (&) przed znakiem, który ma być używany jako skrót klawiaturowy. Na przykład aby przypisać klawisze ALT + B, jako skrót klawiaturowy dla przycisku Prześlij i polecenia, wpisz & przycisk Prześlij.

  10. Jeśli nie chcesz używać polecenia Prześlij lub przycisk Zatwierdź na pasku narzędzi Standardowy, podczas wypełniania formularza użytkownicy, wyczyść pole wyboru Pokaż polecenie Prześlij i przycisk Prześlij.

    1. Domyślnie po użytkownikom przesyłanie formularzy programu InfoPath zachowuje formularz otwarty i zostanie wyświetlony komunikat, aby wskazać, jeśli formularz został pomyślnie przesłany. Aby zmienić to zachowanie domyślne, kliknij przycisk Zaawansowane, a następnie wykonaj jedną z następujących czynności:

      • Aby zamknąć formularz lub Utwórz nowy pusty formularz po przesłaniu wypełniony formularz, kliknij opcję, która ma na liście po przesyłanie.

      • Aby utworzyć niestandardowe wiadomości, który wskazuje, jeśli formularz został pomyślnie przesłany, zaznacz pole wyboru Użyj niestandardowych wiadomości, a następnie wpisz wiadomości w polach w przypadku powodzenia i niepowodzenia.

        Porada : Poinstruuj użytkowników za pomocą wiadomości w polu w przypadku awarii co należy zrobić, jeśli nie można ich przesłać formularz. Na przykład można sugerują, że użytkownicy zapisywać formularze i skontaktować się z osobą Aby uzyskać dodatkowe instrukcje.

      • Jeśli nie chcesz wyświetlać wiadomości, gdy użytkownik przesyła formularz, wyczyść pole wyboru Pokaż sukcesów i porażek wiadomości.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×