Przesyłanie danych formularza do kilku lokalizacji

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Szablon formularza można zaprojektować tak, aby użytkownicy mogli przesyłać dane formularza do kilku lokalizacji, klikając przycisk Prześlij.

W tym artykule

Omówienie

Krok 1: Dodawanie przesyłania połączenia danych

Krok 2: Konfigurowanie szablonu formularza, aby umożliwić przesyłania

Przegląd

Aby zezwolić użytkownikom na przesyłanie danych formularza do kilku lokalizacji, należy dodać do szablonu formularza pomocnicze połączenie danych przesyłające dane do każdej z lokalizacji, do których użytkownicy mają przesyłać formularz. Po dodaniu wszystkich połączeń danych do przesyłania należy przy użyciu reguła skonfigurować szablon formularza tak, aby zezwolić użytkownikom na przesyłanie danych formularza do wielu lokalizacji. Dzięki temu podczas wypełniania formularza przez użytkowników program Microsoft Office InfoPath doda przycisk Prześlij do paska narzędzi Standardowy oraz polecenie Prześlij do menu Plik. Program InfoPath przesyła dane formularza do pomocniczych połączeń danych w kolejności, w jakiej są one wymienione w regule. Nie można skonfigurować reguły w celu używania wszystkich połączeń danych do przesyłania w tym samym czasie.

Po skonfigurowaniu szablonu formularza w sposób umożliwiający użytkownikom przesyłanie danych formularza można też dostosować opcje przesyłania:

  • zmieniając tekst pojawiający się na przycisku Prześlij na pasku narzędzi Standardowy i na poleceniu Prześlij w menu Plik;

  • zmieniając skrót klawiaturowy dotyczący przycisku Prześlij na pasku narzędzi Standardowy i polecenia Prześlij w menu Plik;

  • tworząc niestandardowe komunikaty wyświetlane, gdy użytkownicy przesyłają formularze;

  • określając, czy po przesłaniu formularza ma on pozostać otwarty, zostać zamknięty czy ma zostać otwarty kolejny pusty formularz.

Początek strony

Krok 1: Dodawanie połączeń danych do przesyłania

Aby skonfigurować szablon formularza w sposób umożliwiający użytkownikom przesyłanie wypełnionych formularzy do wielu lokalizacji, należy dodać do szablonu formularza niezbędne połączenia danych do przesyłania. Można dodawać połączenia danych do następujących lokalizacji:

  • usługa sieci Web,

  • biblioteka dokumentów na serwerze z uruchomionym programem Microsoft Windows SharePoint Services,

  • wiadomość e-mail.

    Uwaga : Przesyłanie danych formularza w wiadomości e-mail jest możliwe tylko pod warunkiem, że na komputerze użytkownika zainstalowano program Microsoft Office Outlook.

W poniższej procedurze wyjaśniono sposób dodawania do tych lokalizacji połączeń danych do przesyłania.

Dodawanie połączenia danych przesyłającego dane do usługi sieci Web

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Utwórz nowe połączenie z, kliknij opcję Prześlij dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij opcję Do usługi sieci Web, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora wpisz lokalizację usługi sieci Web, do której użytkownicy będą przesyłać formularze, a następnie kliknij przycisk Dalej.

    Aby przeszukać serwer UDDI (Universal Description, Discovery, and Integration) w poszukiwaniu usługi sieci Web, należy kliknąć opcję Przeszukaj zasoby UDDI, wprowadzić adres serwera UDDI do przeszukania, określić, czy należy wyszukiwać według dostawcy czy według dostępnych usług, wprowadzić słowo kluczowe wyszukiwania, a następnie kliknąć przycisk Szukaj. Usługi sieci Web pasujące do słowa kluczowego wyszukiwania zostaną wyświetlone na liście Wynik wyszukiwania.

  6. Na liście Wybierz operację na następnej stronie kreatora kliknij operację usługi sieci Web, która będzie odbierać dane formularza, a następnie kliknij przycisk Dalej.

  7. Na następnej stronie kreatora wykonaj jedną z następujących czynności:

    Przesyłanie danych do pola lub grupy

    1. Na liście Parametry kliknij parametr usługi sieci Web, która będzie odbierać dane z formularza.

    2. W oknie Opcje parametru kliknij opcję Pole lub grupa.

    3. Kliknij przycisk Modyfikuj Obraz przycisku .

    4. W oknie dialogowym Wybieranie pola lub grupy kliknij pole lub grupę, których dane chcesz przesyłać, a następnie kliknij przycisk OK.

    5. W polu Dołącz kliknij pozycję Tylko tekst i elementy podrzędne, aby przesyłać tylko zawartość i wszystkie elementy podrzędne pola lub grupy, albo kliknij pozycję Poddrzewo XML, włącznie z zaznaczonym elementem, aby przesyłać zarówno zawartość, jak i wybraną grupę lub pole.

    Przesyłanie wszystkich danych w formularzu

    1. Kliknij opcję Cały formularz (dokument XML włącznie z instrukcjami przetwarzania).

    Przesyłanie danych w postaci ciągu

    1. Zaznacz pole wyboru Prześlij dane jako ciąg.

      Najczęściej to pole wyboru jest zaznaczane w celu przesłania danych podpisanych cyfrowo. W większości przypadków należy wyczyścić to pole wyboru.

  8. Kliknij przycisk Dalej.

  9. Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz opisową nazwę dla tego przedstawia połączenia danych.

  10. Sprawdź, czy informacje w sekcji Podsumowanie są poprawne, a następnie kliknij przycisk Zakończ.

Dodawanie połączenia danych przesyłającego dane do biblioteki dokumentów

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Utwórz nowe połączenie z, kliknij opcję Prześlij dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij opcję Do biblioteki dokumentów w witrynie programu SharePoint, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora w polu Biblioteka dokumentów wpisz lokalizację biblioteki dokumentów programu SharePoint.

  6. W polu Nazwa pliku wpisz nazwę, która będzie służyć do identyfikowania formularza w bibliotece dokumentów. Aby zagwarantować, że każda nazwa formularza jest unikatowa, można użyć formuły.

    Jak to zrobić?

    1. Kliknij przycisk Wstaw formułę Obraz przycisku .

    2. W oknie dialogowym Wstawianie formuły wykonaj jedną z następujących czynności:

      • Aby użyć pola w formule, kliknij przycisk Wstaw pole lub grupę, w oknie dialogowym Wybieranie pola lub grupy kliknij pole, którego chcesz użyć, a następnie kliknij przycisk OK.

      • Aby użyć funkcji w formule, kliknij przycisk Wstaw funkcję, w oknie dialogowym Wstawianie funkcji wybierz funkcję, której chcesz użyć, a następnie kliknij przycisk OK.

        Jeśli funkcja wymaga parametrów, należy zaznaczyć funkcję w oknie dialogowym Wstawianie funkcji, kliknąć przycisk OK, a następnie w polu Formuła w oknie dialogowym Wstawianie formuły kliknąć dwukrotnie dodaną funkcję i kliknąć pole lub grupę. W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o funkcjach.

      • Aby wstawić wartość lub operator matematyczny w formule, w polu Formuła wpisz wartość lub symbol operacji matematycznej.

    Operacja

    Symbol

    Dodawanie

    +

    Odejmowanie

    -

    Mnożenie

    *

    Dzielenie

    /

    • Uwaga : Jeśli w formule występuje operator dzielenia (/), przed nim i po nim musi wystąpić spacja. W przeciwnym przypadku program InfoPath może zinterpretować symbol „/” jako separator kroków położenia XPath, a nie jako operator dzielenia.

    • Aby sprawdzić, czy formuła ma poprawną składnię, kliknij przycisk Weryfikuj formułę w oknie dialogowym Wstawianie formuły.

      W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o formułach.

  7. Aby zastępować w bibliotece dokumentów istniejące formularze o tej samej nazwie, zaznacz pole wyboru Zezwalaj na zastąpienie, jeżeli plik istnieje.

  8. Kliknij przycisk Dalej.

  9. Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz opisową nazwę dla tego przedstawia połączenia danych.

  10. Sprawdź, czy informacje w sekcji Podsumowanie są poprawne, a następnie kliknij przycisk Zakończ.

Dodawanie połączenia danych przesyłającego dane w wiadomości e-mail

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Utwórz nowe połączenie z, kliknij opcję Prześlij dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij opcję Jako wiadomość e-mail, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora wpisz w odpowiednich polach adresy e-mail adresatów wiadomości, temat, który ma być wyświetlany w wiadomości, oraz odpowiedni tekst wprowadzający, a następnie kliknij przycisk Dalej. W każdym polu oprócz pola Wprowadzenie można zastosować formułę.

    Jak to zrobić?

    1. Kliknij przycisk Wstaw formułę Obraz przycisku .

    2. W oknie dialogowym Wstawianie formuły wykonaj jedną z następujących czynności:

      • Aby użyć pola w formule, kliknij przycisk Wstaw pole lub grupę, w oknie dialogowym Wybieranie pola lub grupy kliknij pole, którego chcesz użyć, a następnie kliknij przycisk OK.

      • Aby użyć funkcji w formule, kliknij przycisk Wstaw funkcję, w oknie dialogowym Wstawianie funkcji wybierz funkcję, której chcesz użyć, a następnie kliknij przycisk OK.

        Jeśli funkcja wymaga parametrów, należy zaznaczyć funkcję w oknie dialogowym Wstawianie funkcji, kliknąć przycisk OK, a następnie w polu Formuła w oknie dialogowym Wstawianie formuły kliknąć dwukrotnie dodaną funkcję i kliknąć pole lub grupę. W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o funkcjach.

      • Aby wstawić wartość lub operator matematyczny w formule, w polu Formuła wpisz wartość lub symbol operacji matematycznej.

    Operacja

    Symbol

    Dodawanie

    +

    Odejmowanie

    -

    Mnożenie

    *

    Dzielenie

    /

    • Uwaga : Jeśli w formule występuje operator dzielenia (/), przed nim i po nim musi wystąpić spacja. W przeciwnym przypadku program InfoPath może zinterpretować symbol „/” jako separator kroków położenia XPath, a nie jako operator dzielenia.

    • Aby sprawdzić, czy formuła ma poprawną składnię, kliknij przycisk Weryfikuj formułę w oknie dialogowym Wstawianie formuły.

      W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o formułach.

  6. Na następnej stronie kreatora wykonaj jedną z następujących czynności:

    1. Aby wyświetlić formularz w treści wiadomości e-mail, kliknij opcję Wyślij tylko aktywny widok formularza bez załącznika.

    2. Aby wysłać danych formularza jako załącznika do wiadomości e-mail, kliknij przycisk Wyślij danych formularza jako załącznik, zaznacz pole wyboru Dołącz szablon formularza, aby upewnić się, że użytkownicy mogą otwierać formularz, a następnie wpisz nazwę formularza w polu Nazwa załącznika. Można również określić pole lub upewnij się, że każda nazwa formularza jest unikatowy za pomocą formuły. Ta opcja jest dostępne tylko, jeśli szablon formularza jest skonfigurowany do automatycznie określić poziom zabezpieczeń lub jest skonfigurowany do poziom zabezpieczeń ograniczone lub pełnego zaufania.

      Jak to zrobić?

      1. Kliknij przycisk Wstaw formułę Obraz przycisku .

      2. W oknie dialogowym Wstawianie formuły wykonaj jedną z następujących czynności:

        • Aby użyć pola w formule, kliknij przycisk Wstaw pole lub grupę, w oknie dialogowym Wybieranie pola lub grupy kliknij pole, którego chcesz użyć, a następnie kliknij przycisk OK.

        • Aby użyć funkcji w formule, kliknij przycisk Wstaw funkcję, w oknie dialogowym Wstawianie funkcji wybierz funkcję, której chcesz użyć, a następnie kliknij przycisk OK.

          Jeśli funkcja wymaga parametrów, należy zaznaczyć funkcję w oknie dialogowym Wstawianie funkcji, kliknąć przycisk OK, a następnie w polu Formuła w oknie dialogowym Wstawianie formuły kliknąć dwukrotnie dodaną funkcję i kliknąć pole lub grupę. W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o funkcjach.

        • Aby wstawić wartość lub operator matematyczny w formule, w polu Formuła wpisz wartość lub symbol operacji matematycznej.

      Operacja

      Symbol

      Dodawanie

      +

      Odejmowanie

      -

      Mnożenie

      *

      Dzielenie

      /

      • Uwaga : Jeśli w formule występuje operator dzielenia (/), przed nim i po nim musi wystąpić spacja. W przeciwnym przypadku program InfoPath może zinterpretować symbol „/” jako separator kroków położenia XPath, a nie jako operator dzielenia.

      • Aby sprawdzić, czy formuła ma poprawną składnię, kliknij przycisk Weryfikuj formułę w oknie dialogowym Wstawianie formuły.

        W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o formułach.

      Adresaci wiadomości e-mail z danymi formularza wysłanymi w formie załącznika muszą mieć zainstalowany program InfoPath, aby móc otworzyć załącznik.

  7. Kliknij przycisk Dalej.

  8. Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz opisową nazwę dla tego przedstawia połączenia danych.

  9. Sprawdź, czy informacje w sekcji Podsumowanie są poprawne, a następnie kliknij przycisk Zakończ.

Początek strony

Krok 2: Konfigurowanie szablonu formularza w sposób umożliwiający przesyłanie

Po dodaniu do szablonu formularza niezbędnych pomocniczych połączeń danych należy skonfigurować szablon formularza tak, aby umożliwić użytkownikom przesyłanie danych formularza. Spowoduje to, że program InfoPath będzie dodawać polecenie Prześlij do menu Plik i przycisk Prześlij do paska narzędzi Standardowy, gdy użytkownicy będą wypełniać formularz. Następnie można skonfigurować akcję następującą po kliknięciu przycisku Prześlij. W tym przypadku należy dodać regułę powodującą przesłanie danych formularza do każdego połączenia danych do przesyłania, gdy użytkownik kliknie polecenie Prześlij w menu Plik lub przycisk Prześlij na pasku narzędzi Standardowy.

W tym samym oknie dialogowym można skonfigurować opcje przesyłania.

  1. W menu Narzędzia kliknij polecenie Opcje przesyłania.

  2. W oknie dialogowym Opcje przesyłania zaznacz pole wyboru Zezwalaj użytkownikom na przesyłanie tego formularza.

    Jeśli to pole wyboru zostanie zaznaczone, podczas wypełniania formularza przez użytkowników program InfoPath doda przycisk Prześlij do paska narzędzi Standardowy oraz polecenie Prześlij do menu Plik.

  3. Kliknij opcję Wykonaj akcję niestandardową przy użyciu reguł, a następnie kliknij przycisk Reguły.

  4. W oknie dialogowym Reguły przesyłania formularzy kliknij przycisk Dodaj.

  5. Kliknij przycisk Dodaj akcję.

  6. W polu Akcja kliknij pozycję Prześlij, używając połączenia danych, na liście Połączenie danych kliknij połączenie danych, którego chcesz użyć dla tej akcji przesyłania, a następnie kliknij przycisk OK.

  7. Powtórz kroki 5 i 6 dla każdego połączenia danych do przesyłania, które zostało dodane do szablonu formularza.

  8. Po dodaniu warunków dla wszystkich połączeń danych do przesyłania w szablonie formularza kliknij dwa razy przycisk OK.

    1. Aby zmienić nazwę przycisk Prześlij, który pojawia się na pasku narzędzi Standardowy, a polecenie Prześlij, który pojawia się w menu plik, podczas wypełniania formularza, wpisz nową nazwę w polu Podpis w oknie dialogowym Opcje przesyłania.

      Jeśli chcesz przypisać skrót klawiaturowy do tego przycisku i polecenia, wpisz handlowe "i" (&) przed znakiem, który ma być używany jako skrót klawiaturowy. Na przykład aby przypisać klawisze ALT + B, jako skrót klawiaturowy dla przycisku Prześlij i polecenia, wpisz & przycisk Prześlij.

  9. Aby uniemożliwić użytkownikom używanie polecenia Prześlij i przycisku Prześlij na pasku zadań Standardowy przy wypełnianiu formularza, wyczyść pole wyboru Pokaż element menu Prześlij i przycisk paska narzędzi Prześlij.

    1. Domyślnie po użytkownikom przesyłanie formularzy programu InfoPath zachowuje formularz otwarty i zostanie wyświetlony komunikat, aby wskazać, jeśli formularz został pomyślnie przesłany. Aby zmienić to zachowanie domyślne, kliknij przycisk Zaawansowane, a następnie wykonaj jedną z następujących czynności:

      • Aby zamknąć formularz lub Utwórz nowy pusty formularz po przesłaniu wypełniony formularz, kliknij opcję, która ma na liście po przesyłanie.

      • Aby utworzyć niestandardowe wiadomości, który wskazuje, jeśli formularz został pomyślnie przesłany, zaznacz pole wyboru Użyj niestandardowych wiadomości, a następnie wpisz wiadomości w polach w przypadku powodzenia i niepowodzenia.

        Poinstruuj użytkowników za pomocą wiadomości w polu w przypadku awarii co należy zrobić, jeśli nie można ich przesłać formularz. Na przykład można sugerują, że użytkownicy zapisywać formularze i skontaktować się z osobą Aby uzyskać dodatkowe instrukcje.

      • Jeśli nie chcesz wyświetlać wiadomości, gdy użytkownik przesyła formularz, wyczyść pole wyboru Pokaż sukcesów i porażek wiadomości.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×