Przesyłanie danych formularza do biblioteki dokumentów

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Wszystkie formularze użytkowników można przechowywać i organizować w bibliotece dokumentów na serwerze z uruchomionym programem Microsoft Windows SharePoint Services. W bibliotece dokumentów użytkownicy mogą wypełniać formularze oparte na szablonie formularza, eksportować dane z wypełnionych formularzy do programu Microsoft Office Excel 2003 lub Microsoft Office Excel 2007, a także scalać dane z kilku formularzy w jeden.

Aby umożliwić użytkownikom przesyłanie formularzy opartych na szablonie formularza do biblioteki dokumentów, można dodać do szablonu formularza pomocnicze połączenie danych służące do przesyłania danych. Po dodaniu połączenia danych do przesyłania można skonfigurować szablon formularza tak, aby umożliwić użytkownikom przesyłanie danych formularza do biblioteki dokumentów. Dzięki temu program Microsoft Office InfoPath będzie dodawać przycisk Prześlij do paska narzędzi Standardowy oraz polecenie Prześlij do menu Plik w formularzu. Można też dostosować opcje przysyłania szablonu formularza:

  • zmieniając tekst pojawiający się na przycisku Prześlij na pasku narzędzi Standardowy i na poleceniu Prześlij w menu Plik;

  • zmieniając skrót klawiaturowy dotyczący przycisku Prześlij na pasku narzędzi Standardowy i polecenia Prześlij w menu Plik;

  • tworząc niestandardowe komunikaty wyświetlane, gdy użytkownicy przesyłają formularze;

  • określając, czy po przesłaniu formularza ma on pozostać otwarty, zostać zamknięty czy ma zostać otwarty kolejny pusty formularz.

Dodawanie połączenia danych do przesyłania

  1. W menu Narzędzia kliknij polecenie Opcje przesyłania.

  2. W oknie dialogowym Opcje przesyłania zaznacz pole wyboru Zezwalaj użytkownikom na przesyłanie tego formularza.

  3. Kliknij opcję Wysyłaj dane formularza do pojedynczego miejsca docelowego, a następnie kliknij na liście pozycję Biblioteka dokumentów programu SharePoint.

  4. Kliknij przycisk Dodaj.

  5. W Kreatorze połączenia danych w polu Biblioteka dokumentów wpisz lokalizację biblioteki dokumentów programu SharePoint.

  6. W polu Nazwa pliku wpisz nazwę, która będzie służyć do identyfikowania formularza w bibliotece dokumentów.

    Porada : Aby zagwarantować, że każda nazwa formularza będzie unikatowa, można użyć formuły.

    Jak?

    1. Kliknij przycisk Wstaw formułę Obraz przycisku .

    2. W oknie dialogowym Wstawianie formuły wykonaj jedną z następujących czynności:

      • Aby użyć pola w formule, kliknij przycisk Wstaw pole lub grupę, w oknie dialogowym Wybieranie pola lub grupy kliknij pole, którego chcesz użyć, a następnie kliknij przycisk OK.

      • Aby użyć funkcji w formule, kliknij przycisk Wstaw funkcję, w oknie dialogowym Wstawianie funkcji wybierz funkcję, której chcesz użyć, a następnie kliknij przycisk OK.

        Porada : Jeśli funkcja wymaga parametrów, należy zaznaczyć funkcję w oknie dialogowym Wstawianie funkcji, kliknąć przycisk OK, a następnie w polu Formuła w oknie dialogowym Wstawianie formuły kliknąć dwukrotnie dodaną funkcję i kliknąć pole lub grupę. W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o funkcjach.

      • Aby wstawić wartość lub operator matematyczny w formule, w polu Formuła wpisz wartość lub symbol operacji matematycznej.

    Operacja

    Symbol

    Dodawanie

    +

    Odejmowanie

    -

    Mnożenie

    *

    Dzielenie

    /

    • Uwaga : Jeśli w formule występuje operator dzielenia (/), przed nim i po nim musi wystąpić spacja. W przeciwnym przypadku program InfoPath może zinterpretować symbol „/” jako separator kroków położenia XPath, a nie jako operator dzielenia.

    • Aby sprawdzić, czy formuła ma poprawną składnię, kliknij przycisk Weryfikuj formułę w oknie dialogowym Wstawianie formuły.

      W sekcji Zobacz też znajdują się łącza do artykułów zawierających więcej informacji o formułach.

  7. Aby zastępować w bibliotece dokumentów istniejące formularze o tej samej nazwie, zaznacz pole wyboru Zezwalaj na zastąpienie, jeżeli plik istnieje.

  8. Kliknij przycisk Dalej.

  9. Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz opisową nazwę dla tego przedstawia połączenia danych.

  10. Sprawdź, czy informacje w sekcji Podsumowanie są poprawne, a następnie kliknij przycisk Zakończ.

    1. Aby zmienić nazwę przycisk Prześlij, który pojawia się na pasku narzędzi Standardowy, a polecenie Prześlij, który pojawia się w menu plik, podczas wypełniania formularza, wpisz nową nazwę w polu Podpis w oknie dialogowym Opcje przesyłania.

      Porada : Jeśli chcesz przypisać skrót klawiaturowy do tego przycisku i polecenia, wpisz handlowe "i" (&) przed znakiem, który ma być używany jako skrót klawiaturowy. Na przykład aby przypisać klawisze ALT + B, jako skrót klawiaturowy dla przycisku Prześlij i polecenia, wpisz & przycisk Prześlij.

  11. Jeśli nie chcesz używać polecenia Prześlij lub przycisk Zatwierdź na pasku narzędzi Standardowy, podczas wypełniania formularza użytkownicy, wyczyść pole wyboru Pokaż polecenie Prześlij i przycisk Prześlij.

    1. Domyślnie po użytkownikom przesyłanie formularzy programu InfoPath zachowuje formularz otwarty i zostanie wyświetlony komunikat, aby wskazać, jeśli formularz został pomyślnie przesłany. Aby zmienić to zachowanie domyślne, kliknij przycisk Zaawansowane, a następnie wykonaj jedną z następujących czynności:

      1. Aby zamknąć formularz lub Utwórz nowy pusty formularz po przesłaniu wypełniony formularz, kliknij opcję, która ma na liście po przesyłanie.

      2. Aby utworzyć niestandardowe wiadomości, który wskazuje, jeśli formularz został pomyślnie przesłany, zaznacz pole wyboru Użyj niestandardowych wiadomości, a następnie wpisz wiadomości w polach w przypadku powodzenia i niepowodzenia.

        Porada : Poinstruuj użytkowników za pomocą wiadomości w polu w przypadku awarii co należy zrobić, jeśli nie można ich przesłać formularz. Na przykład można sugerują, że użytkownicy zapisywać formularze i skontaktować się z osobą Aby uzyskać dodatkowe instrukcje.

      3. Jeśli nie chcesz wyświetlać wiadomości, gdy użytkownik przesyła formularz, wyczyść pole wyboru Pokaż sukcesów i porażek wiadomości.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×