Przesyłanie danych formularza do bazy danych programu Microsoft SQL Server

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W tym artykule

Omówienie

Krok 1: Włączenie połączenia przesyłania danych

Krok 2: Skonfiguruj opcje przesyłania

Przegląd

W przypadku projektowania szablonu formularza opartego na bazie danych programu Microsoft SQL Server Kreator połączenia danych włącza połączenie danych do przesyłania do bazy danych po spełnieniu następujących warunków:

  • Formularze utworzone na podstawie tego szablonu formularza są wypełniane przy użyciu programu Microsoft Office InfoPath. Jeśli formularz zostanie wypełniony przy użyciu przeglądarki sieci Web, nie można przesłać danych formularza bezpośrednio do bazy danych. Aby skonfigurować szablon formularza zgodny z przeglądarką do przesyłania danych do bazy danych, należy użyć połączenia danych, które przesyła dane do usługi sieci Web współpracującej z bazą danych.

  • Tabela podstawowa bazy danych, która jest używana w głównym połączeniu danych, zawiera klucz podstawowy, ograniczenie unikatowe lub indeks unikatowy.

  • Wszystkie inne tabele bazy danych używane z głównym połączeniem danych są w prostej relacji z tabelą podstawową bazy danych.

Jeśli baza danych spełnia te wymagania, program InfoPath włącza połączenie danych do przesyłania i dodaje przycisk Prześlij do paska narzędzi Standardowy oraz polecenie Prześlij do menu Plik w formularzu.

Połączenie danych do przesyłania można wyłączyć w kreatorze podczas projektowania szablonu formularza opartego na bazie danych. Jeśli połączenie danych do przesyłania zostanie wyłączone w kreatorze, a później będzie trzeba użyć tego połączenia danych do przesyłania, można je włączyć, modyfikując główne połączenie danych. W tym artykule omówiono, jak włączać to połączenie danych do przesyłania.

Uwaga : Połączenie danych do przesyłania może istnieć tylko w głównym połączeniu danych z bazą danych. Do szablonu formularza nie można dodawać połączenia danych do przesyłania będącego pomocniczym połączeniem danych z bazą danych. Aby użyć połączenia danych do przesyłania jako pomocniczego połączenia danych, należy użyć usługi sieci Web współpracującej z bazą danych, a następnie dodać połączenie danych do przesyłania do tej usługi sieci Web.

Po włączeniu połączenia danych do przesyłania można również dostosować opcje przesyłania szablonu formularza:

  • zmieniając tekst pojawiający się na przycisku Prześlij na pasku narzędzi Standardowy i na poleceniu Prześlij w menu Plik;

  • zmieniając skrót klawiaturowy dotyczący przycisku Prześlij na pasku narzędzi Standardowy i polecenia Prześlij w menu Plik;

  • tworząc niestandardowe komunikaty wyświetlane, gdy użytkownicy przesyłają formularze;

  • określając, czy po przesłaniu formularza ma on pozostać otwarty, zostać zamknięty czy ma zostać otwarty kolejny pusty formularz.

Początek strony

Krok 1. Włączanie połączenia danych do przesyłania

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij główne połączenie danych, a następnie kliknij przycisk Modyfikuj.

  3. W oknie Kreatora połączenia danych kliknij przycisk Dalej.

  4. Na następnej stronie kreatora zaznacz pole wyboru Włącz przesyłanie dla tego połączenia, a następnie kliknij przycisk Zakończ.

Początek strony

Krok 2. Konfigurowanie opcji przesyłania

Po włączeniu połączenia danych do przesyłania program InfoPath doda przycisk Prześlij do paska narzędzi Standardowy i polecenie Prześlij do menu Plik. Program InfoPath konfiguruje także formularze oparte na tym szablonie formularza w celu wyświetlania komunikatu po przesłaniu przez użytkowników wypełnionych formularzy. Komunikat informuje o tym, czy przesłanie formularza powiodło się. Domyślnie formularze po przesłaniu pozostają otwarte w programie InfoPath. Aby zmienić tekst wyświetlany na przycisku Prześlij oraz zachowanie formularzy po przesłaniu, należy wykonać następujące czynności:

  1. W menu Narzędzia kliknij polecenie Opcje przesyłania.

    1. Aby zmienić nazwę przycisk Prześlij, który pojawia się na pasku narzędzi Standardowy, a polecenie Prześlij, który pojawia się w menu plik, podczas wypełniania formularza, wpisz nową nazwę w polu Podpis w oknie dialogowym Opcje przesyłania.

      Porada : Jeśli chcesz przypisać skrót klawiaturowy do tego przycisku i polecenia, wpisz handlowe "i" (&) przed znakiem, który ma być używany jako skrót klawiaturowy. Na przykład aby przypisać klawisze ALT + B, jako skrót klawiaturowy dla przycisku Prześlij i polecenia, wpisz & przycisk Prześlij.

  2. Jeśli nie chcesz używać polecenia Prześlij lub przycisk Zatwierdź na pasku narzędzi Standardowy, podczas wypełniania formularza użytkownicy, wyczyść pole wyboru Pokaż polecenie Prześlij i przycisk Prześlij.

    1. Domyślnie po użytkownikom przesyłanie formularzy programu InfoPath zachowuje formularz otwarty i zostanie wyświetlony komunikat, aby wskazać, jeśli formularz został pomyślnie przesłany. Aby zmienić to zachowanie domyślne, kliknij przycisk Zaawansowane, a następnie wykonaj jedną z następujących czynności:

      • Aby zamknąć formularz lub Utwórz nowy pusty formularz po przesłaniu wypełniony formularz, kliknij opcję, która ma na liście po przesyłanie.

      • Aby utworzyć niestandardowe wiadomości, który wskazuje, jeśli formularz został pomyślnie przesłany, zaznacz pole wyboru Użyj niestandardowych wiadomości, a następnie wpisz wiadomości w polach w przypadku powodzenia i niepowodzenia.

        Porada : Poinstruuj użytkowników za pomocą wiadomości w polu w przypadku awarii co należy zrobić, jeśli nie można ich przesłać formularz. Na przykład można sugerują, że użytkownicy zapisywać formularze i skontaktować się z osobą Aby uzyskać dodatkowe instrukcje.

      • Jeśli nie chcesz wyświetlać wiadomości, gdy użytkownik przesyła formularz, wyczyść pole wyboru Pokaż sukcesów i porażek wiadomości.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×