Przenoszenie opublikowanego szablonu formularza do nowej biblioteki programu SharePoint

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

W tym artykule

Omówienie

Przed rozpoczęciem

Pobierz kopię szablonu formularza w pracy

Krok 1: Publikowanie szablonu formularza do nowej biblioteki dokumentów

Krok 2: Kopiowanie i ponowne łączenie istniejących formularzy

Omówienie

Po opublikowaniu szablonu formularza w bibliotece dokumentów użytkownikom wypełnianie, może być konieczne przeniesienie tego szablonu formularza do innej biblioteki dokumentów. Na przykład może być konieczne przeniesienie szablonu formularza na serwerze z możliwości, tak aby więcej użytkowników mogą wypełniać formularze w tym samym czasie. Niektórzy użytkownicy mogą mieć już wypełniać formularze oparte na szablonie formularza, który został zapisany w bibliotece dokumentów oryginalny. Po przeniesieniu szablonu formularza do Nowa biblioteka dokumentów zostanie chcesz przenieść zbyt tych istniejących formularzy. Należy upewnić się, że istniejące formularze będą działać w nowej biblioteki dokumentów przed archiwizowanie lub usuń starą bibliotekę dokumentów.

Porada: Przed szablony opublikowany formularz zostanie przeniesiony do nowej biblioteki dokumentów, należy utworzyć plan, który zawiera informowanie użytkowników czy formularzy zostały przeniesione do nowej biblioteki dokumentów. Chcesz, aby użytkownicy mogli korzystać z nowej biblioteki dokumentów do przechowywania nowych formularzy lub zmodyfikować istniejące formularze. Plan obejmuje również proces archiwizacji lub usuwania oryginalnej bibliotece dokumentów.

Aby przenieść szablonu formularza i jego istniejących formularzy zostanie Nowa biblioteka dokumentów, należy najpierw opublikować kopię roboczą szablonu formularza do nowej biblioteki dokumentów. Kopię roboczą jest wersja, który jest przechowywany na komputerze lub w programie kontroli wersji, takich jak Microsoft nim.

Porada: Jeśli nie masz kopię szablonu formularza w pracy, można zapisać kopię szablonu formularza z oryginalnym biblioteki dokumentów z komputerem, aby użyć jako kopię roboczą.

Po opublikowaniu kopię roboczą Nowa biblioteka dokumentów, należy skopiować wszystkie formularze z stare biblioteki dokumentów do nowej biblioteki dokumentów i ponowne łączenie formularzy w bibliotece dokumentów do nowo opublikowany szablon formularza.

Jeśli chcesz wprowadzić zmiany w wyniku przenoszenie szablonu formularza, należy wprowadzić zmiany przed publikowanie szablonu formularza. Na przykład lokalizacji zewnętrznych źródeł danych używanych w formularzach, które są oparte na tym szablonie formularza mogą ulec zmianie w wyniku przenoszenie szablonu formularza. W tym przypadku należy zmienić połączenia danych w szablonie formularza do nowej lokalizacji zewnętrznych źródeł danych, przed opublikowaniem szablonu formularza. Łącza do dodatkowych informacji na temat zmieniania połączenia danych w sekcji Zobacz też.

Uwaga: Publikowanie szablonu formularza nie jest taki sam, jak zapisywanie szablonu formularza. Po opublikowaniu szablonu formularza Publishing Wizard dodaje lokalizacji publikowania i przetwarzanie instrukcje do szablonu formularza, dzięki czemu użytkownicy mogą otwierać formularzy opartych na tym szablonie formularza. Po zapisaniu szablonu formularza, tak samo jak podczas zapisywania pliku na komputerze są zapisanie kopii szablonu formularza. Zawsze należy użyć Kreatora publikowania, gdy użytkownik chce udostępnić użytkownikom wypełnianie szablonu formularza.

Początek strony

Zanim rozpoczniesz

Przed przeniesieniem szablonu formularza i formularzy opartych na szablonie formularza do nowej biblioteki dokumentów, potrzebne następujące elementy:

  • Kopia robocza szablonu formularza    Jest to kopia szablon formularza, który będzie zmodyfikować, a następnie ponowne opublikowanie nowej biblioteki dokumentów. Kopię roboczą mogą być przechowywane na komputerze lub w programie kontroli wersji, takich jak nim.

  • Lokalizacje dowolnego nowych źródeł danych zewnętrznych    Jeśli formularze, które są oparte na szablonie formularza za pomocą źródeł danych zewnętrznych, które zostały zmienione, konieczne będzie nowa lokalizacja zewnętrznych źródeł danych. Sprawdź ze swoim administratorem, że użytkownicy mają odpowiednie uprawnienia do korzystania ze źródeł danych zewnętrznych. Jeśli szablon formularza ustawień w pliku połączenia danych nawiązywania połączenia z zewnętrznym źródłem danych, upewnij się, że plik połączenia danych został zaktualizowany o nową lokalizację z zewnętrznym źródłem danych.

  • Odpowiednich uprawnień na serwerze z Windows SharePoint Services 3.0    Konieczne będzie odpowiednie prawa na serwerze w celu publikowanie szablonu formularza i skopiuj istniejących formularzy ze starej biblioteki dokumentów do nowej biblioteki dokumentów. Zapoznaj się z administratorem serwera, aby upewnić się, że masz tych praw.

Początek strony

Pobierz kopię szablonu formularza w pracy

Jeśli chcesz zmodyfikować szablon formularza, który został opublikowany w bibliotece dokumentów lub do udostępnionej lokalizacji sieciowej, a nie masz kopię szablonu formularza w pracy, można zapisać jego kopię roboczą szablonu formularza z lokalizacji publikowania z komputerem.

Porada: Warto rozważyć użycie programu kontroli wersji, takich jak nim w programie Microsoft do zarządzania kopie robocze szablonów formularzy.

Zapisz kopię szablonu formularza z biblioteki dokumentów z komputerem

  1. W przeglądarce sieci Web otwórz bibliotekę dokumentów, w której został opublikowany szablon formularza.

  2. W menu Ustawienia kliknij pozycję Ustawienia, a następnie kliknij przycisk Ustawienia biblioteki formularzy.

  3. W obszarze Ustawienia ogólne kliknij przycisk Ustawienia zaawansowane.

  4. W sekcji Szablon dokumentu kliknij przycisk Edytuj szablon.

    Szablon formularza zostanie otwarty w programie Microsoft Office InfoPath.

  5. W oknie dialogowym Programu Microsoft Office InfoPath kliknij przycisk Tak.

  6. W menu Plik kliknij polecenie Zapisz jako.

  7. W oknie dialogowym Programu Microsoft Office InfoPath kliknij przycisk OK.

  8. W oknie dialogowym Zapisywanie jako przejdź do lokalizacji, w której chcesz zapisać kopię szablonu formularza, a następnie kliknij przycisk Zapisz.

Zapisz kopię szablonu formularza z udostępnionego folderu sieciowego na komputerze

  1. W menu plik kliknij pozycję Projektowanie szablonu formularza.

  2. W obszarze, Otwórz szablon formularza kliknij Na moim komputerze.

  3. Przejdź do folderu udostępnionego sieci opublikowany szablon formularza, kliknij szablon formularza, a następnie kliknij przycisk Otwórz.

  4. W menu Plik kliknij polecenie Zapisz jako.

  5. W oknie dialogowym Programu Microsoft Office InfoPath kliknij przycisk OK.

  6. W oknie dialogowym Zapisywanie jako wybierz lokalizację innych niż oryginał Publikowanie lokalizacji, w której chcesz zapisać jego kopię roboczą szablonu formularza i kliknij przycisk Zapisz.

Początek strony

Krok 1: Publikowanie szablonu formularza do nowej biblioteki dokumentów

  1. Otwórz kopię roboczą szablonu formularza w trybie projektowania.

  2. W menu plik kliknij pozycję Publikuj.

  3. W Kreatorze publikowania kliknij do programu SharePoint server z lub bez usług InfoPath Forms Services, a następnie kliknij przycisk Dalej.

  4. W polu Wprowadź lokalizację witryny programu SharePoint lub usług InfoPath Forms Services wpisz lokalizację witryny programu SharePoint, która zawiera Nowa biblioteka dokumentów, który chcesz przenieść do szablonu formularza, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora kliknij Bibliotekę dokumentów, a następnie kliknij przycisk Dalej.

  6. Kliknij pozycję Utwórz nową bibliotekę dokumentów, a następnie kliknij przycisk Dalej.

  7. Na następnej stronie kreatora wpisz nazwę i opis nowej biblioteki dokumentów, a następnie kliknij przycisk Dalej.

  8. Wybierz pola w szablonie formularza, który ma być wyświetlany jako kolumny w widoku domyślnym biblioteki dokumentów.

    Jak to zrobić?

    1. Kliknij przycisk Dodaj.

    2. Wybierz pole, które chcesz dodać jako kolumna w bibliotece dokumentów, a następnie wykonaj jedną z następujących czynności:

      • Wpisz nazwę kolumny w polu Nazwa kolumny.

      • Zaznacz kolumnę witryny na liście grupy kolumn witryny, wybierz nazwę z listy Nazwa kolumny, a następnie kliknij przycisk OK.

        Uwaga: W przypadku wybrania polem powtarzającym się do wyświetlania danych w bibliotece dokumentów, można zdefiniować, jak mają być wyświetlane pola w bibliotece dokumentów, klikając pozycję wartość na liście funkcji. Możesz wybrać, czy ma być wyświetlana pierwsza wartość w polu, ostatnia wartość w polu lub liczba wszystkich wystąpień pola lub czy mają być scalane wszystkie wartości.

    3. Kliknij przycisk OK.

    Łącza do dodatkowych informacji na temat wyświetlania danych w kolumnach w bibliotece dokumentów w sekcji Zobacz też.

  9. Kliknij przycisk Dalej.

  10. Na następnej stronie kreatora sprawdź poprawność informacji wyświetlanych, a następnie kliknij pozycję Publikuj.

  11. Otwórz bibliotekę dokumentów i przetestować proces wypełniania formularza, który jest oparty na tym szablonie formularza, zaznacz pole wyboru Otwórz tę bibliotekę dokumentów, a następnie kliknij przycisk Zamknij.

    Biblioteka dokumentów zostanie otwarty w przeglądarce. Po kliknięciu przycisku Nowy na pasku narzędzi listy formularz oparty na tym szablonie formularza zostanie otwarty w programie Microsoft Office InfoPath.

Po opublikowaniu szablonu formularza do nowej biblioteki dokumentów, możesz skopiować istniejących formularzy, które są oparte na starszą wersję szablonu formularza z stare biblioteki dokumentów do nowej biblioteki dokumentów. Po skopiowaniu istniejących formularzy ponownym połączeniu istniejących formularzy do nowej wersji szablonu formularza. Jeśli nie utworzysz łącza istniejących formularzy, użytkownicy mogą nie można otworzyć tych istniejących formularzy.

Początek strony

Krok 2: Kopiowanie i ponowne łączenie istniejących formularzy

W poniższej procedurze założono, to zarówno bibliotek dokumentów na serwerze, na którym działa Windows SharePoint Services 3.0.

  1. Otwórz starą bibliotekę dokumentów w przeglądarce sieci Web.

  2. W menu Widok kliknij polecenie Widok Eksploratora.

  3. Naciśnij i przytrzymaj naciśnięty klawisz CTRL, zaznacz każdy formularz, który chcesz przenieść, a następnie kliknij prawym przyciskiem myszy jeden z formularzy.

  4. W oknie dialogowym Programu Internet Explorer kliknij przycisk Tak, a następnie w menu skrótów kliknij polecenie Kopiuj.

  5. Otwórz nową bibliotekę dokumentów.

  6. W obszarze Wybierz widok kliknij Widok Eksploratora.

  7. Kliknij prawym przyciskiem myszy pusty obszar w oknie folderu.

  8. W oknie dialogowym Programu Internet Explorer kliknij przycisk Tak, a następnie w menu skrótów kliknij polecenie Wklej.

  9. W menu Widok kliknij polecenie Połącz ponownie dokumenty.

  10. W kolumnie połączeniu zaznacz pole wyboru dla każdego formularza, który chcesz utworzyć łącze do nowego szablonu formularza.

  11. Na pasku narzędzi listy kliknij przycisk Połącz ponownie zaznaczone dokumenty.

Po ponownym połączeniu istniejących formularzy do nowego szablonu formularza, użytkownicy mogą zmieniać istniejących formularzy, które zostały skopiowane do nowej biblioteki dokumentów lub wypełniania nowych formularzy opartych na tym szablonie nowo opublikowany formularz.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×