Projektowanie widoku tylko do odczytu

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W programie Microsoft Office InfoPath można tworzyć różne widoki tego samego szablonu formularza. Widok jest alternatywny sposób wyświetlania danych w szablonie formularza. Podczas wypełniania formularzy na podstawie szablonu formularza użytkownicy przełączać się między widokami do wybierz zakres danych, który jest wyświetlany w formularzu. Na przykład w szablonie formularza raportu stanu, możesz zaprojektować widoku podsumowania oprócz szczegółowy widok. Użytkownicy mogą następnie wybrać widok chcą przeglądać w zależności od tego, jakiego rodzaju informacje są potrzebne.

W tym artykule opisano sposób projektowania widoku, którego nie mogą edytować użytkownicy. Przedstawiono także, jak używać reguł, aby po kliknięciu przez użytkownika przycisku w widoku do odczytu i zapisu nastąpiło automatyczne przełączenie na widok formularza tylko do odczytu.

Co chcesz zrobić?

Projektowanie widoku tylko do odczytu

Wstawianie przycisku przełączającego między widokiem do odczytu i zapisu a widokiem tylko do odczytu

Wstawianie przycisku przełączającego na widok tylko do odczytu po przesłaniu formularza przez użytkowników

Projektowanie widoku tylko do odczytu

Widoki tylko do odczytu są przydatne, gdy trzeba podsumować dane formularzy użytkowników, unikając przy tym ich przypadkowej zmiany przez użytkowników. Przypuśćmy na przykład, że trzeba uniemożliwić zmienianie danych w formularzu po przesłaniu go przez użytkowników do usługi sieci Web. Można tak skonfigurować szablon formularza, aby po kliknięciu w formularzu przycisku Prześlij widok do odczytu i zapisu był przełączany na widok tylko do odczytu. Pozwoli to użytkownikom wyświetlić przesłane dane, ale uniemożliwi ich modyfikowanie.

  1. W menu Widok kliknij polecenie Zarządzaj widokami.

  2. W obszarze Akcje kliknij łącze Dodaj nowy widok.

  3. W oknie dialogowym Dodawanie widoku wpisz nazwę widoku, a następnie kliknij przycisk OK.

  4. Zaprojektuj widok, dodając do niego tabele układu i formanty.

    Porada : Jeśli chcesz oprzeć projekt nowego widoku na istniejącym widoku, otwórz ten widok, naciśnij klawisze CTRL+A, aby zaznaczyć wszystko w widoku, a następnie naciśnij klawisze CTRL+C, aby skopiować zaznaczenie do Schowka. W okienku zadań Widoki przełącz do nowego widoku i naciśnij klawisze CTRL+V, aby wkleić zaznaczenie do nowego widoku. Następnie możesz usunąć z nowego widoku wszelkie niepotrzebne formanty lub elementy układu.

  5. W okienku zadań Widoki kliknij pozycję Wyświetl właściwości.

  6. Kliknij kartę Ogólne.

  7. W obszarze Ustawienia widoku zaznacz pole wyboru Tylko do odczytu, a następnie kliknij przycisk OK.

  8. Aby sprawdzić, czy widok jest tylko do odczytu, kliknij przycisk Podgląd na pasku narzędzi Standardowy.

  9. W oknie podglądu upewnij się, że nie można wprowadzić danych w formularzu.

  10. Aby powrócić do trybu projektowania, kliknij przycisk Zamknij podgląd na pasku narzędzi Standardowy.

Początek strony

Wstawianie przycisku przełączającego między widokiem do odczytu i zapisu a widokiem tylko do odczytu

Widoki są często zaprojektowane do współpracy z przyciskami i regułami. Pozwala to zautomatyzować pewne zadania w szablonie formularza w ramach reakcji na zdarzenia lub czynności zainicjowane przez osobę wypełniającą formularz. Można na przykład wstawić przycisk do szablonu formularza, a następnie utworzyć regułę powodującą przełączanie widoków po kliknięciu tego przycisku. W poniższym przykładzie w oknie dialogowym Reguła projektant formularza utworzył regułę, która powoduje przełączanie na widok podsumowania tylko do odczytu. Reguła jest uruchamiana po każdym kliknięciu przez użytkownika przycisku w formularzu.

Fragment okna dialogowego Reguła

Wstawianie przycisku przełączającego między widokami

  1. W menu Widok kliknij polecenie Zarządzaj widokami.

  2. W obszarze Wybierz widok kliknij widok do odczytu i zapisu, do którego chcesz dodać przycisk.

  3. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  4. W szablonie formularza umieść kursor w miejscu, w którym chcesz wstawić przycisk.

  5. W obszarze Wstaw formanty kliknij pozycję Przycisk.

  6. W szablonie formularza kliknij dwukrotnie wstawiony przycisk.

  7. Kliknij kartę Ogólne.

  8. Na liście Akcja kliknij pozycję Reguły i kod niestandardowy.

  9. W polu Etykieta wpisz tekst, który ma się znajdować na przycisku.

  10. Kliknij przycisk Reguły.

  11. W oknie dialogowym Reguły kliknij przycisk Dodaj.

  12. W polu Nazwa wpisz nazwę reguły.

  13. Kliknij przycisk Dodaj akcję.

  14. Na liście Akcja kliknij pozycję Przełącz widoki.

  15. Na liście Widok kliknij widok, na który chcesz się przełączyć, a następnie kliknij przycisk OK.

  16. Kliknij przycisk OK, aby zamknąć wszystkie otwarte okna dialogowe.

  17. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

  18. Kliknij przycisk w oknie podglądu.

    Powinien zostać otwarty widok określony w kroku 15.

  19. Aby powrócić do trybu projektowania, kliknij przycisk Zamknij podgląd na pasku narzędzi Standardowy.

  20. Aby dodać drugi przycisk i regułę do widoku tylko do odczytu, co pozwoli użytkownikom przełączać się z powrotem na widok do odczytu i zapisu, otwórz widok tylko do odczytu, a następnie powtórz kroki od 3 do 19.

Początek strony

Wstawianie przycisku przełączającego na widok tylko do odczytu po przesłaniu formularza przez użytkowników

W poniższej procedurze opisano sposób dodawania do szablonu formularza przycisku, który powoduje wyświetlenie widoku tylko do odczytu, zawierającego przesłane dane. Można to zrobić w formularzu raportów o stanie, aby umożliwić użytkownikom przełączanie się z widoku domyślnego na widok podsumowania danych formularza będący widokiem tylko do odczytu.

Uwaga : Ta procedura działa tylko wtedy, gdy szablon formularza zawiera istniejące połączenie danych na potrzeby przesyłania danych formularza. Jeśli jeszcze nie skonfigurowano połączenia do przesyłania danych, należy to zrobić przed wykonaniem tej procedury. W przeciwnym razie poniższe kroki nie przyniosą zamierzonego efektu. W sekcji Zobacz też znajdują się łącza do dodatkowych informacji na temat połączeń danych.

  1. W menu Widok kliknij polecenie Zarządzaj widokami.

  2. W obszarze Wybierz widok kliknij widok, który ma zawierać przycisk Prześlij.

  3. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  4. W szablonie formularza umieść kursor w miejscu, w którym chcesz wstawić przycisk.

  5. W obszarze Wstaw formanty kliknij pozycję Przycisk.

  6. W szablonie formularza kliknij dwukrotnie wstawiony przycisk.

  7. Kliknij kartę Ogólne.

  8. Na liście Akcja kliknij pozycję Prześlij.

  9. Aby jako etykieta przycisku był wyświetlany tekst inny niż „Prześlij”, wpisz właściwy tekst w polu Etykieta.

  10. Kliknij przycisk Opcje przesyłania.

  11. W oknie dialogowym Opcje przesyłania upewnij się, że jest zaznaczone pole wyboru Zezwalaj użytkownikom na przesyłanie tego formularza.

  12. Kliknij opcję Wykonaj akcję niestandardową przy użyciu reguł, a następnie kliknij przycisk Reguły.

  13. W oknie dialogowym Reguły przesyłania formularzy kliknij przycisk Dodaj.

  14. W polu Nazwa wpisz nazwę reguły, a następnie kliknij przycisk Dodaj akcję.

  15. Na liście Akcja kliknij pozycję Przełącz widoki.

  16. Na liście Widok kliknij widok tylko do odczytu, na który chcesz się przełączyć, a następnie kliknij przycisk OK.

  17. Kliknij przycisk OK, aby zamknąć wszystkie otwarte okna dialogowe.

  18. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

  19. W oknie podglądu kliknij przycisk służący do przesyłania formularza.

    Powinien zostać otwarty widok tylko do odczytu.

  20. Aby powrócić do trybu projektowania, kliknij przycisk Zamknij podgląd na pasku narzędzi Standardowy.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×