Projektowanie szablonu formularza przy użyciu ustawień zapisanych w bibliotece połączeń danych

Ważne: Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W tym artykule omówiono sposób projektowania szablonu formularza w oparciu o ustawienia zapisane w bibliotece połączeń danych zlokalizowanej w witrynie programu Microsoft Office SharePoint Server 2007. Szablon może obsługiwać oba kierunki transferu informacji, tzn. wykonywanie kwerend i przesyłanie danych.

W tym artykule

Omówienie

Przed rozpoczęciem

Projektowanie szablonu formularza z połączeniem danych służącym do wykonywania kwerend

Projektowanie szablonu formularza z połączeniem danych służącym do przesyłania danych

Omówienie

Pomocniczego połączenia danych jest wszystkie połączenia danych z zewnętrznego źródła danych dodany do szablonu formularza. To połączenie danych różni się od głównego połączenia danych utworzony podczas projektowania szablonu formularza na podstawie bazy danych, usługi sieci Web lub ustawień w bibliotece połączeń. Możesz dodać pomocniczego połączenia danych tylko wtedy, gdy nie można kwerendy lub przesyłania danych głównego połączenia danych.

W ustawieniach formularza można zdefiniować jedno nadrzędne połączenie danych (nazywane „głównym połączeniem danych”) i jedno lub więcej opcjonalnych pomocniczych połączeń danych. Zależnie od przeznaczenia formularza połączenie danych może służyć do wykonywania kwerend w zewnętrznym źródle danych (na przykład w bazie danych programu Microsoft SQL Server czy w usłudze sieci Web) albo do wysyłania danych do tego źródła.

Jeśli projektujesz kilka szablonów certyfikatów zawierających podobne połączenia danych, rozważ użycie plik połączenia danych zamiast tworzenia połączenia danych z zewnętrznego źródła danych dla każdego szablonu formularza. Dzięki temu musisz zaktualizować tylko jeden plik połączenia danych, gdy informacje o połączeniu danych dla zestaw szablonów powiązanym formularzu. Na przykład po przeniesieniu do sieci produkcyjnej szablonów formularzy z sieci test, należy zaktualizować dane ustawienia połączenia tylko raz w bibliotece połączeń zamiast aktualizowanie połączenia danych w szablonie formularza. Gdy formularz oparty na szablonie formularza, który używa plik połączenia danych jest używany połączenia danych, połączenia danych jest automatycznie zaktualizowane przy użyciu nowych ustawień.

Plik połączenia danych jest plikiem XML z rozszerzeniem pliku XML lub udcx, zawierający informacje o połączeniu dla pojedynczego zewnętrznego źródła danych. Ten plik jest przechowywany w bibliotece połączeń danych na serwerze z systemem Microsoft Office SharePoint Server 2007. Plik połączenia danych zostanie utworzony przez dewelopera lub konwertując połączenia danych w istniejącego szablonu formularza do pliku połączenia danych, klikając przycisk Konwertuj, w oknie dialogowym Połączenia danych (menuNarzędzia ).

Zalety korzystania z plikami połączeń danych obejmują:

  • Wiele formularzy można użyć tego samego pliku połączenia danych, dlatego nie trzeba utworzyć połączenie danych od podstaw dla każdego szablonu formularza.

  • W przypadku zmiany lokalizacji zewnętrznego źródła danych lub ustawień połączenia z tym źródłem wystarczy zaktualizować dane w pliku — nie jest wymagane modyfikowanie ustawień szablonu

  • Plik połączenia danych może zawierać informacje uwierzytelniające alternatywnego, który może być używany przez serwer, gdy użytkownik wypełnia formularza za pomocą przeglądarki sieci Web.

  • Formularze na podstawie szablonu formularza zgodnego z przeglądarkami, które są wypełnione w przeglądarce można nawiązać serwerów w innej domeny tylko w przypadku połączeń danych za pomocą plików połączenia danych.

Program Microsoft Office InfoPath używa plików połączeń danych, występujące po tym formacie plików 2.0 wersji uniwersalny połączenia danych. Ta wersja jest podzbiorem wersji 1.0 format używany przez program Microsoft Office FrontPage i Microsoft Office Excel. Program InfoPath nie można używać plików połączenia danych w wersji 1.0 formacie.

Po utworzeniu szablonu formularza, który zależy od ustawień w pliku połączenia danych programu Microsoft Office InfoPath tworzy połączenie danych oparty na stronie ustawień w bibliotece połączeń danych. Jeśli plik połączenia danych zawiera ustawień połączenia danych kwerendy, InfoPath tworzy formularza głównego źródło danych z pól kwerendy, pól i grup, które odpowiadają tak, że dane są przechowywane w źródle danych zewnętrznych, które odwołują się do ustawień w pliku połączenia danych. Pola kwerendy zawierają dane, które używa zewnętrznego źródła danych, aby określić, co do wysłania do formularza. Wyniki kwerendy są wprowadzane do pól danych. Aby umożliwić użytkownikom tworzenie kwerendy źródła danych zewnętrznych, InfoPath dodaje przycisk Uruchom kwerendę do szablonu formularza.

Ponieważ struktura danych pól kwerendy i pól danych musi być zgodna ze sposobem przechowywania danych w zewnętrznym źródle danych, nie można samodzielnie modyfikować istniejących pól i grup w głównym źródle danych. Dopuszcza się jedynie dodawanie pól i grup na poziomie głównej grupy źródła danych.

Jeśli używane ustawienia dotyczą połączenia służącego do przesyłania danych, w formularzach bazujących na tym szablonie program InfoPath włączy przycisk Prześlij na pasku narzędzi Standardowy oraz polecenie Prześlij w menu Plik. Umożliwi to użytkownikom inicjowanie operacji wysyłania danych do zewnętrznego źródła.

Początek strony

Przed rozpoczęciem

Przed rozpoczęciem projektowania szablonu formularza opartego na ustawieniach zapisanych w bibliotece połączeń danych należy zwrócić się do administratora biblioteki lub twórcy pliku połączenia danych o następujące informacje:

  • Lokalizacja witryny programu Office SharePoint Server 2007 zawierającej bibliotekę połączeń.

  • Nazwa należącego do biblioteki pliku połączenia danych, którego chcesz używać.

Początek strony

Projektowanie szablonu formularza z połączeniem danych służącym do wykonywania kwerend

Aby zaprojektować szablon formularza używający pliku połączenia danych z ustawieniami połączenia służącego do wykonywania kwerend, należy wykonać następujące czynności:

  1. Utworzenie szablonu formularza opartego na pliku połączenia danych    Na tym etapie powstaje główne źródło danych szablonu formularza z polami i grupami odpowiadającymi ustawieniom zapisanym w pliku połączenia danych.

  2. Dodanie do szablonu formularza formantów umożliwiających wyświetlanie wyników kwerend    Aby użytkownicy formularza mogli wyświetlać dane przechowywane w polach i grupach głównego źródła danych, należy do szablonu formularza dodać odpowiednie formanty i powiązać je z polami kwerend lub z polami danych w głównym źródle danych.

Krok 1: Projektowanie szablonu formularza opartego na pliku połączenia danych

  1. W menu Plik kliknij polecenie Projektuj szablon formularza.

  2. W obszarze Projektuj nowy w oknie dialogowym Projektowanie szablonu formularza kliknij opcję Szablon formularza.

  3. Na liście Na podstawie kliknij opcję Biblioteka połączeń.

  4. W przypadku projektowania szablonu formularza zgodnego z przeglądarkami należy zaznaczyć pole wyboru Włącz tylko funkcje zgodne z przeglądarką.

  5. Kliknij przycisk OK.

  6. W Kreatorze połączenia danych na liście Witryna kliknij nazwę witryny umieszczonej na serwerze z uruchomionym programem Office SharePoint Server 2007, w której znajduje się biblioteka połączeń danych.

    Dodawanie witryny do listy

    1. Kliknij przycisk Zarządzaj witrynami.

    2. W oknie dialogowym Zarządzanie witrynami kliknij przycisk Dodaj.

    3. W polu adres URL wpisz lokalizację biblioteki połączeń danych.

    4. W polu Nazwa wyświetlana wpisz nazwę biblioteki połączeń danych. Ta nazwa będzie wyświetlana na liście w Kreatorze połączenia danych.

    5. Kliknij przycisk OK.

    6. Kliknij przycisk Zamknij.

  7. Kliknij nazwę biblioteki połączeń danych, aby wyświetlić listę plików połączeń danych, kliknij nazwę pliku połączenia danych, który ma być używany dla tego połączenia danych, a następnie kliknij przycisk Dalej.

  8. W przypadku zaznaczenia pliku połączenia danych zawierającego ustawienia połączenia z usługą sieci Web na następnej stronie kreatora może pojawić się monit o podanie przykładowych wartości wszystkich parametrów. Ma to na celu ustalenie, które pola lub grupy powinny zostać dodane do pomocniczego źródła danych.

    Jak?

    1. Wybierz parametr w tabeli Parametry, a następnie kliknij Ustaw przykładową wartość.

    2. W polu wartość próbki wpisz wartość, że użytkownika może użyć dla tego pola, a następnie kliknij przycisk OK.

    3. Powtórz te czynności dla każdego parametru w tabeli Parametry, a następnie kliknij przycisk Dalej.

    Szczegóły techniczne

    Po skonfigurowaniu połączenia danych z usługi sieci Web w Kreatorze połączenia danych programu Microsoft Office InfoPath nawiązuje połączenie z usługą sieci Web i żąda pliku Web Service Description Language (WSDL). Plik języka WSDL zawiera schematu używane przez usługę sieci Web. Usługa sieci Web odpowiada na żądanie, wysyłając ten plik do programu InfoPath. Program InfoPath używa informacji w tym pliku dodać odpowiednie pola i grupy do pomocnicze źródło danych w szablonie formularza. Jeśli program InfoPath znajdzie typu nieznany element w pliku WSDL, InfoPath używa przykładowych danych w celu określenia definicji typu nieznany element i następnie dodaje odpowiednich pól i grup pomocnicze źródło danych.

  9. Jeśli z zewnętrznego źródła danych wymienionego w ustawieniach pliku jest zwracany zestaw danych Microsoft ADO.NET, na następnej stronie kreatora pojawi się monit o wskazanie, czy do danych wysyłanych przez użytkowników mają być dołączane informacje o zmianach. Najczęściej należy pozostawić zaznaczone pole wyboru Uwzględnij informacje o zmianach podczas przesyłania danych i kliknąć przycisk Dalej. Jeśli informacje o zmianach nie mają być przesyłane, należy wyczyścić pole wyboru Uwzględnij informacje o zmianach podczas przesyłania danych i kliknąć przycisk Dalej.

    Szczegóły techniczne

    Ta strona kreatora jest wyświetlana tylko wtedy, gdy ustawienia w pliku połączeń odnoszą się do usługi sieci Web, a ustawienia pliku WSDL (Web Service Description Language) dla tej usługi powodują zwracanie z niej zestawu danych ADO.NET.

  10. Na następnej stronie kreatora wpisz nazwę połączenia danych, a następnie kliknij przycisk Zakończ.

Krok 2: Dodawanie formantu umożliwiającego wyświetlanie danych zawartych w polu

  1. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  2. Przeciągnij formant na szablon formularza.

  3. W oknie dialogowym Powiązanie formantu zaznacz pole, z którym ma być powiązany formant.

Początek strony

Projektowanie szablonu formularza z połączeniem danych służącym do przesyłania danych

Jeśli plik połączenia danych zawiera ustawienia połączenia służącego do przesyłania danych, można tak skonfigurować szablon formularza, aby umożliwić użytkownikom wysyłanie zawartości formularza przez to połączenie. Wówczas program InfoPath doda przycisk Prześlij do paska narzędzi Standardowy i polecenie Prześlij do menu Plik. Opcje przesyłania danych z formularza można konfigurować w oknie dialogowym Opcje przesyłania (menu Narzędzia). Sposób konfiguracji jest taki sam, jak w przypadku projektowania szablonu formularza na podstawie bazy danych lub usługi sieci Web. W sekcji Zobacz też znajdują się dodatkowe łącza do informacji na temat projektowania szablonów formularzy na podstawie baz danych i usług sieci Web.

  1. W menu Plik kliknij polecenie Projektuj szablon formularza.

  2. W obszarze Projektuj nowy w oknie dialogowym Projektowanie szablonu formularza kliknij opcję Szablon formularza.

  3. Na liście Na podstawie kliknij opcję Biblioteka połączeń.

  4. W przypadku projektowania szablonu formularza zgodnego z przeglądarkami należy zaznaczyć pole wyboru Włącz tylko funkcje zgodne z przeglądarką.

  5. Kliknij przycisk OK.

  6. W Kreatorze połączenia danych na liście Witryna kliknij nazwę witryny umieszczonej na serwerze z uruchomionym programem Office SharePoint Server 2007, w której znajduje się biblioteka połączeń.

    Dodawanie witryny do listy

    1. Kliknij przycisk Zarządzaj witrynami.

    2. W oknie dialogowym Zarządzanie witrynami kliknij przycisk Dodaj.

    3. W polu adres URL wpisz lokalizację biblioteki połączeń danych.

    4. W polu Nazwa wyświetlana wpisz nazwę biblioteki połączeń danych. Ta nazwa będzie wyświetlana na liście w Kreatorze połączenia danych.

    5. Kliknij przycisk OK.

    6. Kliknij przycisk Zamknij.

  7. Kliknij nazwę biblioteki połączeń danych, aby wyświetlić listę plików połączeń danych, kliknij nazwę pliku połączenia danych, który ma być używany dla tego połączenia danych, a następnie kliknij przycisk Dalej.

  8. W przypadku zaznaczenia pliku połączenia danych zawierającego ustawienia połączenia z usługą sieci Web na następnej stronie kreatora może pojawić się monit o podanie przykładowych wartości wszystkich parametrów. Ma to na celu ustalenie, które pola lub grupy powinny zostać dodane do pomocniczego źródła danych.

    Jak?

    1. Wybierz parametr w tabeli Parametry, a następnie kliknij Ustaw przykładową wartość.

    2. W polu wartość próbki wpisz wartość, że użytkownika może użyć dla tego pola, a następnie kliknij przycisk OK.

    3. Powtórz te czynności dla każdego parametru w tabeli Parametry, a następnie kliknij przycisk Dalej.

    Szczegóły techniczne

    Po skonfigurowaniu połączenia danych z usługi sieci Web w Kreatorze połączenia danych programu Microsoft Office InfoPath nawiązuje połączenie z usługą sieci Web i żąda pliku Web Service Description Language (WSDL). Plik języka WSDL zawiera schematu używane przez usługę sieci Web. Usługa sieci Web odpowiada na żądanie, wysyłając ten plik do programu InfoPath. Program InfoPath używa informacji w tym pliku dodać odpowiednie pola i grupy do pomocnicze źródło danych w szablonie formularza. Jeśli program InfoPath znajdzie typu nieznany element w pliku WSDL, InfoPath używa przykładowych danych w celu określenia definicji typu nieznany element i następnie dodaje odpowiednich pól i grup pomocnicze źródło danych.

  9. Na następnej stronie kreatora wprowadź opisową nazwę połączenia danych, a następnie kliknij przycisk Zakończ.

Początek strony

Uwaga: Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×