Projektowanie szablonu formularza powiązanego z usługą sieci Web

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Komunikacja szablonu formularza z usługą sieci Web może polegać na wysyłaniu do niej kwerend o dane, przesyłaniu danych do usługi lub wykonywaniu obu tych operacji.

W tym artykule

Omówienie

Informacje dotyczące zgodności

Przed rozpoczęciem

Projektowanie szablonu formularza za pomocą kwerendy połączenia danych

Projektowanie szablonu formularza z połączenia przesyłania danych

Projektowanie szablonu formularza z kwerendy i przesyłanie połączeń danych

Omówienie

W ustawieniach formularza można zdefiniować jedno nadrzędne połączenie danych (nazywane „głównym połączeniem danych”) i jedno lub więcej opcjonalnych pomocniczych połączeń danych. Zależnie od przeznaczenia formularza połączenie danych może służyć do wykonywania kwerend w zewnętrznym źródle danych (na przykład w bazie danych programu Microsoft SQL Server czy w usłudze sieci Web) albo do wysyłania danych do tego źródła.

Podczas projektowania szablonu formularza, oparty na usłudze sieci Web, dostępne są następujące opcje konfigurowania szablonu formularza umożliwia formularzy opartych na tym szablonie formularza, aby pobieranie danych z, Wyślij dane, lub wysyłać i odbierać dane do i z usługi sieci Web. W przypadku projektowania szablonu formularza, aby umożliwić formularzy w celu odbioru danych z usługi sieci Web, program Microsoft Office InfoPath tworzy połączenie danych kwerendy jako głównego połączenia danych w formularzu. W zależności od tego połączenia danych, InfoPath tworzy głównym źródło danych z pól kwerendy, pól i grup, które są oparte na schemat XML usługi sieci Web. Pola kwerendy zawierają dane, które usługa sieci Web komunikuje Aby ustalić, co do wysłania do formularza. Użycie głównego połączenia danych, formularze oparte na tym szablonie formularza programu InfoPath tworzy kwerendę przy użyciu danych w polach kwerendy. Program InfoPath przesyła zapytania przez połączenie danych kwerendy do usługi sieci Web. Usługa sieci Web zwraca wyniki kwerendy powrót do formularza za pomocą kwerendy połączenia danych.

Ponieważ struktura danych pól kwerendy i danych musi odpowiadać układowi składowania danych w usłudze sieci Web, samodzielne modyfikowanie istniejących pól i grup głównego źródła danych jest zabronione. Dopuszcza się jedynie dodawanie pól i grup na poziomie głównej grupy źródła. W sekcji Zobacz też znajdują się łącza do dodatkowych informacji na temat źródeł danych.

W wariancie wysyłania danych do usługi sieci Web program InfoPath tworzy w ustawieniach głównego połączenia danych połączenie służące do przesyłania danych. Za jego pośrednictwem użytkownicy będą mogli wysyłać dane wprowadzane przez siebie w formularzu do usługi sieci Web. Ponadto w oknie formularza do menu Plik program dodaje polecenie Prześlij, a na pasku narzędzi Standardowy aktywuje przycisk Prześlij. Opcje przesyłania danych można dostosowywać. Podczas konfigurowania połączenia służącego do przesyłania danych program InfoPath identyfikuje parametry w usłudze sieci Web mogące odbierać dane. W oparciu o te informacje użytkownik może wskazać pola, z których wartości będą przekazywane do usługi sieci Web.

W wariancie wysyłania danych do usługi sieci Web i pobierania z niej danych program InfoPath tworzy zarówno połączenie służące do wykonywania kwerend, jak i połączenie służące do przesyłania danych.

Do nawiązywania połączeń z usługami sieci Web program InfoPath stosuje następujące protokoły usług:

  • Protokół SOAP (Simple Object Access Protocol)     SOAP to protokół komunikacyjny określający treść komunikatów XML używanych w komunikacji z usługami sieci Web.

  • WSDL (Web Services Description Language)     WSDL to standard schematów XML określający położenie usług sieci Web oraz protokoły i interfejsy komunikacji z tymi usługami. Program InfoPath może współpracować wyłącznie z usługami sieci Web korzystającymi z kodowania dokument/literał.

  • UDDI (Universal Description Discovery and Integration)     UDDI to usługa katalogowa opisująca usługi sieci Web oferowane przez firmy.

Początek strony

Zgodność

Nie można skonfigurować połączenia przesyłania danych w szablon formularza zgodny z przeglądarką, aby umożliwić użytkownikom przesyłanie informacji o zmianach wraz z danymi formularza do usługi sieci Web akceptującej standard Microsoft ADO.NET DataSet. Informacje o zmianach obejmują wprowadzane przez użytkownika modyfikacje danych przechowywanych w bazie danych. Do łączenia użytkowników z bazą danych jest używana usługa sieci Web. W składniku ADO.NET na podstawie informacji o zmianach jest określany sposób aktualizacji danych w bazie danych. Informacje, czy usługa sieci Web wymaga informacji o zmianie w celu zaktualizowania bazy danych można uzyskać u administratora usługi. Jeśli tak, należy zaprojektować szablon formularza, którego formularze można wypełniać tylko przy użyciu programu InfoPath.

Początek strony

Przed rozpoczęciem

Przed rozpoczęciem konstruowania szablonu formularza związanego z usługą sieci Web należy uzyskać od administratora usługi sieci Web następujące informacje:

  • Lokalizacja usługi sieci Web.

  • Weryfikacja stosowania przez usługę sieci Web stylu kodowania dokument/literał. Program InfoPath może korzystać tylko ze stylu kodowania dokument/literał.

  • Nazwa operacji usługi sieci Web, która będzie powodowała wysyłanie danych do formularzy opartych na tym szablonie formularza lub pobieranie danych z takich formularzy.

Początek strony

Projektowanie szablonu formularza z połączeniem danych służącym do wykonywania kwerend

Aby zaprojektować szablon formularza z połączeniem danych kwerendy, należy wykonać następujące czynności:

  1. Utworzenie szablonu formularza     Podczas konfigurowania szablonu formularza mogącego przyjmować dane z usługi sieci Web program InfoPath tworzy między usługą a szablonem główne połączenie danych służące do wykonywania kwerend. Ponadto generuje główne źródło danych szablonu.

  2. Dodawanie jednego lub więcej kontrolek w celu wyświetlania wyników kwerendy    Aby użytkownicy mogli wyświetlać i edytować dane w polach głównego źródła danych, po otwarciu formularza, można dodać formant do szablonu formularza i następnie powiązać tego formantu z polem w źródle danych głównym.

Krok 1: Tworzenie szablonu formularza

  1. W menu Plik kliknij polecenie Projektuj szablon formularza.

  2. W obszarze Projektuj nowy w oknie dialogowym Projektowanie szablonu formularza kliknij opcję Szablon formularza.

  3. Na liście Na podstawie kliknij opcję Usługa sieci Web.

  4. Jeżeli projektowany jest szablon formularza zgodny z przeglądarką, należy zaznaczyć pole wyboru Włącz tylko funkcje zgodne z przeglądarką.

  5. Kliknij przycisk OK.

  6. W Kreatorze połączenia danych kliknij opcję Odbierz dane, a następnie kliknij przycisk Dalej.

  7. Na następnej stronie kreatora wpisz lokalizację usługi sieci Web, a następnie kliknij przycisk Dalej.

    Jeśli chcesz wyszukać usługi sieci Web przy użyciu serwera uniwersalnej odnajdowanie opis i Integration (UDDI), kliknij przycisk Przeszukaj ZASOBY, wprowadź adres URL serwera UDDI, który chcesz przeszukać, określ, czy chcesz przeszukać przez dostawcę lub usługi, wpisz słowo kluczowe wyszukiwania, a następnie kliknij wyszukiwania. Usługi sieci Web, które są zgodne z słowo kluczowe wyszukiwania pojawią się na liście wyników wyszukiwania. Wybierz usługę sieci Web, którego chcesz użyć, a następnie kliknij przycisk OK.

  8. Na liście Wybierz operację kliknij operację usługi sieci Web zwracającą dane do formularza, a następnie kliknij przycisk Dalej.

  9. Jeśli Kreator połączenia danych napotka nieznany element w schemacie usługi sieci Web, na następnej stronie kreatora może się pojawić monit o podanie przykładowych wartości dla każdego parametru. Ma to na celu ustalenie, które pola lub grupy powinny zostać dodane do głównego źródła danych.

    Jak to zrobić?

    1. Wybierz parametr w tabeli Parametry, a następnie kliknij Ustaw przykładową wartość.

    2. W polu wartość próbki wpisz wartość, że użytkownika może użyć dla tego pola, a następnie kliknij przycisk OK.

    3. Powtórz te czynności dla każdego parametru w tabeli Parametry, a następnie kliknij przycisk Dalej.

    Szczegóły techniczne

    Po skonfigurowaniu połączenia danych z usługi sieci Web w Kreatorze połączenia danych programu Microsoft Office InfoPath nawiązuje połączenie z usługą sieci Web i żąda pliku Web Service Description Language (WSDL). Plik języka WSDL zawiera schematu używane przez usługę sieci Web. Usługa sieci Web odpowiada na żądanie, wysyłając ten plik do programu InfoPath. Program InfoPath używa informacji w tym pliku dodać odpowiednie pola i grupy do pomocnicze źródło danych w szablonie formularza. Jeśli program InfoPath znajdzie typu nieznany element w pliku WSDL, InfoPath używa przykładowych danych w celu określenia definicji typu nieznany element i następnie dodaje odpowiednich pól i grup pomocnicze źródło danych.

  10. Jeżeli usługa sieci Web akceptuje informacje o zmianach, na następnej stronie kreatora zostanie wyświetlony monit o to, czy w danych kwerendy mają być uwzględniane informacje o zmianach. W większości przypadków należy pozostawić zaznaczone pole wyboru Uwzględnij informacje o zmianach podczas przesyłania danych, a następnie kliknąć przycisk Dalej. Jeżeli informacje o zmianach nie mają być uwzględniane, należy wyczyścić pole wyboru Uwzględnij informacje o zmianach podczas przesyłania danych, a następnie kliknąć przycisk Dalej.

    W przypadku projektowania szablonu formularza zgodnego z przeglądarkami sieci Web to pole wyboru jest wyczyszczone.

    Szczegóły techniczne

    Ta strona kreatora jest wyświetlana tylko wtedy, gdy plik Web Services Description Language (WSDL) dla usługi sieci Web wskazuje, że zwraca ona zestaw danych Microsoft ADO.NET.

  11. Na następnej stronie kreatora wpisz nazwę połączenia danych.

  12. Zweryfikuj poprawność informacji w sekcji Podsumowanie, a następnie kliknij przycisk Zakończ.

Krok 2: Dodanie jeden lub więcej formantów, aby wyświetlić wyniki kwerendy

  1. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  2. Przeciągnij formant na szablon formularza.

  3. W oknie dialogowym Powiązanie formantu zaznacz grupę lub pole, które chcesz powiązać kontrolkę.

Początek strony

Projektowanie szablonu formularza z połączeniem danych służącym do przesyłania danych

Aby zaprojektować formularz z połączeniem danych służącym do przesyłania danych, należy wykonać następujące czynności:

  1. Utworzenie szablonu formularza     Podczas konfigurowania szablonu formularza mogącego wysyłać dane do usługi sieci Web program InfoPath tworzy między usługą a szablonem główne połączenie danych służące do przesyłania danych. Ponadto generuje główne źródło danych szablonu.

  2. Dodaj co najmniej jeden controlsand powiązanie ich do grup lub pól lub ustawić właściwości kontrolki w celu wyświetlania danych w polu    Aby zezwolić użytkownikom na edytowanie danych w polach głównego źródła danych, można dodać formanty do szablonu formularza i następnie powiązać formanty te pola w głównym źródle danych.

  3. Konfigurowanie opcji przesyłania    Możliwe jest skonfigurowanie danych, które są przesyłane do usługi sieci Web i opcji przesyłania dla formularza.

Krok 1: Tworzenie szablonu formularza

  1. W menu Plik kliknij polecenie Projektuj szablon formularza.

  2. W obszarze Projektuj nowy w oknie dialogowym Projektowanie szablonu formularza kliknij opcję Szablon formularza.

  3. Na liście Na podstawie kliknij opcję Usługa sieci Web.

  4. Jeżeli projektowany jest szablon formularza zgodny z przeglądarką, należy zaznaczyć pole wyboru Włącz tylko funkcje zgodne z przeglądarką.

  5. Kliknij przycisk OK.

  6. W Kreatorze połączenia danych kliknij opcję Prześlij dane, a następnie kliknij przycisk Dalej.

  7. Na następnej stronie kreatora wpisz lokalizację usługi sieci Web, do której użytkownicy będą przesyłać dane, i kliknij przycisk Dalej.

    Jeśli chcesz wyszukać usługi sieci Web przy użyciu serwera uniwersalnej odnajdowanie opis i Integration (UDDI), kliknij przycisk Przeszukaj ZASOBY, wprowadź adres URL serwera UDDI, który chcesz przeszukać, określ, czy chcesz przeszukać przez dostawcę lub usługi, wpisz słowo kluczowe wyszukiwania, a następnie kliknij wyszukiwania. Usługi sieci Web, które są zgodne z słowo kluczowe wyszukiwania pojawią się na liście wyników wyszukiwania. Wybierz usługę sieci Web, którego chcesz użyć, a następnie kliknij przycisk OK.

  8. Kliknij przycisk Dalej.

  9. Na liście Wybierz operację zaznacz operację usługi sieci Web, która będzie powodowała pobieranie wysyłanych informacji, i kliknij przycisk Dalej.

  10. Na następnej stronie kreatora wpisz nazwę połączenia danych.

  11. Zweryfikuj poprawność informacji w sekcji Podsumowanie, a następnie kliknij przycisk Zakończ.

Krok 2: Dodawanie jednego lub kilku formantów i powiązać je z grup lub pól

  1. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  2. Przeciągnij formant na szablon formularza.

  3. W oknie dialogowym Powiązanie formantu zaznacz grupę lub pole, które chcesz powiązać kontrolkę.

  4. Powtórz kroki 2 i 3 dla pozostałych kontrolek, które chcesz dodać do szablonu formularza.

Krok 3. Konfigurowanie opcji przesyłania

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych w ustawieniach głównego połączenia danych zaznacz połączenie służące do wysyłania danych i kliknij przycisk Modyfikuj.

  3. W oknie Kreatora połączenia danych kliknij dwa kolejne przyciski Dalej.

  4. Na następnej stronie kreatora wskaż dane formularza, które mają być przesyłane dla każdego parametru usługi sieci Web. W tym celu wykonaj jedną z następujących czynności:

    Przesyłanie danych do pola lub grupy

    1. Na liście Parametry kliknij parametr usługi sieci Web, która będzie odbierać dane z formularza.

    2. W obszarze Opcje parametru kliknij pozycję Pole lub grupa.

    3. Kliknij przycisk Modyfikuj Obraz przycisku .

    4. W oknie dialogowym Wybieranie pola lub grupy kliknij pole lub grupę, których dane chcesz przesyłać, a następnie kliknij przycisk OK.

    5. W polu Dołącz kliknij pozycję Tylko tekst i elementy podrzędne, aby przesyłać tylko dane z tego pola i elementy podrzędne pola lub grupy, albo kliknij pozycję Poddrzewo XML, włącznie z zaznaczonym elementem, aby przesyłać nazwę pola, dane z pola i elementy podrzędne w wybranej grupie lub polu.

    Przesyłanie wszystkich danych w formularzu

    1. Na liście Parametry kliknij parametr usługi sieci Web, która będzie odbierać dane z formularza.

    2. W obszarze Opcje parametrów kliknij cały formularz (dokument XML włącznie z instrukcjami przetwarzania).

    Przesyłanie danych w postaci ciągu

    1. Na liście Parametry kliknij parametr usługi sieci Web, która będzie odbierać dane z formularza.

    2. W obszarze Opcje parametrów kliknij cały formularz (dokument XML włącznie z instrukcjami przetwarzania).

    3. Zaznacz pole wyboru Prześlij dane jako ciąg.

      Uwaga : Najczęściej to pole wyboru jest zaznaczane w celu przesłania danych podpisanych cyfrowo. W większości przypadków należy wyczyścić to pole wyboru.

    Szczegółowe informacje techniczne dotyczące zestawu danych ADO.NET obiektów

    Jeśli usługa sieci Web wymaga obiektu zestawu danych ADO.NET, podczas konfigurowania połączenia danych należy zaznaczyć węzeł zestawu danych. Użycie jakiegokolwiek innego typu węzła dla połączenia danych z usługą sieci Web wymagającą takiego obiektu spowoduje niepowodzenie operacji przesyłania danych.

  5. Kliknij przycisk Dalej.

  6. Kliknij przycisk Zakończ.

  7. Kliknij przycisk Zamknij.

  8. W menu Narzędzia kliknij polecenie Opcje przesyłania.

    1. Aby zmienić nazwę przycisk Prześlij, który pojawia się na pasku narzędzi Standardowy, a polecenie Prześlij, który pojawia się w menu plik, podczas wypełniania formularza, wpisz nową nazwę w polu Podpis w oknie dialogowym Opcje przesyłania.

      Jeśli chcesz przypisać skrót klawiaturowy do tego przycisku i polecenia, wpisz handlowe "i" (&) przed znakiem, który ma być używany jako skrót klawiaturowy. Na przykład aby przypisać klawisze ALT + B, jako skrót klawiaturowy dla przycisku Prześlij i polecenia, wpisz & przycisk Prześlij.

  9. Jeśli nie chcesz używać polecenia Prześlij lub przycisk Zatwierdź na pasku narzędzi Standardowy, podczas wypełniania formularza użytkownicy, wyczyść pole wyboru Pokaż polecenie Prześlij i przycisk Prześlij.

    1. Domyślnie po użytkownikom przesyłanie formularzy programu InfoPath zachowuje formularz otwarty i zostanie wyświetlony komunikat, aby wskazać, jeśli formularz został pomyślnie przesłany. Aby zmienić to zachowanie domyślne, kliknij przycisk Zaawansowane, a następnie wykonaj jedną z następujących czynności:

      1. Aby zamknąć formularz lub Utwórz nowy pusty formularz po przesłaniu wypełniony formularz, kliknij opcję, która ma na liście po przesyłanie.

      2. Aby utworzyć niestandardowe wiadomości, który wskazuje, jeśli formularz został pomyślnie przesłany, zaznacz pole wyboru Użyj niestandardowych wiadomości, a następnie wpisz wiadomości w polach w przypadku powodzenia i niepowodzenia.

        Poinstruuj użytkowników za pomocą wiadomości w polu w przypadku awarii co należy zrobić, jeśli nie można ich przesłać formularz. Na przykład można sugerują, że użytkownicy zapisywać formularze i skontaktować się z osobą Aby uzyskać dodatkowe instrukcje.

      3. Jeśli nie chcesz wyświetlać wiadomości, gdy użytkownik przesyła formularz, wyczyść pole wyboru Pokaż sukcesów i porażek wiadomości.

Początek strony

Projektowanie szablonu formularza z połączeniami służącymi do wykonywania kwerend i przesyłania danych

Aby zaprojektować szablon formularza z oboma typami połączeń (do wykonywania kwerend i przesyłania danych), należy wykonać następujące czynności:

  1. Utworzenie szablonu formularza     Podczas konfigurowania szablonu formularza mogącego pobierać dane z usługi sieci Web i je do niej wysyłać, program InfoPath tworzy między usługą a szablonem główne połączenie danych zawierające zarówno połączenia służące do wykonywania kwerend, jak i do przesyłania danych. Ponadto generuje główne źródło danych szablonu.

  2. Dodanie formantu i powiązanie go z polem w celu wyświetlania danych w tym polu     Aby użytkownicy mogli wyświetlać i edytować zawartość pól głównego źródła danych, można dodać do szablonu odpowiednie formanty, po czym powiązać je z polami źródła danych.

  3. Konfigurowanie opcji przesyłania    Możliwe jest skonfigurowanie danych, które są przesyłane do usługi sieci Web i opcji przesyłania dla formularza.

Krok 1: Tworzenie szablonu formularza

  1. W menu Plik kliknij polecenie Projektuj szablon formularza.

  2. W obszarze Projektuj nowy okna dialogowego Projektuj formularz kliknij opcję Szablon formularza.

  3. Na liście Na podstawie kliknij opcję Usługa sieci Web.

  4. Jeżeli projektowany jest szablon formularza zgodny z przeglądarką, należy zaznaczyć pole wyboru Włącz tylko funkcje zgodne z przeglądarką.

  5. Kliknij przycisk OK.

  6. W Kreatorze połączenia danych zaznacz opcję Odbierz i prześlij dane, po czym kliknij przycisk Dalej.

  7. Na następnej stronie kreatora wpisz lokalizację usługi sieci Web zawierającej w swoich ustawieniach operację, która będzie powodowała wysyłanie danych do formularza, i kliknij przycisk Dalej.

    Jeśli chcesz wyszukać usługi sieci Web przy użyciu serwera uniwersalnej odnajdowanie opis i Integration (UDDI), kliknij przycisk Przeszukaj ZASOBY, wprowadź adres URL serwera UDDI, który chcesz przeszukać, określ, czy chcesz przeszukać przez dostawcę lub usługi, wpisz słowo kluczowe wyszukiwania, a następnie kliknij wyszukiwania. Usługi sieci Web, które są zgodne z słowo kluczowe wyszukiwania pojawią się na liście wyników wyszukiwania. Wybierz usługę sieci Web, którego chcesz użyć, a następnie kliknij przycisk OK.

  8. Na liście Wybierz operację kliknij operację usługi sieci Web zwracającą dane do formularza, a następnie kliknij przycisk Dalej.

  9. Jeżeli Kreator łączenia danych napotka na nieznany element w schemacie usługi sieci Web, na następnej stronie kreatora może pojawić się monit o podanie wartości przykładowych dla każdego parametru w celu określenia pól lub grup, które mają być dodane do głównego źródła danych.

    Jak to zrobić?

    1. Wybierz parametr w tabeli Parametry, a następnie kliknij Ustaw przykładową wartość.

    2. W polu wartość próbki wpisz wartość, że użytkownika może użyć dla tego pola, a następnie kliknij przycisk OK.

    3. Powtórz te czynności dla każdego parametru w tabeli Parametry, a następnie kliknij przycisk Dalej.

    Szczegóły techniczne

    Po skonfigurowaniu połączenia danych z usługi sieci Web w Kreatorze połączenia danych programu Microsoft Office InfoPath nawiązuje połączenie z usługą sieci Web i żąda pliku Web Service Description Language (WSDL). Plik języka WSDL zawiera schematu używane przez usługę sieci Web. Usługa sieci Web odpowiada na żądanie, wysyłając ten plik do programu InfoPath. Program InfoPath używa informacji w tym pliku dodać odpowiednie pola i grupy do pomocnicze źródło danych w szablonie formularza. Jeśli program InfoPath znajdzie typu nieznany element w pliku WSDL, InfoPath używa przykładowych danych w celu określenia definicji typu nieznany element i następnie dodaje odpowiednich pól i grup pomocnicze źródło danych.

  10. Jeśli usługa sieci Web akceptuje informacje o zmianach, na następnej stronie kreatora pojawi się monit o wskazanie, czy informacje te mają się znaleźć w danych kwerendy. Najczęściej należy pozostawić zaznaczone pole wyboru Uwzględnij informacje o zmianach podczas przesyłania danych i kliknąć przycisk Dalej. Jeśli informacje o zmianach nie mają być przesyłane, należy wyczyścić topole wyboru i kliknąć przycisk Dalej.

    W przypadku projektowania szablonu formularza zgodnego z przeglądarkami sieci Web to pole wyboru jest wyłączone.

    Szczegóły techniczne

    Ta strona kreatora jest wyświetlana tylko wtedy, gdy ustawienia pliku Web Services Description Language (WSDL) usługi sieci Web powodują zwracanie z tej usługi zestawu danych ADO.NET.

  11. Na następnej stronie kreatora wpisz nazwę połączenia danych służącego do wykonywania kwerend i kliknij przycisk Dalej.

  12. Na następnej stronie kreatora wpisz lokalizację usługi sieci Web, do której użytkownicy będą przesyłać formularze, a następnie kliknij przycisk Dalej.

    Jeśli chcesz wyszukać usługi sieci Web przy użyciu serwera uniwersalnej odnajdowanie opis i Integration (UDDI), kliknij przycisk Przeszukaj ZASOBY, wprowadź adres URL serwera UDDI, który chcesz przeszukać, określ, czy chcesz przeszukać przez dostawcę lub usługi, wpisz słowo kluczowe wyszukiwania, a następnie kliknij wyszukiwania. Usługi sieci Web, które są zgodne z słowo kluczowe wyszukiwania pojawią się na liście wyników wyszukiwania. Wybierz usługę sieci Web, którego chcesz użyć, a następnie kliknij przycisk OK.

  13. Na liście Wybierz operację zaznacz operację usługi sieci Web, która będzie powodowała pobieranie wysyłanych informacji, i kliknij przycisk Dalej.

  14. Na następnej stronie kreatora wskaż dane formularza, które mają być przesyłane dla każdego parametru usługi sieci Web. W tym celu wykonaj jedną z następujących czynności:

    Przesyłanie danych do pola lub grupy

    1. Na liście Parametry kliknij parametr usługi sieci Web, która będzie odbierać dane z formularza.

    2. W obszarze Opcje parametru kliknij pozycję Pole lub grupa.

    3. Kliknij przycisk Modyfikuj Obraz przycisku .

    4. W oknie dialogowym Wybieranie pola lub grupy kliknij pole lub grupę, których dane chcesz przesyłać, a następnie kliknij przycisk OK.

    5. W polu Dołącz kliknij pozycję Tylko tekst i elementy podrzędne, aby przesyłać tylko dane z tego pola i elementy podrzędne pola lub grupy, albo kliknij pozycję Poddrzewo XML, włącznie z zaznaczonym elementem, aby przesyłać nazwę pola, dane z pola i elementy podrzędne w wybranej grupie lub polu.

    Przesyłanie wszystkich danych w formularzu

    1. Na liście Parametry kliknij parametr usługi sieci Web, która będzie odbierać dane z formularza.

    2. W obszarze Opcje parametrów kliknij cały formularz (dokument XML włącznie z instrukcjami przetwarzania).

    Przesyłanie danych w postaci ciągu

    1. Na liście Parametry kliknij parametr usługi sieci Web, która będzie odbierać dane z formularza.

    2. W obszarze Opcje parametrów kliknij cały formularz (dokument XML włącznie z instrukcjami przetwarzania).

    3. Zaznacz pole wyboru Prześlij dane jako ciąg.

      Najczęściej to pole wyboru jest zaznaczane w celu przesłania danych podpisanych cyfrowo. W większości przypadków należy wyczyścić to pole wyboru.

    Szczegółowe informacje techniczne dotyczące zestawu danych ADO.NET obiektów

    Jeżeli usługa sieci Web wymaga obiektu zestawu danych ADO.NET, należy zaznaczyć węzeł zestawu danych podczas konfigurowania tego połączenia danych. Jeżeli dla połączenia danych z usługą sieci Web wymagającą zestawu danych ADO.NET użyty zostanie dowolny inny typ węzła, akcja przesyłania zakończy się błędem.

  15. Kliknij przycisk Dalej.

  16. Na następnej stronie kreatora wpisz nazwę połączenia danych służącego do przesyłania danych i kliknij przycisk Zakończ.

Krok 2: Dodanie formantu i powiązanie go z polem w celu wyświetlania danych w tym polu

  1. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  2. Przeciągnij formant na szablon formularza.

  3. W oknie dialogowym Powiązanie kontrolki wybierz pole, które chcesz powiązać kontrolkę.

Krok 3. Konfigurowanie opcji przesyłania

  1. W menu Narzędzia kliknij polecenie Opcje przesyłania.

    1. Aby zmienić nazwę przycisk Prześlij, który pojawia się na pasku narzędzi Standardowy, a polecenie Prześlij, który pojawia się w menu plik, podczas wypełniania formularza, wpisz nową nazwę w polu Podpis w oknie dialogowym Opcje przesyłania.

      Jeśli chcesz przypisać skrót klawiaturowy do tego przycisku i polecenia, wpisz handlowe "i" (&) przed znakiem, który ma być używany jako skrót klawiaturowy. Na przykład aby przypisać klawisze ALT + B, jako skrót klawiaturowy dla przycisku Prześlij i polecenia, wpisz & przycisk Prześlij.

  2. Jeśli nie należy używać polecenia Prześlij lub przycisk Zatwierdź na pasku narzędzi Standardowy, podczas wypełniania formularza użytkownicy, wyczyść pole wyboru Pokaż polecenie Prześlij i przycisk Prześlij.

    1. Domyślnie po użytkownikom przesyłanie formularzy programu InfoPath zachowuje formularz otwarty i zostanie wyświetlony komunikat, aby wskazać, jeśli formularz został pomyślnie przesłany. Aby zmienić to zachowanie domyślne, kliknij przycisk Zaawansowane, a następnie wykonaj jedną z następujących czynności:

      • Aby zamknąć formularz lub Utwórz nowy pusty formularz po przesłaniu wypełniony formularz, kliknij opcję, która ma na liście po przesyłanie.

      • Aby utworzyć niestandardowe wiadomości, który wskazuje, jeśli formularz został pomyślnie przesłany, zaznacz pole wyboru Użyj niestandardowych wiadomości, a następnie wpisz wiadomości w polach w przypadku powodzenia i niepowodzenia.

        Poinstruuj użytkowników za pomocą wiadomości w polu w przypadku awarii co należy zrobić, jeśli nie można ich przesłać formularz. Na przykład można sugerują, że użytkownicy zapisywać formularze i skontaktować się z osobą Aby uzyskać dodatkowe instrukcje.

      • Jeśli nie chcesz wyświetlać wiadomości, gdy użytkownik przesyła formularz, wyczyść pole wyboru Pokaż sukcesów i porażek wiadomości.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×