Projektowanie szablonu formularza powiązanego z bazą danych programu Microsoft SQL Server

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Komunikacja szablonu formularza z bazą danych programu Microsoft SQL Server może polegać na wysyłaniu do niej kwerend o dane lub wysyłaniu kwerend i przesyłaniu danych.

W tym artykule

Omówienie

Informacje dotyczące zgodności

Przed rozpoczęciem

Projektowanie szablonu formularza

Skonfiguruj opcje przesyłania

Omówienie

W ustawieniach formularza można zdefiniować jedno nadrzędne połączenie danych (nazywane „głównym połączeniem danych”) i jedno lub więcej opcjonalnych pomocniczych połączeń danych. Zależnie od przeznaczenia formularza połączenie danych może służyć do wykonywania kwerend w zewnętrznym źródle danych (na przykład w bazie danych programu Microsoft SQL Server czy w usłudze sieci Web) albo do wysyłania danych do tego źródła.

Podczas projektowania szablonu formularza, oparty na bazie danych programu Microsoft Office InfoPath tworzy głównym źródło danych z grupami, które zawierają pól kwerendy i pól danych i kwerendy połączenia danych jako głównego połączenia danych dla szablonu formularza. Te pola i grupy odpowiadają tak, że dane są przechowywane w tabelach w bazie danych. Pola kwerendy zawierają dane wprowadzone przez użytkownika, aby ograniczyć wyniki kwerendy do rekordów, które spełniają dane z pól kwerendy. Gdy formularz oparty na tym szablonie formularza używa głównego połączenia danych, InfoPath tworzy kwerendy przy użyciu danych w polach kwerendy. Program InfoPath przesyła zapytania przez połączenie danych kwerendy. Baza danych zwraca wyniki kwerendy powrót do formularza za pomocą kwerendy połączenia danych. Wyniki kwerendy są umieszczane w polach danych, które mogą być edytowane za pomocą kontrolek, które są związane z tych pól.

Ponieważ struktura danych pól kwerendy i danych musi odpowiadać układowi składowania informacji w bazie danych, samodzielne modyfikowanie pól i grup głównego źródła danych jest zabronione. Dopuszcza się jedynie dodawanie pól i grup na poziomie głównej grupy źródła. W sekcji Zobacz też znajdują się łącza do dodatkowych informacji na temat źródeł danych.

Formularz może przesyłać dane do bazy danych za pomocą formularza głównego połączenia z danymi, jeśli formularz oparty na szablonie formularza i baza danych nie spełnia następujące wymagania:

  • Szablon formularza jest nie szablonu formularza zgodnego z przeglądarkami    W przypadku projektowania szablonu formularza zgodnego z przeglądarkami programu InfoPath nie utworzy połączenia przesyłania danych w głównego połączenia danych. Aby umożliwić użytkownikom przesyłanie danych w formularzu, który jest oparty na szablonie formularza zgodnego z przeglądarkami, za pomocą usługi sieci Web, działającego w programie bazy danych.

  • Lewa tabela w każdej pary tabel powiązanych w głównym źródle danych zawiera klucz podstawowy    Co najmniej jeden z relacji dla każdej pary powiązanych tabel może zawierać klucz podstawowy z tabeli po lewej stronie.

  • Brak pól danych w źródle danych głównym magazynie formularza typu dużych danych binarnych    Program InfoPath powoduje wyłączenie połączenia przesyłania danych, jeśli kwerenda zawiera pola, które mogą zawierać typu dużych danych binarnych, takich jak obrazy, obrazy, OLE obiektów, plików załączników, typ danych Nota Office Access lub typ danych tekst SQL.

Gdy program InfoPath skonfiguruje połączenie służące do przesyłania danych, użytkownicy zyskują możliwość wysyłania zawartości pól głównego źródła danych do bazy danych. Ponadto mogą dostosowywać opcje wysyłania w ustawieniach formularzy opartych na szablonie.

Początek strony

Zgodność

Podczas projektowania szablonu formularza powiązanego z bazą danych istnieje możliwość zaprojektowania szablon formularza zgodny z przeglądarką. Program InfoPath utworzy dla takiego szablonu główne połączenie danych o charakterze połączenia służącego do wykonywania kwerend. W szablonach zgodnych z przeglądarkami nie można jednak konfigurować połączeń służących do przesyłania informacji do baz danych, dlatego jeśli użytkownicy projektowanego formularza powiązanego z bazą danych programu SQL Server powinni wysyłać zawartość formularza do bazy za pośrednictwem głównego połączenia danych, formularz nie może być zgodny z przeglądarkami.

Początek strony

Przed rozpoczęciem

Przed rozpoczęciem projektowania szablonu formularza związanego z bazą danych programu SQL Server należy uzyskać od administratora bazy następujące informacje:

  • Nazwa serwera zawierającego bazę danych, z którą zostanie powiązany formularz.

  • Nazwa bazy danych, która będzie używana z tym szablonem formularza.

  • Uwierzytelnianie wymagane przez bazę danych. Do określenia sposobu uzyskiwania przez użytkowników dostępu do bazy danych może ona stosować uwierzytelnianie systemu Microsoft Windows lub uwierzytelnianie serwera SQL Server.

  • Nazwa tabeli zawierającej dane, które mają być wysyłane do formularza lub do której mają trafić dane z formularza. Jest to tabela podstawowa. Jeśli zamierzasz używać więcej niż jednej tabeli z bazy, będą potrzebne nazwy tych tabel podrzędnych. Należy również ustalić nazwy pól w tabelach podrzędnych, które są powiązane z polami tabeli podstawowej.

Początek strony

Projektowanie szablonu formularza

Aby zaprojektować szablon formularza z połączeniem danych kwerendy, należy wykonać następujące czynności:

  1. Utwórz szablon formularza     Podczas konfigurowania szablonu formularza związanego z bazą danych program InfoPath tworzy połączenie danych służące do wykonywania kwerend, które pełni rolę głównego połączenia danych między szablonem a bazą. W ramach tej czynności następuje automatyczne utworzenie głównego źródła danych szablonu formularza.

  2. Dodawanie jednego lub więcej kontrolek w celu wyświetlania wyników kwerendy    Aby użytkownicy mogli wyświetlać i edytować dane w polach głównego źródła danych, po otwarciu formularza, można dodać formant do szablonu formularza i następnie powiązać tego formantu z polem w źródle danych głównym.

Krok 1: Tworzenie szablonu formularza

  1. W menu Plik kliknij polecenie Projektuj szablon formularza.

  2. W obszarze Projektuj nowy w oknie dialogowym Projektowanie szablonu formularza kliknij opcję Szablon formularza.

  3. Na liście Na podstawie zaznacz pozycję Baza danych.

  4. Jeżeli projektowany jest szablon formularza zgodny z przeglądarką, należy zaznaczyć pole wyboru Włącz tylko funkcje zgodne z przeglądarką.

    Uwaga : Kreator połączenia danych nie włączy połączenia służącego do przesyłania danych w szablonie formularza zgodnego z przeglądarką. Aby umożliwić użytkownikom wysyłanie informacji do bazy danych z formularza opartego na szablonie zgodnym z przeglądarką, należy dodać pomocnicze połączenie danych prowadzące do usługi sieci Web współpracującej z bazą. W sekcji Zobacz też znajdują się łącza do dodatkowych informacji o pomocniczych połączeniach danych.

  5. Kliknij przycisk OK.

  6. W oknie Kreatora połączenia danych zaznacz opcję Wybierz bazę danych.

  7. W oknie dialogowym Wybierz źródło danych kliknij przycisk Nowe źródło.

  8. Na liście Z jakim rodzajem źródła danych chcesz się połączyć? kliknij opcję Microsoft SQL Server, a następnie kliknij przycisk Dalej.

  9. W polu Nazwa serwera wpisz nazwę serwera zawierającego bazę danych programu SQL Server.

  10. W obszarze Poświadczenia logowania wykonaj jedną z następujących czynności:

    • Jeżeli baza danych określa dostęp użytkowników na podstawie poświadczeń stosowanych w sieci Microsoft Windows, kliknij opcję Użyj uwierzytelniania systemu Windows.

    • Jeżeli baza danych określa dostęp użytkowników na podstawie podanej przez administratora określonej nazwy użytkownika i hasła, kliknij opcję Użyj następującej nazwy użytkownika i hasła, a następnie wpisz nazwę użytkownika i hasło w polach Nazwa użytkownika i Hasło.

  11. Kliknij przycisk Dalej.

  12. Na liście Wybierz bazę danych zawierającą żądane dane zaznacz nazwę bazy danych, której chcesz używać, zaznacz pole wyboru Połącz z określoną tabelą, zaznacz nazwę tabeli podstawowej, po czym kliknij przycisk Dalej.

  13. Na następnej stronie kreatora w polu Nazwa pliku wpisz nazwę pliku zawierającego informacje o połączeniu danych i kliknij przycisk Dalej. Wprowadzone ustawienia zostaną zapisane.

    Jeżeli planowane jest zastosowanie innych tabel w połączeniu danych kwerendy, na tej stronie kreatora można dodać pozostałe tabele.

    Jak to zrobić?

    1. Kliknij przycisk Dodaj tabelę.

    2. W oknie dialogowym Dodawanie tabeli lub kwerendy kliknij nazwę tabeli podrzędnej, a następnie kliknij przycisk Dalej. Program InfoPath próbuje ustawić relacje dopasowując nazwy pól w obu tabelach. Jeśli nie chcesz używać sugerowane relacji, wybierz relację, a następnie kliknij Usuwanie relacji. Aby dodać relację, kliknij pozycję Dodaj relację. W oknie dialogowym Dodaj relację kliknij nazwę każdego pola pokrewne w odpowiedniej kolumnie, a następnie kliknij przycisk OK.

    3. Kliknij przycisk Zakończ.

    4. W celu dodania kolejnych tabel podrzędnych powtórz wszystkie kroki.

  14. Kliknij przycisk Dalej.

  15. Na ostatniej stronie kreatora wpisz nazwę połączenia danych głównym. Ta nazwa będzie wyświetlana na liście źródła danych w okienku zadań Źródło danych.

  16. Szablon formularza, która spełnia wymagania w sekcji Omówienie , ta strona kreatora wskaże włączenia przesyłania połączenia danych w głównego połączenia danych programu InfoPath. Aby zmienić nazwę połączenia przesyłania danych, wpisz nową nazwę w odpowiednim polu. Jeśli chcesz użytkownikom przesyłanie ich danych formularza za pomocą przesyłania połączenia danych, która zostanie dodana do szablonu formularza później, kliknij przycisk Wyczyść pole wyboru Włącz przesyłanie dla tego połączenia.

    Uwaga : Jeśli szablon formularza nie spełnia wymagań w sekcji Omówienie , InfoPath wyłącza połączenia przesyłania danych i polu Wprowadź nazwę połączenia przesyłania i pole wyboru Włącz przesyłanie dla tego połączenia są niedostępne (wyłączone). Jeśli programu InfoPath wyłączy połączenia przesyłania danych, głównego połączenia danych dla szablonu formularza będą mieć tylko połączenia danych kwerendy.

Krok 2: Dodanie jeden lub więcej formantów, aby wyświetlić wyniki kwerendy

  1. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  2. Przeciągnij formant na szablon formularza.

  3. W oknie dialogowym Powiązanie kontrolki wybierz grupę lub pole, które chcesz powiązać kontrolkę.

Początek strony

Konfigurowanie opcji przesyłania

Jeśli szablonu formularza i tabele, które zostały wybrane w Kreatorze połączenia danych nie spełnia wymagań w sekcji Omówienie , InfoPath konfiguruje szablonu formularza w celu przesyłania danych przez połączenie danych głównym. Jeśli zdecydujesz się na użycie to połączenie danych przesyłania, InfoPath konfiguruje szablon formularza, tak aby użytkownicy mogą przesyłać dane o jego formularza do bazy danych i dodaje przycisk Zatwierdź na pasku narzędzi Standardowy, a polecenie Prześlij z menu plik, podczas wypełniania formularza. Program InfoPath konfiguruje również szablonu formularza tak, aby po użytkownikom przesyłanie formularzy, formularz pozostanie otwarty i zostanie wyświetlony komunikat użytkownikowi, który wskazuje, czy formularz został pomyślnie przesłany. Możesz zmienić tekst na przycisk Zatwierdź i działanie po przesłaniu formularza przez użytkownika.

  1. W menu Narzędzia kliknij polecenie Opcje przesyłania.

    1. Aby zmienić nazwę przycisk Prześlij, który pojawia się na pasku narzędzi Standardowy, a polecenie Prześlij, który pojawia się w menu plik, podczas wypełniania formularza, wpisz nową nazwę w polu Podpis w oknie dialogowym Opcje przesyłania.

      Porada : Jeśli chcesz przypisać skrót klawiaturowy do tego przycisku i polecenia, wpisz handlowe "i" (&) przed znakiem, który ma być używany jako skrót klawiaturowy. Na przykład aby przypisać klawisze ALT + B, jako skrót klawiaturowy dla przycisku Prześlij i polecenia, wpisz & przycisk Prześlij.

  2. Jeśli nie chcesz używać polecenia Prześlij lub przycisk Zatwierdź na pasku narzędzi Standardowy, podczas wypełniania formularza użytkownicy, wyczyść pole wyboru Pokaż polecenie Prześlij i przycisk Prześlij.

    1. Domyślnie po użytkownikom przesyłanie formularzy programu InfoPath zachowuje formularz otwarty i zostanie wyświetlony komunikat, aby wskazać, jeśli formularz został pomyślnie przesłany. Aby zmienić to zachowanie domyślne, kliknij przycisk Zaawansowane, a następnie wykonaj jedną z następujących czynności:

      • Aby zamknąć formularz lub Utwórz nowy pusty formularz po przesłaniu wypełniony formularz, kliknij opcję, która ma na liście po przesyłanie.

      • Aby utworzyć niestandardowe wiadomości, który wskazuje, jeśli formularz został pomyślnie przesłany, zaznacz pole wyboru Użyj niestandardowych wiadomości, a następnie wpisz wiadomości w polach w przypadku powodzenia i niepowodzenia.

        Porada : Poinstruuj użytkowników za pomocą wiadomości w polu w przypadku awarii co należy zrobić, jeśli nie można ich przesłać formularz. Na przykład można sugerują, że użytkownicy zapisywać formularze i skontaktować się z osobą Aby uzyskać dodatkowe instrukcje.

      • Jeśli nie chcesz wyświetlać wiadomości, gdy użytkownik przesyła formularz, wyczyść pole wyboru Pokaż sukcesów i porażek wiadomości.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×