Projektowanie szablonu formularza do używania w trybie offline

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W tym artykule

Opis formularzy w trybie offline

Tworzenie połączenia danych z bazą danych SQL w trybie offline

Tworzenie połączenia danych bazy danych programu Access w trybie offline

Tworzenie połączenia danych w bibliotece dokumentów programu SharePoint w trybie offline

Konfigurowanie dostępności danych

Wyłącz tryb offline

Opis formularzy w trybie offline

Może być konieczne projektowanie szablonu formularza programu Microsoft Office InfoPath, które użytkownicy mogą wypełniać podczas swój komputer jest połączony z siecią. Można na przykład zaprojektować szablon formularza, którego ubezpieczeniowych powierzchniowego można użyć w polu podczas roszczenia. Szablon formularza zawiera pomocniczych połączeń danych dostarczających dane do formularza z zewnętrznej bazy danych. Zasób dopasowany musi tych danych, aby wypełnić formularz. Podczas nadal w biurze i połączony z siecią, powierzchniowego ubezpieczenia można utworzyć formularz oparty na tym szablonie formularza, a następnie zapisz formularz na swoim komputerze. W polu Zasób dopasowany można otworzyć i wypełnij formularz bez połączenia z siecią. Po powrocie do pakietu office i ponowne połączenie z siecią, Zasób dopasowany następnie można przesłać formularz.

Domyślnie formularza zapisany na komputerze można pracować bez połączenia sieciowego. Gdy użytkownik utworzy formularz oparty na szablonie formularza, program InfoPath — pliki do pobrania i przechowuje kopię tego szablonu formularza na komputerze użytkownika. Przy każdym otwarciu formularza opartego na tym szablonie formularza programu InfoPath najpierw sprawdza, czy jest połączenie sieciowe na komputerze. Jeśli istnieje połączenie sieciowe, program InfoPath sprawdza lokalizację, w której szablon formularza pobranego z, aby ustalić, czy jest zaktualizowana wersja szablonu formularza. Jeśli istnieje zaktualizowanej wersji, program InfoPath aktualizuje szablonu formularza na komputerze użytkownika. Jeśli połączenie sieciowe nie istnieje, program InfoPath używa wersji szablonu formularza, który jest przechowywany na komputerze użytkownika.

Aby można było projektowanie szablonu formularza do używania w trybie offline, szablon formularza musi być przechowywany na komputerze użytkownika i wszystkie dane, które jest wymagane przez użytkownika jest wypełnienie formularza, takich jak elementy w polu listy muszą być dostępne dla użytkownika, nawet jeśli komputer nie jest połączony z siecią. Dane w tych formantach są dostarczane z pomocniczego połączenia danych do zewnętrznego źródła danych. Te dane mogą być przechowywane w komputerze użytkownika w szablonie formularza lub w lokalizacji przechowywania specjalne o nazwie pamięci podręcznej.

Po dodaniu pomocniczego połączenia danych do szablonu formularza danych kwerendy z zewnętrznego źródła danych, InfoPath wysyła kwerendy do tego źródła danych zewnętrznych. Wyniki kwerendy następnie są przechowywane w szablonie formularza. Gdy użytkownik tworzy nowy formularz oparty na tym szablonie formularza, dane zapisane w szablonie formularza są dostępne dla użytkownika.

Gdy formularz używa tego połączenia pomocniczego, aby zaktualizować zawartość pola listy lub formantu pola kombi przy użyciu najnowszych danych z zewnętrznego źródła danych, programu InfoPath są przechowywane wyniki kwerendy w lokalizacji przechowywania specjalne o nazwie pamięci podręcznej, jeśli komputer jest połączony z siecią. Program InfoPath używa danych w pamięci podręcznej dostarczać dane do tych kontrolek.

Aby udostępnić dane z pomocniczego połączenia danych wśród użytkowników, nawet jeśli ich komputery nie są połączone z siecią, możesz wykonać jedną lub obie z następujących czynności:

  • Przechowywanie danych z zewnętrznego źródła danych w szablonie formularza.

  • Po otwarciu formularza za pomocą pomocniczego połączenia danych.

Po skonfigurowaniu pomocniczego połączenia danych do pracy, gdy na komputerze użytkownika jest w trybie offline, można również skonfigurować szablon formularza, aby pobrać najnowsze dane z zewnętrznego źródła danych. Można skonfigurować szablon formularza, aby pobrać najnowszych danych (ograniczając dostępności istniejących danych w formularzu do określonej liczby dni), a następnie dodając przycisk umożliwiający uzyskanie najnowszych danych.

Przechowywanie danych w szablonie formularza

Dane z pomocniczego połączenia danych można przechowywać w szablonie formularza przez zaznaczenie pola wyboru Przechowaj kopię danych w szablonie formularza w Kreatorze połączenia danych, podczas tworzenia pomocniczego połączenia danych.

Okno dialogowe Kreator połączenia danych

Po zaznaczeniu tego pola wyboru program InfoPath używa połączenia danych do pobierania danych z zewnętrznego źródła danych. Następnie zapisuje je w szablonie formularza. Gdy użytkownik tworzy formularz lub otwiera istniejący formularz oparty na szablonie formularza, kopię szablonu formularza, wraz z przechowywane dane są pobierane do komputera użytkownika. Jeśli na komputerze użytkownika jest połączony z siecią, podczas tworzenia formularza, InfoPath pobiera dane z połączenia danych zewnętrznych zawsze, gdy formularz używa tego połączenia danych. Jeśli użytkownik nie jest połączony z siecią, podczas tworzenia formularza, program InfoPath używa danych, który jest przechowywany w szablonie formularza na komputerze użytkownika.

Ponieważ dane zostały pobrane w czasie, której utworzono połączenie danych, z zewnętrznym źródłem danych może być zostały zaktualizowane do momentu, gdy użytkownik utworzy formularz oparty na tym szablonie formularza. Jeśli chcesz, aby użytkownicy mogli otrzymywać najnowszych danych z zewnętrznego źródła danych, podczas tworzenia nowego formularza lub Otwórz istniejący formularz oparty na szablonie formularza, należy projektowanie formularza za pomocą pomocniczego połączenia danych po pierwszym otwarciu formularza.

Po otwarciu formularza za pomocą połączenia danych pomocniczej

Jeśli chcesz, aby użytkownicy uzyskanie najnowszych danych z zewnętrznego źródła danych, a nie przy użyciu danych przechowywanych w szablonie formularza, zaznacz pole wyboru automatycznie Pobierz dane po otwarciu formularza w Kreatorze połączenia danych, podczas tworzenia połączenia danych pomocniczą. Ostatnia strona w oknie dialogowym Kreator połączenia danych

Gdy użytkownik utworzy nowy formularz podczas połączenia z siecią, programu InfoPath używa tej pomocniczego połączenia danych do pobierania najnowszych danych z zewnętrznego źródła danych. Te dane są przechowywane w pamięci podręcznej. Jeśli użytkownik otwiera istniejący formularz zapisany na komputerze, program InfoPath sprawdza, jeśli komputer jest połączony z siecią. Jeśli komputer jest połączony z siecią, InfoPath pobiera najnowszych danych z zewnętrznego źródła danych przy użyciu tego połączenia danych. Jeśli użytkownik pracuje w trybie offline, korzysta z danych przechowywanych w pamięci podręcznej lub w szablonie formularza programu InfoPath.

Uwaga dotycząca zabezpieczeń : Dane pobrane z pomocnicze źródło danych jest przechowywany na komputerze jako zwykły tekst. Jeśli korzystasz z pomocniczego połączenia danych do pobierania danych poufnych z zewnętrznego źródła danych, można wyłączyć tę funkcję w celu ochrony danych przed nieautoryzowanym użyciem w przypadku, gdy komputer jest utraconych lub kradzież. Jeśli wyłączysz tę funkcję, dane będą dostępne tylko wtedy, gdy użytkownik jest połączony z siecią.

Uzyskiwanie najnowszych danych

Jeśli zewnętrznego źródła danych jest regularnie aktualizowana, można skonfigurować szablon formularza, aby zezwolić użytkownikom na pobieranie najnowszych danych przez połączenie danych pomocniczą. Aby to zrobić, można ograniczyć dostępność danych, które są obecnie przechowywane w pamięci podręcznej do określonej liczby dni, a następnie można dodać przycisk do pobierania danych z dowolnego zewnętrznych źródeł danych za pomocą wszystkich połączeń pomocniczych danych w formularzu. Dzięki temu, upewnij się, że pracy użytkowników z najnowszych danych.

Można też kliknąć można ograniczyć dostępności danych z pomocniczego połączenia danych, jak długo trwa Ustawianie daty wygaśnięcia wiadomości na którego dane mają być przechowywane na komputerze użytkownika. Okno dialogowe Opcje formularza

Tej opcji programu InfoPath udostępnia dane z wszystkich pomocniczych połączeń danych formularza do określonej liczby dni. Po tej liczbie dni dane nie będą wyświetlane w formularzu. Następnie można dodać przycisk do formularza, które użytkownicy mogą kliknąć do pobierania danych, za pomocą określonego pomocniczego połączenia danych lub wszystkich połączeń pomocniczego w formularzu.

Uwaga dotycząca zabezpieczeń : Nawet jeśli dane nie są dostępne w formularzu, dane pozostają na komputerze użytkownika, po upływie ustalona liczba dni. System operacyjny używa tego miejsca przechowywania czegoś innego danych jedynie jest zastępowana.

Początek strony

Tworzenie połączenia danych z bazą danych SQL w trybie offline

Zanim dodasz pomocniczego połączenia danych do bazy danych programu Microsoft SQL Server do szablonu formularza, należy następujące informacje z administratorem bazy danych.

  • Nazwa serwera, na którym jest przechowywana baza danych, korzystające z tego szablonu formularza.

  • Nazwa bazy danych, która będzie używana z tym szablonem formularza.

  • Uwierzytelnianie wymagane przez bazę danych. Do określenia sposobu uzyskiwania przez użytkowników dostępu do bazy danych może ona stosować uwierzytelnianie systemu Microsoft Windows lub uwierzytelnianie serwera SQL Server.

  • Nazwa tabeli zawierającej dane, które chcesz wysłać do formularza. To jest tabela podstawowa. Jeśli zamierzasz użyć więcej niż jednej tabeli w bazie danych, należy nazwiska innych osób, tabele podrzędne. Należy również nazw pól w tabelach podrzędne, które mają relacji do pól w tabeli podstawowej.

  • Czy wyniki kwerendy można bezpiecznie przechowywać w formularzu w celu umożliwienia dostępu do nich w trybie offline.

Gdy te informacje, można utworzyć połączenie danych z bazą danych SQL w trybie offline za pomocą poniższej procedury.

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Utwórz nowe połączenie z, kliknij opcję Odbierz dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij opcję Baza danych (tylko programu Microsoft SQL Server lub Microsoft Office Access), a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora kliknij przycisk Wybierz bazę danych.

  6. W oknie dialogowym Wybierz źródło danych kliknij przycisk Nowe źródło.

  7. Na liście Z jakim rodzajem źródła danych chcesz się połączyć? kliknij opcję Microsoft SQL Server, a następnie kliknij przycisk Dalej.

  8. W polu Nazwa serwera wpisz nazwę serwera, na którym jest przechowywana baza danych.

  9. W obszarze Poświadczenia logowania wykonaj jedną z następujących czynności:

    • Jeśli baza danych określa, kto ma dostęp do serwera, na podstawie poświadczeń używanych w sieci Microsoft Windows, kliknij pozycję Użyj uwierzytelniania systemu Windows.

    • Jeśli baza danych określa, kto ma dostęp do serwera, na podstawie określonej nazwy użytkownika i hasła, pobranego z administratorem bazy danych, kliknij opcję Użyj następujących nazwę użytkownika i hasło, a następnie wpisz tę nazwę użytkownika i hasło w polach Nazwa użytkownika i hasło.

  10. Kliknij przycisk Dalej.

  11. Na następnej stronie kreatora na liście Wybierz bazę danych, która zawiera dane, które chcesz kliknij bazę danych, którą chcesz użyć, zaznacz pole wyboru Połącz z określonej tabeli, kliknij nazwę tabeli podstawowej i kliknij przycisk Dalej.

  12. Na następnej stronie kreatora, w polu Nazwa pliku wpisz nazwę pliku, w którym przechowywane są informacje o połączeniu danych.

  13. Aby zapisać wprowadzone ustawienia, kliknij przycisk Zakończ.

  14. Dodaj inne dowolne tabele, których chcesz używać w połączeniu danych kwerendy.

    Jak?

    1. Kliknij przycisk Dodaj tabelę.

    2. W oknie dialogowym Dodawanie tabeli lub kwerendy kliknij nazwę tabeli podrzędnej, a następnie kliknij przycisk Dalej. Program InfoPath próbuje ustawić relacje dopasowując nazwy pól w obu tabelach. Jeśli nie chcesz używać sugerowane relacji, wybierz relację, a następnie kliknij Usuwanie relacji. Aby dodać relację, kliknij pozycję Dodaj relację. W oknie dialogowym Dodaj relację kliknij nazwę każdego pola pokrewne w odpowiedniej kolumnie, a następnie kliknij przycisk OK.

    3. Kliknij przycisk Zakończ.

    4. W celu dodania kolejnych tabel podrzędnych powtórz wszystkie kroki.

  15. Kliknij przycisk Dalej.

  16. Jeśli chcesz, aby dane z tego pomocniczego połączenia danych ma być dostępny, nawet jeśli na komputerze użytkownika nie jest połączony z siecią, zaznacz pole wyboru Przechowaj kopię danych w szablonie formularza. Po zaznaczeniu tego pola wyboru programu InfoPath kwerendy zewnętrznego źródła danych i przechowuje wyniki w szablonie formularza.

    Uwaga dotycząca zabezpieczeń : Zaznaczenie tego pola wyboru przechowuje wyników kwerendy w szablonie formularza. Ponieważ dane są przechowywane w szablonie formularza, jest dostępny w formularzach, które wypełniania przez użytkowników, nawet jeśli ich komputery nie są połączone z siecią. Jeśli występują poufne dane z tego połączenia danych, można wyłączyć tę funkcję w celu ochrony danych w przypadku, gdy komputer jest utraconych lub kradzież.

  17. Kliknij przycisk Dalej.

  18. Na następnej stronie kreatora wpisz opisową nazwę dla tego połączenia danych pomocniczej. Upewnij się, że informacje w sekcji Podsumowanie są poprawne. Aby umożliwić użytkownikom tworzenie nowego formularza lub Otwórz istniejący formularz na podstawie tego szablonu formularza za pomocą tego pomocniczego połączenia danych, zaznacz pole wyboru automatycznie Pobierz dane po otwarciu formularza.

Początek strony

Tworzenie połączenia danych bazy danych programu Access w trybie offline

Zanim dodasz pomocniczego połączenia danych do bazy danych programu Access do szablonu formularza, należy następujące informacje z administratorem bazy danych.

  • Nazwa i lokalizacja bazy danych.

    Uwaga : Konieczne będzie również ustalić, czy baza danych znajduje się w lokalizacji sieciowej, która jest dostępna dla użytkowników. Jeśli inni użytkownicy w sieci będą tworzyć formularze oparte na tym szablonie formularza, bazy danych musi znajdować się w lokalizacji sieciowej, która jest dostępna dla użytkowników.

  • Jeśli szablon formularza zostanie tylko kwerendy bazy danych, konieczne będzie nazwę tabeli, która dostarcza wyników kwerendy wysyłane do bazy danych. W tej tabeli będą tabeli podstawowej, podczas konfigurowania kwerendy połączenia danych.

  • Nazwy innych wymagające podstawowej tabeli danych z tabel. W większości przypadków relacji między tabelami są już ustalone w bazie danych. Jeśli musisz ustanowić relacje między tabeli podstawowej i innej tabeli, konieczne będzie nazwy pól powiązanych w obu tabelach.

Gdy te informacje, możesz utworzyć połączenie danych z bazy danych programu Access w trybie offline za pomocą poniższej procedury.

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Utwórz nowe połączenie z, kliknij opcję Odbierz dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij opcję Baza danych (tylko programu Microsoft SQL Server lub Microsoft Office Access), a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora kliknij przycisk Wybierz bazę danych.

  6. W oknie dialogowym Wybieranie źródła danych przejdź do lokalizacji bazy danych.

    Uwaga : Jeśli bazy danych jest przechowywany w lokalizacji sieciowej, przejdź do ścieżki UNC lokalizacji. Nie przejdź do lokalizacji sieciowej za pośrednictwem mapowanego dysku sieciowego. Jeśli używasz mapowanego dysku sieciowego, formularze utworzone na podstawie tego szablonu formularza spowoduje wyszukanie bazy danych na serwerze sieciowym zamapowane. Jeśli użytkownik nie posiada mapowanego dysku sieciowego, formularz nie znajdzie bazy danych.

  7. Kliknij nazwę bazy danych, a następnie kliknij przycisk Otwórz.

  8. W oknie dialogowym Wybieranie tabeli kliknij tabeli podstawowej, którego chcesz użyć, a następnie kliknij przycisk OK.

  9. Na następnej stronie kreatora zaznacz pole wyboru Pokaż kolumny w tabeli.

    Domyślnie wszystkie pola w tabeli można dodać do głównego źródła danych szablonu formularza.

  10. W obszarze Struktura źródła danych wyczyść pola wyboru dla pola, które chcesz uwzględnić w głównego źródła danych.

    Dodaj inne tabele lub kwerendy, które ma być używany w związku z tym danych.

    Jak?

    1. Kliknij przycisk Dodaj tabelę.

    2. W oknie dialogowym Dodawanie tabeli lub kwerendy kliknij nazwę tabeli podrzędnej, a następnie kliknij przycisk Dalej. Program InfoPath próbuje ustawić relacje dopasowując nazwy pól w obu tabelach. Jeśli nie chcesz używać sugerowane relacji, wybierz relację, a następnie kliknij Usuwanie relacji. Aby dodać relację, kliknij pozycję Dodaj relację. W oknie dialogowym Dodaj relację kliknij nazwę każdego pola pokrewne w odpowiedniej kolumnie, a następnie kliknij przycisk OK.

    3. Kliknij przycisk Zakończ.

    4. W celu dodania kolejnych tabel podrzędnych powtórz wszystkie kroki.

  11. Kliknij przycisk Dalej.

  12. Aby udostępnić dane z tego pomocniczego połączenia danych, nawet jeśli na komputerze użytkownika nie jest połączony z siecią, zaznacz pole wyboru Przechowaj kopię danych w szablonie formularza. Po zaznaczeniu tego pola wyboru programu InfoPath kwerendy zewnętrznego źródła danych i zapisuje wyniki kwerendy w szablonie.

    Uwaga dotycząca zabezpieczeń : Zaznaczenie tego pola wyboru przechowuje wyników kwerendy w szablonie formularza. Ponieważ dane są przechowywane w szablonie formularza, jest dostępny w formularzach, które wypełniania przez użytkowników, nawet jeśli ich komputery nie są połączone z siecią. Jeśli występują poufne dane z tego połączenia danych, można wyłączyć tę funkcję w celu ochrony danych w przypadku, gdy komputer jest utraconych lub kradzież.

  13. Kliknij przycisk Dalej.

  14. Na następnej stronie kreatora wpisz opisową nazwę dla tego połączenia danych pomocniczej. Upewnij się, że informacje w sekcji Podsumowanie są poprawne. Aby umożliwić użytkownikom tworzenie nowego formularza lub Otwórz istniejący formularz na podstawie tego szablonu formularza za pomocą tego pomocniczego połączenia danych, zaznacz pole wyboru automatycznie Pobierz dane po otwarciu formularza.

Początek strony

Tworzenie połączenia danych w bibliotece dokumentów programu SharePoint w trybie offline

Przed dodaniem pomocniczego połączenia danych do szablonu formularza konieczne następujące informacje od administratora witryny.

  • Lokalizacja witryny Microsoft Windows SharePoint Services i uprawnień wymaganych do nich dostęp.

  • Weryfikacja czy witryna została skonfigurowana, tak aby użytkownicy mogą uzyskać dostęp do danych z biblioteki dokumentów lub listy.

  • Sprawdzanie, czy dane z biblioteki dokumentów lub listy można przechowywać na komputerach użytkowników w trybie offline.

Gdy te informacje, możesz utworzyć połączenie danych z bazy danych programu Access w trybie offline za pomocą poniższej procedury.

  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Utwórz nowe połączenie z, kliknij opcję Odbierz dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij opcję Biblioteka lub lista programu SharePoint, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora wpisz adres URL witryny programu SharePoint zawierającej bibliotekę lub listę dokumentów, a następnie kliknij przycisk Dalej.

  6. Na następnej stronie kreatora na liście Wybierz listę lub bibliotekę kliknij listę lub bibliotekę, której chcesz używać, a następnie kliknij przycisk Dalej.

  7. Na następnej stronie kreatora zaznacz pola wyboru obok pól, które będzie dostarczać dane do szablonu formularza. Jeśli będzie można opublikować tego szablonu formularza do biblioteki dokumentów i chcesz formularzy opartych na tym szablonie formularza do pobierania metadanych dotyczących formularza, zaznacz pole wyboru Dołącz dane tylko do aktywnego formularza.

  8. Kliknij przycisk Dalej.

  9. Aby udostępnić dane z tego pomocniczego połączenia danych, nawet jeśli na komputerze użytkownika nie jest połączony z siecią, zaznacz pole wyboru Przechowaj kopię danych w szablonie formularza. Po zaznaczeniu tego pola wyboru programu InfoPath kwerendy zewnętrznego źródła danych i zapisuje wyników kwerendy w szablonie formularza.

    Uwaga dotycząca zabezpieczeń : Zaznaczenie tego pola wyboru przechowuje wyników kwerendy w szablonie formularza. Ponieważ dane są przechowywane w szablonie formularza, jest dostępny w formularzach, które wypełniania przez użytkowników, nawet jeśli ich komputery nie są połączone z siecią. Jeśli występują poufne dane z tego połączenia danych, można wyłączyć tę funkcję w celu ochrony danych w przypadku, gdy komputer jest utraconych lub kradzież.

  10. Kliknij przycisk Dalej.

  11. Na następnej stronie kreatora wpisz opisową nazwę dla tego połączenia danych pomocniczej, a następnie sprawdź, czy informacje w sekcji Podsumowanie są poprawne.

  12. Aby umożliwić użytkownikom tworzenie nowego formularza lub Otwórz istniejący formularz na podstawie tego szablonu formularza za pomocą tego pomocniczego połączenia danych, zaznacz pole wyboru automatycznie Pobierz dane po otwarciu formularza.

Początek strony

Konfigurowanie dostępności danych

Jeśli zewnętrznego źródła danych jest regularnie aktualizowana przy użyciu nowych danych, można skonfigurować szablon formularza, aby udostępnić wszystkie buforowane dane. Te dane są dostępne dla formularzy opartych na tym szablonie formularza przez ograniczoną liczbę dni odpowiadającej harmonogram aktualizacji z zewnętrznego źródła danych. Ograniczając liczbę dni, które dane są dostępne dla formularzy opartych na tym szablonie formularza, może wymagać, aby użytkownicy aktualizowanie danych na podstawie zewnętrznego źródła danych w regularnych odstępach.

Aby zaktualizować dane, można dodać przycisk do szablonu formularza, który można kliknąć, aby zaktualizować dane ze wszystkich połączeń pomocniczego używanych w szablonie formularza.

Uwaga : Jeśli odświeżanie połączenia danych za pomocą przycisku, poinstruuj swoich użytkowników, kliknij ten przycisk tylko wtedy, gdy jest połączony z siecią.

Określ liczbę dni, przez które pamięci podręcznej danych jest dostępna

To ustawienie jest stosowane do wszystkich połączeń danych pomocniczej w szablonie formularza.

  1. W menu Narzędzia kliknij polecenie Opcje formularza.

  2. W oknie dialogowym Opcje formularza na liście Kategoria zaznacz pozycję W trybie offline.

  3. W obszarze tryb Offline zaznacz pole wyboru Przechowuj dane zwracane przez kwerendy, aby można było używać w trybie Offline.

  4. Kliknij pozycję przechowywane kwerendy wygasają po tej liczbie dni.

  5. Na liście określ liczbę dni, że ma buforowane dane mają być dostępne w formularzu.

Dodawanie przycisku do odświeżyć połączenia danych

  1. Jeśli szablon formularza zawiera wiele widoków, kliknij nazwę widoku, w menu Widok, aby przejść do widoku z formantem, w którym chcesz wyświetlić dane z pomocnicze źródło danych.

  2. Jeśli okienko zadań Kontrolki nie jest widoczne, kliknij pozycję Więcej kontrolek w menu Wstawianie lub naciśnij klawisze ALT + I, a następnie klawisz C.

  3. Przeciągnij formant przycisku na szablon formularza.

  4. Kliknij dwukrotnie przycisk dodany do szablonu formularza.

  5. Kliknij kartę Ogólne.

  6. Na liście Akcja kliknij polecenie Odśwież.

  7. W polu Etykieta wpisz nazwę, która ma być wyświetlany na przycisku.

  8. Kliknij przycisk Ustawienia.

  9. W oknie dialogowym odświeżanie wykonaj jedną z następujących czynności:

    • Aby skonfigurować ten przycisk, aby pobrać najnowsze dane przez to połączenie danych, kliknij jedno pomocnicze źródło danych.

    • Aby skonfigurować ten przycisk, aby pobrać najnowsze dane przez wszystkie połączenia danych pomocniczej, kliknij pozycję wszystkie pomocnicze źródła danych.

  10. Na liście Wybierz pomocnicze źródło danych kliknij pomocnicze źródło danych, które jest skojarzone z połączeniem danych kwerendy.

  11. Kliknij przycisk OK, aby zamknąć wszystkie otwarte okna dialogowe.

  12. Aby sprawdzić wprowadzone zmiany, kliknij pozycję Podgląd na pasku narzędzi Standardowy lub naciśnij klawisze CTRL+SHIFT+B.

Początek strony

Wyłącz tryb offline

W niektórych przypadkach można projektowanie szablonu formularza tylko umożliwia użytkownikom wypełnianie formularzy, gdy są połączeni z siecią. Na przykład szablon formularza zawiera połączenie danych do zewnętrznego źródła danych zawierającego dane poufne lub tajne, można skonfigurować szablon formularza, aby umożliwić formularzy do wypełniania w stanie połączenia tylko. Konfigurowanie szablonu formularza w ten sposób, może pozwolić na ochrony danych w przypadku, gdy komputer jest utraconych lub kradzież, ponieważ dane nie są przechowywane na komputerze użytkownika.

Aby skonfigurować szablon formularza, aby użytkownicy mogli wypełniać, tylko wtedy, gdy komputer jest połączony z siecią, wykonaj następujące czynności.

  1. W menu Narzędzia kliknij polecenie Opcje formularza.

  2. W oknie dialogowym Opcje formularza na liście Kategoria zaznacz pozycję W trybie offline.

  3. W obszarze tryb Offline wyczyść pole wyboru Zezwalaj użytkownikom na Wypełnij formularz, jeśli dane są niedostępne.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×