Projektowanie formularza reagującego na stan przepływu pracy

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Możesz projektować formularze programu Microsoft Office InfoPath, aby wyświetlić określone dane, która odpowiada do bieżący stan przepływu pracy. W tym celu trybu projektowania szablonu formularza, aby używać reguł, które inicjująca akcję w jego formularze oparte na stan przepływu pracy. Można to usprawnianie procesów, które osoby za pomocą wypełnianie formularzy.

W tym artykule opisano, jak zaprojektować szablon formularza raportu wydatków był wyświetlany różnych widoków szablonu formularza w zależności od stanu przepływu pracy Zatwierdzanie skojarzone. Na przykład przed przepływ pracy jest uruchamiany, formularz będzie wyświetlanie wydatki zawierający tabelę powtarzaną, w której użytkownicy będą mogli wprowadzać kosztów. Jeśli stan przepływu pracy jest W toku, formularz zostanie wyświetlona widoku Podsumowanie wydatków, zawierającego łącznych wydatków w poszczególnych kategoriach. Stan przepływu pracy po ukończeniu formularz wyświetli widoku wykonane, który zawiera szczegółowe informacje na zwrot szacowany czas.

Aby formularze reagowały na stany przepływu pracy, należy wykonać zadania w witrynie programu Microsoft Office SharePoint Server 2007 lub witrynie programu Windows SharePoint Services 3.0, w której znajdują się formularze, oraz zadania w programie InfoPath. W witrynie programu SharePoint należy utworzyć przepływ pracy oraz typ zawartości witryny, a w programie InfoPath należy dodać połączenie danych do szablonu formularza, utworzyć regułę oraz opublikować szablon formularza.

Uwaga : W tym artykule użyto przykładowego scenariusza, w którym szablon formularza jest opublikowany jako typ zawartości witryny. Można też opublikować szablon formularza w udostępnionej lokalizacji sieciowej lub utworzyć nową bibliotekę dokumentów podczas publikowania szablonu formularza w witrynie programu SharePoint. Więcej informacji na temat publikowania szablonów formularzy można znaleźć w sekcji Zobacz też.

W tym artykule

Wprowadzenie do używania przepływów pracy w formularzach programu InfoPath

Zgodność

Przed rozpoczęciem

Krok 1. Dodawanie przepływu pracy Zatwierdzanie do biblioteki programu SharePoint

Krok 2. Dodawanie połączenia danych do szablonu formularza

Krok 3. Dodawanie reguły do szablonu formularza w celu wyświetlania określonego widoku

Krok 4. Publikowanie szablonu formularza jako typu zawartości witryny

Krok 5. Dodawanie typu zawartości do biblioteki dokumentów

Wprowadzenie do używania przepływów pracy w formularzach programu InfoPath

Przepływy pracy ułatwiają użytkownikom współpracę nad dokumentami i zarządzanie zadaniami projektu, implementując określone procesy biznesowe dla dokumentów i elementów w witrynie programu Microsoft Office SharePoint Server 2007 lub witrynie programu Windows SharePoint Services 3.0. Przepływy pracy pomagają organizacjom utrzymywać spójne procesy biznesowe, a także zwiększają efektywność i produktywność organizacyjną, zarządzając zadaniami i krokami związanymi z określonymi procesami biznesowymi. Dzięki temu osoby wykonujące te zadania mogą się skoncentrować na pracy zamiast na zarządzaniu przepływem pracy.

Możesz włączyć formularza programu InfoPath wyświetlić określone dane, która odpowiada do bieżący stan przepływu pracy. W tym celu trybu projektowania szablonu formularza, aby używać reguł, które inicjująca akcję w formularzu na podstawie stanu przepływu pracy. Można to usprawnianie procesów, które osoby za pomocą wypełnianie formularzy. Na przykład aby umożliwić formularza w celu wyświetlania widoku tylko do odczytu, po zakończeniu stan przepływu pracy, i dlatego nie należy zmieniać danych w formularzu.

Przepływy pracy należy dodać do listy, biblioteki lub typu zawartości programu SharePoint, aby były dostępne do użycia w szablonach formularzy programu InfoPath. Przepływy pracy dostępne dla witryny różnią się w zależności od typu witryny oraz tego, czy niestandardowe przepływy pracy zostały utworzone za pomocą programu Microsoft Office SharePoint Designer 2007.

W tym artykule dla potrzeb ilustracji sposobów używania przepływów pracy z szablonami formularzy programu InfoPath, jest używany przepływ pracy Zatwierdzanie. Przepływ pracy Zatwierdzanie rozsyła formularz programu InfoPath zapisany w bibliotece do grupy osób w celu zatwierdzenia. Domyślnie przepływ pracy Zatwierdzanie jest skojarzony z typem zawartości Dokument i jest automatycznie dostępny w bibliotekach dokumentów lub formularzy.

Każdy przepływ pracy jest określona przez różne stany z nazwy opisowe, na przykład W toku. Nazwy statusy zależą od typu przepływu pracy. Na przykład przepływu pracy Zatwierdzanie, który jest dostępny na serwerach z programem Microsoft Office SharePoint Server 2007 — zawiera stan W trakcie wykonywania, Anulowane i wykonane. Stany trójstanowego przepływu pracy, który jest dostępny w Windows SharePoint Services 3.0 — można zdefiniować przez osobę, która powoduje dodanie przepływu pracy do biblioteki lub listy, należy statusy standardowy, takich jak już wspomniano stan W trakcie wykonywania za pomocą innych przepływów pracy. Mimo że opisową nazwę jest widoczny dla użytkownika, Stany przepływu pracy są programowy reprezentowane przez wartości liczbowe. Aby projektowanie szablonu formularza reagującego na stan przepływu pracy określonych, trzeba znać wartość liczbowa dla stan przepływu pracy, którego chcesz użyć. Jest tak, ponieważ program InfoPath używa wartości liczbowej przepływu pracy do inicjująca akcję, takich jak przełączania widoków.

Jak napisano wcześniej, można włączyć wyświetlanie przez szablon formularza programu InfoPath określonych danych odpowiadających bieżącemu stanowi przepływu pracy. Chociaż w tym artykule opisano, jak włączyć automatyczne wyświetlanie przez szablon formularza raportu z wydatków określonego widoku w zależności od jego stanu w przepływie pracy, użytkownik może też dostosować przepływ pracy, dodając dodatkowe akcje. Na przykład zamiast włączać wyświetlanie w formularzach określonego widoku można włączyć wyświetlanie okna dialogowego z komunikatem zawierającym stosowne instrukcje. Zamiast używać przepływu pracy Zatwierdzanie można użyć trójstanowego przepływu pracy.

Uwaga : Jeśli użytkownik włączy akcje inne niż opisane w tym artykule, może być konieczne wykonanie dodatkowych kroków w celu zagwarantowania, że szablon formularza prawidłowo współpracuje z używanym przepływem pracy.

Początek strony

Zgodność

Planując utworzenie szablon formularza zgodny z przeglądarką, należy pamiętać, że pasek akcji dokumentu widoczny podczas wypełniania formularzy w dokumentach pakietu Microsoft Office, w tym formularzy programu InfoPath, nie jest widoczny w szablonach formularzy zgodnych z przeglądarkami wypełnianych przez użytkowników w przeglądarce sieci Web. Mimo to można jednak używać formularzy opartych na przeglądarce z przepływami pracy. Uczestnicy przepływu pracy mogą zmieniać stan przepływu pracy dla takich formularzy za pomocą ustawień biblioteki dokumentów. Aby uzyskać więcej informacji na temat zmieniania ustawień przepływu pracy za pomocą witryn programu SharePoint, należy skorzystać z sekcji Zobacz też.

Początek strony

Przed rozpoczęciem

Przed wykonaniem zadań opisanych w tym artykule należy się upewnić, że są spełnione poniższe warunki:

  • Skontaktuj się z administratorem farmy w celu sprawdzenia, czy przepływy pracy Zatwierdzanie są zainstalowane i włączone dla witryny programu SharePoint, która ma być używana.

  • Upewnij się, że masz co najmniej poziom uprawnień Projektowanie dla witryny programu SharePoint. Ten poziom uprawnień jest niezbędny do opublikowania szablonu formularza i utworzenia przepływu pracy.

  • Utwórz szablon formularza zawierający co najmniej dwa widoki i dostosuj każdy widok, aby wyświetlał typ danych odpowiedni dla każdego stanu przepływu pracy. Na przykład w przypadku widoku, który ma być wyświetlany po ukończeniu przepływu pracy, możesz ustawić formanty jako tylko do odczytu.

  • Utwórz bibliotekę dokumentów lub formularzy i upewnij się, że jest ona skonfigurowana tak, aby zezwalała na wiele typów zawartości.

Początek strony

Krok 1. Dodawanie przepływu pracy Zatwierdzanie do biblioteki programu SharePoint

W tym scenariuszu skoncentrowano się na przepływie pracy Zatwierdzanie, ale w razie potrzeby można użyć innego przepływu pracy. Jeśli zostanie użyty inny typ przepływu pracy, opcje dla tego przepływu pracy mogą się różnić od opcji opisanych w tym artykule.

  1. Otwórz bibliotekę, do której chcesz dodać przepływ pracy.

  2. W menu Ustawienia kliknij ustawienie dla typu otwieranej biblioteki.

    Na przykład w przypadku biblioteki dokumentów kliknij opcję Ustawienia biblioteki dokumentów.

  3. W obszarze Uprawnienia i zarządzanie kliknij pozycję Ustawienia przepływu pracy.

  4. Kliknij pozycję Dodaj przepływ pracy.

  5. Na stronie Dodawanie przepływu pracy w sekcji Przepływ pracy kliknij pozycję Zatwierdzanie.

  6. W sekcji Nazwa wpisz unikatową nazwę przepływu pracy.

    1. W sekcji Lista zadań określ listę zadań, która ma być używana w tym przepływie pracy.

      Uwagi : 

      • Można użyć domyślnej listy Zadania albo utworzyć nową listę. Jeśli użyjesz domyślnej listy Zadania, uczestnicy przepływu pracy będą mogli w łatwy sposób odnaleźć i przejrzeć swoje przepływy pracy przy użyciu widoku Moje zadania na liście Zadania.

      • Jeśli w zadaniach dla tego przepływu pracy zostaną ujawnione poufne dane, które powinny być oddzielone od ogólnej listy Zadania, należy utworzyć nową listę zadań.

      • Jeśli w organizacji wystąpi wiele przepływów pracy lub przepływy pracy będą zawierać wiele zadań, należy utworzyć nową listę zadań. W takim przypadku można utworzyć listę zadań dla każdego przepływu pracy.

  7. W sekcji Lista historii zaznacz listę historii, która ma być używana w tym przepływie pracy. Na liście historii są wyświetlane wszystkie zdarzenia mające miejsce w ramach poszczególnych wystąpień przepływu pracy.

    Użytkownik może skorzystać z domyślnej listy Historia lub utworzyć nową listę. Jeśli organizacja będzie miała liczne przepływy pracy, można utworzyć oddzielną listę historii dla każdego przepływu.

  8. Aby zezwolić na ręczne uruchamianie przepływu pracy, zaznacz pole wyboru Zezwalaj na ręczne uruchamianie tego przepływu pracy przez uwierzytelnionego użytkownika z uprawnieniami Edytowanie elementów w sekcji Opcje uruchamiania.

  9. Aby wymagać dodatkowych uprawnień do uruchamiania przepływu pracy, zaznacz pole wyboru Wymagaj uprawnień Zarządzanie listami do uruchamiania przepływu pracy.

  10. Określ dowolne inne żądane opcje, w tym to, kiedy przepływ pracy ma zostać uruchomiony, a następnie kliknij przycisk Dalej.

  11. Na stronie Dostosowywanie przepływu pracy określ żądane opcje, w tym sposób rozsyłania zadań, domyślne wartości początkowe przepływu pracy oraz sposób ukończenia przepływu pracy, a następnie kliknij przycisk OK.

    Zaznacz opcje w dowolnych z poniższych sekcji. Nie musisz określać opcji w każdej sekcji:

    Zadania przepływu pracy

    Aby

    Wykonaj następujące czynności

    Jednoczesne przydzielenie zadań do wszystkich uczestników (równoległy przepływ pracy)

    Zaznacz opcję Wszyscy uczestnicy jednocześnie (równolegle).

    Przydzielenie zadań do jednego uczestnika naraz, co wymaga, aby jeden uczestnik ukończył zadanie, zanim następny uczestnik otrzyma zadanie (szeregowy przepływ pracy)

    Zaznacz opcję Jeden uczestnik jednocześnie (szeregowo).

    Zezwolenie uczestnikom przepływu pracy na ponowne przydzielanie ich zadań innym osobom

    Zaznacz pole wyboru Przydziel ponownie to zadanie innej osobie.

    Zezwolenie uczestnikom przepływu pracy na żądanie zmiany w dokumencie lub elemencie (ta zmiana musi zostać zatwierdzona przed ukończeniem zadania)

    Zaznacz pole wyboru Żądanie zmiany przed ukończeniem zadania.

    Domyślne wartości początkowe przepływu pracy

    Aby

    Wykonaj następujące czynności

    Określenie domyślnej listy uczestników dla wszystkich wystąpień danego przepływu pracy

    Wpisz nazwy uczestników, których chcesz uwzględnić podczas uruchamiania przepływu pracy, lub kliknij pozycję Osoby zatwierdzające, a następnie wybierz osoby i grupy z usługi katalogowej.

    Uwagi : 

    • Oddziel nazwy średnikami.

    • Jeśli ten przepływ pracy został skonfigurowany jako szeregowy przepływ pracy, dodaj nazwy uczestników przepływu pracy w kolejności, w jakiej mają być przydzielane zadania.

    Przydzielenie jednego zadania do grup zamiast przydzielenia poszczególnych zadań dla każdego członka grupy

    Zaznacz pole wyboru Przydziel pojedyncze zadanie do każdej wprowadzonej grupy (nie rozwijaj grup).

    Zezwolenie osobom uruchamiającym przepływ pracy na zmienianie lub dodawanie uczestników

    Zaznacz pole wyboru Zezwalaj na zmiany listy uczestników przy uruchamianiu tego przepływu pracy.

    Określenie domyślnego komunikatu wyświetlanego z każdym zadaniem

    Wpisz komunikat lub instrukcje w polu tekstowym.

    Określenie daty ukończenia dla równoległych przepływów pracy

    Wprowadź datę w obszarze Zadanie mają być ukończone do dnia (równolegle).

    Określenie, ile czasu mają uczestnicy szeregowego przepływu pracy na ukończenie zadań przepływu pracy

    W obszarze Przydziel każdej osobie następującą ilość czasu na zakończenie jej zadania (szeregowo) wpisz liczbę, a następnie wybierz ustawienie Dni lub Tygodnie jako jednostkę przyrostu czasu.

    Określenie listy osób, które powinny otrzymać alerty (nie przydziały zadań) po uruchomieniu przepływu pracy

    W obszarze Powiadamianie innych osób wpisz nazwy osób, które mają być powiadamiane, lub kliknij pozycję DW i wybierz osoby oraz grupy z usługi katalogowej.

    Uwaga : Oddziel nazwy średnikami.

    Kończenie przepływu pracy

    Aby

    Wykonaj następujące czynności

    Określanie, że równoległy przepływ pracy jest zakończony po zakończeniu zadań przez określoną liczbę uczestników

    Zaznacz pole wyboru Zostanie zakończona następująca liczba zadań, a następnie wpisz liczbę.

    Określenie, że przepływ pracy jest ukończony, gdy dokument lub element zostanie odrzucony

    Zaznacz pole wyboru Dokument zostanie odrzucony.

    Określanie, że przepływ pracy jest zakończony po zmianie dokumentu lub elementu

    Zaznacz pole wyboru Dokument zostanie zmieniony.

    Działania po ukończeniu przepływu pracy

    Aby

    Wykonaj następujące czynności

    Aktualizowanie stanu zatwierdzania dokumentu lub elementu po zakończeniu przepływu pracy

    Zaznacz pole wyboru Aktualizuj stan zatwierdzenia (użyj tego przepływu pracy do sterowania zatwierdzaniem zawartości).

    Uwagi : 

    • Jeśli użytkownik za pomocą przepływu pracy Zatwierdzanie zarządza zatwierdzaniem zawartości dla biblioteki i zaznaczył pole wyboru Uruchom ten przepływ pracy, aby zatwierdzić opublikowanie wersji głównej elementu na stronie Dodawanie przepływu pracy, to pole wyboru jest zaznaczone domyślnie.

    • Jeśli użytkownik nie zaznaczył pola wyboru Uruchom ten przepływ pracy, aby zatwierdzić opublikowanie wersji głównej elementu na stronie Dodawanie przepływu pracy, ponieważ nie chce, aby ten przepływ pracy był domyślnym przepływem pracy zatwierdzania zawartości dla biblioteki, może zaznaczyć to pole wyboru, aby uczynić ten przepływ pracy pomocniczym przepływem pracy zatwierdzania zawartości, który będzie mógł być uruchamiany ręcznie przez określonych użytkowników.

Początek strony

Krok 2. Dodawanie połączenia danych do szablonu formularza

W poniższej procedurze wyjaśniono, jak dodać pomocnicze połączenie danych, które wykonuje kwerendę z zapytaniem o stan przepływu pracy dodanego w kroku 1. To pomocnicze połączenie danych zapewnia dane, które włączają reguły w formularzu w celu przełączania widoków w zależności od stanu przepływu pracy.

  1. W programie InfoPath w menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij opcję Utwórz nowe połączenie z, kliknij opcję Odbierz dane, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij opcję Biblioteka lub lista programu SharePoint, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kreatora wpisz adres URL witryny programu SharePoint.

  6. Na liście Wybierz listę lub bibliotekę kliknij nazwę biblioteki dokumentów, do której w kroku 1 został dodany przepływ pracy Zatwierdzanie, a następnie kliknij przycisk Dalej.

  7. Na następnej stronie kreatora na liście Wybierz pola zaznacz pole wyboru obok nazwy pola zgodnej z nazwą przepływu pracy.

    Nazwa tego pola może nie być w pełni zgodna z nazwą przepływu pracy. Jeśli nazwa pola zaczyna się od znaku specjalnego innego niż podkreślenie lub litera, nazwa przepływu pracy zostanie dostosowana na tej liście.

  8. Zaznacz pole wyboru Uwzględnij tylko dane dla aktywnego formularza, a następnie kliknij przycisk Dalej.

  9. Wyczyść pole wyboru Przechowuj kopię danych w szablonie formularza, a następnie kliknij przycisk Dalej.

  10. Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz opisową nazwę dla tego pomocniczego połączenia danych. Nazwa ta będzie wyświetlana na liście Źródło danych w okienku zadań Źródło danych.

  11. Aby kwerenda była uruchamiana automatycznie zawsze, gdy formularz zostanie otwarty przez użytkownika, zaznacz pole wyboru Automatycznie pobierz dane podczas otwierania formularza.

  12. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

  13. W oknie dialogowym Połączenia danych kliknij przycisk Zamknij.

Początek strony

Krok 3. Dodawanie reguły do szablonu formularza w celu wyświetlania określonego widoku

Podczas projektowania szablonu formularza możesz za pomocą reguł automatycznie wyświetli okno dialogowe, ustaw wartość pola, kwerendy lub przesyłanie danych formularza do połączenia danych, przełączanie widoków, lub otwieranie lub zamykanie formularza w odpowiedzi na określone zdarzenie lub warunki. Zdarzenia może obejmować zmianę określonego pola lub grupy źródło danych, kliknięcie przycisku, wstawienie sekcja powtarzająca się lub wierszu w tabela powtarzająca się otwarcie lub przesłanie formularza. Warunki może zawierać obliczeń, wyrażenia XPath i role użytkowników. Warunki można także, czy wartość pola jest pusta, jest w określonym zakresie, jest równa wartości innego pola, zaczyna się lub zawiera określone znaki.

W tym przypadku użytkownik utworzy regułę przełączającą widoki na podstawie stanu przepływu pracy.

  1. W menu Narzędzia kliknij polecenie Opcje formularza.

  2. Na liście Kategoria kliknij opcję Otwieranie i zapisywanie.

  3. W obszarze Zachowanie podczas otwierania kliknij opcję Reguły.

  4. W oknie dialogowym Reguły otwierania formularzy kliknij przycisk Dodaj.

  5. W polu Nazwa wpisz nazwę reguły.

    Na przykład wpisz Przełączanie widoków.

  6. Aby określić warunek uruchomienia reguły, kliknij pozycję Ustaw warunek.

  7. W obszarze Zastosuj regułę, jeżeli ten warunek jest spełniony w pierwszym polu kliknij pozycję Wybierz pole lub grupę.

  8. Na liście Źródło danych kliknij nazwę pomocniczego źródła danych, które zostało dodane w kroku 2, a następnie kliknij przycisk OK.

  9. Kliknij nazwę pola odpowiadającego stanowi przepływu pracy.

    Wyświetlenie żądanego pola może wymagać rozwinięcia folderów w tym oknie.

  10. W oknie dialogowym Warunek na drugiej liście kliknij pozycję równa się.

  11. Na trzeciej liście kliknij pozycję Wpisz liczbę, a następnie wpisz wartość odpowiadającą stanowi przepływu pracy.

    Na przykład w przypadku widoku wyświetlanego po ukończeniu przepływu pracy wpisz wartość 5.

    Wartości liczbowe dla stanów przepływu pracy w przepływie pracy Zatwierdzanie

    Stan

    Wartość liczbowa

    W toku

    2

    Ukończone

    5

    Anulowane

    15

    Zatwierdzone

    16

    Odrzucone

    17

    Uwagi : 

    • Wartości liczbowe dla stanów w innych przepływach pracy mogą być inne.

    • Wartość stanu przepływu pracy w programie InfoPath jest tylko do odczytu. To oznacza, że nie można zaprojektować szablonu formularza tak, aby użytkownik mógł ręcznie zmieniać stan przepływu pracy przez wprowadzanie wartości w formancie w samym formularzu.

  12. Kliknij przycisk OK.

  13. W oknie dialogowym Reguła kliknij pozycję Dodaj akcję.

  14. W obszarze Akcja kliknij pozycję Przełączanie widoków.

  15. W obszarze Widok kliknij nazwę widoku, który ma być wyświetlany, gdy stan przepływu pracy jest zgodny ze stanem dla tego warunku, a następnie kliknij przycisk OK.

    Jeśli na przykład wpisano wartość 2 w kroku 11, kliknij nazwę widoku, który ma być wyświetlany, gdy stan przepływu pracy to W toku.

  16. W oknie dialogowym Reguła kliknij przycisk OK.

  17. Powtórz kroki od 4 do 16, aby utworzyć dodatkowe reguły przełączające odpowiednie widoki na każdym etapie w przepływie pracy.

Początek strony

Krok 4. Publikowanie szablonu formularza jako typu zawartości witryny

Szablon formularza można opublikować w bibliotece dokumentów lub jako typ zawartości witryny, który może być używany w wielu bibliotekach dokumentów należących do zbioru witryn. Ponieważ już utworzono bibliotekę dokumentów i przydzielono do niej przepływ pracy, szablon formularza należy opublikować jako typ zawartości. Później można skojarzyć typ zawartości witryny szablonu formularza z utworzoną biblioteką.

Podczas publikowania szablonu formularza w witrynie programu SharePoint poza opublikowaniem szablonu formularza jako typu zawartości witryny można też opublikować go w udostępnionej lokalizacji sieciowej lub utworzyć nową bibliotekę dokumentów. Więcej informacji na temat publikowania szablonów formularzy znajduje się w sekcji Zobacz też.

  1. W menu Plik kliknij polecenie Zapisz.

  2. W oknie dialogowym Zapisywanie jako przejdź do lokalizacji, w której chcesz zapisać szablon formularza, a następnie kliknij przycisk Zapisz.

  3. Aby otworzyć okienko zadań Sprawdzanie projektu, kliknij polecenie Sprawdzanie projektu w menu Narzędzia.

  4. Jeśli w okienku zadań Sprawdzanie projektu są wyszczególnione błędy, usuń je, a następnie kliknij przycisk Odśwież, aby określić, czy błędy nadal występują.

  5. W menu Plik kliknij polecenie Publikuj.

  6. W Kreatorze publikowania kliknij opcję Do serwera programu SharePoint z usługami formularzy programu InfoPath lub bez nich, a następnie kliknij przycisk Dalej.

  7. Na następnej stronie kreatora w polu Wprowadź lokalizację witryny programu SharePoint lub usług InfoPath Forms Services wpisz lokalizację witryny programu SharePoint, w której chcesz opublikować szablon formularza, a następnie kliknij przycisk Dalej.

  8. Aby umożliwić użytkownikom wypełnianie tego formularza za pomocą przeglądarki sieci Web, na następnej stronie kreatora zaznacz pole wyboru Włącz możliwość wypełniania tego formularza za pomocą przeglądarki.

  9. Kliknij pozycję Typ zawartości witryny (zaawansowane), a następnie kliknij przycisk Dalej.

  10. Na następnej stronie kreatora kliknij opcję Utwórz nowy typ zawartości.

  11. Na liście Podstawa typu zawartości kliknij pozycję Formularz, a następnie kliknij przycisk Dalej.

  12. Na następnej stronie kreatora wpisz nazwę i opis nowego typu zawartości, a następnie kliknij przycisk Dalej.

  13. Na następnej stronie kreatora w polu Określ lokalizację i nazwę pliku szablonu formularza wpisz lokalizację witryny programu SharePoint, a następnie kliknij przycisk Przeglądaj.

  14. W oknie dialogowym Przeglądanie przejdź do lokalizacji na serwerze, w której chcesz opublikować szablon formularza jako typ zawartości witryny, a następnie w polu Nazwa pliku wpisz nazwę szablonu formularza i kliknij przycisk Zapisz.

  15. Kliknij przycisk Dalej.

  16. Wybierz pola w szablonie formularza, które mają się pojawić jako kolumny w widoku domyślnym biblioteki dokumentów.

    Jak?

    1. Kliknij przycisk Dodaj.

    2. Wybierz pole, które chcesz dodać jako kolumna w bibliotece dokumentów, a następnie wykonaj jedną z następujących czynności:

      • Wpisz nazwę kolumny w polu Nazwa kolumny.

      • Zaznacz kolumnę witryny na liście grupy kolumn witryny, wybierz nazwę z listy Nazwa kolumny, a następnie kliknij przycisk OK.

        W przypadku wybrania polem powtarzającym się do wyświetlania danych w bibliotece dokumentów, można zdefiniować, jak mają być wyświetlane pola w bibliotece dokumentów, klikając pozycję wartość na liście funkcji. Możesz wybrać, czy ma być wyświetlana pierwszą wartość w polu, ostatnia wartość w polu lub liczba wszystkich wystąpień pola, czy wszystkie wartości scalane.

    3. Kliknij przycisk OK.

  17. Kliknij przycisk Dalej.

  18. Na następnej stronie kreatora sprawdź, czy informacje są prawidłowe, a następnie kliknij przycisk Opublikuj.

  19. Kliknij przycisk Zamknij, a następnie upewnij się czy szablon formularza jest typem zawartości w witrynie programu SharePoint.

    Jak?

    1. Otwórz witrynę programu SharePoint za pomocą przeglądarki sieci Web.

    2. W menu Akcje witryny w prawym górnym rogu witryny kliknij opcję Ustawienia witryny.

    3. W obszarze Ustawienia witryny w obszarze Galerie kliknij typy zawartości witryny.

      Szablon formularza powinien być wymieniony w obszarze Typy zawartości programu InfoPath w Galeria typów zawartości witryny.

Początek strony

Krok 5. Dodawanie typu zawartości do biblioteki dokumentów

Typy zawartości umożliwiają organizacjom organizowanie, zarządzanie zawartością i bardziej efektywną komunikację w zbiorze witryn. Definiując typy zawartości dla określonych typów dokumentów, organizacja może zagwarantować, że każda grupa zawartości odbywa się bardziej efektywną komunikację. Możesz skonfigurować listy lub biblioteki do zawiera elementy wielu typów elementów lub dokumentów, dodając typy zawartości do listy lub biblioteki.

Uwaga : Aby dodawać typy zawartości do listy lub biblioteki, należy mieć dla tej listy lub biblioteki co najmniej poziom uprawnień Projektowanie.

Przed rozpoczęciem sprawdź, czy biblioteka jest skonfigurowana tak, aby zezwalała na wiele typów zawartości.

Zezwalanie na wiele typów zawartości

  1. W menu Ustawienia kliknij polecenie Ustawienia biblioteki dokumentów.

  2. W obszarze Ustawienia ogólne kliknij przycisk Ustawienia zaawansowane.

  3. W sekcji Typy zawartości zaznacz opcję Tak, aby zezwolić na wiele typów zawartości, a następnie kliknij przycisk OK.

  1. Jeśli lista lub biblioteka nie jest jeszcze otwarta, kliknij jej nazwę na pasku Szybkie uruchamianie.

    Uwaga : Jeśli nazwa danej listy lub biblioteki nie jest wyświetlana, kliknij polecenie Wyświetl całą zawartość witryny, a następnie kliknij nazwę listy lub biblioteki.

  2. W menu Ustawienia kliknij polecenie Ustawienia biblioteki dokumentów.

  3. W obszarze Typy zawartości kliknij łącze Dodaj z istniejących typów zawartości witryny.

  4. Na liście Wybierz typy zawartości witryny z w sekcji Wybieranie typów zawartości wybierz grupę typów zawartości witryny, z której chcesz wybrać.

  5. Na liście Dostępne typy zawartości witryny kliknij odpowiedni typ zawartości, a następnie kliknij przycisk Dodaj, aby przenieść zaznaczony typ zawartości na listę Typy zawartości do dodania.

  6. Aby dodać dodatkowe typy zawartości, powtórz kroki 4 i 5, a następnie kliknij przycisk OK.

Teraz, gdy użytkownik utworzy nowy formularz w tej bibliotece, widok formularza będzie wyświetlany zgodnie ze stanem przepływu pracy.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×