Praca z hiperłączami w programie Excel

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Aby uzyskać szybki dostęp do powiązanych informacji w innym pliku lub na stronie sieci Web, możesz wstawić hiperlink w komórce arkusza. Możesz również wstawiać hiperlinki w określonych elementach wykresu.

Uwaga: Większość zrzutów ekranu w tym artykule zrobiono w Excel 2016. Jeśli masz inną wersję programu, wygląd może się nieco różnić, ale funkcje pozostają takie same, chyba że zaznaczono inaczej.

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć hiperlink.

     Można też zaznaczyć obiekt, taki jak obraz lub element wykresu, który ma reprezentować hiperlink.

    • Na karcie Wstawianie w grupie łącza kliknij przycisk hiperłącze Przycisk Hiperłącze .

    Możesz również kliknąć prawym przyciskiem myszy komórkę lub grafikę, a następnie w menu skrótów kliknąć polecenie hiperłącze lub nacisnąć klawisze CTRL + K.

  2. W obszarze Połącz z kliknij przycisk Utwórz nowy dokument.

  3. W polu Nazwa nowego dokumentu wpisz nazwę nowego pliku.

    Porada: Aby określić lokalizację inną niż ta pokazana w obszarze pełna ścieżka, możesz wpisać nową lokalizację przed nazwą w polu Nazwa nowego dokumentu lub kliknąć pozycję Zmień , aby wybrać odpowiednią lokalizację, a następnie kliknąć przycisk OK.

  4. W obszarze Kiedy edytować kliknij opcję Edytuj nowy dokument później lub Edytuj nowy dokument teraz, aby określić, kiedy nowy plik ma zostać otwarty do edycji.

  5. W polu Tekst do wyświetlenia wpisz tekst, który ma reprezentować hiperlink.

  6. Aby po zatrzymaniu wskaźnika myszy na hiperlinku były wyświetlane pomocne informacje, kliknij przycisk Etykietka ekranowa, wpisz odpowiedni tekst w polu Tekst etykietki ekranowej i kliknij przycisk OK.

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć hiperlink.

     Można też zaznaczyć obiekt, taki jak obraz lub element wykresu, który ma reprezentować hiperlink.

    • Na karcie Wstawianie w grupie łącza kliknij przycisk hiperłącze Przycisk Hiperłącze .

    Możesz również kliknąć prawym przyciskiem myszy komórkę lub obiekt, a następnie w menu skrótów kliknąć polecenie hiperlink lub nacisnąć klawisze CTRL + K.

  2. W obszarze Połącz z kliknij opcję Istniejący plik lub strona sieci Web.

  3. Wykonaj jedną z następujących czynności:

    • Aby wybrać plik, kliknij pozycję Bieżący folder, a następnie kliknij plik, do którego ma zostać utworzony link.

      Bieżący folder można zmienić, wybierając inny folder na liście Szukaj w.

    • Aby wybrać stronę sieci Web, kliknij pozycję strony przeglądane , a następnie kliknij stronę sieci Web, do której chcesz utworzyć link.

    • Aby wybrać ostatnio używany plik, kliknij pozycję ostatnio używane pliki, a następnie kliknij plik, do którego chcesz utworzyć link.

    • Aby wprowadzić znaną nazwę i lokalizację pliku lub strony sieci Web, do których ma zostać utworzony link, wpisz te informacje w polu Adres.

    • Aby zlokalizować stronę sieci Web, kliknij pozycję Przeglądaj witrynę sieciWeb Przycisk Przeglądaj sieć Web , Otwórz stronę sieci Web, do której chcesz utworzyć link, a następnie przejdź z powrotem do programu Excel bez zamykania przeglądarki.

  4. Jeśli chcesz utworzyć hiperłącze do określonej lokalizacji w pliku lub na stronie sieci Web, kliknij pozycję zakładka, a następnie kliknij dwukrotnie żądany zakładka.

    Uwaga:  Zakładka musi istnieć w pliku lub na stronie sieci Web, do których ma zostać utworzony link.

  5. W polu Tekst do wyświetlenia wpisz tekst, który ma reprezentować hiperlink.

  6. Aby po zatrzymaniu wskaźnika myszy na hiperlinku były wyświetlane pomocne informacje, kliknij przycisk Etykietka ekranowa, wpisz odpowiedni tekst w polu Tekst etykietki ekranowej i kliknij przycisk OK.

Aby utworzyć link do określonej lokalizacji w bieżącym lub innym skoroszycie, można albo zdefiniować nazwa komórek miejsce docelowe, albo użyć odwołania do komórki.

  1. Aby posłużyć się nazwą, musisz nadać nazwę komórkom docelowym znajdującym się w skoroszycie docelowym.

    Jak nadać nazwę komórce lub zakresowi komórek

    1. Zaznacz komórkę, zakres komórek albo zaznaczenie nieprzylegające, którym chcesz nadać nazwę.

    2. Kliknij pole Nazwa na lewym końcu pasek formuły Obraz przycisku .

      Przykładowe pole Nazwa

      Obraz przycisku Pole Nazwa

    3. W polu Nazwa wpisz nazwę dla komórek, a następnie naciśnij klawisz ENTER.

      Uwaga:  Nazwy nie mogą zawierać spacji i muszą zaczynać się od litery.

  2. W arkuszu skoroszytu źródłowego Kliknij komórkę, w której chcesz utworzyć hiperlink.

     Można też zaznaczyć obiekt, taki jak obraz lub element wykresu, który ma reprezentować hiperlink.

    • Na karcie Wstawianie w grupie łącza kliknij przycisk hiperłącze Przycisk Hiperłącze .

    Możesz również kliknąć prawym przyciskiem myszy komórkę lub obiekt, a następnie w menu skrótów kliknąć polecenie hiperlink lub nacisnąć klawisze CTRL + K.

  3. W obszarze Połącz z wykonaj jedną z następujących czynności:

    • Aby utworzyć link do lokalizacji w bieżącym skoroszycie, kliknij pozycję Miejsce w tym dokumencie.

    • Aby utworzyć link do lokalizacji w innym skoroszycie, kliknij pozycję istniejący plik lub strona sieci Web, Znajdź i zaznacz skoroszyt, do którego chcesz utworzyć link, a następnie kliknij pozycję zakładka.

  4. Wykonaj jedną z następujących czynności:

    • W polu Lub wybierz miejsce w tym dokumencie w obszarze Adres komórki kliknij arkusz, do którego ma zostać utworzony link, wpisz odwołanie do komórki w polu Wpisz odwołanie do komórki, a następnie kliknij przycisk OK.

    • Na liście w obszarze Nazwy zdefiniowane kliknij nazwę reprezentującą komórki, do których ma zostać utworzony link, a następnie kliknij przycisk OK.

  5. W polu Tekst do wyświetlenia wpisz tekst, który ma reprezentować hiperlink.

  6. Aby po zatrzymaniu wskaźnika myszy na hiperlinku były wyświetlane pomocne informacje, kliknij przycisk Etykietka ekranowa, wpisz odpowiedni tekst w polu Tekst etykietki ekranowej i kliknij przycisk OK.

Za pomocą funkcji HIPERŁĄCZe można utworzyć hiperłącze otwierające dokument przechowywany na serwerze sieciowym, w intranet lub w Internecie. Gdy zostanie kliknięta komórka zawierająca funkcję HIPERŁĄCZE, program Excel otworzy plik przechowywany w lokalizacji, do której prowadzi link.

Składnia

=HIPERŁĄCZE(lokalizacja_docelowa_linku;przyjazna_nazwa)

Lokalizacja_docelowa_linku     to ścieżka i nazwa pliku dokumentu, który ma być otwierany jako tekst. Argument łącze_lokalizacja może się odwoływać do miejsca w dokumencie, na przykład do określonej komórki lub nazwanego zakresu arkusza bądź skoroszytu programu Excel, albo odwoływać się do zakładki w dokumencie programu Microsoft Word. Ścieżka może być plikiem przechowywanym na dysku twardym lub ścieżką może być ścieżka UNC (Universal Naming Convention) na serwerze (w programie Microsoft Excel dla systemu Windows) lub ścieżką URL (Uniform Resource Locator) w Internecie lub intranecie.

  • Argument lokalizacja_docelowa_linku może być ciągiem tekstowym ujętym w znaki cudzysłowu lub komórką, która zawiera link w postaci ciągu tekstowego.

  • Jeśli skok określony argumentem łącze_lokalizacja nie istnieje lub nie można go nawigować, po kliknięciu komórki pojawi się błąd.

Przyjazna_nazwa     to tekst skoku lub wartość liczbowa, która jest wyświetlana w komórce. Argument przyjazna_nazwa jest wyświetlany w kolorze niebieskim i jest podkreśleniem. Jeśli argument przyjazna_nazwa zostanie pominięty, komórka wyświetli argument lokalizacja_docelowa_linku jako tekst skoku.

  • Argument przyjazna_nazwa może być wartością, ciągiem tekstowym lub komórką, która zawiera tekst skoku lub wartość.

  • Jeśli argument przyjazna_nazwa zwraca wartość błędu (np. #ARG!), to komórka wyświetla błąd zamiast tekstu skoku.

Przykłady

W poniższym przykładzie jest otwierany arkusz o nazwie Raport budżetu. xls przechowywany w Internecie w lokalizacji o nazwie example.microsoft.com/report i wyświetlany jest tekst "kliknij, aby wyświetlić raport":

=HYPERLINK("http://example.microsoft.com/report/budget report.xls", "Click for report")

W poniższym przykładzie jest tworzone hiperłącze do komórki F10 w arkuszu o nazwie roczny w skoroszycie raport budżetowy. xls, który jest przechowywany w Internecie w lokalizacji o nazwie example.microsoft.com/report. W komórce arkusza zawierającej hiperlink jest wyświetlana zawartość komórki D1 jako tekst skoku.

=HYPERLINK("[http://example.microsoft.com/report/budget report.xls]Annual!F10", D1)

W poniższym przykładzie jest tworzone hiperłącze do zakresu o nazwie DeptTotal w arkuszu o nazwie pierwszy kwartał w skoroszycie raport budżetowy. xls, który jest przechowywany w Internecie w lokalizacji o nazwie example.microsoft.com/report. W komórce arkusza zawierającej hiperlink jest wyświetlany tekst „Kliknij tutaj, aby zobaczyć podsumowanie pierwszego kwartału dla działu”.

=HYPERLINK("[http://example.microsoft.com/report/budget report.xls]First Quarter!DeptTotal", "Click to see First Quarter Department Total")

Aby utworzyć hiperłącze do określonej lokalizacji w dokumencie programu Microsoft Word, należy użyć zakładki w celu zdefiniowania lokalizacji, do której chcesz przejść w dokumencie. W poniższym przykładzie jest tworzone hiperłącze do zakładki o nazwie QrtlyProfits w dokumencie o nazwie roczny raport. doc znajdującym się pod adresem example.microsoft.com:

=HYPERLINK("[http://example.microsoft.com/Annual Report.doc]QrtlyProfits", "Quarterly Profit Report")

W poniższym przykładzie w programie Excel dla systemu Windows jest wyświetlana zawartość komórki "moje" jako tekst skoku w komórce i zostanie otwarty plik o nazwie 1stqtr. xls, który jest przechowywany na serwerze o nazwie FINANSe w instrukcjach Share. W przykładzie jest używana ścieżka UNC:

=HYPERLINK("\\FINANCE\Statements\1stqtr.xls", D5)

W poniższym przykładzie jest otwierany plik 1stqtr. xls w programie Excel dla systemu Windows, który jest przechowywany w katalogu o nazwie Finanse na dysku D, i wyświetla wartość liczbową przechowywaną w komórce H10:

=HYPERLINK("D:\FINANCE\1stqtr.xls", H10)

W poniższym przykładzie w programie Excel dla systemu Windows jest tworzone hiperłącze do obszaru o nazwie sumy w innym (zewnętrznym) skoroszycie, Book. xls:

=HYPERLINK("[C:\My Documents\Mybook.xls]Totals")

W poniższym przykładzie w programie Microsoft Excel dla komputerów Macintosh jest wyświetlany komunikat "kliknij tutaj" w komórce i zostanie otwarty plik o nazwie pierwszy kwartał, który jest przechowywany w folderze o nazwie raporty budżetu na dysku twardym o nazwie Macintosh HD:

=HYPERLINK("Macintosh HD:Budget Reports:First Quarter", "Click here")

Możesz utworzyć hiperlinki w arkuszu, aby przeskoczyć z jednej komórki do innej. Na przykład, jeśli arkusz aktywny nosi nazwę "Czerwiec" i znajduje się w skoroszycie o nazwie Budżet, następujący przykład tworzy link do komórki E56. Sam tekst linku to wartość znajdująca się w komórce E56.

=HYPERLINK("[Budget]June!E56", E56)

Aby skoczyć do innego arkusza w tym samym skoroszycie, należy zmienić nazwę arkusza w linku. W poprzednim przykładzie, aby utworzyć link do komórki E56 w arkuszu Wrzesień, należy zmienić słowo "Czerwiec" na słowo "Wrzesień".

Po kliknięciu hiperłącza do adresu e-mail program poczty e-mail zostanie automatycznie uruchomiony i zostanie utworzona wiadomość e-mail z prawidłowym adresem w polu do , pod warunkiem, że jest zainstalowany program poczty e-mail.

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć hiperlink.

     Można też zaznaczyć obiekt, taki jak obraz lub element wykresu, który ma reprezentować hiperlink.

    • Na karcie Wstawianie w grupie łącza kliknij przycisk hiperłącze Przycisk Hiperłącze .

    Możesz również kliknąć prawym przyciskiem myszy komórkę lub obiekt, a następnie w menu skrótów kliknąć polecenie hiperlink lub nacisnąć klawisze CTRL + K.

  2. W obszarze Połącz z kliknij opcję Adres e-mail.

  3. W polu adres e-mail wpisz odpowiedni adres e-mail.

  4. W polu Temat wpisz temat wiadomości e-mail.

    Uwaga: Niektóre przeglądarki sieci Web i programy poczty e-mail mogą nie rozpoznawać wiersza tematu.

  5. W polu Tekst do wyświetlenia wpisz tekst, który ma reprezentować hiperlink.

  6. Aby po zatrzymaniu wskaźnika myszy na hiperlinku były wyświetlane pomocne informacje, kliknij przycisk Etykietka ekranowa, wpisz odpowiedni tekst w polu Tekst etykietki ekranowej i kliknij przycisk OK.

    Hiperlink do adresu e-mail można też utworzyć przez wpisanie adresu bezpośrednio w komórce. Hiperlink zostanie utworzony automatycznie na przykład po wpisaniu adresu e-mail osoba@example.com.

Możesz wstawić co najmniej jedno odwołanie zewnętrzne (nazywane również linkami) ze skoroszytu do innego skoroszytu, który znajduje się w intranet lub w Internecie. Skoroszyt nie może zostać zapisany jako plik HTML.

  1. Otwórz źródłowy skoroszyt i zaznacz komórkę lub zakres komórek do skopiowania.

  2. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Kopiuj.

    Przyciski Kopiuj i Wklej na karcie Narzędzia główne
  3. Przejdź do arkusza, w którym chcesz umieścić informacje, a następnie kliknij komórkę, w której mają się pojawić informacje.

  4. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Wklej specjalnie.

  5. Kliknij pozycję Wklej łącze.

    W programie Excel zostanie utworzony link odwołania zewnętrznego dla zaznaczonej komórki lub wszystkich komórek z zakresu.

Uwaga: Można także utworzyć link odwołania zewnętrznego bez otwierania skoroszytu w sieci Web. W przypadku każdej komórki w skoroszycie docelowym, w której chcesz dodać łącze do odwołania zewnętrznego, kliknij komórkę, a następnie wpisz znak równości (=), adres URL i lokalizację w skoroszycie. Przykład:

= "http://www.Someones.homepage/[plik. xls] Arkusz1"! A1

= "FTP. Server. gdzieś/plik. xls"! MyNamedCell

Aby wybrać hiperlink bez uaktywnienia linku do jego miejsce docelowe, wykonaj jedną z następujących czynności:

  • Kliknij komórkę zawierającą hiperlink i przytrzymaj przycisk myszy, aż wskaźnik przybierze kształt krzyżyka Wskaźnik zaznaczenia w programie Excel , a następnie puść przycisk myszy.

  • Zaznacz za pomocą klawiszy strzałek komórkę zawierającą hiperlink.

  • Jeśli hiperlink jest reprezentowany przez grafikę, przytrzymaj naciśnięty klawisz CTRL i kliknij tę grafikę.

Istniejący w skoroszycie hiperlink można zmienić, modyfikując jego miejsce docelowe, wygląd lub reprezentujący je tekst albo grafikę.

Zmienianie lokalizacji docelowej hiperlinku

  1. Zaznacz komórkę lub grafikę zawierającą hiperlink, który chcesz zmienić.

    Porada: Aby zaznaczyć komórkę zawierającą hiperlink bez przechodzenia do miejsca docelowego hiperlinku, kliknij tę komórkę i przytrzymaj przycisk myszy do momentu, aż wskaźnik przybierze kształt krzyżyka Wskaźnik zaznaczenia w programie Excel , a następnie zwolnij przycisk myszy. Komórkę można także zaznaczyć za pomocą klawiszy strzałek. Aby zaznaczyć grafikę, przytrzymaj naciśnięty klawisz Ctrl i kliknij tę grafikę.

    • Na karcie Wstawianie w grupie Łącza kliknij przycisk Hiperłącze. Przycisk Hiperłącze

    Możesz również kliknąć prawym przyciskiem myszy komórkę lub grafikę, a następnie w menu skrótów kliknąć polecenie Edytuj hiperlink lub nacisnąć klawisze CTRL + K.

  2. Wprowadź odpowiednie zmiany w oknie dialogowym Edytowanie hiperlinku .

    Uwaga: Jeśli hiperlink utworzono za pomocą funkcji arkusza HIPERŁĄCZE, należy edytować formułę, aby zmienić miejsce docelowe. Zaznacz komórkę zawierającą hiperlink, a następnie kliknij pasek formuły, aby edytować formułę.

Wygląd tekstu wszystkich hiperlinków w bieżącym skoroszycie można zmienić, modyfikując styl komórki dla hiperlinków.

  1. Na karcie Narzędzia główne w grupie Style kliknij przycisk Style komórki.

  2. W obszarze Dane i model wykonaj następujące czynności:

    • Aby zmienić wygląd hiperlinków, które nie zostały kliknięte, aby przejść do ich miejsc docelowych, kliknij prawym przyciskiem myszy pozycję hiperlink, a następnie kliknij polecenie Modyfikuj.

    • Aby zmienić wygląd hiperlinków, które zostały kliknięte, aby przejść do ich miejsc docelowych, kliknij prawym przyciskiem myszy pozycję odwiedzone hiperłącze, a następnie kliknij polecenie Modyfikuj.

      Uwaga: Styl komórki hiperlinku jest dostępny tylko wtedy, gdy skoroszyt zawiera hiperlink. Styl komórki odwiedzony hiperlink jest dostępny tylko wtedy, gdy skoroszyt zawiera kliknięte hiperłącze.

  3. W oknie dialogowym Styl kliknij przycisk Formatuj.

  4. Na kartach Czcionka i Wypełnienie zaznacz odpowiednie opcje formatowania, a następnie kliknij przycisk OK.

    Uwagi: 

    • Opcje zaznaczone w oknie dialogowym Formatowanie komórek są wyświetlane jako zaznaczone w obszarze Styl zawiera w oknie dialogowym Styl. Można wyczyścić pola wyboru dla opcji, które nie mają być stosowane.

    • Zmiany wprowadzone w stylach komórek Hiperłącze i Odwiedzone hiperłącze są stosowane do wszystkich hiperlinków w bieżącym skoroszycie. Nie można zmienić wyglądu pojedynczych hiperlinków.

  1. Zaznacz komórkę lub grafikę zawierającą hiperlink, który chcesz zmienić.

    Porada: Aby zaznaczyć komórkę zawierającą hiperlink bez przechodzenia do miejsca docelowego hiperlinku, kliknij tę komórkę i przytrzymaj przycisk myszy do momentu, aż wskaźnik przybierze kształt krzyżyka Wskaźnik zaznaczenia w programie Excel , a następnie zwolnij przycisk myszy. Komórkę można także zaznaczyć za pomocą klawiszy strzałek. Aby zaznaczyć grafikę, przytrzymaj naciśnięty klawisz Ctrl i kliknij tę grafikę.

  2. Wykonaj co najmniej jedną z następujących czynności:

    • Aby zmienić tekst hiperlinku, kliknij pasek formuły, a następnie Edytuj tekst.

    • Aby zmienić format grafiki, kliknij ją prawym przyciskiem myszy, a następnie kliknij opcję, która jest wymagana do zmiany jego formatu.

    • Aby zmienić tekst w grafice, kliknij dwukrotnie zaznaczoną grafikę, a następnie wprowadź odpowiednie zmiany.

    • Aby zmienić grafikę przedstawiającą hiperlink, wstaw nową grafikę, zamień ją na hiperlink o tym samym miejscu docelowym, a następnie usuń starą grafikę i hiperlink.

  1. Kliknij prawym przyciskiem myszy hiperlink, który chcesz skopiować lub przenieść, a następnie kliknij polecenie Kopiuj lub Wytnij w menu skrótów.

  2. Kliknij prawym przyciskiem myszy komórkę, do której chcesz skopiować lub przenieść hiperlink, a następnie w menu skrótów kliknij polecenie Wklej .

Domyślnie nieokreślone ścieżki do hiperlink plików docelowych są względne w stosunku do lokalizacji aktywnego skoroszytu. Za pomocą tej procedury możesz ustawić inną ścieżkę domyślną. Za każdym razem, gdy tworzysz hiperlink do pliku w tej lokalizacji, wystarczy określić nazwę pliku, a nie ścieżkę, w oknie dialogowym Wstawianie hiperlinku .

Postępuj zgodnie z jednym z kroków w zależności od używanej wersji programu Excel:

  • W Excel 2016, Excel 2013 i Excel 2010:

    1. Kliknij kartę Plik.

    2. Kliknij pozycję Informacje.

    3. Kliknij pozycję Właściwości, a następnie wybierz pozycję Właściwości zaawansowane.

      Właściwości zaawansowane
    4. Na karcie Podsumowanie w polu tekstowym podstawa hiperłącza wpisz ścieżkę, której chcesz użyć.

      Uwaga:  Można zastąpić adres podstawowy hiperlinku, używając pełnego lub bezwzględnego adresu tego hiperlinku w oknie dialogowym Wstawianie hiperłącza.

  • W Excel 2007:

    1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , kliknij pozycję Przygotuj, a następnie kliknij pozycję Właściwości.

    2. W panelu informacji o dokumencie kliknij pozycję Właściwości, a następnie kliknij pozycję Właściwości zaawansowane.

      Właściwości zaawansowane
    3. Kliknij kartę Podsumowanie.

    4. W polu Baza hiperłącza wpisz ścieżkę, której chcesz użyć.

    Uwaga:  Można zastąpić adres podstawowy hiperlinku, używając pełnego lub bezwzględnego adresu tego hiperlinku w oknie dialogowym Wstawianie hiperłącza.

Aby usunąć hiperlink, wykonaj jedną z następujących czynności:

  • Aby usunąć hiperlink i tekst, który je reprezentuje, kliknij prawym przyciskiem myszy komórkę zawierającą hiperlink, a następnie w menu skrótów kliknij polecenie Wyczyść zawartość .

  • Aby usunąć hiperlink i grafikę, która je reprezentuje, przytrzymaj naciśnięty klawisz Ctrl i kliknij grafikę, a następnie naciśnij klawisz Delete.

  • Aby wyłączyć jedno hiperłącze, kliknij prawym przyciskiem myszy hiperlink, a następnie w menu skrótów kliknij polecenie Usuń hiperlink .

  • Aby wyłączyć kilka hiperlinków jednocześnie, wykonaj następujące czynności:

    1. W pustej komórce wpisz cyfrę 1.

    2. Kliknij komórkę prawym przyciskiem myszy, a następnie w menu skrótów kliknij polecenie Kopiuj .

    3. Przytrzymaj naciśnięty klawisz Ctrl i zaznacz każde hiperłącze, które chcesz wyłączyć.

      Porada: Aby zaznaczyć komórkę, która zawiera hiperlink, nie przechodząc do miejsca docelowego hiperlinku, należy kliknąć tę komórkę i przytrzymać przycisk myszy naciśnięty do momentu, gdy wskaźnik przybierze kształt krzyżyka Wskaźnik zaznaczenia w programie Excel , a następnie puścić przycisk myszy.

    4. Na karcie Narzędzia główne w grupie Schowek kliknij strzałkę poniżej przycisku Wklej, a następnie kliknij polecenie Wklej specjalnie.

      Przyciski Kopiuj i Wklej na karcie Narzędzia główne
    5. W obszarze operacjakliknij pozycję pomnóż, a następnie kliknij przycisk OK.

    6. Na karcie Narzędzia główne w grupie Style kliknij przycisk Style komórki.

    7. W obszarze dobre, złe i neutralnewybierz pozycję normalny.

Hiperlink to link z dokumentu, który po kliknięciu otwiera inną stronę lub plik. Miejsce docelowe to często inna strona sieci Web, ale może również być obrazem, adresem e-mail lub programem. Hiperlinkiem może być tekst lub obraz.

Gdy użytkownik witryny kliknie hiperlink, miejsce docelowe jest wyświetlane w przeglądarka sieci Web, otwarty lub uruchomiony, w zależności od typu miejsca docelowego. Na przykład hiperlink do strony powoduje wyświetlenie tej strony w przeglądarce sieci Web, a hiperlink do pliku AVI powoduje otwarcie tego pliku w odtwarzaczu multimediów.

Jak korzystać z hiperlinków

Hiperlinków można używać do wykonywania następujących czynności:

  • Przechodzenie do pliku lub strony sieci Web w sieci, intranet lub Internecie

  • Przechodzenie do pliku lub strony sieci Web, która ma zostać utworzona w przyszłości

  • Wysyłanie wiadomości e-mail

  • Uruchamianie transferu pliku, na przykład pobierania pliku z sieci lub sesji protokołu FTP

Po wskazaniu tekstu lub obrazu zawierającego hiperlink wskaźnik myszy przybiera kształt dłoni Wskaźnik w kształcie dłoni , co oznacza, że wskazywany element można kliknąć.

Co to jest i jak działa adres URL

Gdy tworzysz hiperlink, jego miejsce docelowe jest kodowane jako adres URL (Uniform Resource Locator), na przykład:

http://example.microsoft.com/wiadomosci.htm

file://NazwaKomputera/FolderUdostepniony/NazwaPliku.htm

Adres URL zawiera protokół, na przykład HTTP, FTP lub plik, serwer sieci Web lub lokalizację sieciową oraz ścieżkę i nazwę pliku. Na poniższej ilustracji określono części adresu URL:

Cztery składniki adresu URL

1. Używany protokół (http, ftp, file)

2. serwer sieci Web lub lokalizacja sieciowa

3. Ścieżka

4. Nazwa pliku

Hiperlinki bezwzględne i względne

Bezwzględny adres URL zawiera pełny adres, łącznie z protokół, serwer sieci Web oraz ocieżką i nazwą pliku.

We względnym adresie URL brak jednej lub kilku części. Brakujące informacje są uzyskiwane ze strony zawierającej dany adres URL. Na przykład, gdy brak protokołu i serwera sieci Web, przeglądarka sieci Web używa protokołu i domeny, takiej jak com, org albo edu, bieżącej strony.

W sieci Web powszechne jest używanie względnych adresów URL, które zawierają jedynie częściową ścieżkę i nazwę pliku. Jeśli pliki zostaną przeniesione na inny serwer, wszelkie hiperlinki nadal będą działać, o ile względne lokalizacje stron pozostaną niezmienione. Na przykład hiperlink na stronie Products. htm wskazuje stronę o nazwie Apple. htm w folderze o nazwie jedzenie; Jeśli obie strony są przenoszone do folderu o nazwie jedzenie na innym serwerze, adres URL hiperlinku nadal będzie prawidłowy.

W skoroszycie programu Excel nieokreślone ścieżki do plików docelowych hiperlinków są domyślnie względne w stosunku do lokalizacji aktywnego skoroszytu. Możesz ustawić inny adres bazowy, który ma być używany domyślnie, aby każdemu tworzeniu hiperlinku do pliku w tej lokalizacji była tylko nazwa pliku, a nie ścieżka, w oknie dialogowym Wstawianie hiperlinku .

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć hiperlink.

  2. Na karcie Wstawianie kliknij przycisk Hiperlink.

    Możesz również kliknąć komórkę prawym przyciskiem myszy, a następnie kliknąć polecenie Hiperłącze w menu skrótów lub nacisnąć klawisze CTRL + K.

  3. W polu tekst wyświetlany wpisz tekst, który ma reprezentować hiperlink.

  4. W obszarze adres URLwpisz pełny adres URL (Uniform Resource Locator) strony sieci Web, do której chcesz utworzyć link.

  5. Kliknij przycisk OK.

Aby utworzyć link do lokalizacji w bieżącym skoroszycie, możesz zdefiniować nazwę komórek docelowych lub użyć odwołania do komórki.

  1. Aby użyć nazwy, należy nadać nazwy komórkom docelowym w skoroszycie.

    Definiowanie nazwy komórki lub zakresu komórek

    1. Zaznacz komórkę lub zakres komórek, który chcesz nazwać.

    2. W polu Nazwa na lewym końcu pasek formuły Obraz przycisku wpisz nazwę komórek, a następnie naciśnij klawisz ENTER.

      Uwaga:  Nazwy nie mogą zawierać spacji i muszą zaczynać się od litery.

  2. W arkuszu kliknij komórkę, w której chcesz utworzyć hiperlink.

  3. Na karcie Wstawianie kliknij przycisk Hiperlink.

    Możesz również kliknąć komórkę prawym przyciskiem myszy, a następnie kliknąć polecenie Hiperłącze w menu skrótów lub nacisnąć klawisze CTRL + K.

  4. W polu tekst wyświetlany wpisz tekst, który ma reprezentować hiperlink.

  5. W polu miejsce w tym dokumencie wprowadź zdefiniowaną nazwę lub odwołanie do komórki.

  6. Kliknij przycisk OK.

Po kliknięciu hiperłącza do adresu e-mail program poczty e-mail zostanie automatycznie uruchomiony i zostanie utworzona wiadomość e-mail z prawidłowym adresem w polu do , pod warunkiem, że jest zainstalowany program poczty e-mail.

  1. W arkuszu kliknij komórkę, w której chcesz utworzyć hiperlink.

  2. Na karcie Wstawianie kliknij przycisk Hiperlink.

    Możesz również kliknąć komórkę prawym przyciskiem myszy, a następnie kliknąć polecenie Hiperłącze w menu skrótów lub nacisnąć klawisze CTRL + K.

  3. W polu tekst wyświetlany wpisz tekst, który ma reprezentować hiperlink.

  4. W obszarze adres e-mailwpisz odpowiedni adres e-mail.

  5. Kliknij przycisk OK.

Hiperlink do adresu e-mail można też utworzyć przez wpisanie adresu bezpośrednio w komórce. Hiperlink zostanie utworzony automatycznie na przykład po wpisaniu adresu e-mail osoba@example.com.

Za pomocą funkcji hiperłącze można utworzyć hiperłącze do adresu URL.

Uwaga: Argument łącze_lokalizacja może być ciągiem tekstowym ujętym w cudzysłów lub odwołaniem do komórki zawierającej łącze jako ciąg tekstowy.

Aby wybrać hiperlink bez uaktywnienia linku do jego miejsce docelowe, wykonaj dowolną z następujących czynności:

  • Zaznacz komórkę, klikając ją, gdy wskaźnik myszy jest strzałką.

  • Zaznacz za pomocą klawiszy strzałek komórkę zawierającą hiperlink.

Istniejące hiperłącze można zmienić w skoroszycie, zmieniając jego miejsce docelowe, wygląd lub tekst, który będzie reprezentował.

  1. Zaznacz komórkę zawierającą hiperłącze, które chcesz zmienić.

    Porada: Aby wybrać hiperlink bez uaktywnienia linku do jego miejsce docelowe, użyj klawiszy strzałek, aby zaznaczyć komórkę zawierającą hiperlink.

  2. Na karcie Wstawianie kliknij przycisk Hiperlink.

    Możesz również kliknąć prawym przyciskiem myszy komórkę lub grafikę, a następnie w menu skrótów kliknąć polecenie Edytuj hiperlink lub nacisnąć klawisze CTRL + K.

  3. Wprowadź odpowiednie zmiany w oknie dialogowym Edytowanie hiperlinku .

    Uwaga: Jeśli hiperlink utworzono za pomocą funkcji arkusza HIPERŁĄCZE, należy edytować formułę, aby zmienić miejsce docelowe. Zaznacz komórkę zawierającą hiperlink, a następnie kliknij pasek formuły, aby edytować formułę.

  1. Kliknij prawym przyciskiem myszy hiperlink, który chcesz skopiować lub przenieść, a następnie kliknij polecenie Kopiuj lub Wytnij w menu skrótów.

  2. Kliknij prawym przyciskiem myszy komórkę, do której chcesz skopiować lub przenieść hiperlink, a następnie w menu skrótów kliknij polecenie Wklej .

Aby usunąć hiperlink, wykonaj jedną z następujących czynności:

  • Aby usunąć hiperlink, zaznacz komórkę i naciśnij klawisz Delete.

  • Aby wyłączyć hiperlink (Usuń hiperlink, ale pozostawić tekst, który go reprezentuje), kliknij komórkę prawym przyciskiem myszy, a następnie kliknij polecenie Usuń hiperlink.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Usuwanie lub wyłączanie hiperlinków

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×