Podstawowe zadania w programie Access 2010

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Poniżej przedstawiono niektóre zadania podstawowe bazy danych, które można wykonać, aby dowiedzieć się, jak za pomocą programu Microsoft Access 2010.

 

W tym artykule

Co to jest dostęp?

Relacyjne bazy danych w programie Access

Po otwarciu programu Access

Znajdowanie i stosowanie szablonu

Tworzenie bazy danych od podstaw

Otwieranie istniejącej bazy danych programu Access

Wprowadzenie do korzystania z nowej bazy danych

Dodawanie tabeli

Wklejanie danych z innego źródła do tabeli programu Access

Importowanie lub łączenie danych z innego źródła

Następne kroki

Importowanie danych z arkusza kalkulacyjnego lub innego programu

Importowanie arkusza programu Excel do programu Access.

Importowanie arkusza programu Excel jako tabeli w nowej bazie danych

Organizowanie danych przy użyciu Kreatora analizatora tabel

Praca z danymi z innych programów

Używanie wcześniejszej wersji bazy danych w kilku wersjach programu Access

Używanie pliku bazy danych programu Access w kilku wersjach programu Access

Krok 1: Utwórz kopię istniejącej bazy danych, a następnie zapisz ją w nowym formacie

Krok 2: Dzielenie kopii bazy danych i użyć oryginalny plik wewnętrznej bazy danych

Krok 3: Łączenie nową zewnętrzną w oryginalnej bazie danych

Używanie aplikacji zewnętrznej/wewnętrznej w kilku wersjach programu Access

Co to jest program Access?

Program access 2010 to narzędzie projektowanie i wdrażanie aplikacji bazy danych , który służy do śledzenia ważnych informacji. Możesz zachować danych na komputerze, lub możesz opublikować w sieci Web, aby inni mogli używać bazy danych za pomocą przeglądarki sieci web.

Wiele osób zaczyna korzystać z programu Access, gdy dotychczasowy program używany do śledzenia i gromadzenia różnych informacji przestaje dobrze pełnić swoje zadanie. Załóżmy na przykład, że użytkownik jest organizatorem imprez i chce śledzić wszystkie informacje niezbędne do realizacji postawionych celów. Jeżeli używa do tego edytora tekstów lub programu arkusza kalkulacyjnego, szybko zacznie mieć problemy ze zduplikowanymi i niespójnymi danymi. Może używać oprogramowania do obsługi kalendarza, lecz śledzenie informacji finansowych w kalendarzu nie jest dobrym pomysłem.

Relacyjne bazy danych w programie Access

Czasami do śledzenia tych informacji może być potrzebna relacyjna baza danych — magazyn danych podzielony na mniejsze kolekcje danych (nazywane tabelami) w celu wyeliminowania nadmiarowości, które są ze sobą powiązane relacjami na podstawie określonych wspólnych informacji (nazywanych polami). Na przykład relacyjna baza danych do organizacji imprez może zawierać tabelę z informacjami o klientach, tabelę z informacjami o dostawcach oraz tabelę z informacjami o imprezie. Tabela z informacjami o imprezie może zawierać pole zapewniające jej powiązanie z tabelą klientów oraz pole zapewniające jej powiązanie z tabelą dostawców. Dzięki temu, jeśli ulegnie zmianie na przykład numer telefonu dostawcy, wystarczy tę informację zmienić raz w tabeli dostawców, zamiast w rekordzie każdej imprezy przygotowywanej z jego udziałem.

Program Access to narzędzie do szybkiego i prostego opracowywania aplikacji relacyjnych baz danych ułatwiających zarządzanie informacjami. Bazę danych można utworzyć w celu śledzenia dowolnego rodzaju informacji, np. stanu zapasów, kontaktów zawodowych lub procesów biznesowych. W programie Access są dostępne szablony, których można od razu użyć do śledzenia szeregu informacji, dzięki czemu nawet początkujący użytkownicy nie mają z tym żadnych trudności.

Po otwarciu programu Access

Po rozpoczęciu Access 2010, zobacz Microsoft Office Backstage widok, gdzie można uzyskać informacje na temat bieżącej bazy danych, Utwórz nową bazę danych, Otwieranie istniejącej bazy danych, a widok promowanie zawartości z Office.com.

Widok Backstage w programie Access 2010

Widok Backstage zawiera też szereg innych poleceń służących do dostosowywania, konserwacji lub udostępniania baz danych. Polecenia dostępne w widoku Backstage dotyczą z reguły całej bazy danych, a nie znajdujących się w niej obiektów.

Uwaga : Dostęp do widoku Backstage można uzyskać w dowolnym czasie, klikając kartę Plik.

Początek strony

Znajdowanie i stosowanie szablonu

Program Access udostępnia szeroką gamę szablonów, których można użyć do szybszego utworzenia własnej bazy danych. Szablon jest gotową do użycia bazą danych, która zawiera wszystkie tabele, kwerendy, formularze i raporty potrzebne do określonego zadania. Istnieją na przykład szablony, które mogą służyć do śledzenia problemów, zarządzania kontaktami lub rejestrowania wydatków. Niektóre szablony zawierają kilka przykładowych rekordów prezentujących ich zastosowanie. Szablony baz danych można stosować w niezmienionej postaci lub dostosowywać do własnych potrzeb.

Aby znaleźć szablon i zastosować go do bazy danych, wykonaj następujące czynności:

  1. Na karcie Plik kliknij pozycję Nowe.

  2. W obszarze Dostępne szablony wykonaj jedną z następujących czynności:

    • Aby ponownie użyć ostatnio używanego szablonu, kliknij pozycję Ostatnio używane szablony, a następnie wybierz odpowiedni szablon.

    • Aby użyć wcześniej zainstalowanego szablonu, kliknij pozycję Moje szablony, a następnie wybierz odpowiedni szablon.

    • Znajdowanie szablonu na Office.com w obszarze Szablony w witrynie Office.com, kliknij kategorię szablonu, wybierz szablon, który ma być, a następnie kliknij przycisk Pobierz, aby pobrać szablon z .com pakietu Office na komputerze.

      Możesz również wyszukać szablony w witrynie Office.com z poziomu programu Access. W polu Wyszukaj w witrynie Office.com szablonów wpisz wyszukiwane terminy, a następnie kliknij przycisk strzałki, aby wyszukać.

  3. Opcjonalnie kliknij ikonę folderu obok pola Nazwa pliku, aby przejść do lokalizacji, w której ma zostać utworzona baza danych. Jeżeli nie zostanie wskazana żadna lokalizacja, program Access utworzy bazę w domyślnej lokalizacji określonej poniżej pola Nazwa pliku.

  4. Kliknij przycisk Utwórz.

Program Access utworzy bazę danych i otworzy ją do użycia.

Początek strony

Tworzenie bazy danych od podstaw

Jeśli chcesz bardziej szczegółowego wprowadzenie do pojęć dotyczących tworzenie bazy danych za pomocą programu Access, zobacz artykuł podstawowe informacje o projekcie bazy danych.

Jeśli żaden z szablonów nie odpowiada potrzebom użytkownika lub dysponuje on danymi w innym programie, które chce wykorzystać w programie Access, może się okazać, że lepszym wyjściem jest utworzenie bazy danych od podstaw. W programie Access 2010 są dostępne dwie opcje: standardowa stacjonarna baza danych i baza danych sieci Web.

Aby uzyskać więcej informacji o bazach danych sieci web zobacz artykuł Tworzenie bazy danych udostępnianej w sieci Web.

Aby utworzyć nową bazę danych, wykonaj następujące czynności:

  1. Uruchom program Access.

  2. Na karcie Nowe w widoku Backstage kliknij pozycję Pusta baza danych lub Pusta baza danych sieci Web.

    Ważne : Wybór dokonany w tym miejscu decyduje o funkcjach dostępnych w bazie danych. Stacjonarnych baz danych nie można publikować w sieci Web, a bazy danych sieci Web nie obsługują niektórych funkcji baz stacjonarnych, na przykład kwerend podsumowujących.

  3. Po prawej stronie okna wpisz nazwę bazy danych w polu Nazwa pliku.

    Aby zmienić lokalizację, w którym możesz utworzyć ten plik, kliknij pozycję Przeglądaj Obraz przycisku obok pola Nazwa pliku, przejdź do i wybierz nową lokalizację, a następnie kliknij przycisk OK.

  4. Kliknij przycisk Utwórz.

    Program Access utworzy bazę danych, a następnie otworzy pustą tabelę (o nazwie Tabela1) w widok arkusza danych.

  5. Program Access umieści kursor w pierwszej pustej komórce w kolumnie Kliknij, aby dodać w nowej tabeli.

    Aby dodać dane, zacznij wpisywać — też wkleić dane z innego źródła, zgodnie z opisem w sekcji Wklejanie danych z innego źródła do tabeli programu Access, w dalszej części tego artykułu.

    Uwagi : 

    • Wprowadzanie danych w widoku arkusza danych zaprojektowano w sposób bardzo podobny do wprowadzania danych w arkuszu programu Excel. Główne ograniczenie polega na tym, że dane muszą być wprowadzane w przyległych wierszach i kolumnach, począwszy od lewego górnego rogu arkusza danych. Nie należy próbować formatować danych, ponieważ spowoduje to utratę miejsca w tabeli. Tabela tylko zawiera dane. Do wizualnej prezentacji danych posłużą formularze i raporty, które zostaną zaprojektowane później.

    • Struktura tabeli jest tworzona podczas wprowadzania danych. Dowolnym momencie dodać nową kolumnę do arkusza danych, nowe pole jest zdefiniowane w tabeli. Program Access ustawia typ danych zależy od typu danych pola. Na przykład jeśli masz kolumnę, w której zostały wprowadzone tylko wartości dat, Access będzie Ustaw typ danych tego pola daty/godziny. Jeśli później próba wprowadź wartość-date (na przykład nazwiska lub numeru telefonu) w tym polu, program Access wyświetli komunikat z informacją, że wartość pasuje do typu danych kolumny. Jeśli to możliwe, należy zaplanować tabeli tak, aby każda kolumna zawiera ten sam typ danych, czy jest tekst, dat, liczb lub innego typu. Ta funkcja znacznie ułatwia tworzenie kwerend, formularzy i raportów, które wybierają tylko odpowiednie dane.

Jeśli nie chcesz jeszcze wprowadzanie danych, kliknij przycisk Zamknij Obraz przycisku .

Uwaga : W przypadku zamknięcia programu bez zapisania Tabela1 zostanie usunięta.

Początek strony

Otwieranie istniejącej bazy danych programu Access

Porada : Aby szybko otworzyć jedną z kilku ostatnio używanych baz danych, na karcie Plik kliknij pozycję Ostatnie, a następnie kliknij nazwę pliku.

  1. Na karcie Plik kliknij przycisk Otwórz.

  2. Kliknij skrót w oknie dialogowym Otwieranie albo kliknij dysk lub folder zawierający bazę danych programu Access na liście w polu Szukaj w .

  3. Na liście folderów klikaj dwukrotnie kolejne foldery, aż zostanie otwarty folder zawierający szukaną bazę danych.

  4. Znalazłszy bazę danych, wykonaj jedną z następujących czynności:

    • Aby otworzyć bazę danych w domyślnym trybie otwierania, kliknij ją dwukrotnie.

    • Aby otworzyć bazę danych do udostępnionego w środowisku, tak aby Ty i inni użytkownicy mogli czytać i zapisywać w bazie danych, w tym samym czasie, kliknij przycisk Otwórz.

    • Aby otworzyć bazę danych w trybie tylko do odczytu, tak aby można było oglądać bazę danych, ale nie można było jej edytować, kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz tylko do odczytu.

    • Aby otworzyć bazę danych do wyłącznego dostępu, tak aby inni użytkownicy nie mogli jej otworzyć, kiedy będzie otwarta, kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz z wyłącznością.

    • Aby otworzyć bazę danych w trybie dostępu tylko do odczytu, kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz z wyłącznością tylko do odczytu. Inni użytkownicy będą mogli otwierać bazę danych, ale będą mieli do niej dostęp w trybie tylko do odczytu.

Postępowanie w sytuacji, gdy nie można znaleźć bazy danych    

  1. W oknie dialogowym Otwieranie kliknij skrót Mój komputer lub w polu Szukaj w kliknij pozycję Mój komputer.

  2. Na liście dysków kliknij prawym przyciskiem myszy dysk, na którym może się znajdować szukana baza danych, a następnie kliknij polecenie Wyszukaj.

  3. Wprowadź kryteria wyszukiwania, a następnie naciśnij klawisz ENTER, aby wyszukać bazę danych.

  4. Jeśli baza danych zostanie znaleziona, otwórz ją, klikając ją dwukrotnie w oknie dialogowym Wyniki wyszukiwania.

    Ponieważ wyszukiwanie zostało zainicjowane w oknie dialogowym Otwieranie, trzeba kliknąć w nim przycisk Anuluj, aby umożliwić otwarcie bazy danych.

Istnieje możliwość bezpośredniego otwarcia pliku danych w zewnętrznym formacie pliku (na przykład dBASE, Paradox, Microsoft Exchange lub Excel). Można także otworzyć bezpośrednio dowolne źródło danych ODBC, na przykład źródło danych programu Microsoft SQL Server lub Microsoft FoxPro. W programie Access jest automatycznie tworzona nowa baza danych programu Access w folderze, w którym znajduje się plik danych, a także dodawane są łącza do każdej tabeli w zewnętrznej bazie danych.

Początek strony

Rozpoczynanie korzystania z nowej bazy danych

W zależności od użytego szablonu przed przystąpieniem do korzystania z nowej bazy danych może być konieczne wykonanie jednej lub kilku poniższych czynności:

  • Jeżeli w programie Access zostanie wyświetlone okno dialogowe Logowanie z pustą listą użytkowników, wykonaj poniższą procedurę, aby rozpocząć:

    1. Kliknij przycisk Nowy użytkownik.

    2. Wypełnij formularz Szczegóły użytkowników.

    3. Kliknij przycisk Zapisz i zamknij.

    4. Zaznacz wprowadzoną właśnie nazwę użytkownika i kliknij przycisk Zaloguj.

  • Jeżeli w programie Access zostanie wyświetlony pusty arkusz danych, można rozpocząć wpisywanie danych bezpośrednio w tym arkuszu lub kliknąć inne przyciski bądź karty, aby przejrzeć bazę.

  • Jeżeli w programie Access zostanie wyświetlona strona Wprowadzenie, można kliknąć łącza na tej stronie, aby dowiedzieć się więcej na temat bazy danych, lub kliknąć inne przyciski i karty, aby przejrzeć bazę danych.

  • Jeżeli na pasku komunikatów w programie Access zostanie wyświetlony komunikat Ostrzeżenie o zabezpieczeniach, a źródło szablonu jest zaufane, należy kliknąć polecenie Włącz zawartość. Jeżeli baza danych wymaga logowania, trzeba się ponownie zalogować.

W przypadku stacjonarnych baz danych i baz danych sieci Web należy rozpocząć od wykonania jednej z następujących czynności:

Początek strony

Dodawanie tabeli

Nową tabelę można dodać do istniejącej bazy danych za pomocą narzędzi w grupie Tabele na karcie Tworzenie.

Grupa Tabele na karcie Tworzenie

Uwaga : W przypadku bazy danych sieci Web w grupie Tabele jest dostępne jedynie polecenie Tabela.

Niezależnie od tego, w którym widoku zostanie rozpoczęta praca, zawsze można przejść do drugiego widoku za pomocą przycisków widoków na pasku stanu okna programu Access.

Tworzenie pustej tabeli w widoku arkusza danych    W widoku arkusza danych można wprowadzać dane bezpośrednio. Program Access utworzy strukturę tabeli w tle. Przypisywane nazwy pól zawierają liczby (Pole1, Pole2 itd.), a typ danych pola jest określany na podstawie typu wprowadzanych danych.

  1. Na karcie Tworzenie w grupie tabele kliknij tabelę Obraz przycisku .

  2. Program Access utworzy tabelę, a następnie umieści kursor w pierwszej pustej komórce w kolumnie Kliknij, aby dodać.

  3. Aby dodać dane, zacznij pisać w pierwszej pustej komórce — możesz także wkleić dane z innego źródła w sposób opisany w dalszej części tego artykułu.

    • Aby zmienić nazwę kolumny (pola), kliknij dwukrotnie nagłówek kolumny, a następnie wpisz nową nazwę.

      Porada : Przypisz opisowe nazwy do wszystkich pól, ponieważ ułatwia to ustalenie ich zawartości bez przeglądania danych.

    • Aby przenieść kolumnę, zaznacz ją, klikając nagłówek kolumny, a następnie przeciągnij w odpowiednie miejsce. Można zaznaczyć kilka przyległych kolumn i przeciągnąć je wszystkie razem w nowe miejsce.

      Aby dodać więcej pól do tabeli, można rozpocząć wpisywanie w kolumnie Kliknij, aby dodać w widoku arkusza danych lub dodać nowe pola przy użyciu poleceń dostępnych w grupie Dodawanie i usuwanie na karcie Pola.

Tworzenie tabeli w widoku projektu    W widoku projektu użytkownik najpierw tworzy strukturę nowej tabeli. Następnie przełącza do widoku arkusza danych i wprowadza dane, używając innej metody, na przykład za pomocą formularza.

Widok projektu jest niedostępny w przypadku tabel bazy danych sieci Web.

  1. Na karcie Tworzenie w grupie Tabele kliknij pozycję Projekt tabeli. Obraz przycisku

  2. Dla każdego pola tabeli wpisz nazwę w kolumnie Nazwa pola, a następnie wybierz typ danych z listy Typ danych.

  3. W kolumnie Opis można wprowadzić dodatkowe informacje o poszczególnych polach. Wprowadzony opis jest wyświetlany na pasku stanu, gdy punkt wstawiania znajduje się w danym polu, i jest używany jako tekst paska stanu dla wszystkich formantów utworzonych przez przeciągnięcie tego pola z okienka Lista pól do formularza lub raportu i wszystkich formantów utworzonych dla tego pola za pomocą Kreatora formularzy lub Kreatora raportów.

  4. Po dodaniu wszystkich pól zapisz tabelę:

    • Na karcie Plik kliknij przycisk Zapisz.

  5. Wprowadzanie danych do tabeli można rozpocząć w dowolnej chwili przez przełączenie do widoku arkusza danych, kliknięcie pierwszej pustej komórki i pisanie. Można też wkleić dane z innego źródła w sposób opisany w następnej sekcji.

Tworzenie tabeli na podstawie listy programu SharePoint    Dzięki zastosowaniu listy SharePoint dane użytkownika mogą być używane przez osoby, które nie mają programu Access. Ponadto dane listy są przechowywane na serwerze, co zasadniczo zapewnia lepszą ochronę przed utratą danych niż w przypadku plików przechowywanych na komputerze stacjonarnym. Można rozpocząć od utworzenia nowej listy lub utworzenia łącza do listy już istniejącej. Trzeba mieć odpowiednie uprawnienia w witrynie programu SharePoint, w której lista ma zostać utworzona. Można mieć różne uprawnienia w różnych witrynach, w związku z czym należy się skontaktować z administratorem programu SharePoint w celu uzyskania szczegółowych informacji o dostępnych opcjach.

Ta funkcja nie jest dostępne w bazie danych sieci Web.

  1. Na karcie Tworzenie w grupie Tabele kliknij przycisk Listy programu SharePoint.

  2. Standardową listę programu SharePoint, np. Kontakty lub Wydarzenia, można utworzyć przy użyciu jednego z szablonów list.

    Można też utworzyć listę niestandardową albo utworzyć łącze do już istniejącej listy bądź zaimportować taką listę. Kliknij wybraną opcję.

  3. Po wybraniu jednego z szablonów list lub opcji utworzenia listy niestandardowej zostanie otwarte okno dialogowe Tworzenie nowej listy, które ułatwi Ci wykonanie tego zadania. W przypadku wybrania istniejącej listy zostanie otwarte okno dialogowe Pobieranie danych zewnętrznych.

Aby uzyskać więcej informacji o tabelach, zobacz artykuł Wprowadzenie do tabel.

Początek strony

Wklejanie danych z innego źródła do tabeli programu Access

Jeśli dane są przechowywane w innym programie, na przykład w programie Excel, można je skopiować i wkleić do tabeli programu Access. Zazwyczaj ten sposób sprawdza się najlepiej, jeśli dane są już podzielone na kolumny, tak jak w arkuszu programu Excel. Jeśli dane znajdują się w edytorze tekstów, przed ich skopiowaniem najlepiej jest rozdzielić kolumny danych przy użyciu znaków tabulacji lub przekonwertować dane na tabelę w edytorze tekstów. Jeśli dane wymagają edycji lub opracowania (na przykład rozdzielenia imion i nazwisk), warto wprowadzić odpowiednie zmiany przed skopiowaniem danych i wklejeniem ich do tabeli programu Access, zwłaszcza jeśli nie ma się doświadczenia w pracy z programem Access.

Podczas wklejania danych do pustej tabeli typ danych każdego pola jest ustawiany według rodzaju danych, które zostaną znalezione. Jeśli na przykład wklejane pole zawiera tylko daty, zostanie do niego zastosowany typ danych Data/Godzina. Jeśli pole zawiera tylko wyrazy „tak” lub „nie”, zostanie do niego zastosowany typ danych Tak/Nie.

W programie Access nazwy pól są nadawane zależnie od zawartości pierwszego wiersza wklejanych danych. Jeśli typ pierwszego wiersza wklejanych danych przypomina dalsze wiersze, program Access uznaje go za część danych i przypisuje polom nazwy ogólne (Pole1, Pole2 itd.). Jeśli pierwszy wiersz wklejanych danych nie jest podobny do następnych wierszy, program Access używa pierwszego wiersza jako nazw pól i nie dołącza pierwszego wiersza do danych.

Jeśli zostaną nadane nazwy ogólne, warto je jak najszybciej zmienić, aby uniknąć pomyłek. Należy postępować zgodnie z poniższą procedurą:

  1. Na karcie Plik kliknij pozycję Zapisz, aby zapisać tabelę.

  2. W widoku arkusza danych kliknij dwukrotnie nagłówek każdej kolumny i wpisz nazwę kolumny.

  3. Ponownie zapisz tabelę.

Początek strony

Importowanie lub łączenie danych z innego źródła

Użytkownik może mieć zgromadzone w innym programie dane, które chce wykorzystać w programie Access. Możliwa jest też sytuacja, w której użytkownik współpracuje z osobami przechowującymi dane w innych programach, a sam chce pracować z tymi danymi w programie Access. Może też mieć kilka osobnych źródeł danych i chcieć utworzyć jedno miejsce, w którym zbierze je wszystkie na potrzeby dokładniejszej analizy.

Program Access ułatwia importowanie lub łączenie danych pochodzących z innych programów. Dane można importować z arkusza programu Excel, z tabeli w innej bazie danych programu Access, z listy programu SharePoint oraz z wielu innych źródeł. Proces wygląda nieco inaczej w przypadku różnych źródeł danych, ale należy zacząć od wykonania następujących instrukcji:

  1. Na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij polecenie odpowiednie do typu importowanego pliku.

    Na przykład w przypadku importowania danych z arkusza programu Excel należy kliknąć przycisk Excel. Jeśli odpowiedni typu programu nie jest wyświetlany, należy kliknąć przycisk Więcej.

    Uwaga : Jeśli nie możesz znaleźć odpowiedniego typu formatu w grupie Importowanie i łączenie, może być konieczne uruchom program, w którym został pierwotnie utworzony dane i zapisywanie danych w formacie pliku, który program Access obsługuje (na przykład rozdzielany plik tekstowy ), za pomocą tego oprogramowania i zaimportowanie lub utworzyć łącze do danych.

  2. W oknie dialogowym Pobieranie danych zewnętrznych kliknij przycisk Przeglądaj, aby przejść do pliku danych źródłowych, lub wpisz pełną ścieżkę do pliku danych źródłowych w polu Nazwa pliku.

  3. Kliknij odpowiednią opcję w obszarze Określ sposób i miejsce przechowywania danych w bieżącej bazie danych. Możesz utworzyć nową tabelę z importowanymi danymi lub utworzyć tabelę połączoną, a w niej łącze do źródła danych.

  4. Kliknij przycisk OK.

    W zależności od wybranej opcji zostanie otwarte okno dialogowe Łączenie obiektów lub Importowanie obiektów.

  5. Zakończ proces przy użyciu okna dialogowego. Dokładna procedura do wykonania zależy od wybranej opcji importowania lub łączenia.

  6. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

    Po wybraniu opcji importowania w programie Access zostanie wyświetlone pytanie, czy użytkownik chce zapisać szczegóły właśnie zakończonej operacji importu.

  7. Jeśli ta sama operacja importowania będzie prawdopodobnie wykonywana ponownie, kliknij pole wyboru Zapisz kroki importowania i wprowadź szczegółowe informacje.

    Można łatwo powtórzyć operację importowania, klikając przycisk Zapis. dane importu w grupie Importowanie na karcie Dane zewnętrzne, klikając specyfikację importowania, a następnie klikając przycisk Uruchom.

  8. Jeśli szczegółowe informacje na temat operacji nie mają zostać zapisane, należy kliknąć przycisk Zamknij.

Program Access zaimportuje dane do nowej tabeli, a następnie tabela ta zostanie wyświetlona w obszarze Tabele w okienku nawigacji.

Aby uzyskać więcej informacji na temat importowania danych do programu Access, skorzystaj z łączy w sekcji Zobacz też w tym artykule.

Początek strony

Dalsze kroki

Pozostała część procesu projektowania różni się w zależności od celów, lecz prawdopodobnie będzie obejmować tworzenie kwerend, formularzy, raportów i makr. W tym artykule nie zamieszczono informacji na temat tworzenia dodatkowych obiektów bazy danych.

Aby uzyskać więcej informacji, zobacz następujące artykuły:

Początek strony

Importowanie danych z arkusza kalkulacyjnego lub innego programu

Jeżeli masz doświadczenie z innymi programami bazy danych lub arkusz kalkulacyjny, prawdopodobnie wiesz, jak działają te aplikacje i do czego służą bazy danych dla. Program Access różni się od wielu innych aplikacji bazy danych umożliwia tworzenie relacyjnych baz danych, a dodatkowo różni się od większości programów arkusza kalkulacyjnego oferując narzędzi do tworzenia zaawansowanych kwerend, formularzy i raportów. Program Access udostępnia również wiele opcji ułatwiających pracę z innymi programami bazy danych, na przykład programu SQL Server.

Importowanie arkusza programu Excel do programu Access

W przypadku wielu użytkowników pracę z programem Access poprzedza utworzenie listy w programie Excel. Program Excel jest doskonałym miejscem na rozpoczęcie listy, ale w miarę jej rozrastania się coraz trudniej jest tę listę organizować i aktualizować. Kolejnym logicznym krokiem jest przeniesienie listy do programu Access.

Tabela bazy danych przypomina w strukturze do arkusza, w którym dane są przechowywane w wierszach i kolumnach. W wyniku jest zazwyczaj można z łatwością importować arkusz do tabeli bazy danych. Główna różnica pomiędzy magazynowaniem danych w arkuszu i przechowywaniu go w bazie danych znajduje się w sposób organizowania danych. Po prostu Importowanie całego arkusza jako nowej tabeli w bazie danych nie rozwiąże problemów związanych z organizowanie i aktualizowanie danych, szczególnie jeśli arkusz zawiera powtarzających się danych. Aby rozwiązać te problemy, należy podzielić dane z arkusza kalkulacyjnego na osobne tabele, każdy z nich zawiera dane pokrewne. Aby uzyskać więcej informacji o rozmieszczaniu danych w tabelach, zobacz artykuł podstawowe informacje o projekcie bazy danych.

Program Access udostępnia Kreatora analizatora tabel, który ułatwia wykonanie tego procesu. Po zaimportowaniu danych do tabeli przez użytkownika kreator umożliwia podzielenie tabeli na osobne tabele zawierające dane, które nie są zduplikowane w żadnej z pozostałych tabel. Kreator umożliwia również tworzenie niezbędnych relacji między tabelami.

Początek strony

Importowanie arkusza programu Excel jako tabeli nowej bazy danych

  1. Na karcie Plik kliknij pozycję Nowy, a następnie kliknij pozycję Pusta baza danych.

  2. Wpisz nazwę nowej bazy danych w polu Nazwa pliku, a następnie kliknij przycisk Utwórz.

    Zostanie otwarta nowa baza danych z nową, pustą tabelą o nazwie Tabela1.

  3. Zamknij tabelę Tabela1.

    Gdy zostanie wyświetlony monit o zapisanie zmian w projekcie tabeli Tabela1, kliknij przycisk Nie.

  4. Na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij programu Excel. Obraz przycisku

  5. W oknie dialogowym Pobieranie danych zewnętrznych kliknij przycisk Przeglądaj.

  6. Zlokalizuj swój plik przy użyciu okna dialogowego Otwieranie pliku.

  7. Zaznacz plik i kliknij przycisk Otwórz.

  8. W oknie dialogowym Pobieranie danych zewnętrznych upewnij się, że jest zaznaczona opcja Importuj dane źródłowe do nowej tabeli w bieżącej bazie danych.

  9. Kliknij przycisk OK.

    Zostanie uruchomiony Kreator importu arkuszy, który zada kilka pytań na temat danych.

  10. Postępuj zgodnie z instrukcjami, klikając przyciski Dalej lub Wstecz, aby przechodzić między stronami. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

    Uwaga : W programie Access zostanie wyświetlone pytanie, czy chcesz zapisać szczegóły właśnie zakończonej operacji importowania. Jeśli ta sama operacja importowania będzie prawdopodobnie wykonywana ponownie, należy kliknąć przycisk Tak i wprowadzić szczegółowe informacje. Ułatwi to powtarzanie operacji importowania przez kliknięcie przycisku Zapis. dane importu w grupie Importowanie na karcie Dane zewnętrzne. Aby nie zapisywać szczegółowych informacji na temat operacji, należy kliknąć przycisk Zamknij.

Program Access zaimportuje dane do nowej tabeli, a następnie tabela zostanie wyświetlona w obszarze Wszystkie tabele w okienku nawigacji.

Początek strony

Organizowanie danych przy użyciu Kreatora analizatora tabel

Po zaimportowaniu danych do tabeli programu Access można użyć Kreatora analizatora tabel do szybkiego zidentyfikowania zbędnych danych. Kreator ułatwia uporządkowanie zbędnych danych w osobnych tabelach, aby dane były przechowywane jak najefektywniej. Program Access zachowa oryginalną tabelę jako kopię zapasową, a następnie utworzy nowe tabele, których będzie można użyć jako podstawy swojej aplikacji bazy danych.

  1. Otwórz bazę danych programu Access zawierającą tabelę, którą chcesz przeanalizować.

  2. Na karcie Narzędzia bazy danych w grupie Analiza kliknij przycisk Analizuj tabelę.

    Zostanie uruchomiony Kreator analizatora tabel.

    Na dwóch pierwszych stronach kreatora zamieszczono krótki samouczek — zawiera on przyciski, których kliknięcie powoduje wyświetlenie przykładów. Jeśli te strony nie są wyświetlane i tylko jest dostępne pole wyboru Czy pokazać strony wprowadzenia?, należy zaznaczyć to pole wyboru, a następnie dwa razy kliknąć przycisk Wstecz, aby zobaczyć wprowadzenie. Aby zapobiec późniejszemu wyświetlaniu stron wprowadzenia, można wyczyścić pole wyboru Czy pokazać strony wprowadzenia?

  3. Na stronie Która tabela zawiera pola zawierające powtarzające się dane w wielu rekordach? zaznacz tabelę, którą chcesz przeanalizować, a następnie kliknij przycisk Dalej.

  4. Możesz zezwolić, aby to kreator zadecydował, które pola zostaną umieszczone w których tabelach, lub zadecydować o tym samodzielnie. Nawet po przyjęciu sugestii kreatora można wprowadzić zmiany do układu tabeli na następnej stronie kreatora.

    Uwaga : Pozostawiając kreatorowi decyzję o tym, które pola zostaną umieszczone w których tabelach, trzeba pamiętać, że wybory kreatora mogą nie być właściwe dla danych, szczególnie jeśli nie jest ich zbyt wiele. Wyniki kreatora należy dokładnie sprawdzić. Z drugiej strony kreator może zaproponować efektywniejszą organizację niż sam użytkownik, warto więc chociaż raz spróbować zastosować decyzje kreatora. Jeśli propozycje kreatora nie będą trafne, można ręcznie zmienić rozmieszczenie pól albo kliknąć przycisk Wstecz i zorganizować wszystkie pola samodzielnie.

  5. Kliknij przycisk Dalej. Na tej stronie należy określić, które tabele mają zawierać które pola. Jeśli zadecydował o tym kreator, powinny być widoczne liczne tabele połączone liniami relacji. Program Access może też utworzyć tylko jedną tabelę zawierającą wszystkie pola. W obu przypadkach na tej stronie można wprowadzać zmiany.

    • Można przeciągać pola z tabeli do pustego obszaru strony, aby utworzyć nową tabelę zawierającą te pola. Program Access wyświetli monit o określenie nazwy tabeli.

    • Można przeciągać pola z jednej tabeli do drugiej, jeśli zdaniem użytkownika takie ich przechowywanie będzie efektywniejsze.

    • Większość tabel otrzyma pole Identyfikator lub pole Wygenerowany unikatowy ID. Aby uzyskać więcej informacji na temat pól identyfikatorów, kliknij łącze Porady w prawym górnym rogu kreatora.

    • Aby cofnąć zmianę, kliknij przycisk Cofnij.

    • Aby zmienić nazwę tabeli, kliknij dwukrotnie jej pasek tytułu, wpisz nową nazwę, a następnie kliknij przycisk OK.

  6. Po ustawieniu pól w odpowiedni sposób kliknij przycisk Dalej.

  7. Jeśli kreator znajdzie rekordy z bardzo podobnymi wartościami, zidentyfikuje te wartości jako prawdopodobne błędy pisowni i wyświetli ekran, na którym można zdecydować, jak wartości te mają być traktowane. Przewiń listę, aby znaleźć te wartości w kolumnie Poprawka, a następnie kliknij odpowiednią pozycję na liście rozwijanej. Wybierz pozycję (Pozostaw bez zmian), aby kreator nie wprowadzał żadnych zmian w tych wartościach. Na koniec kliknij przycisk Dalej.

  8. Kreator zapyta, czy chcesz utworzyć kwerendę podobną do pierwotnej tabeli. Jeśli formularze i raporty oparte na pierwotnej tabeli już zostały utworzone, utworzenie takiej kwerendy jest dobrym pomysłem. Jeśli wybierzesz przycisk Tak, utwórz kwerendę, kreator zmieni nazwę pierwotnej tabeli, dodając do nazwy tabeli „_OLD”, a następnie użyje pierwszej nazwy pierwotnej tabeli jako nazwy nowej kwerendy. Formularze i raporty oparte na tabeli użyją teraz danych z kwerendy i będą działać tak jak wcześniej.

  9. Kliknij przycisk Zakończ.

    Kreator utworzy nowe tabele zgodnie z wybranymi opcjami, a następnie otworzy je. Po zakończeniu sprawdzania wyników zamknij te tabele.

Początek strony

Praca z danymi z innych programów

Program Access 2010 udostępnia funkcje pracy z danymi przechowywanymi w innych programach.

Tworzenie nowej bazy danych programu Access z połączeniem do danych w innym formacie pliku    Program Access pozwala otworzyć plik w innym formacie, na przykład plik tekstowy, plik bazy danych dBASE czy plik arkusza kalkulacyjnego. Program Access automatycznie utworzy bazę danych i połączy z nią wskazany plik.

  1. Uruchom program Access.

  2. Na karcie Plik kliknij pozycję Otwórz.

  3. W oknie dialogowym Otwieranie kliknij typ pliku, który chcesz otworzyć. Jeśli nie masz pewności co do typu pliku, kliknij pozycję Wszystkie pliki (*.*).

  4. W razie potrzeby przejdź do folderu zawierającego plik, który chcesz otworzyć. Znalazłszy plik, kliknij go dwukrotnie, aby go otworzyć.

  5. Postępuj zgodnie z instrukcjami kreatora. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

Importowanie danych lub tworzenie łącza do istniejącej bazy danych programu Access    Dane z innych źródeł i programów można importować do tabel programu Access, aby dane te znalazły się w pliku programu Access. Można też tworzyć w programie Access łącza do tych danych, aby pozostały w pierwotnym pliku (poza plikiem programu Access).

  1. Na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij format, w którym są przechowywane dane.

    Można importować lub łączyć dane z następujących źródeł:

    • Excel    Można importować dane z arkusza lub nazwanego zakresu ze skoroszytu programu Excel. Każdy arkusz lub nazwany zakres należy zaimportować lub połączyć osobno.

    • Access    W celu oddzielenia procesu od danych warto utworzyć podzieloną bazę danych. Oznacza to, że w jednej bazie danych można przechowywać wszystkie formularze, raporty oraz makra, a w drugiej bazie — dane. Następnie można opracowywać usprawnienia bez przerywania pracy innych osób. Można też połączyć dane z różnych baz danych programu Access w jednej bazie, co ułatwi na przykład podsumowywanie danych dotyczących różnych działów lub partnerów biznesowych.

    • Baza danych ODBC    Ten format jest obsługiwany przez wiele programów, w tym wiele serwerów baz danych. Pomaga to w tworzeniu centralnych baz danych, w których można łączyć dane z różnych systemów.

    • Plik tekstowy    Można ustanowić połączenie z prostym plikiem tekstowym i nawet zmieniać zawartość tego pliku z poziomu programu Access. Dzięki temu dane programu Access mogą być łatwo stosowane w szeregu innych programów.

    • Plik XML    Ten format także zapewnia zgodność z wieloma innymi programami, w tym niektórymi serwerami sieci Web.

    • Lista programu SharePoint    Ten format umożliwia korzystanie z danych użytkownika w przeglądarce sieci Web, tak jak standardowo korzysta się z listy programu SharePoint.

    • Usługi danych    Można ustanowić połączenie z usługami danych sieci Web w ramach przedsiębiorstwa.

    • Dokument HTML   

    • Folder programu Outlook    Można ustanowić połączenie z folderami programu Outlook, aby łatwiej integrować informacje kontaktowe z pozostałymi danymi.

    • Plik dBase    dBase to popularny alternatywny system bazy danych obsługiwany przez program Access.

      Zostanie wyświetlone okno dialogowe Pobieranie danych zewnętrznych.

  2. Postępuj zgodnie z instrukcjami wyświetlanymi w oknie dialogowym.

    Program Access zaimportuje dane do bazy danych lub połączy je z bazą danych. Większość formatów wymaga określenia lokalizacji danych, a następnie wybrania sposobu przechowywania danych w bazie danych.

Początek strony

Używanie wcześniejszej wersji bazy danych w kilku wersjach programu Access

Jeśli baza danych programu Access lub projekt programu Access zostały utworzone w programie Access 2000 lub nowszym, można użyć tej bazy danych lub projektu w wersji programu Access, w której zostały utworzone, lub w dowolnej nowszej wersji — nawet jeśli zostały włączone zabezpieczenia pliku. Na przykład plików programu Access 2000 można używać w programie w wersji Access 2000, Access 2002, Access 2003, Access 2007 i Access 2010.

Może zaistnieć sytuacja, w której dane są przechowywane we wcześniejszej wersji programu Access, ale niektórzy użytkownicy mają nowszą wersję programu Access i chcą nawiązać połączenie z danymi, korzystając jednocześnie z niektórych funkcji nowszej wersji programu. Odpowiednim rozwiązaniem jest utworzenie nowej „zewnętrznej” bazy danych w nowszej wersji (zawierającej formularze, raporty, kwerendy, makra, ale nie tabele) i połączenie jej z tabelami we wcześniejszej wersji pliku. W zależności od tego, czy baza danych jest zawarta w jednym pliku, czy jest podzielona na aplikacja zewnętrzna/wewnętrzna, należy zastosować jedną z poniższych procedur.

Używanie pliku bazy danych programu Access w kilku wersjach programu Access

Jeśli wszystkie tabele, formularze i inne obiekty bazy danych wcześniejszej wersji programu Access są zawarte w jednym pliku i baza danych ma być używana w kilku wersjach programu Access, można utworzyć nową zewnętrzną bazę danych w nowszej wersji i połączyć ją z plikiem oryginalnym. Użytkownicy dysponujący starszą wersją programu Access będą mogli nadal używać oryginalnej bazy danych. Użytkownicy dysponujący nowszą wersją będą mogli używać nowej zewnętrznej bazy danych, aby nawiązywać połączenie z tymi samymi danymi. Jeśli będzie trzeba pogodzić kilka wersji programu Access, można utworzyć kilka wersji zewnętrznych.

Początek strony

Krok 1. Utworzenie kopii istniejącej bazy danych i zapisanie jej w nowym formacie

Poniżej przedstawiono procedurę konwertowania bazy danych na jeden z trzech najnowszych formatów: programu Access 2000, Access 2002–2003 lub Access 2007. To polecenie pozwala zachować bazę danych w jej pierwotnym formacie i utworzyć jej kopię w wybranym formacie.

  1. Zamknij plik programu Access. Jeśli plik jest bazą danych programu Access z dostępem wielu użytkowników znajdującą się na serwerze lub w folderze udostępnionym, upewnij się, że nie został otwarty przez innego użytkownika.

  2. Uruchom program Access 2010.

  3. Na karcie Plik kliknij pozycję Otwórz.

  4. Przejdź do lokalizacji pliku do przekonwertowania i kliknij go dwukrotnie, aby go otworzyć.

    Jeśli zostanie otwarte okno dialogowe Ostatnio używane pliki z pytaniem, czy chcesz rozszerzyć bazę danych, kliknij przycisk Nie.

  5. Jeśli po uruchomieniu bazy danych zostanie otwarty formularz, zamknij go.

  6. Na karcie Plik kliknij pozycję Zapisz bazę danych jako.

  7. W oknie dialogowym Zapisywanie jako wpisz nazwę nowej bazy danych.

    Uwaga : Jeśli nowa baza danych nie jest zapisywana w innej lokalizacji, jej nazwa musi być inna niż nazwa pierwotnej bazy danych. W obu przypadkach najlepiej użyć innej nazwy, aby z łatwością odróżniać wewnętrzną i zewnętrzną bazę danych. Jeśli jednak baza danych jest konwertowana na format programu Access 2007, rozszerzenie nazwy pliku zmieni się z mdb na accdb, można więc użyć tej samej nazwy pliku.

  8. Kliknij przycisk Zapisz.

Początek strony

Krok 2. Podzielenie skopiowanej bazy danych i użycie oryginalnego pliku jako wewnętrznej bazy danych

Przekonwertowaną bazę danych należy podzielić zgodnie z poniższą procedurą:

  • Na karcie Narzędzia bazy danych w grupie Przenoszenie danych kliknij Bazę danych programu Access. Obraz przycisku

  • W oknie dialogowym Rozdzielacz bazy danych kliknij przycisk Podziel bazę danych.

    Jeśli chcesz, możesz utworzyć kopię zapasową lub tylko odświeżyć kopię przy użyciu oryginalnej bazy danych.

  • Wpisz nazwę wewnętrznej bazy danych, a następnie kliknij przycisk Podziel.

Początek strony

Krok 3. Połączenie nowej zewnętrznej bazy danych z oryginalną bazą danych

  1. Usuń wewnętrzną bazę danych utworzoną przez narzędzie Rozdzielacz bazy danych — uważaj, aby nie usunąć pierwotnej bazy danych.

  2. Połącz nową zewnętrzną bazę danych z tabelami w pierwotnej bazy danych: na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij pozycję Menedżer tabel połączonych. Obraz przycisku

  3. Kliknij przycisk Zaznacz wszystko, a następnie zaznacz pole wyboru Zawsze monituj o nową lokalizację.

  4. Kliknij przycisk OK, przejdź do bazy danych w starszej wersji, a następnie kliknij ją dwukrotnie.

    Jeśli nie wystąpią problemy, w programie Access zostanie wyświetlony komunikat informujący, że wszystkie zaznaczone tabele połączone zostały pomyślnie odświeżone.

Teraz można wzbogacić funkcjonalność nowej zewnętrznej bazy danych o obsługę nowych funkcji dla użytkowników nowszych wersji programu Access. Użytkownicy dysponujący starszymi wersjami nadal mogą używać starszej wersji bazy danych.

Początek strony

Używanie aplikacji zewnętrznej/wewnętrznej w kilku wersjach programu Access

Jeśli baza danych programu Access jest już aplikacja zewnętrzna/wewnętrzna, można przekonwertować fronton na nowy format pliku. Zmiany nie są niezbędne do wewnętrznej bazy danych.

Poniżej przedstawiono procedurę konwertowania zewnętrznej bazy danych pomocą polecenia Zapisz bazę danych jako na jeden z trzech najnowszych formatów: programu Access 2000, Access 2002–2003 lub Access 2007. To polecenie pozwala zachować bazę danych w jej pierwotnym formacie i utworzyć jej kopię w wybranym formacie.

  1. Zamknij zewnętrzną bazę danych. Jeśli plik jest współużytkowaną bazą danych programu Access, która znajduje się na serwerze lub w folderze udostępnionym, upewnij się, że ten plik nie został otwarty przez innego użytkownika.

  2. Uruchom program Access 2010.

  3. Na karcie Plik kliknij pozycję Otwórz.

  4. Przejdź do lokalizacji zewnętrznej bazy danych, a następnie kliknij ją dwukrotnie, aby ją otworzyć.

    Jeśli zostanie otwarte okno dialogowe Ostatnio używane pliki z pytaniem, czy chcesz rozszerzyć bazę danych, kliknij przycisk Nie.

  5. Jeśli po otwarciu bazy danych zostanie wyświetlony formularz, zamknij go.

  6. Na karcie Plik kliknij pozycję Zapisz bazę danych jako.

  7. W oknie dialogowym Zapisywanie jako wpisz nazwę nowej bazy danych.

  8. Kliknij przycisk Zapisz.

Teraz możesz wzbogacić obsługę nowej zewnętrznej bazy danych o obsługę nowych funkcji.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×