Pobieranie danych zewnętrznych ze strony sieci Web

Aby pobrać tekst lub dane ze strony sieci Web, można utworzyć lub uruchomić zapytanie sieci Web. Strony sieci Web często zawierają informacje świetnie poddające się do analizie w programie Excel. Zależnie od potrzeb można pobrać odświeżalne dane (czyli możliwe do aktualizowania w programie Excel z uwzględnieniem najnowszych danych na stronie sieci Web) lub uzyskać dane ze strony sieci Web i przechowywać je w arkuszu jako dane statyczne.

W przypadku korzystania z programu Excel 2010 lub nowszego możesz użyć funkcji Pobieranie i przekształcanie (Power Query), aby nawiązać połączenie ze stroną internetową.

Co chcesz zrobić?

Informacje na temat pobierania danych zewnętrznych ze strony sieci Web

Tworzenie i edytowanie zapytania sieci Web

Tworzenie zapytania parametrycznego zapytania sieci Web

Kopiowanie danych ze strony sieci Web

Uruchamianie pliku zapisanego zapytania sieci Web

Konfigurowanie strony sieci Web do przekierowywania zapytania sieci Web do innego źródła danych

Problem: mam problemy z sortowaniem, filtrowaniem lub wyszukiwaniem danych zewnętrznych z zapytania sieci Web

Informacje na temat pobierania danych zewnętrznych ze strony sieci Web

Przy użyciu zapytania sieci Web można pobierać odświeżalne dane przechowywane w intranecie lub Internecie, takie jak jedna lub wiele tabel czy cały tekst na stronie sieci Web. Następnie można analizować te dane za pomocą narzędzi i funkcji dostępnych w programie Excel. Można na przykład pobierać i aktualizować notowania giełdowe z publicznej strony sieci Web lub informacje z firmowej strony sieci Web zawierającej tabelę danych o sprzedaży.

Zapytania sieci Web są szczególnie przydatne do pobierania danych, które są umieszczone w tabelach lub wstępnie sformatowanych obszarach. (Tabele są definiowane za pomocą tagu HTML <TABLE>. Wstępnie sformatowane obszary są często definiowane za pomocą tagu HTML <PRE>). Pobrane dane nie zawierają obrazów, takich jak obrazy gif, ani skryptów.

Aby utworzyć zapytanie sieci Web, należy uzyskać dostęp do sieci WWW (World Wide Web) przez firmowy intranet albo modem podłączony do komputera lub sieci. Można też uruchamiać zapytania dla lokalnych plików HTML lub XML.

Przykładowe zapytania sieci Web

Kilka przykładowych zapytań sieci Web jest instalowanych z programem Microsoft Office Excel 2007. Domyślnie te zapytania są zapisywane w folderze \Program Files\Microsoft Office\Office12\QUERIES na dysku twardym komputera:

  • MSN MoneyCentral Investor Major Indicies.iqy

  • MSN MoneyCentral Investor Currency Rates.iqy

  • MSN MoneyCentral Investor Stock Quotes.iqy (zapytanie parametryczne zapytania sieci Web)

Sposoby pobierania danych zewnętrznych

W przypadku korzystania z programu Excel dane pochodzące ze strony sieci Web można importować w oknie dialogowym Nowe zapytanie sieci Web. (Na karcie Dane w grupie Dane zewnętrzne należy kliknąć pozycję Z sieci Web).

W przypadku korzystania z programu Internet Explorer dostępne są dwa sposoby pobierania danych zewnętrznych do programu Office Excel:

  • Korzystając ze znanych poleceń służących do kopiowania i wklejania, można przenosić dane ze strony sieci Web do arkusza programu Excel. Dane wklejane ze strony sieci Web do programu Excel mogą być zachowane jako statyczne lub odświeżalne dzięki kliknięciu polecenia Opcje wklejania Obraz przycisku , a następnie opcji Utwórz odświeżalne zapytanie sieci Web.

  • Kliknij prawym przyciskiem myszy stronę sieci Web, a następnie kliknij polecenie Eksportuj do programu Microsoft Excel w menu skrótów. Zostanie wyświetlone okno dialogowe Nowe zapytanie sieci Web.

Uwaga : W programie Excel można również otworzyć dowolny plik HTML, plik MHTML lub poprawnie sformułowany plik XML. Otwarcie pliku HTML or MHTML umożliwia uzyskanie całej strony sieci Web, ale może spowodować utratę części formatowania, skryptów, plików obrazów (tylko HTML) lub list danych w pojedynczej komórce. W przypadku otwarcia pliku XML można zastosować jeden lub kilka arkuszy stylów zgodnie z odwołaniami. W obu przypadkach dane nie są odświeżalne.

Tworzenie zapytania parametrycznego zapytania sieci Web

Zapytanie parametryczne zawsze po uruchomieniu monituje o wprowadzenie informacji. Można utworzyć zapytanie parametryczne zapytania sieci Web, edytując plik zapisanego zapytania sieci Web (iqy). Na przykład zapytanie sieci Web, które pobiera notowania giełdowe ze strony sieci Web, może monitować o wartość parametru, taką jak symbol giełdowy, zawsze po uruchomieniu tego zapytania parametrycznego zapytania sieci Web.

Zapytanie parametryczne zapytania sieci Web jest oparte na ciągu zapytania adresu URL, który składa się z jednej lub kilku par nazwa/wartość dołączonych na końcu adresu URL. Niektóre witryny internetowe używają ciągu zapytania adresu URL do zmiany zawartości strony sieci Web. Format ciągu zapytania adresu URL powinien być zgodny z następującym przykładem: 1 2 3 4 5 -----------------------------URL------------------------------?<Nazwa>=<Wartość> http://moneycentral.msn.com/investor/external/excel/quotes.asp?quote=MSFT

1

Adres URL

Adres URL strony sieci Web

2

?

Znak zapytania (?) rozpoczyna ciąg zapytania adresu URL.

3

<Nazwa>

W tym przykładzie nazwa to Oferta.

4

=

Znak równości (=) rozdziela nazwę i wartość.

5

<Wartość>

W tym przykładzie wartość to MSFT.

W przypadku przekazywania dwóch lub większej liczby par nazwa/wartość należy oddzielić je znakiem handlowego „i” (&), na przykład: 1 2 3 ...?<Nazwa>=<Wartość>&<Nazwa>=<Wartość> ...?Oferta=MSFT&Oferta=IBM

1

<Nazwa>=<Wartość>

Pierwsza para nazwa/wartość to Oferta=MSFT.

2

&

Znak handlowego „i” (&) rozdziela każdą parę nazwa/wartość.

3

<Nazwa>=<Wartość>

Druga para nazwa/wartość to Oferta=IBM.

Zapytanie parametryczne zapytania sieci Web można oprzeć na ciągu zapytania adresu URL za pomocą następującego formatu. Na przykład: 1 2 3 4 5 6 ...?<Nazwa>=["Parametr","Monit"] ...?Symbol=["StockSymbol","Wprowadź symbol giełdowy:"]

1

<Nazwa>

W tym przykładzie nazwa to Symbol.

2

=

Znak równości (=) oddziela nazwę od parametru i ciągu monitu.

3

"Parametr"

Nazwa parametru, ujęta w cudzysłowy, używana przez program Excel do identyfikowania parametru w oknie dialogowym Parametry. W tym przykładzie jest to StockSymbol.

4

,

Przecinek (,) rozdziela parametr i monit.

5

"Monit"

Monit, ujęty w cudzysłowy, wyświetlany przez program Excel w oknie dialogowym Wprowadź symbol giełdowy:. W tym przykładzie jest to Wprowadź symbol giełdowy:.

6

[...]

Ciąg monitu jest ujęty w lewy nawias kwadratowy ([) i prawy nawias kwadratowy (]).

Przekierowywanie zapytań sieci Web do innych źródeł danych

Autor strony sieci Web może zwiększyć niezawodność pobierania z niej danych przez użytkowników, przekierowując zapytania sieci Web z programu Excel do źródła danych, takiego jak XML lub plik tekstowy.

Na przykład jeśli strona HTML zawiera tabelę notowań giełdowych, można użyć danych z tej tabeli w zapytaniu sieci Web, nawet jeśli dane są pobierane z innego źródła danych. A jeśli wskazywana jest tabela w witrynie programu Windows SharePoint Services, w której znajduje się podsumowanie stanu projektu, można utworzyć zapytanie sieci Web w celu pobrania danych z głównej listy stanów.

To przekierowanie ma dwie podstawowe zalety. Po pierwsze importowana strona sieci Web w formacie HTML może być sformatowana do przeglądania, nawet jeśli dane są zoptymalizowane dla analizy (na przykład w formacie XML). Po drugie widok HTML danych może być podzielony na strony danych (na przykład po 20 wyników), ale zapytania sieci Web mogą być przekierowywane do pełnego zestawu danych.

Można używać atrybutu HTML z tagiem TABLE, PRE, XMP, LISTING lub PLAINTEXT, który identyfikuje lokalizację przechowywania danych źródłowych. Korzystając z tego atrybutu przekierowywania (o:WebQuerySourceHRef), autorzy stron sieci Web mogą wyświetlać adres URL źródła danych, aby umożliwić łączenie zapytań sieci Web z danymi źródłowymi. Ten atrybut przekierowania zdefiniowano w przestrzeni nazw Microsoft Office, aby uniknąć konfliktów z innymi atrybutami przekierowania. Źródło danych może być dowolnym obsługiwanym typem danych zapytania sieci Web, takim jak HTML, tekst lub XML. Gdy ten atrybut jest używany, można nie martwić się o wprowadzenie prawidłowej zawartości podczas odświeżania. Zapytanie sieci Web zawiera informacje o ścieżce do źródła danych i może pobierać zaktualizowane dane bezpośrednio z tego źródła.

Początek strony

Tworzenie i edytowanie zapytania sieci Web

  1. Aby utworzy nowe zapytanie sieci Web lub edytować istniejące zapytanie sieci Web, wykonaj jedną z następujących czynności:

    Tworzenie nowego zapytania sieci Web    

    1. Wykonaj jedną z następujących czynności:

      • W programie Office Excel na karcie Dane w grupie Dane zewnętrzne kliknij pozycję Z sieci Web.

      • Wyświetl w przeglądarce stronę sieci Web, z której zapytanie powinno pobierać dane, kliknij stronę sieci Web prawym przyciskiem myszy, a następnie kliknij polecenie Eksportuj do programu Microsoft Excel w menu skrótów.

        Zostanie wyświetlone okno dialogowe Nowe zapytanie sieci Web.

    2. W oknie dialogowym Nowe zapytanie sieci Web wpisz adres URL strony sieci Web, z której chcesz pobrać dane. Adres URL można wpisać, można go wkleić ze skopiowanego adresu albo kliknąć strzałkę obok listy Adres i wybrać ostatnio używany adres.

      Uwaga : Maksymalna długość adresu URL wynosi 255 znaków.

    3. Kliknij przycisk Przejdź.

      Edytowanie istniejącego zapytania sieci Web    

    4. Na karcie Dane w grupie Połączenia kliknij przycisk Połączenia.

      Obraz Wstążki programu Excel

    5. W oknie dialogowym Połączenia skoroszytu zaznacz zapytanie sieci Web, a następnie kliknij przycisk Właściwości.

    6. W oknie dialogowym Właściwości połączenia kliknij kartę Definicja, a następnie kliknij przycisk Edytuj zapytanie.

  2. Kliknij przycisk Zaznaczanie tabeli obok tabel, które chcesz importować, albo kliknij przycisk Zaznaczanie tabeli w lewym górnym narożniku strony, aby importować całą stronę.

    Porada : Jeśli obok tabel na stronie nie ma przycisków Zaznaczanie tabeli , kliknij przycisk Pokaż ikony Ikony Ukryj w górnej części okna dialogowego, aby je wyświetlić.

  3. Aby ustawić opcje formatowania i importowania określające sposób zwrotu danych, kliknij przycisk Opcje, a następnie wykonaj jedną lub kilka z następujących czynności w oknie dialogowym Opcje zapytania sieci Web.

    1. W obszarze Formatowanie kliknij jedną z następujących opcji:

      • Brak     Ta opcja nie zwraca formatowania strony sieci Web badanej zapytaniem, a jedynie tekst. Zastosowane zostanie formatowanie arkusza.

      • Tylko tekst formatowany     Ta opcja zwraca typ formatowania, który program Office Excel może odtworzyć najlepiej, na przykład style czcionek. Nie obejmuje to formatowania HTML, na przykład formatowania typu hiperlink.

      • Pełne formatowanie HTML     Ta opcja zwraca każde formatowanie HTML obsługiwane przez program Excel, na przykład formatowanie hiperłączy. Wybranie tej opcji powoduje wyczyszczenie pola wyboru Zachowaj formatowanie komórki w oknie dialogowym Właściwości zakresu danych zewnętrznych.

    2. W obszarze Ustawienia importu wstępnie sformatowanych bloków <PRE> zaznacz co najmniej jedno z następujących pól wyboru:

      • Importuj bloki <PRE> do kolumn      Bloki danych ujęte w tagi <PRE> będą importowane do osobnych kolumn arkusza. Wyczyść to pole wyboru, aby dane zwracane były do jednej kolumny.

      • Kolejne ograniczniki traktuj jako jeden     Jeśli są znaki (na przykład przecinki) definiujące albo rozgraniczające tekst każdej z kolumn w sekcjach <PRE>, to można określić, że gdy program Excel napotka co najmniej dwa sąsiadujące ograniczniki, potraktuje je jako jeden. W takim przypadku pusta kolumna nie będzie umieszczana kolejnymi ogranicznikami. To pole wyboru jest dostępne tylko w przypadku zaznaczenia pola wyboru Importuj bloki <PRE> do kolumn.

      • Użyj tych samych ustawień importu dla całej sekcji     Zaznacz to pole wyboru, aby ustawienie opcji Kolejne ograniczniki traktuj jako jeden było używane dla całych wstępnie sformatowanych sekcji na stronie sieci Web. Wyczyść to pole wyboru, aby użyć ustawienia tylko do pierwszej wstępnie sformatowanej sekcji albo aby to program Microsoft Excel określał najlepsze ustawienia. To pole wyboru jest dostępne tylko w przypadku zaznaczenia pola wyboru Importuj bloki <PRE> do kolumn.

    3. W obszarze Inne ustawienia importu zaznacz co najmniej jedno z następujących pól wyboru:

      • Wyłącz rozpoznawanie daty     Ta opcja zapewnia, że liczby na stronie sieci Web wyglądające podobnie do dat będą wyświetlane w arkuszu jako liczby. Na przykład wynik sportowy 03-07 zostanie rozpoznany przez program Excel jako data 7 marca, jeśli ta opcja nie zostanie zaznaczona.

      • Wyłącz przekierowywanie zapytań sieci Web     Ta opcja zapewnia, że zapytanie sieci Web nie zostanie przekierowane do źródła danych innego niż to, które widać na badanej zapytaniem stronie sieci Web. Zaznacz to pole wyboru, aby zapewnić zgodność z zapytaniami utworzonymi we wcześniejszych wersjach programu Excel.

  4. Kliknij przycisk OK. Zapytanie sieci Web zostanie zapisane w skoroszycie.

  5. Można również zapisać zapytanie sieci Web w pliku zapytania sieci Web (iqy), dzięki czemu można uruchamiać je w innych skoroszytach i utworzyć zapytanie parametryczne.

    Aby uzyskać więcej informacji, zobacz temat Tworzenie zapytania parametrycznego zapytania sieci Web.

    Zapisywanie zapytania sieci Web w pliku zapytania sieci Web

    1. W oknie dialogowym Edytowanie zapytania sieci Web kliknij przycisk Zapisz zapytanie Obraz przycisku .

    2. Zlokalizuj folder, w którym chcesz zapisać zapytanie.

      Domyślnie zapytania są zapisywane w folderze \Documents and Settings\<nazwa użytkownika>\Application Data\Microsoft\Queries na dysku twardym komputera.

    3. W polu Nazwa pliku wpisz nazwę pliku.

    4. Kliknij przycisk Zapisz.

      Zapytanie jest zapisywane w pliku tekstowym o rozszerzeniu nazwy pliku iqy.

  6. Kliknij przycisk Importuj.

    W oknie dialogowym Importowanie danych wykonaj jedną z następujących czynności:

    1. Aby zwrócić dane ze strony Web do wybranego arkusza, kliknij przycisk Istniejący arkusz. W arkuszu kliknij komórkę, w której chcesz umieścić lewy górny róg zakresu danych zewnętrznych, a następnie kliknij przycisk OK.

    2. Aby zwrócić dane do nowego arkusza, kliknij opcję Nowy arkusz, a następnie kliknij przycisk OK. Program Excel dodaje nowy arkusz roboczy do skoroszytu i automatycznie umieszcza zewnętrzny zakres danych w górnym lewym rogu nowego arkusza roboczego.

      Po kliknięciu przycisku OKpasek stanu będzie zawierać ikonę Odświeżanie w tle Wskaźnik odświeżania , co będzie znaczyć, że zapytanie zostało uruchomione. Aby sprawdzić stan zapytania, kliknij dwukrotnie ikonę odświeżania.

Początek strony

Tworzenie zapytania parametrycznego zapytania sieci Web

  1. W Eksploratorze Windows zlokalizuj plik zapytania na swoim komputerze.

    Domyślnie zapytania są zapisywane w folderze \Documents and Settings\<nazwa użytkownika>\Application Data\Microsoft\Queries na dysku twardym komputera.

  2. Kliknij prawym przyciskiem myszy plik, a następnie kliknij polecenie Edytuj za pomocą — Notatnik. Zapytanie zostanie otwarte w Notatniku firmy Microsoft, w którym można wprowadzać zmiany w pliku.

  3. W tekście pliku znajdź adres URL adresu internetowego, z którego pochodzą zaimportowane dane. Na przykład:

http://moneycentral.msn.com/investor/external/excel/quotes.asp

Na końcu adresu URL wpisz następujący ciąg (nie wstawiaj spacji na końcu adresu URL):

?Symbol=["Quote", "Enter one or more financial symbols separated by commas."]

  1. W menu Plik kliknij polecenie Zapisz, a następnie zamknij Notatnik.

Początek strony

Kopiowanie danych ze strony sieci Web

  1. W przeglądarce sieci Web zaznacz dane, które chcesz skopiować.

  2. Skopiuj dane.

    Uwaga : Aby uzyskać informacje dotyczące operacji kopiowania, skorzystaj z Pomocy przeglądarki.

  3. Przejdź do programu Excel.

  4. Kliknij w lewym górnym rogu obszaru arkusza w miejscu, w którym chcesz umieścić skopiowane dane.

  5. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Wklej.

    Grupa Schowek na karcie Narzędzia główne

  6. Jeśli dane nie pojawiają się zgodnie z oczekiwaniami, kliknij przycisk Opcje wklejania Obraz przycisku , a następnie kliknij jedną z następujących opcji:

    • Zachowaj formatowanie źródłowe, aby nie wprowadzać żadnych zmian.

    • Dopasuj do formatowania docelowego, aby dopasować formatowanie do istniejącego formatowania komórek.

    • Utwórz odświeżalne zapytanie sieci Web, aby utworzyć zapytanie dotyczące strony sieci Web, z której skopiowano dane. Jeśli strona sieci Web zmieni się później, można odświeżyć dane.

Początek strony

Uruchamianie pliku zapisanego zapytania sieci Web

Zapytania są zapisywane w plikach tekstowych o rozszerzeniu nazwy pliku iqy. Zapisane zapytania są przydatne do udostępniania tego samego zapytania sieci Web w różnych skoroszytach lub innym użytkownikom i tworzenia zapytania parametrycznego zapytania sieci Web.

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Otwórz.

  2. W polu Szukaj w zlokalizuj folder, w którym jest zapisany odpowiedni plik zapytania.

  3. Wybierz zapytanie sieci Web, które chcesz uruchomić.

  4. Kliknij przycisk Otwórz.

  5. W oknie dialogowym Importowanie danych wykonaj jedną z następujących czynności:

    • Aby zwrócić dane ze strony Web do wybranego arkusza, kliknij przycisk Istniejący arkusz. W arkuszu kliknij komórkę, w której chcesz umieścić lewy górny róg zakresu danych zewnętrznych, a następnie kliknij przycisk OK.

    • Aby zwrócić dane do nowego arkusza, kliknij opcję Nowy arkusz, a następnie kliknij przycisk OK. Program Excel dodaje nowy arkusz roboczy do skoroszytu i automatycznie umieszcza zewnętrzny zakres danych w górnym lewym rogu nowego arkusza roboczego.

  6. Jeśli zapytanie sieci Web jest zapytaniem parametrycznym, zostanie wyświetlone okno dialogowe Wprowadzanie wartości parametru z monitem o wprowadzenie parametrów, chyba że zapytanie parametryczne zostało skonfigurowane do zwracania określonej wartości.

    Aby edytować ustawienia parametrów, kliknij przycisk Parametry w oknie dialogowym Importowanie danych w kroku 5.

    Aby uzyskać więcej informacji, zobacz Dostosowywanie zapytania parametrycznego.

    Program Excel uruchomi zapytanie. Teraz pasek stanu będzie zawierać ikonę Odświeżanie w tle Wskaźnik odświeżania , co będzie znaczyć, że zapytanie zostało uruchomione. Aby sprawdzić stan zapytania, kliknij dwukrotnie ikonę odświeżania.

Początek strony

Konfigurowanie strony sieci Web do przekierowywania zapytania sieci Web do innego źródła danych

  1. W otwierającym tagu HTML strony sieci Web umieść deklarację przestrzeni nazw pakietu Microsoft Office:

    <HTML xmlns:o="urn:schemas-microsoft-com:office:office”>

  2. W treści strony sieci Web dodaj następujący atrybut do otwierającego tagu TABLE, PRE, XMP, LISTING lub PLAINTEXT. Na przykład:

    <TABLE ... o:WebQuerySourceHRef="URL">

    — gdzie wartością jest adres URL (względny lub bezwzględny), do którego ma być przekierowywane zapytanie sieci Web.

Uwaga :  Użytkownicy mogą pomijać przekierowanie na stronach sieci Web, zaznaczając pole wyboru Wyłącz przekierowywanie zapytań sieci Web w oknie dialogowym Opcje zapytania sieci Web. Dostęp do tej opcji można uzyskać z okna dialogowego Nowe zapytanie sieci Web.

Początek strony

Problem: mam problemy z sortowaniem, filtrowaniem lub wyszukiwaniem danych zewnętrznych z zapytania sieci Web

Dane zewnętrzne z zapytania sieci Web mogą zawierać wiodące, końcowe lub wielokrotne osadzone znaki spacji Unicode (wartość 160). Te znaki spacji mogą czasami powodować nieoczekiwane wyniki podczas sortowania lub filtrowania danych albo wykonywania operacji wyszukiwania.

Aby uzyskać więcej informacji na temat obchodzenia się z tymi i innymi znakami, zobacz Usuwanie spacji i znaków niedrukowanych z tekstu.

Początek strony

Zobacz też

Importowanie danych z zewnętrznych źródeł danych (Power Query)

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×