Organizowanie plików w bibliotece

Sposób organizowania plików w biblioteka zależy od potrzeb grupy oraz od preferowanego sposobu przechowywania i wyszukiwania informacji. Dzięki wcześniejszemu planowaniu można skonfigurować strukturę, która najlepiej sprawdzi się w danej organizacji.

Program Microsoft Office SharePoint Server 2007 zawiera pewną liczbę gotowych do użycia bibliotek i szablonów bibliotek. Te biblioteki i szablony stanowią dobry punkt wyjścia do organizowania plików.

W tym artykule

Biblioteki i szablony bibliotek programu Office SharePoint Server 2007

Sposoby organizowania plików

Dodawanie kolumny do biblioteki

Tworzenie widoku

Tworzenie folderu w bibliotece

Biblioteki i szablony bibliotek programu Office SharePoint Server 2007

Podczas instalowania programu Office SharePoint Server 2007 jest tworzona pewna liczba bibliotek, które pomagają w dobrym organizowaniu zbioru witryn. Tworzone biblioteki zależą od konfiguracji zbioru witryn. Na przykład zbiory witryn, w których zostały skonfigurowane funkcje publikowania, zawierają następujące biblioteki:

  • Dokumenty     Ta biblioteka jest tworzona w każdej witrynie w celu przechowywania dokumentów używanych na stronach tej witryny.

  • Obrazy     Ta biblioteka jest tworzona w każdej witrynie w celu przechowywania obrazów używanych na stronach tej witryny.

  • Strony     Ta biblioteka jest tworzona w każdej witrynie w celu przechowywania stron znajdujących się w tej witrynie.

  • Dokumenty zbioru witryn     Ta biblioteka jest tworzona w celu przechowywania dokumentów używanych w całym zbiorze witryn.

  • Obrazy zbioru witryn     Ta biblioteka jest tworzona w celu przechowywania obrazów używanych w całym zbiorze witryn.

  • Biblioteka stylów     Ta biblioteka jest tworzona w celu przechowywania niestandardowych stylów XSL i kaskadowych arkuszy stylów.

Szablony bibliotek to kolejny sposób organizowania plików dostępny w programie Office SharePoint Server 2007. Przy użyciu szablonów bibliotek można łatwo tworzyć biblioteki przeznaczone do obsługi plików określonych rodzajów i włączać w nich określone funkcje bibliotek. Aby uzyskać więcej informacji o szablonach bibliotek programu Office SharePoint Server 2007, zobacz Szablony bibliotek dostępne w programie Microsoft Office SharePoint Server 2007.

Początek strony

Sposoby organizowania plików

Biblioteki mają kilka funkcji, które pomagają w pracy z wieloma plikami w jednej bibliotece. Czasami jednak dla organizacji bardziej odpowiednie może być użycie wielu bibliotek.

Przechowywanie wielu dokumentów w jednej bibliotece

Czasami zachodzi potrzeba, aby jedna duża biblioteka miała różne funkcje. W tej samej grupie może na przykład występować kilka projektów lub nad tym samym projektem może pracować wiele grup.

Użycie jednej biblioteki należy rozważyć w następujących przypadkach:

  • W grupie muszą być widoczne informacje podsumowujące na temat tego samego zestawu plików lub różne jego widoki. Menedżer może na przykład chcieć wyświetlić wszystkie pliki pogrupowane według działów lub dat ukończenia.

  • Użytkownicy chcą wyszukiwać pliki w tej samej lokalizacji w witrynie.

  • Do plików mają być stosowane te same ustawienia, na przykład śledzenie przechowywanie wersji plików lub wymaganie zatwierdzenia.

  • Grupy pracujące z biblioteką mają podobne cechy wspólne, na przykład te same poziomy uprawnień.

    Uwaga : Do określonych plików można zastosować unikatowe poziomy uprawnień. Jeśli jednak poziomy uprawnień znacznie się różnią, należy rozważyć użycie wielu bibliotek.

  • Wymagane jest analizowanie informacji o plikach w arkuszu kalkulacyjnym lub otrzymywanie skonsolidowanych aktualizacji dotyczących plików.

    Uwaga : Przy użyciu technologii RSS można otrzymywać alerty o zmianach w bibliotece, na przykład o zmianie przechowywanych w niej plików. Źródła danych RSS umożliwiają członkom grupy roboczej wyświetlanie skonsolidowanych list zmienionych plików.

Poniżej wymieniono niektóre sposoby wyświetlania plików w tej samej bibliotece i zarządzania nimi:

  • Dodawanie kolumn     Aby ułatwić grupie ustalanie najważniejszych danych oraz wyświetlanie danych na różne sposoby, do biblioteki można dodać kolumna. Kolumny są wyświetlane w górnej części strony biblioteki jako nagłówki, na przykład „Nazwa działu” lub „Data ukończenia”. Za pomocą nagłówków kolumn można sortować i filtrować pliki w bibliotece.

  • Tworzenie widoków    widok można używać w sytuacji, gdy członkowie grupy często muszą wyświetlać dane w określony sposób. W widokach kolumny umożliwiają sortowanie, grupowanie, filtrowanie i wyświetlanie danych.

  • Tworzenie folderów     Jeśli biblioteka zawiera wiele plików, które można logicznie pogrupować, takie grupy w bibliotece można utworzyć przy użyciu folderów. Foldery ułatwiają przeszukiwanie plików i zarządzanie nimi w znajomy sposób. W programie Office SharePoint Server 2007 udostępniono widok drzewa, który umożliwia nawigowanie w witrynach i folderach, podobnie jak podczas pracy z folderami na dysku twardym.

  • Konfigurowanie wielu szablonów     Jeśli w bibliotece jest skonfigurowanych wiele typów zawartości, to w obrębie tej samej biblioteki można tworzyć szablony domyślne różnego typu, takie jak umowy sprzedaży, prezentacje marketingowe i arkusze budżetowe. Typy zawartości zwiększają elastyczność i spójność wielu bibliotek.

Tworzenie wielu bibliotek

Wiele bibliotek można tworzyć, gdy istnieją wyraźne różnice między zestawami plików, które mają być przechowywane i zarządzane, lub między grupami osób, które będą pracować z plikami.

Wiele bibliotek należy stosować w następujących przypadkach:

  • Istnieją różne typy przechowywanych i zarządzanych plików, a także nie przewiduje się, że użytkownicy będą często wyświetlali podsumowania plików lub przeszukiwali wszystkie pliki.

  • Z plików korzystają różne grupy osób, których poziomy uprawnień znacznie się różnią.

  • Wymagane jest stosowanie różnych ustawień, takich jak przechowywanie wersji lub zatwierdzanie, do różnych zestawów plików.

  • Nie jest wymagane analizowanie plików razem ani otrzymywanie skonsolidowanych aktualizacji dotyczących plików.

  • Wymagane jest udostępnienie różnych zestawów opcji do tworzenia nowych plików lub zmiana kolejności wyświetlania opcji w menu Nowy biblioteki.

Poniżej podano wybrane sposoby efektywnej pracy z wieloma bibliotekami:

  • Konfigurowanie szablonów i kolumn witryn     Jeśli organizacja chce określić spójne ustawienia w swoich bibliotekach, można skonfigurować szablony i kolumny witryn. Ustawienia te mogą być współużytkowane przez wiele bibliotek, nie trzeba więc każdorazowo ponownie tworzyć ustawień.

  • Wysyłanie plików do innej lokalizacji     Jeśli plik ma być dostępny w wielu bibliotekach, można go zachować w jednej bibliotece, a następnie wysłać kopię do innych bibliotek. W przypadku wprowadzenia zmian w oryginale może być wyświetlane przypomnienie o potrzebie zaktualizowania kopii dokumentu.

  • Tworzenie szablonów bibliotek     Jeśli jest wymagane określenie jednolitych ustawień bibliotek lub wielokrotne używanie tych samych cech w różnych bibliotekach, można zapisać bibliotekę jako szablon. Szablony bibliotek są dostępne jako opcja w witrynie po kliknięciu polecenia Utwórz w menu Akcje witryny.

Uwaga : Jeśli do biblioteki zawierającej pliki z wcześniejszego projektu są dodawane nowe pliki, decyzja o tym, czy utworzyć nową bibliotekę, czy dodać pliki do biblioteki już istniejącej, może być trudna. Każda sytuacja jest inna, ale jeśli można się spodziewać, że w pewnym momencie będzie wymagane wspólne analizowanie wszystkich plików lub zarządzanie nimi, należy rozważyć dodanie ich do istniejącej biblioteki. Można użyć kolumn, filtrów i widoków, aby w widoku domyślnym zostały wyświetlone tylko niedawno używane pliki.

Początek strony

Dodawanie kolumny do biblioteki

W bibliotece domyślnie jest śledzona nazwa pliku, a także informacje o jego stanie, na przykład to, czy jest zaewidencjonowany. Można określić dodatkowe kolumny, które pomogą w kategoryzowaniu i śledzeniu plików, na przykład nazwę działu lub numer projektu. Dodawanie kolumn pomaga optymalnie wykorzystać wiele widoków biblioteki.

Dostępnych jest kilka opcji typu tworzonej kolumny, w tym pojedynczy wiersz tekstu, lista rozwijana opcji, liczba obliczana na podstawie innych kolumn, a nawet nazwa i zdjęcie osoby w witrynie.

Uwaga : Poniższa procedura zaczyna się od strony biblioteki, do której ma zostać dodana kolumna. Jeśli biblioteka jeszcze nie jest otwarta, należy kliknąć jej nazwę na pasku Szybkie uruchamianie. Jeśli nazwa biblioteki nie zostanie wyświetlona, należy kliknąć pozycję Wyświetl całą zawartość witryny, a następnie kliknąć nazwę biblioteki.

  1. W menu Ustawienia Settings menu kliknij polecenie Utwórz kolumnę.

  2. W sekcji Nazwa i typ wpisz nazwę w polu Nazwa kolumny.

  3. W obszarze Typ informacji w tej kolumnie to wybierz typ informacji, które mają być wyświetlane w kolumnie.

  4. W sekcji Ustawienia dodatkowej kolumny wpisz opis w polu Opis, aby użytkownicy wiedzieli, do czego służy kolumna i jakie dane powinna zawierać. Opis jest opcjonalny.

  5. Zależnie od wybranego typu kolumny w sekcji Ustawienia dodatkowej kolumny może być dostępnych więcej opcji. Wybierz odpowiednie ustawienia dodatkowe.

  6. Aby dodać kolumnę do widoku domyślnego, to jest widoku wyświetlanego, gdy użytkownicy witryny otwierają listę lub bibliotekę po raz pierwszy, kliknij opcję Dodaj do widoku domyślnego.

  7. Kliknij przycisk OK.

Początek strony

Tworzenie widoku

Za pomocą widoków można wyświetlać pliki, które są najważniejsze lub najbardziej przydatne w określonym celu. Można na przykład tworzyć widoki plików ostatnio utworzonych, plików pochodzących z określonego działu lub plików utworzonych przez określoną osobę. Utworzony widok jest zawsze dostępny po wyświetleniu biblioteki.

Widoki w menu Widok

Po wyświetleniu plików w bibliotece można je tymczasowo posortować lub przefiltrować, wskazując nazwę kolumny, a następnie klikając strzałkę obok nazwy. Jest to przydatne w razie potrzeby wyświetlenia plików w określony sposób, ale po następnym wyświetleniu biblioteki należy powtórzyć odpowiednie czynności.

Sortowanie elementów na liście lub w bibliotece

Jeśli przewiduje się, że pliki będą często wyświetlane w określony sposób, można utworzyć widok. Tego widoku można używać za każdym razem podczas pracy z biblioteką. Utworzony widok jest dodawany do menu Widok Menu Widok biblioteki.

Biblioteki mogą zawierać widoki osobiste i publiczne. Każdy może utworzyć widok osobisty, aby wyświetlić pliki w określony sposób lub przefiltrować je i uzyskać tylko potrzebne pliki. Użytkownik mający uprawnienia do projektowania witryny może utworzyć widok publiczny, którego będzie mogła używać każda osoba wyświetlająca bibliotekę. Ponadto każdy publiczny widok biblioteki można określić jako domyślny, aby był on wyświetlany automatycznie dla wszystkich osób.

Ponadto podczas projektowania witryny można się połączyć z innymi widokami lub stronami projektu za pomocą składnik Web Part, w których są używane inne widoki.

Jeśli członkowie grupy wyświetlają biblioteki na urządzeniach przenośnych, można utworzyć widoki dla urządzeń przenośnych z określeniem limitów — takich jak liczba elementów wyświetlanych w widoku — które są optymalne z punktu widzenia przepustowości i ograniczonych możliwości tych urządzeń. Aby uzyskać więcej informacji na temat tworzenia widoków, skorzystaj z łączy dostępnych w sekcji Zobacz też.

Poniższa procedura umożliwia utworzenie widoku standardowego typu. Dla niektórych pozostałych typów widoków opcje do wyboru są nieco inne, ale podstawowe czynności podczas tworzenia widoku są podobne.

  1. Jeśli biblioteka nie jest jeszcze otwarta, kliknij jej nazwę na pasku Szybkie uruchamianie.

    Jeśli nazwa danej biblioteki nie jest wyświetlana, kliknij polecenie Wyświetl całą zawartość witryny, a następnie kliknij nazwę biblioteki.

  2. W menu Ustawienia Settings menu kliknij polecenie Utwórz widok.

  3. W obszarze Wybierz format widoku kliknij typ widoku, który chcesz utworzyć. W wielu sytuacjach będzie to pozycja Widok standardowy, ale w określonych sytuacjach, na przykład podczas tworzenia raportu, można wybierać inne widoki.

  4. W polu Nazwa widoku wpisz nazwę widoku, na przykład Sortowane według nazwiska.

  5. Jeśli dany widok ma być domyślnym widokiem biblioteki, zaznacz pole wyboru Uczyń ten widok domyślnym. Widok można ustawić jako domyślny tylko wtedy, gdy jest widokiem publicznym.

  6. W sekcji Odbiorcy w obszarze Wyświetl grupę odbiorców wybierz, czy chcesz utworzyć widok osobisty czy widok publiczny, z którego będą mogli korzystać inni użytkownicy.

  7. W sekcji Kolumny można pokazywać lub ukrywać kolumny, zaznaczając lub czyszcząc odpowiednie pola wyboru. Obok nazwy kolumny wprowadź liczbę porządkową kolumny w widoku.

  8. W sekcji Sortowanie wybierz opcje określające, czy i jak pliki mają być sortowane. Do sortowania możesz używać dwóch kolumn. Możesz na przykład sortować najpierw według autorów, a następnie według nazw plików dla każdego autora.

  9. W sekcji Filtr wybierz opcje określające, czy i jak chcesz filtrować pliki. W widoku przefiltrowanym jest pokazany mniejszy podzbiór plików, na przykład tylko pliki utworzone przez określony dział lub tylko pliki zatwierdzone.

  10. W sekcji Grupowanie według można grupować elementy mające taką samą wartość w określonej sekcji, na przykład w sekcji z dokumentami każdego autora, którą można rozwijać i zwijać.

  11. W sekcji Sumy można policzyć elementy w kolumnie, na przykład obliczyć łączną liczbę problemów. W niektórych wypadkach można także podsumowywać lub obliczać dodatkowe dane, na przykład średnie.

  12. W sekcji Styl wybierz styl, który chcesz wyświetlić, na przykład listę cieniowaną, na której co drugi wiersz jest cieniowany.

  13. Jeśli w bibliotece znajdują się foldery, można utworzyć widok, który ich nie zawiera. Jest on czasem nazywany widokiem płaskim. Aby wyświetlić wszystkie pliki na tym samym poziomie, kliknij pozycję Pokaż wszystkie elementy bez folderów w sekcji Foldery.

  14. Można ograniczyć liczbę plików, które mogą być wyświetlane w bibliotece lub na tej samej stronie. Te ustawienia są szczególnie ważne, jeśli tworzysz widok dla urządzenia przenośnego. W sekcji Limit elementów wybierz odpowiednie opcje.

  15. Jeśli planujesz wyświetlanie biblioteki na urządzeniu przenośnym, wybierz odpowiednie opcje w sekcji Urządzenie przenośne.

  16. Kliknij przycisk OK.

Początek strony

Tworzenie folderu w bibliotece

Jeśli biblioteka zawiera kilka typów dokumentów lub zróżnicowaną zawartość, można tworzyć foldery pomagające w organizowaniu zawartości.

  1. Jeśli biblioteka nie jest jeszcze otwarta, kliknij jej nazwę na pasku Szybkie uruchamianie.

    Jeśli nazwa danej biblioteki nie jest wyświetlana, kliknij polecenie Wyświetl całą zawartość witryny, a następnie kliknij nazwę biblioteki.

  2. W menu Nowy Obraz menu kliknij polecenie Nowy folder.

    Uwaga : Jeśli osoba tworząca bibliotekę określiła, że nie można tworzyć folderów w tej bibliotece, polecenie Nowy folder jest niedostępne.

  3. Wpisz nazwę folderu, a następnie kliknij przycisk OK.

Porada : Jeśli istnieje wiele bibliotek z folderami i członkowie grupy wolą przeglądać bibliotekę podobnie jak zawartość dysku twardego, można włączyć dla grupy widok drzewa. Widok drzewa umożliwia rozwijanie i zwijanie folderów oraz łatwe poruszanie się między nimi. Mając uprawnienia do projektowania stron, można włączyć widok drzewa w obszarze Opcje nawigacji na stronie Ustawienia witryny.

Początek strony

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×