Określanie, kiedy mają być aktualizowane odwołania zewnętrzne (łącza)

Podczas tworzenia odwołań zewnętrznych (nazywanych również linkami) można określić, czy i kiedy mają one być aktualizowane. Jeśli inny użytkownik zmienił wartość w komórce, automatyczna aktualizacja nastąpi dopiero po skonfigurowaniu odpowiednich ustawień.

Więcej informacji o odwołaniach zewnętrznych

Skoroszyt zawierający linki jest nazywany skoroszytem docelowym, a skoroszyt z nim połączony jest nazywany skoroszytem źródłowym. Jeśli otwarty skoroszyt (czyli plik docelowy) zawiera linki do innych skoroszytów lub plików (nazywanych plikami źródłowymi), a pliki źródłowe zostały zmienione, linki w otwieranym skoroszycie mogą zawierać nieaktualne informacje.

Skoroszyt zawierający łącza

1. Skoroszyt docelowy zawiera odwołanie zewnętrzne.

2. Odwołanie zewnętrzne (czyli link) jest odwołaniem do zakresu komórek w skoroszycie źródłowym.

3. Skoroszyt źródłowy zawiera komórkę i rzeczywistą wartość, która jest pobierana i umieszczana w skoroszycie docelowym.

Sterowanie linkami do innych skoroszytów

Gdy skoroszyt źródłowy i skoroszyt docelowy są otwarte na tym samym komputerze, linki są aktualizowane automatycznie. Jeśli zostanie otwarty skoroszyt docelowy, a skoroszyt źródłowy będzie zamknięty, na pasku zaufania może zostać wyświetlony alert z pytaniem o aktualizację linków. Można określić, czy alert ma być wyświetlany na pasku zaufania oraz czy mają być aktualizowane wszystkie linki, gdy alert nie będzie wyświetlany. Można także aktualizować tylko niektóre linki, jeśli skoroszyt zawiera więcej niż jeden link.

Ręczne aktualizowanie wszystkich linków albo nieaktualizowanie linków w skoroszycie

  1. Zamknij wszystkie skoroszyty. Jeśli jeden skoroszyt źródłowy jest otwarty, a inne są zamknięte, aktualizacje nie będą jednolite.

  2. Otwórz skoroszyt zawierający linki.

  3. Aby zaktualizować linki, na pasku zaufania kliknij przycisk Opcje, a następnie kliknij pozycję Włącz tę zawartość.

Ręczne aktualizowanie tylko niektórych linków do innych skoroszytów

  1. Zamknij wszystkie skoroszyty.

  2. Otwórz skoroszyt zawierający linki.

  3. Na karcie Dane w grupie Połączenia kliknij przycisk Edytuj łącza.

    Połączenia danych

  4. Na liście Źródło kliknij obiekt połączony, który chcesz zaktualizować.

    Aby zaznaczyć wiele linków, przytrzymaj naciśnięty klawisz CTRL i kliknij każdy połączony obiekt.

    Aby zaznaczyć wszystkie linki, naciśnij klawisze CTRL+A.

  5. Kliknij przycisk Aktualizuj wartości.

Sterowanie monitem o aktualizację wszystkich linków podczas uruchamiania

Można zdecydować, czy linki mają być aktualizowane automatycznie podczas uruchamiania, czy po uruchomieniu.

Nie monituj o aktualizację linków dla tego skoroszytu i pozwól mi kontrolować aktualizację linków

Ostrzeżenie : Ta opcja ma wpływ na wszystkich użytkowników skoroszytu. Jeśli zostanie wybrana opcja nieaktualizowania linków i niewyświetlania monitów, użytkownicy skoroszytu nie będą informowani o tym, że dane są nieaktualne.

  1. Na karcie Dane w grupie Połączenia kliknij przycisk Edytuj łącza.

  2. Kliknij pozycję Monit podczas uruchamiania.

  3. Wybierz odpowiednią opcję.

Uwaga : Nawet jeśli użytkownik określi, że program Excel nie powinien pytać o aktualizację linków, będzie w dalszym ciągu powiadamiany o przerwanych linkach.

Podejmowanie decyzji dotyczącej aktualizacji linków po wyświetleniu monitu podczas uruchamiania

Okno dialogowe Monit podczas uruchamiania umożliwia podjęcie kilku decyzji.

Jeżeli nie pamiętasz, jak są tworzone linki

  1. Na karcie Dane w grupie Połączenia kliknij przycisk Edytuj łącza.

  2. Kliknij pozycję Monit podczas uruchamiania.

  3. Kliknij pozycję Nie wyświetlaj alertu i nie aktualizuj automatycznych łączy.

Czasami link może zostać utworzony przypadkowo podczas przenoszenia lub kopiowania zakresu, arkusza albo wykresu między skoroszytami. Należy wtedy otworzyć skoroszyt, a następnie odszukać utworzone linki i przerwać je lub zamienić na wartości.

Przerywanie linku do źródła

Ważne : Po przerwaniu linku do źródła wszystkie formuły używające tego źródła są konwertowane na ich bieżące wartości. Na przykład link =SUMA([Budżet.xls]Roczny!C10:C25) zostanie przekonwertowany na wartość =45. Ponieważ tej akcji nie można cofnąć, warto najpierw zapisać wersję pliku.

  1. Na karcie Dane w grupie Połączenia kliknij przycisk Edytuj łącza.

  2. Na liście Źródło kliknij link, który chcesz przerwać.

    • Aby zaznaczyć wiele połączonych obiektów, przytrzymaj klawisz CTRL i kliknij każdy połączony obiekt.

    • Aby zaznaczyć wszystkie linki, naciśnij klawisze CTRL+A.

  3. Kliknij pozycję Przerwij łącze.

  4. Jeśli link używa zdefiniowanej nazwa, nazwa nie jest usuwana automatycznie. Można ją także usunąć.

    Aby usunąć nazwę

  5. Na karcie Formuły w grupie Nazwy zdefiniowane kliknij pozycję Menedżer nazw.

  6. W kolumnie Nazwa kliknij nazwę, którą chcesz usunąć, a następnie kliknij przycisk Usuń.

  7. Jeśli używasz zakres danych zewnętrznych, parametr zapytania może używać również danych z innego skoroszytu. Możesz wyszukać i usunąć każdy z tych typów linków.

Zamienianie pojedynczej formuły na jej obliczoną wartość

Po zamianie formuły na jej wartość program Excel trwale usunie formułę. Jeśli do zamiany formuły na wartość doszło przypadkowo, kliknij przycisk Cofnij Obraz przycisku bezpośrednio po wprowadzeniu lub wklejeniu wartości, aby przywrócić formułę.

  1. Zaznacz komórkę zawierającą formułę.
    Jeśli formuła to formuła tablicowa, zaznacz zakres zawierający formułę tablicową.
    Aby zaznaczyć zakres zawierający tablicę   

    1. Kliknij dowolną komórkę w zakresie tablica.

    2. Na karcie Narzędzia główne w grupie Edytowanie kliknij przycisk Znajdź i zaznacz, a następnie kliknij polecenie Przejdź do — specjalnie.

    3. W oknie dialogowym Przechodzenie do — specjalnie kliknij opcję Bieżąca tablica.

  2. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Kopiuj Obraz przycisku .

  3. Kliknij polecenie Wklej Obraz przycisku .

  4. Kliknij strzałkę obok przycisku Opcje wklejania Obraz przycisku , a następnie kliknij przycisk Wartości Obraz przycisku .

Jeżeli wiadomo, że nie nawiązano połączenia ze źródłem

Kliknij przycisk Nie aktualizuj. Program Excel nie może pobrać aktualizacji ze źródła, z którym nie jest połączony. Źródło może na przykład znajdować się w sieci, z którą może nie być połączenia.

Jeżeli należy pozostawić dane w obecnej formie i nie zastępować ich nowymi danymi

Kliknij przycisk Nie aktualizuj.

Jeżeli ostatnia próba aktualizacji trwała zbyt długo

Kliknij przycisk Nie aktualizuj. Jeśli aktualizowanie danych nie jest konieczne, można zaoszczędzić czas, rezygnując z aktualizacji wszystkich linków. Po otwarciu skoroszytu na karcie Dane w grupie Połączenia kliknij przycisk Edytuj łącza, a następnie zaktualizuj tylko linki do potrzebnych źródeł.

Jeżeli inna osoba utworzyła skoroszyt i nie można ustalić powodu wyświetlenia tego monitu

Kliknij przycisk Nie aktualizuj. Skontaktuj się z właścicielem skoroszytu. Możesz również ustalić, jakie linki znajdują się w skoroszycie. Na karcie Dane w grupie Połączenia kliknij pozycję Edytuj łącza.

Jeżeli zawsze jest wybierana ta sama odpowiedź po wyświetleniu monitu i monit nie powinien być ponownie wyświetlany

Można ustawić wybieranie zawsze tej samej odpowiedzi po wyświetleniu monitu podczas uruchamiania i uniknąć ponownego wyświetlania monitu dla danego skoroszytu.

Nie monituj w przypadku wszystkich otwieranych skoroszytów i aktualizuj linki automatycznie    

Ta opcja ma wpływ na wszystkie otwarte skoroszyty na komputerze. Nie ma natomiast wpływu na użytkowników otwierających skoroszyt na innym komputerze.

  1. Kliknij kartę Plik, kliknij pozycję Opcje, a następnie kliknij kategorię Zaawansowane.

    W programie Excel 2007 kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , przycisk Opcje programu Excel, a następnie kategorię Zaawansowane.

  2. W obszarze Ogólne wyczyść pole wyboru Pytaj przy automatycznym aktualizowaniu łączy. Jeśli to pole wyboru jest wyczyszczone, linki są aktualizowane automatycznie, a alerty nie są wyświetlane.

Monituj każdego użytkownika tego skoroszytu w ten sam sposób    

Ostrzeżenie : Ta opcja ma wpływ na wszystkich użytkowników skoroszytu. Jeśli zdecydujesz się na nieaktualizowanie linków i niewyświetlanie monitów, użytkownicy skoroszytu nie będą informowani o tym, że dane są nieaktualne.

  1. Na karcie Dane w grupie Połączenia kliknij pozycję Edytuj łącza.

  2. Kliknij pozycję Monit podczas uruchamiania.

  3. Wybierz odpowiednią opcję.

Uwaga : W dalszym ciągu będziesz otrzymywać powiadomienia o przerwanych linkach.

Jeżeli wiadomo, że skoroszyt, z którym program Excel próbuje nawiązać połączenie, jest dostępny

Kliknij przycisk Aktualizuj. Dzięki temu można uzyskać pewność, że dane są aktualne.

Jeśli jest używane zapytanie parametryczne

Link do zapytania parametrycznego może być aktualizowany dopiero po otwarciu skoroszytu.

  1. Kliknij przycisk Nie aktualizuj.

  2. Zamknij skoroszyt docelowy.

  3. Otwórz skoroszyt źródłowy.

  4. Otwórz skoroszyt docelowy.

  5. Kliknij przycisk Aktualizuj.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×