Odtwarzanie animacji programu Adobe Macromedia Flash w prezentacji

PowerPoint dla Office 365, PowerPoint 2019, PowerPoint 2016, PowerPoint 2013, PowerPoint 2010

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Jeśli masz animowaną grafikę utworzoną za pomocą programu Adobe Macromedia Flash i zapisano ją jako plik Shockwave z rozszerzeniem SWF, możesz odtworzyć plik w prezentacji programu PowerPoint.

Plik Flash można dodać do prezentacji w programie PowerPoint 2010 i nowszych wersjach, osadzając lub łącząc plik na slajdzie.

Uwagi: 

  • W przypadku korzystania z programu Flash w PowerPoint mogą wystąpić pewne ograniczenia, w tym niemożność użycia efektów specjalnych (takich jak cienie, odbicia, efekty poświaty, wygładzone krawędzie, skosy i obrót 3-w), możliwości zanikania i przycinania oraz możliwość ich kompresowania. Pliki ułatwiające udostępnianie i rozpowszechnianie.

  • Wersja PowerPoint 2010 64-bitowa jest niezgodna z 32-bitowymi wersjami programu QuickTime lub Flash. Musisz zainstalować 64-bitową wersję programu QuickTime lub Flash albo 32-bitowej wersji programu PowerPoint 2010.

Osadzanie pliku Flash

  1. W widoku normalny kliknij slajd, w którym chcesz osadzić klip wideo.

  2. Na karcie Wstawianie w grupie multimedia kliknij strzałkę pod pozycją wideo, a następnie kliknij pozycję wideo na moim komputerze lub klip wideo z pliku.

  3. W oknie dialogowym Wstawianie wideo znajdź i kliknij klip wideo, który chcesz osadzić, a następnie kliknij przycisk Wstaw.  

    Aby upewnić się, że pliki SWF są widoczne w oknie dialogowym, Zmień filtr pliku (powyżej przycisku Wstaw ) na wszystkie pliki.

    Filtr typ pliku w oknie dialogowym Wstawianie wideo zawiera opcję "wszystkie pliki".
  4. Aby wyświetlić podgląd animacji Flash, kliknij pozycję Odtwórz na karcie Narzędzia wideo > formatowanie .

Łącze do pliku Flash

  1. W widoku Normalny na karcie Slajdy kliknij slajd, do którego chcesz dodać klip wideo lub animowany plik GIF.

  2. Na karcie Wstawianie w grupie Multimedia kliknij strzałkę w obszarze Wideo.

  3. Kliknij pozycję wideo na moim komputerze lub klip wideo z pliku, Znajdź i kliknij plik, do którego chcesz utworzyć link.

    Aby upewnić się, że pliki SWF są widoczne w oknie dialogowym, Zmień filtr pliku (powyżej przycisku Wstaw ) na wszystkie pliki.

    Filtr typ pliku w oknie dialogowym Wstawianie wideo zawiera opcję "wszystkie pliki".
  4. Kliknij strzałkę w dół na przycisku Wstaw, a następnie kliknij polecenie Łącze do pliku.

    Ważne: Aby zapobiec ewentualnym problemom z przerwanymi łączami, warto skopiować pliki wideo do tego samego folderu, w którym znajduje się prezentacja, i utworzyć link do nich.

  5. Aby wyświetlić podgląd animacji Flash, kliknij pozycję Odtwórz na karcie Narzędzia wideo > formatowanie .

Klipy wideo programu Adobe Macromedia Director

Nie można wstawić pliku wideo programu Adobe Macromedia Director do prezentacji programu PowerPoint.

Aby dodać plik SWF w programie PowerPoint 2007, użyj kontrolki ActiveX o nazwie Shockwave Flash Object oraz programu Adobe Macromedia Flash Player. Aby odtworzyć plik Flash, Dodaj kontrolkę ActiveX do slajdu i Utwórz z niego łącze do pliku Flash.

Ustawienia zabezpieczeń kontrolek ActiveX znajdują się w Centrum zaufania, które zawiera ustawienia zabezpieczeń i prywatności programów pakietu Microsoft Office 2007. W celu zezwolenia na uruchamianie kontrolek ActiveX może być wymagana zmiana ustawień zabezpieczeń. Ustawienia kontrolek ActiveX w Centrum zaufania są stosowane do wszystkich programów pakietu Office 2007. Na przykład zmiana ustawienia w programie PowerPoint spowoduje zmianę tego ustawienia również w innych programach pakietu Office korzystających z Centrum zaufania. Aby uzyskać więcej informacji na temat kontrolek Active X i zmieniania ustawień, zobacz Włączanie lub wyłączanie ustawień kontrolEk ActiveX w plikach pakietu Office.

Ważne: 

  • W celu odtworzenia pliku Flash w prezentacji należy zarejestrować odpowiednią kontrolkę Shockwave Flash Object na komputerze. Aby sprawdzić, czy obiekt Shockwave Flash jest zarejestrowany, na karcie deweloper w grupie formanty kliknij przycisk Więcej kontrolek Obraz przycisku . Jeśli na liście kontrolek widać kontrolkę Shockwave Flash Object, jest ona zarejestrowana na komputerze. Jeśli nie jest ona zarejestrowana, Pobierz najnowszą wersję programu Flash Player z witryny firmy Adobe w sieci Web, aby zarejestrować Shockwave Flash Object na komputerze.

  • W celu zagwarantowania prawidłowego działania złożonych animacji zainstaluj najnowszą wersję programu Flash Player, nawet jeśli na komputerze są zarejestrowane starsze wersje kontrolki Shockwave Flash Object.

Dodawanie pliku Flash do prezentacji

  1. Zainstaluj program Flash Player na komputerze.

  2. W widoku normalnym programu PowerPoint wyświetl slajd, na którym chcesz odtwarzać animację.

  3. Kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Opcje programu PowerPoint.

  4. Kliknij pozycję Popularne, a następnie w obszarze Najczęściej używane opcje w pracy z programem PowerPoint zaznacz pole wyboru Pokaż kartę Deweloper na wstążce i kliknij przycisk OK.

  5. Na karcie deweloper w grupie kontrolki kliknij przycisk Więcej kontrolek Obraz przycisku .

  6. Na liście kontrolek kliknij pozycję Shockwave Flash Object, kliknij przycisk OK, a następnie przeciągnij na slajd, aby narysować kontrolkę.

    Zmień rozmiar kontrolki, przeciągając uchwyty zmiany rozmiaru.

  7. Kliknij prawym przyciskiem myszy kontrolkę Shockwave Flash Object, a następnie kliknij polecenie Właściwości.

  8. Na karcie Alfabetyczne kliknij właściwość Film.

  9. W kolumnie wartości (pusta komórka obok właściwości Film) wpisz pełną ścieżkę wraz z nazwą pliku (na przykład C\:MojPlik.swf) lub adres URL pliku Flash, który chcesz odtworzyć.

  10. Aby ustawić szczegółowe opcje odtwarzania animacji, wykonaj poniższe czynności, a następnie zamknij okno dialogowe Właściwości:

    • Aby plik był odtwarzany automatycznie po wyświetleniu slajdu, zmień wartość właściwości Odtwarzanie na Prawda. Jeśli plik Flash ma wbudowaną kontrolkę Uruchom/Przewiń, można ustawić wartość właściwości Odtwarzanie na Fałsz.

    • Jeśli animacja powinna odtworzyć się tylko raz, zmień wartość właściwości Pętla na Fałsz.

Wyświetlanie podglądu animacji w widoku Pokaz slajdów

  • Na karcie Widok w grupie Widoki prezentacji kliknij przycisk Pokaz slajdów lub naciśnij klawisz F5.

    Aby zakończyć pokaz slajdów i powrócić do widoku normalnego, naciśnij klawisz ESC.

Uwagi: 

  • W przeciwieństwie do obrazów lub rysunków pliki Flash są zawsze połączone z prezentacją w programie PowerPoint 2007, a nie osadzone. Po wstawieniu pliku połączonego program PowerPoint tworzy link do bieżącej lokalizacji tego pliku. Jeśli później przeniesiesz plik do innej lokalizacji, program PowerPoint nie będzie mógł go zlokalizować, gdy zechcesz go odtworzyć. Przed wstawieniem plików Flash do prezentacji najlepiej skopiować je do folderu, w którym znajduje się prezentacja. Program PowerPoint utworzy link do pliku Flash i będzie mógł go znaleźć, dopóki plik pozostanie w folderze prezentacji, nawet jeśli przeniesiesz folder lub skopiujesz go na inny komputer. Innym sposobem zapewnienia, że pliki połączone znajdują się w tym samym folderze, co prezentacja, jest użycie funkcji Spakuj na dysk CD. Ta funkcja powoduje skopiowanie wszystkich plików do jednej lokalizacji (dysku CD lub folderu) razem z prezentacją i automatyczne zaktualizowanie wszystkich linków do plików. Gdy prezentacja zawiera pliki połączone, należy skopiować połączone pliki oraz prezentację, jeśli planujesz prezentację na innym komputerze lub wysłać ją do kogoś w wiadomości e-mail.

  • Produkty innych firm omawiane w tym artykule są wytwarzane przez dostawców niezależnych od firmy Microsoft i firma Microsoft nie udziela jakichkolwiek gwarancji, dorozumianych ani innych, co do ich wydajności i niezawodności.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×