Obliczanie średniej wartości dla grupy liczb

Obliczanie średniej wartości dla grupy liczb

Załóżmy, że należy obliczyć średnią liczbę dni, jaka jest konieczna do osiągnięcia określonego punktu kontrolnego w projekcie, lub średnią temperaturę w określonym dniu w ciągu 10 lat. Średnią wartość dla grupy liczb można obliczyć na kilka sposobów.

Funkcja ŚREDNIA dokonuje pomiaru tendencji centralnej, którą jest lokalizacja środka zbioru liczb w rozkładzie statystycznym. Trzy najczęściej używane miary tendencji centralnej to:

  • Średnia     — średnia arytmetyczna, obliczana jako suma zbioru wartości podzielona przez ich liczbę. Na przykład średnią liczb 2, 3, 3, 5, 7 i 10 jest wartość 30 podzielona na 6, czyli 5.

  • Mediana     — środkowa liczba w zbiorze wartości (połowa liczb jest większa lub równa medianie, a połowa liczb jest mniejsza lub równa medianie). Na przykład medianą zbioru 2, 3, 3, 5, 7 i 10 jest 4.

  • Wyst.najczęściej     — najczęściej występująca wartość w zbiorze (dominanta). Na przykład dominantą zbioru 2, 3, 3, 5, 7 i 10 jest 3.

W przypadku symetrycznego rozkładu zbioru liczb wszystkie trzy miary tendencji centralnej są takie same. W przypadku skośnego rozkładu zbioru liczb miary mogą być różne.

Obliczanie średniej wartości liczb znajdujących się w ciągłym wierszu lub kolumnie

  1. Kliknij komórkę poniżej lub po prawej stronie liczb, dla których chcesz obliczyć średnią.

  2. Na karcie Narzędzia główne w grupie Edytowanie kliknij strzałkę obok przycisku Obraz przycisku Autosumowanie, kliknij polecenie Średnia, a następnie naciśnij klawisz ENTER.

Obliczanie średniej wartości liczb nieznajdujących się w ciągłym wierszu lub kolumnie

Aby wykonać to zadanie, należy użyć funkcji ŚREDNIA.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.

  2. Zaznacz przykład w tym temacie Pomocy.

    Uwaga : Nie zaznaczaj nagłówków wierszy ani kolumn.

    Zaznaczanie przykładu w Pomocy

    Zaznaczanie przykładu w Pomocy

  3. Naciśnij klawisze CTRL+C.

  4. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.

  5. Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

1

2

3

4

5

6

7

A

Dane

10

7

9

27

0

4

Formuła

Opis (wynik)

=ŚREDNIA(A2:A7)

Uśrednia wszystkie liczby na powyższej liście (9,5)

=ŚREDNIA(A2:A4;A7)

Uśrednia trzy pierwsze i ostatnią liczbę na liście (7,5)

=ŚREDNIA(A2:A7; "<>0")

Uśrednia liczby na liście z wyjątkiem komórek zawierających zero, takich jak komórka A6 (11,4)

Obliczanie średniej ważonej

Aby wykonać to zadanie, należy użyć funkcji SUMA.ILOCZYNÓW i SUMA.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.

  2. Zaznacz przykład w tym temacie Pomocy.

    Uwaga : Nie zaznaczaj nagłówków wierszy ani kolumn.

    Zaznaczanie przykładu w Pomocy

    Zaznaczanie przykładu w Pomocy

  3. Naciśnij klawisze CTRL+C.

  4. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.

  5. Aby przełączyć między wyświetlaniem wyników a wyświetlaniem formuł zwracających te wyniki, naciśnij klawisze CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

Ten przykład oblicza średnią cenę produktu z trzech zakupów, gdzie każdy zakup dotyczy innej liczby produktów przy innej cenie jednostkowej.

1

2

3

4

A

B

Cena jednostkowa

Liczba jednostek

20

500

25

750

35

200

Formuła

Opis (wynik)

=SUMA.ILOCZYNÓW(A2:A4;B2:B4)/SUMA(B2:B4)

Dzieli całkowity koszt wszystkich trzech zamówień przez całkowitą liczbę zamówionych produktów (24,66)

Obliczanie średniej wartości liczb z ignorowaniem wartości zerowych (0)

Aby wykonać to zadanie, należy użyć funkcji ŚREDNIA i JEŻELI.

Przykład

Przykład będzie bardziej zrozumiały po skopiowaniu go do pustego arkusza.

Jak skopiować przykład

  1. Utwórz pusty skoroszyt lub arkusz.

  2. Zaznacz przykład w tym temacie Pomocy.

    Uwaga : Nie zaznaczaj nagłówków wierszy ani kolumn.

    Zaznaczanie przykładu w Pomocy

    Zaznaczanie przykładu w Pomocy

  3. Naciśnij klawisze CTRL+C.

  4. W arkuszu zaznacz komórkę A1 i naciśnij klawisze CTRL+V.

  5. Aby przełączać się między wyświetlaniem wyników i wyświetlaniem formuł zwracających te wyniki, naciśnij klawisz CTRL+` (akcent słaby) albo na karcie Formuły w grupie Inspekcja formuł kliknij przycisk Pokaż formuły.

1

2

3

4

5

6

7

A

Dane

10

7

9

27

0

4

Formuła

Opis (wynik)

=ŚREDNIA(A2:A7; "<>0")

Uśrednia liczby na liście z wyjątkiem komórek zawierających zero, takich jak komórka A6 (11,4)

Zobacz też

ŚREDNIA

ŚREDNIA.JEŻELI

SUMA

SUMA.ILOCZYNÓW

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×