Objaśnianie struktury diagramów przy użyciu kontenerów i list

Objaśnianie struktury diagramów przy użyciu kontenerów i list

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Na złożonych diagramach dobrze jest zidentyfikować i oznaczyć powiązane kształty. Możliwość rozróżnienia grup ułatwia i przyspiesza zrozumienie struktury diagramu.

Kontenery

Kontenery to kolekcje kształtów otoczonych widocznym obramowaniem.

Dodawanie kontenerów

  1. Zaznacz kształty, które chcesz zawrzeć w kontenerze.

  2. Na karcie Wstawianie w grupie Części diagramu kliknij pozycję Kontener.

  3. Zatrzymuj wskaźnik myszy na stylach kontenerów, aby wyświetlić podgląd kontenerów na stronie.

  4. Kliknij, aby wstawić kontener.

  5. Mając zaznaczony kontener, wpisz nagłówek dla grupy kształtów.

Jeśli podczas wstawiania kontenera nie będą zaznaczone żadne kształty, kontener zostanie dodany na środku bieżącego widoku. Nie będzie zawierał żadnych kształtów, nawet jeśli będzie wyglądało, że są w nim kształty. Te kształty tylko znajdują się w tym samym miejscu, ale kontener ich nie zawiera.

Zachowanie kształtów zawartych w kontenerze

Kształty zawarte w kontenerze mają określoną relację z tym kontenerem i podlegają akcjom, które są wykonywane na kontenerze:

  • Przeniesienie kontenera powoduje przeniesienie zawartych w nim kształtów.

  • Skopiowanie kontenera powoduje skopiowanie także zawartych w nim kształtów.

  • Usunięcie kontenera powoduje usunięcie zawartych w nim kształtów.

Dodawanie kształtów do kontenera

Kształty dodaje się, upuszczając je wewnątrz kontenera. To, czy dany kształt jest zawarty w kontenerze, można poznać, zaznaczając kształt — zaznaczenie kształtu zawartego w kontenerze powoduje, że kontener jest delikatnie wyróżniany.

Jeśli kontener nie jest wyróżniany po zaznaczeniu kształtu umieszczonego wewnątrz niego, należy przesunąć kształt odrobinę do wewnątrz kontenera. Daje to taki sam efekt co upuszczenie kształtu na kontener. Można także kliknąć kształt prawym przyciskiem myszy, wskazać polecenie Kontener, a następnie kliknąć polecenie Dodaj do kontenera podstawowego.

Kształty można także dołączać do krawędzi kontenerów. Przytrzymanie kształtu na krawędzi powoduje wyświetlenie wyróżnienia tylko na tej krawędzi. Po upuszczeniu kształtu będzie on pozostawał na krawędzi podczas przesuwania i zmieniania rozmiaru kontenera.

Formatowanie kontenera

Gdy kontener jest zaznaczony, na wstążce jest dostępna karta Narzędzia kontenerów o nazwie Formatowanie. Ta karta zawiera polecenia umożliwiające dostosowywanie wyglądu i działania kontenera.

  • Ustawianie marginesów i automatycznej zmiany rozmiaru.

  • Wzbogacanie stylu.

  • Określanie poleceń dotyczących członkostwa.

    • Zablokuj kontener    powoduje, że kształty nie mogą być dodawane do zaznaczonego kontenera ani z niego usuwane. Kształty mogą być jednak przenoszone w obrębie kontenera. Ponadto na kontener można upuszczać kształty, ale nie stają się one jego zawartością.

    • Wybierz zawartość    powoduje po prostu zaznaczenie wszystkich kształtów zawartych w kontenerze.

    • Opróżnij i usuń kontener    usuwa zaznaczony kontener, pozostawiając kształty, które były w nim zawarte (zaznaczenie kontenera i naciśnięcie klawisza DELETE powoduje, że kształty zawarte w kontenerze są również usuwane).

Ponadto można używać poleceń formatowania na karcie Narzędzia główne. Można na przykład określać położenie tekstu nagłówka kontenera, używając poleceń wyrównania akapitu.

Listy

Listy to szczególny rodzaj kontenerów — każdy element dodany do listy jest automatycznie ustawiany w odpowiedniej kolejności.

W przeciwieństwie do kontenerów nie ma list uniwersalnych, które by można było dodawać do diagramu. Rekompensuje to fakt, że niektóre kształty do zastosowań specjalnych mają wbudowane zachowania listy. Przykładami są kształty torów w schemacie blokowym współzależności funkcjonalnych, kształty legend dla grafik związanych z danymi i kształty kontrolek, takie jak pole listy w szablonie diagramu szkieletowego.

Kolejność elementów na listach można zmieniać, przeciągając je w nowe miejsce. Nowe elementy dodaje się, klikając strzałkę wstawiania do listy.

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×