Nie można zapisać zreplikowanej bazy danych w formacie programu Access 2007

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Objawy

W Microsoft Office Access 2007 replikowane baz danych utworzonych we wcześniejszych wersjach programu Access (. MDB format) nie można zapisać w nowym. Format pliku ACCDB. Opcja ma być wyświetlana jest wyszarzone (niedostępne) podczas próby za pomocą polecenia Zapisz bazę danych jako (w tym celu należy kliknąć Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij strzałkę obok przycisku Zapisz jako ).

Przyczyna

Format pliku ACCDB nie obsługuje replikacji.

Rozwiązanie

Używanie zreplikowanej bazy danych w formacie pliku MDB

Można nadal używać zreplikowanej bazy danych w formacie pliku MDB. Funkcje replikacji są nadal obsługiwane dla formatu pliku MDB.

Ręczne ponowne tworzenie bazy danych w formacie pliku programu Office Access 2007

Jeśli okaże się, że nowy format pliku oferuje korzyści, które przewyższają zalety replikacji, można utworzyć nową bazę danych w formacie programu Office Access 2007 i ręcznie ponownie utworzyć zreplikowaną bazę danych.

Uwaga : Ta metoda będzie skuteczna w przypadku dowolnej zreplikowanej bazy danych, ale jeśli użytkownik nie pracuje z pełną repliką, która została zsynchronizowana ze wszystkimi innymi replikami w zestawie replik, wszelkie dane i projekty, które nie znajdują się jeszcze w replice, nie znajdą się w nowej bazie danych.

Przed rozpoczęciem ponownego tworzenia bazy danych należy sprawdzić, czy wszystkie obiekty ukryte i systemowe w replice są widoczne. Pozwoli to upewnić się, że użytkownik będzie mieć dostęp do wszystkich specyficznych dla repliki pól w tej replice podczas jej ponownego tworzenia.

  1. Otwórz replikę, którą chcesz przekonwertować. Replika musi zostać otwarta za pomocą tej samej wersji programu Access, której użyto do jej utworzenia, aby wyświetlić pola ukryte i systemowe.

  2. W menu Narzędzia kliknij polecenie Opcje. Zostanie otwarte okno dialogowe Opcje.

  3. Na karcie Widok w sekcji Pokaż zaznacz pola wyboru Obiekty ukryte i Obiekty systemowe. Kliknij przycisk OK, aby zastosować nowe ustawienia i zamknąć okno dialogowe Opcje.

Ręczne ponowne tworzenie bazy danych

  1. Utwórz pustą bazę danych i otwórz ją.

    Uwaga : W programie Access zostanie utworzona nowa pusta tabela o nazwie Tabela1. Należy usunąć tę tabelę — można to zrobić, zamykając ją natychmiast, bez wprowadzania do niej jakichkolwiek zmian. Należy kliknąć prawym przyciskiem myszy jej kartę obiektu, a następnie kliknąć polecenie Zamknij w menu skrótów.

  2. Na karcie Dane zewnętrzne w grupie Importowanie kliknij programu Access.

    Zostanie wyświetlone okno dialogowe Pobieranie danych zewnętrznych — baza danych programu Access.

  3. Kliknij przycisk Przeglądaj, aby zlokalizować zreplikowaną bazę danych.

  4. Kliknij zreplikowaną bazę danych zawierającą obiekty bazy danych, które chcesz ponownie utworzyć w nowej bazie danych, a następnie kliknij przycisk Otwórz.

  5. W oknie dialogowym Pobieranie danych zewnętrznych — baza danych programu Access kliknij opcję Importuj tabele, kwerendy, formularze, raporty, makra i moduły do bieżącej bazy danych, a następnie kliknij przycisk OK.

  6. Kliknij obiekty bazy danych, które chcesz zaimportować do nowej bazy danych. Jeśli chcesz zaimportować wszystkie obiekty, kliknij przycisk Zaznacz wszystkie na każdej karcie.

    Ważne    Nie zaznaczaj żadnych tabel na tym etapie. Tabele utworzysz w późniejszym kroku.

  7. Po zakończeniu zaznaczania obiektów kliknij przycisk OK, aby je zaimportować.

    Na ostatniej stronie kreatora jest dostępna opcja zapisania kroków importowania w celu ich ponownego użycia w przyszłości. Aby to zrobić, zaznacz pole wyboru Zapisz kroki importowania, wprowadź odpowiednie informacje, a następnie kliknij przycisk Zapisz importowanie.

  8. Otwórz zreplikowaną bazę danych w programie Office Access 2007. Dla każdej tabeli w zreplikowanej bazie danych utwórz kwerendę tworzącą tabele, która zbierze wszystkie dane w starej tabeli i utworzy tabelę w nowej bazie danych z tymi samymi danymi.

    Uwaga : Jeśli klucz podstawowy jest s_GUID (i kluczy obcych w innych tabelach odwołują się do niego), należy uwzględnić pole s_GUID w nowej tabeli. Jeśli pole s_GUID nie jest używane jako klucz podstawowy, istnieje potrzeba zachowywania go w nowej tabeli. Nie należy kopiować pól s_Lineage i s_Generation do nowej tabeli.

    Pola s_GUID, s_Lineage oraz s_Generation są domyślnie ukryte. Aby je wyświetlić, należy użyć poniższej procedury:

    1. Upewnij się, że wszystkie tabele w zreplikowanej bazie danych są zamknięte.

    2. Kliknij prawym przyciskiem myszy u góry okienka nawigacji, a następnie kliknij polecenie Opcje nawigacji. Zostanie otwarte okno dialogowe Opcje nawigacji.

    3. W sekcji Opcje wyświetlania zaznacz pole wyboru Pokaż obiekty systemowe, a następnie kliknij przycisk OK.

      Jak?

      1. Utwórz kwerendę, wybierając tabele zawierające te rekordy, które mają się znaleźć w nowej tabeli.

        Jak?

        1. Na karcie Tworzenie w grupie Inne kliknij przycisk Projekt kwerendy.

        2. W oknie dialogowym Pokazywanie tabeli kliknij kartę zawierającą tabele, z którymi chcesz pracować.

        3. Kliknij dwukrotnie nazwę każdego obiektu, który ma być dodany do kwerendy, a następnie kliknij przycisk Zamknij.

        4. Dodaj pola do wiersza Pole w siatka projektu.

        5. Aby wyświetlić wyniki kwerendy, kliknij menu Widok, a następnie kliknij polecenie Widok arkusza danych.

      2. W widok projektu kwerendy na karcie Projekt w grupie Typ kwerendy kliknij przycisk Utwórz tabelę. Zostanie wyświetlone okno dialogowe Tworzenie tabeli.

      3. W polu Nazwa tabeli wprowadź nazwę tabeli, która ma być utworzona lub zamieniona.

      4. Kliknij przycisk Inna baza danych, a następnie wpisz ścieżkę do bazy danych, w której ma się znaleźć nowa tabela, lub kliknij przycisk Przeglądaj, aby określić położenie tej bazy danych.

      5. Kliknij przycisk OK.

      6. Na karcie Projektowanie w grupie wyniki kliknij przycisk Uruchom. Spowoduje to utworzenie nowej tabeli.

        Uwaga : Nowa tabela nie dziedziczy właściwości pola ani ustawienia klucz podstawowy z oryginalnej tabeli.

  9. Dla każdej tabeli w nowej bazie danych utwórz taki sam indeks i klucz podstawowy, jaki był używany w tabeli repliki.

    Jak?

    1. Otwórz tabelę w widoku Projekt.

    2. W górnej części okna kliknij pole, dla którego chcesz utworzyć indeks.

    3. W dolnej części okna kliknij pole właściwości Indeksowane, a następnie kliknij opcję Tak (Duplikaty OK) lub Tak (Bez Duplikatów).

    4. Zaznacz pole lub pola stanowiące klucz podstawowy.

    5. Na karcie Projektowanie w grupie Narzędzia kliknij przycisk Klucz podstawowy.

  10. Dla każdej tabeli w nowej bazie danych utworzyć relacje istniejące dla tej tabeli w replice.

    Jak?

    Podczas tworzenia relacji między tabelami pola pokrewne nie muszą mieć takie same nazwy. Jednak pola pokrewne musi mieć samej typ danych, chyba że klucz podstawowy jest polem typu Autonumerowanie. Tylko wtedy, gdy właściwość rozmiar pola obu zgodnych pól jest taka sama, można dopasować pola typu Autonumerowanie z polem numer. Na przykład można dopasować pola typu Autonumerowanie i pole Liczba, jeżeli właściwość rozmiar pola obu tych pól jest Liczba całkowita długa. Nawet wtedy, gdy oba zgodne pola są polami Autonumerowanie, muszą mieć takie same ustawienie właściwości rozmiar pola.

    Definiowanie jeden do wielu lub relacją

    1. Zamknij wszystkie otwarte tabele. Nie można tworzyć ani modyfikować relacji między otwartymi tabelami.

    2. Na karcie Narzędzie bazy danych w grupie Pokazywanie/ukrywanie kliknij przycisk Relacje.

    3. Jeśli w bazie danych nie zostały jeszcze zdefiniowane żadne relacje, zostanie automatycznie wyświetlone okno dialogowe Pokazywanie tabeli.

      Jeśli potrzebujesz dodać tabele do utworzenia relacji, a okno dialogowe Pokazywanie tabeli nie jest wyświetlane, wywołaj je: na karcie Projekt w grupie Pokazywanie/ukrywanie kliknij przycisk Pokaż tabelę.

    4. Kliknij dwukrotnie nazwy tabel, które chcesz związać relacją, a następnie zamknij okno dialogowe Pokazywanie tabeli. Aby utworzyć relację w ramach jednej tabeli, dwukrotnie dodaj tę tabelę.

    5. Przeciągnij z pierwszej tabeli pole, które chcesz związać relacją, do odpowiedniego pola drugiej tabeli.

      Aby przeciągnąć kilka pól, przed przeciągnięciem kliknij kolejne pola przy naciśniętym klawiszu CTRL.

      W większości przypadków z tabeli jest przeciągane pole klucza podstawowego (wyróżnione pogrubieniem tekstu) do podobnego pola (często o tej samej nazwie) zwanego klucz obcy w drugiej tabeli.

    6. Pojawia się okno dialogowe Edytowanie relacji. Sprawdź poprawność nazw wyświetlanych w obu kolumnach. W razie potrzeby możesz je zmienić.

      Jeśli to konieczne, ustaw opcje relacji.

    7. Kliknij przycisk Utwórz, aby utworzyć relację.

    8. Powtórz kroki opisane w punktach od 4 do 7 dla każdej pary tabel, które chcesz związać relacją.

      Przy zamykaniu okno Relacje program Microsoft Access wyświetla zapytanie, czy chcesz zapisać zmiany układu. Niezależnie od tego, czy zmiany układu zostaną zapisane, utworzone relacje są zapisywane w bazie danych.

    Definiowanie relacji wiele do wielu

    1. Utwórz dwie tabele, między którymi chcesz utworzyć relacja wiele-do-wielu.

    2. Utwórz trzecią tabelę, nazywaną tabelą połączeń, i dodaj do niej pola o identycznej definicji, jak pola klucza podstawowego dwóch pierwszych tabel. Te pola pełnią w tabeli skrzyżowań rolę klucza obcego. Do tabeli skrzyżowań można również dodać inne pola, jak do każdej innej tabeli.

    3. W tabeli sprzęgającej ustaw klucz podstawowy obejmujący wszystkie pola kluczy podstawowych z dwóch pozostałych tabel. Na przykład w tabeli sprzęgającej Opisy zamówień klucz podstawowy obejmowałby pola IDZamówienia i IDProduktu.

      Jak?

      1. Otwórz tabelę w widoku projektu.

      2. Zaznacz pole lub pola, które chcesz zdefiniować jako klucz podstawowy.

        Aby zaznaczyć jedno pole, kliknij selektor wiersza dla żądanego pola.

        Aby zaznaczyć kilka pól, przytrzymaj klawisz CTRL, a następnie kliknij selektor wiersza dla każdego pola.

      3. Na karcie Projektowanie w grupie Narzędzia kliknij przycisk Klucz podstawowy.

        Uwaga : Jeśli chcesz, aby kolejność pól w kluczu podstawowym składającym się z wielu pól była inna niż kolejność tych pól w tabeli, kliknij przycisk Indeksy w grupie Pokaż/Ukryj w celu wyświetlenia okno indeksów, a następnie zmień kolejność nazw pól dla indeks o nazwie KluczPodstawowy.

    4. Definiowanie relacja jeden-do-wielu między każdą z dwóch tabel podstawowych a tabeli skrzyżowań.

  11. Zapisz nową bazę danych.

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×