Naprawianie uszkodzonego skoroszytu

Podczas otwierania uszkodzonego skoroszytu program Excel automatycznie uruchamia tryb odzyskiwania pliku i próbuje ponownie otworzyć i jednocześnie naprawić skoroszyt.

Program Excel nie zawsze może automatycznie uruchomić tryb odzyskiwania pliku. Jeśli nie możesz otworzyć skoroszytu, ponieważ został uszkodzony, możesz podjąć próbę naprawienia go ręcznie.

Jeśli naprawianie skoroszytu nie powiodło się, możesz również spróbować innych metod odzyskania danych ze skoroszytu. W ramach działań zapobiegawczych warto często zapisywać skoroszyt i tworzyć kopię zapasową podczas każdego zapisu skoroszytu. Możesz też zdecydować się na automatyczne tworzenie przez program Excel pliku odzyskiwania w określonych odstępach. Dzięki temu będziesz dysponować sprawną kopią skoroszytu na wypadek przypadkowego usunięcia lub uszkodzenia oryginalnego skoroszytu.

Ręczna naprawa uszkodzonego skoroszytu

  1. Na karcie Plik kliknij pozycję Otwórz.

  2. W programach Excel 2013 i Excel 2016 kliknij w miejscu, w którym znajduje się arkusz kalkulacyjny, i kliknij przycisk Przeglądaj.

  3. W oknie dialogowym Otwieranie wybierz uszkodzony skoroszyt, który chcesz otworzyć.

  4. Kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz i napraw.

  5. Wykonaj jedną z następujących czynności:

    • Aby odzyskać możliwie największą część danych skoroszytu, wybierz pozycję Napraw.

    • Aby wyodrębnić wartości i formuły ze skoroszytu, gdy próba naprawy skoroszytu nie powiedzie się, kliknij przycisk Wyodrębnij dane.

Odzyskiwanie danych z uszkodzonego skoroszytu

Poniższe metody mogą pomóc w odzyskaniu danych, które mogłyby zostać utracone. Jeśli jedna metoda nie poskutkuje, możesz spróbować innej. Jeśli żadna z tych metod nie umożliwi odzyskania danych, możesz także skorzystać z rozwiązań innych producentów i spróbować odzyskać dane ze skoroszytu za ich pomocą.

Ważne : Jeśli błąd dysku lub błąd sieciowy uniemożliwia otwarcie skoroszytu, przed wypróbowaniem dowolnej z poniższych opcji odzyskiwania przenieś skoroszyt na inny dysk twardy albo z sieci na dysk lokalny.

  • Aby odzyskać dane, gdy skoroszyt jest otwarty w programie Excel, wykonaj jedną z następujących czynności:

    • Przywracanie skoroszytu do ostatniej zapisanej wersji     Jeśli edytujesz arkusz i skoroszyt zostanie uszkodzony przed zapisaniem wprowadzonych zmian, możesz odzyskać oryginalny arkusz przez przywrócenie ostatniej zapisanej wersji skoroszytu.

      Aby przywrócić ostatnią zapisaną wersję skoroszytu, wykonaj następujące czynności:

      1. Na karcie Plik kliknij pozycję Otwórz.

      2. Kliknij dwukrotnie nazwę skoroszytu otwartego w programie Excel.

      3. Kliknij przycisk Tak, aby ponownie otworzyć skoroszyt.

        Uwaga : Zostanie przywrócona ostatnia zapisana wersja skoroszytu. Wszelkie zmiany, które mogły spowodować uszkodzenie skoroszytu, zostaną odrzucone. Aby uzyskać więcej informacji dotyczących przywracania starszych wersji skoroszytu, zobacz Automatyczne zapisywanie i odzyskiwanie plików pakietu Office.

    • Zapisywanie skoroszytu w formacie SYLK (Łącze symboliczne)     Zapisanie skoroszytu w formacie SYLK daje możliwość odfiltrowania uszkodzonych elementów. Format SYLK jest zazwyczaj używany do usuwania uszkodzenia pliku drukarki.

      Aby zapisać skoroszyt w formacie SYLK, wykonaj następujące czynności:

      1. Kliknij kartę Plik, a następnie kliknij polecenie Zapisz jako.

      2. Na liście Zapisz jako typ kliknij pozycję SYLK (Łącze symboliczne), a następnie kliknij przycisk Zapisz.

        Uwaga : Gdy używany jest format pliku SYLK, zapisywany jest tylko aktywny arkusz skoroszytu.

      3. Jeśli zostanie wyświetlony komunikat informujący, że wybrany typ pliku nie obsługuje skoroszytów zawierających wiele arkuszy, kliknij przycisk OK, aby zapisać tylko aktywny arkusz.

      4. Jeśli zostanie wyświetlony komunikat informujący, że skoroszyt może zawierać funkcje, które nie są zgodne z formatem SYLK, kliknij przycisk Tak.

      5. Na karcie Plik kliknij pozycję Otwórz.

      6. Wybierz plik slk, który został uprzednio zapisany, a następnie kliknij przycisk Otwórz.

        Uwaga : Jeśli plik slk nie jest wyświetlany, może być konieczne kliknięcie pozycji Wszystkie pliki lub Pliki SYLK na liście Pliki typu.

      7. Na karcie Plik kliknij przycisk Zapisz jako.

      8. W polu Zapisz jako typ kliknij pozycję Skoroszyt programu Excel.

      9. W polu Nazwa pliku wpisz nową nazwę skoroszytu, aby utworzyć kopię bez zastępowania oryginalnego skoroszytu, a następnie kliknij przycisk Zapisz.

        Uwaga : Ponieważ ten format umożliwia tylko zapisanie aktywnego arkusza w skoroszycie, należy wielokrotnie otwierać uszkodzony skoroszyt i zapisać oddzielnie poszczególne arkusze.

  • Aby odzyskać dane, gdy nie można otworzyć skoroszytu w programie Excel, wykonaj jedną z następujących czynności:

    • Ustawianie opcji obliczania w programie Excel na obliczanie ręczne     Aby otworzyć skoroszyt, spróbuj zmienić ustawienie obliczania z automatycznego na ręczne. Ponieważ skoroszyt nie będzie ponownie obliczany, być może uda się go otworzyć.

      Aby ustawić opcję ręcznego obliczania w programie Excel, wykonaj następujące czynności:

      1. Upewnij się, że w programie Excel jest otwarty nowy, pusty skoroszyt. Jeśli nowy, pusty skoroszyt nie jest otwarty, wykonaj następujące czynności:

    • Na karcie Plik kliknij pozycję Nowy.

    • W obszarze Dostępne szablony kliknij pozycję Pusty skoroszyt.

      1. Na karcie Plik kliknij pozycję Opcje.

      2. W kategorii Formuły w obszarze Opcje obliczania kliknij opcję Ręcznie.

      3. Kliknij przycisk OK.

      4. Na karcie Plik kliknij pozycję Otwórz.

      5. Wybierz uszkodzony skoroszyt, a następnie kliknij przycisk Otwórz.

    • Używanie odwołań zewnętrznych do łączenia z uszkodzonym skoroszytem     Jeśli chcesz pobrać ze skoroszytu tylko dane, a nie formuły lub wartości obliczane, spróbuj użyć odwołań zewnętrznych w celu ustanowienia połączenia z uszkodzonym skoroszytem.

      Aby użyć odwołań zewnętrznych do łączenia z uszkodzonym skoroszytem, wykonaj następujące czynności:

      1. Na karcie Plik kliknij pozycję Otwórz.

      2. Wybierz folder zawierający plik uszkodzonego skoroszytu, skopiuj nazwę uszkodzonego skoroszytu, a następnie kliknij przycisk Anuluj.

      3. Kliknij kartę Plik, a następnie kliknij pozycję Nowy.

      4. W obszarze Dostępne szablony kliknij pozycję Pusty skoroszyt.

      5. W komórce A1 nowego skoroszytu wpisz =Nazwa pliku!A1, gdzie Nazwa pliku jest nazwą uszkodzonego skoroszytu skopiowanego w kroku 2, a następnie naciśnij klawisz ENTER.

        Porada : Wystarczy wprowadzić tylko nazwę skoroszytu — nie trzeba wpisywać rozszerzenia nazwy pliku.

      6. Jeśli zostanie wyświetlone okno dialogowe Aktualizowanie wartości, wybierz uszkodzony skoroszyt i kliknij przycisk OK.

      7. Jeśli zostanie wyświetlone okno dialogowe Zaznaczanie arkusza, wybierz odpowiedni arkusz, a następnie kliknij przycisk OK.

      8. Zaznacz komórkę A1.

      9. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Kopiuj.

      10. Rozpoczynając w komórce A1, zaznacz obszar, który w przybliżeniu ma taki sam rozmiar, jak zakres komórek zawierających dane w uszkodzonym skoroszycie.

      11. Na karcie Narzędzia główne w grupie Schowek kliknij pozycję Wklej.

      12. Po upewnieniu się, że ten zakres komórek jest zaznaczony, na karcie Narzędzia główne w grupie Schowek kliknij ponownie przycisk Kopiuj.

      13. Na karcie Narzędzia główne w grupie Schowek kliknij strzałkę pod przyciskiem Wklej, a następnie w obszarze Wklej wartości kliknij pozycję Wartości.

        Uwaga : Wklejenie wartości powoduje usunięcie łączy do uszkodzonego skoroszytu i pozostawienie tylko danych.

    • Wyodrębnianie danych z uszkodzonego skoroszytu za pomocą makra     Jeśli z uszkodzonym skoroszytem jest połączony wykres, możesz użyć makra w celu wyodrębnienia danych źródłowych wykresu.

      Aby użyć makra, wykonaj następujące czynności:

      1. Wprowadź poniższy kod makra w arkuszu modułu:

        Sub GetChartValues() 
        Dim NumberOfRows As Integer
        Dim X As Object
        Counter = 2
        ' Calculate the number of rows of data.
        NumberOfRows = UBound(ActiveChart.SeriesCollection(1).Values)
        Worksheets("ChartData").Cells(1, 1) = "X Values"
        ' Write x-axis values to worksheet.
        With Worksheets("ChartData")
        .Range(.Cells(2, 1), _
        .Cells(NumberOfRows + 1, 1)) = _
        Application.Transpose(ActiveChart.SeriesCollection(1).XValues) 
        End With
        ' Loop through all series in the chart and write their values to
        ' the worksheet.
        For Each X In ActiveChart.SeriesCollection
        Worksheets("ChartData").Cells(1, Counter) = X.Name
        With Worksheets("ChartData")
        .Range(.Cells(2, Counter), _ 
        .Cells(NumberOfRows + 1, Counter)) = _
        Application.Transpose(X.Values)
        End With
         Counter = Counter + 1
        Next
        End Sub
      2. Wstaw nowy arkusz w skoroszycie i zmień jego nazwę na DaneWykresu.

      3. Wybierz wykres, z którego chcesz wyodrębnić wartości danych źródłowych.

      4. Uwaga : Wykres można osadzić w arkuszu lub w oddzielnym arkuszu wykresu.

      5. Uruchom makro GetChartValues.

      6. Dane z wykresu zostaną umieszczone w arkuszu DaneWykresu.

Automatyczne zapisywanie kopii zapasowej skoroszytu

Automatyczne zapisywanie kopii zapasowej skoroszytu pomaga zapewnić sprawną kopię skoroszytu na wypadek przypadkowego usunięcia lub uszkodzenia oryginalnego skoroszytu.

  1. Na karcie Plik kliknij przycisk Zapisz jako.

  2. W programach Excel 2013 i Excel 2016 kliknij w miejscu, w którym znajduje się arkusz kalkulacyjny, i kliknij przycisk Przeglądaj.

  3. Kliknij strzałkę rozwijaną obok pozycji Narzędzia znajdującej się obok przycisku Zapisz, a następnie kliknij pozycję Opcje ogólne.

  4. Zaznacz pole wyboru Zawsze twórz kopię zapasową.

Aby uzyskać więcej informacji na temat zapisywania i odzyskiwania starszych wersji skoroszytu, a także informacje dotyczące odzyskiwania nowych skoroszytów (które nie zostały wcześniej zapisane), zobacz Odzyskiwanie plików pakietu Office.

Automatyczne tworzenie pliku odzyskiwania w określonych odstępach

Skonfigurowanie programu Excel, aby okresowo tworzył plik odzyskiwania, pomaga zapewnić sprawną kopię skoroszytu na wypadek przypadkowego usunięcia lub uszkodzenia oryginalnego skoroszytu.

  1. Na karcie Plik kliknij pozycję Opcje.

  2. W kategorii Zapisywanie w obszarze Zapisywanie skoroszytów zaznacz pole wyboru Zapisz informacje Autoodzyskiwania co, a następnie wprowadź liczbę minut.

  3. W polu Lokalizacja pliku Autoodzyskiwania wprowadź lokalizację, w której chcesz zapisać plik odzyskiwania.

  4. Upewnij się, że pole wyboru Wyłącz Autoodzyskiwanie tylko dla tego skoroszytu nie jest zaznaczone.

Aby uzyskać więcej informacji na temat zapisywania i odzyskiwania starszych wersji skoroszytu, a także informacje dotyczące odzyskiwania nowych skoroszytów (które nie zostały wcześniej zapisane), zobacz Odzyskiwanie plików pakietu Office.

Ręczna naprawa uszkodzonego skoroszytu

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Otwórz.

  2. W oknie dialogowym Otwieranie wybierz uszkodzony skoroszyt, który chcesz otworzyć.

  3. Kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz i napraw.

  4. Wykonaj jedną z następujących czynności:

    • Aby odzyskać możliwie największą część danych skoroszytu, wybierz pozycję Napraw.

    • Aby wyodrębnić wartości i formuły ze skoroszytu, gdy próba naprawy skoroszytu nie powiedzie się, kliknij przycisk Wyodrębnij dane.

Odzyskiwanie danych z uszkodzonego skoroszytu

Poniższe metody mogą pomóc w odzyskaniu danych, które mogłyby zostać utracone. Jeśli jedna metoda nie poskutkuje, możesz spróbować innej. Jeśli żadna z tych metod nie umożliwi odzyskania danych, możesz także skorzystać z rozwiązań innych producentów i spróbować odzyskać dane ze skoroszytu za ich pomocą.

Ważne : Jeśli błąd dysku lub błąd sieciowy uniemożliwia otwarcie skoroszytu, przed wypróbowaniem dowolnej z poniższych opcji odzyskiwania przenieś skoroszyt na inny dysk twardy albo z sieci na dysk lokalny.

  • Aby odzyskać dane, gdy skoroszyt jest otwarty w programie Excel, wykonaj jedną z następujących czynności:

    • Przywracanie skoroszytu do ostatniej zapisanej wersji     Jeśli edytujesz arkusz i skoroszyt zostanie uszkodzony przed zapisaniem wprowadzonych zmian, możesz odzyskać oryginalny arkusz przez przywrócenie ostatniej zapisanej wersji skoroszytu.

      Aby przywrócić ostatnią zapisaną wersję skoroszytu, wykonaj następujące czynności:

      1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Otwórz.

      2. Kliknij dwukrotnie nazwę skoroszytu otwartego w programie Excel.

      3. Kliknij przycisk Tak, aby ponownie otworzyć skoroszyt.

        Uwaga : Zostanie przywrócona ostatnia zapisana wersja skoroszytu. Wszelkie zmiany, które mogły spowodować uszkodzenie skoroszytu, zostaną odrzucone.

    • Zapisywanie skoroszytu w formacie SYLK (Łącze symboliczne)     Zapisanie skoroszytu w formacie SYLK daje możliwość odfiltrowania uszkodzonych elementów. Format SYLK jest zazwyczaj używany do usuwania uszkodzenia pliku drukarki.

      Aby zapisać skoroszyt w formacie SYLK, wykonaj następujące czynności:

      1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie wskaż strzałkę obok polecenia Zapisz jako.

      2. Na liście Zapisz jako typ kliknij pozycję SYLK (Łącze symboliczne), a następnie kliknij przycisk Zapisz.

        Uwaga : Gdy używany jest format pliku SYLK, zapisywany jest tylko aktywny arkusz skoroszytu.

      3. Jeśli zostanie wyświetlony komunikat informujący, że wybrany typ pliku nie obsługuje skoroszytów zawierających wiele arkuszy, kliknij przycisk OK, aby zapisać tylko aktywny arkusz.

      4. Jeśli zostanie wyświetlony komunikat informujący, że skoroszyt może zawierać funkcje, które nie są zgodne z formatem SYLK, kliknij przycisk Tak.

      5. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Zamknij.

      6. Jeśli zostanie wyświetlony monit o zapisanie wprowadzonych zmian, kliknij przycisk Tak.

      7. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Otwórz.

      8. Wybierz plik slk, który został uprzednio zapisany, a następnie kliknij przycisk Otwórz.

        Uwaga : Jeśli plik slk nie jest wyświetlany, może być konieczne kliknięcie pozycji Wszystkie pliki lub Pliki SYLK na liście Pliki typu.

      9. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie wskaż strzałkę obok polecenia Zapisz jako.

      10. W polu Zapisz jako typ kliknij pozycję Skoroszyt programu Excel.

      11. W polu Nazwa pliku wpisz nową nazwę skoroszytu, aby utworzyć kopię bez zastępowania oryginalnego skoroszytu, a następnie kliknij przycisk Zapisz.

        Uwaga : Ponieważ ten format umożliwia tylko zapisanie aktywnego arkusza w skoroszycie, należy wielokrotnie otwierać uszkodzony skoroszyt i zapisać oddzielnie poszczególne arkusze.

  • Aby odzyskać dane, gdy nie można otworzyć skoroszytu w programie Excel, wykonaj jedną z następujących czynności:

    • Ustawianie opcji obliczania w programie Excel na obliczanie ręczne     Aby otworzyć skoroszyt, spróbuj zmienić ustawienie obliczania z automatycznego na ręczne. Ponieważ skoroszyt nie będzie ponownie obliczany, być może uda się go otworzyć.

      Aby ustawić opcję ręcznego obliczania w programie Excel, wykonaj następujące czynności:

      1. Upewnij się, że w programie Excel jest otwarty nowy, pusty skoroszyt. Jeśli nowy, pusty skoroszyt nie jest otwarty, wykonaj następujące czynności:

        1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Nowe.

        2. W obszarze Nowy, pusty dokument kliknij pozycję Pusty dokument.

      2. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij przycisk Opcje programu Excel.

      3. W kategorii Formuły w obszarze Opcje obliczania kliknij opcję Ręcznie.

      4. Kliknij przycisk OK.

      5. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Otwórz.

      6. Wybierz uszkodzony skoroszyt, a następnie kliknij przycisk Otwórz.

    • Używanie odwołań zewnętrznych do łączenia z uszkodzonym skoroszytem     Jeśli chcesz pobrać ze skoroszytu tylko dane, a nie formuły lub wartości obliczane, spróbuj użyć odwołań zewnętrznych w celu ustanowienia połączenia z uszkodzonym skoroszytem.

      Aby użyć odwołań zewnętrznych do łączenia z uszkodzonym skoroszytem, wykonaj następujące czynności:

      1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Otwórz.

      2. W polu Szukaj w wybierz folder zawierający plik uszkodzonego skoroszytu, a następnie kliknij przycisk Anuluj.

      3. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Nowy.

      4. W obszarze Nowy, pusty dokument kliknij pozycję Pusty dokument.

      5. W komórce A1 nowego skoroszytu wpisz =Nazwa_pliku!A1, gdzie Nazwa_pliku jest nazwą uszkodzonego skoroszytu, a następnie naciśnij klawisz ENTER.

        Porada : Wystarczy wprowadzić tylko nazwę skoroszytu — nie trzeba wpisywać rozszerzenia nazwy pliku.

      6. Kliknij skoroszyt, a następnie kliknij przycisk OK.

      7. Jeśli zostanie wyświetlone okno dialogowe Zaznaczanie arkusza, wybierz odpowiedni arkusz, a następnie kliknij przycisk OK.

      8. Zaznacz komórkę A1.

      9. Na karcie Narzędzia główne w grupie Schowek kliknij przycisk Kopiuj.

        Skrót klawiaturowy  Możesz także nacisnąć klawisze CTRL+C.

      10. Zaznacz obszar, który w przybliżeniu ma taki sam rozmiar jak zakres komórek zawierających dane w uszkodzonym skoroszycie.

      11. Na karcie Narzędzia główne w grupie Schowek kliknij pozycję Wklej.

      12. Po upewnieniu się, że ten zakres komórek jest zaznaczony, na karcie Narzędzia główne w grupie Schowek kliknij ponownie przycisk Kopiuj.

      13. Na karcie Narzędzia główne w grupie Schowek kliknij strzałkę poniżej przycisku Wklej, a następnie kliknij polecenie Wklej specjalnie.

      14. W obszarze Wklej wybierz opcję Wartości, a następnie kliknij przycisk OK.

        Uwaga : Wklejenie wartości powoduje usunięcie łączy do uszkodzonego skoroszytu i pozostawienie tylko danych.

    • Otwieranie uszkodzonego skoroszytu w programie Microsoft Office Word lub Microsoft WordPad     Jeśli masz zainstalowany konwerter programu Microsoft Office Excel, istnieje możliwość otworzenia skoroszytu w programie Word. Jeśli skoroszyt uda się otworzyć w programie Word, można odzyskać dane. Ta metoda nie umożliwia odzyskiwania arkuszy modułów, arkuszy okien dialogowych, arkuszy wykresów, arkuszy makr ani jakichkolwiek wykresów osadzonych. Nie można także odzyskać formuł komórek. Możliwe jest odzyskanie wyników tylko tych formuł, które są obecnie wyświetlane w komórkach uszkodzonego skoroszytu.

      Skoroszyt programu Excel można również otworzyć w programie WordPad. Jeśli skoroszyt zostanie otwarty, można niekiedy odzyskać kod języka Microsoft Visual Basic w modułach użytkownika i modułach klas. W celu znalezienia kodu można wyszukać słowa „Sub” lub „Function”.

    • Wyodrębnianie danych z uszkodzonego skoroszytu za pomocą makra     Jeśli z uszkodzonym skoroszytem jest połączony wykres, możesz użyć makra w celu wyodrębnienia danych źródłowych wykresu.

      Aby użyć makra, wykonaj następujące czynności:

      1. Wprowadź poniższy kod makra w arkuszu modułu:

        Wprowadź poniższy kod makra w arkuszu modułu:

        Sub GetChartValues() 
        Dim NumberOfRows As Integer
        Dim X As Object
        Counter = 2
        ' Calculate the number of rows of data.
        NumberOfRows = UBound(ActiveChart.SeriesCollection(1).Values)
        Worksheets("ChartData").Cells(1, 1) = "X Values"
        ' Write x-axis values to worksheet.
        With Worksheets("ChartData")
        .Range(.Cells(2, 1), _
        .Cells(NumberOfRows + 1, 1)) = _
        Application.Transpose(ActiveChart.SeriesCollection(1).XValues) 
        End With
        ' Loop through all series in the chart and write their values to
        ' the worksheet.
        For Each X In ActiveChart.SeriesCollection
        Worksheets("ChartData").Cells(1, Counter) = X.Name
        With Worksheets("ChartData")
        .Range(.Cells(2, Counter), _ 
        .Cells(NumberOfRows + 1, Counter)) = _
        Application.Transpose(X.Values)
        End With
         Counter = Counter + 1
        Next
        End Sub
      2. Wstaw nowy arkusz w skoroszycie i zmień jego nazwę na DaneWykresu.

      3. Wybierz wykres, z którego chcesz wyodrębnić wartości danych źródłowych.

        Uwaga : Wykres można osadzić w arkuszu lub w oddzielnym arkuszu wykresu.

      4. Uruchom makro GetChartValues97.

        Dane z wykresu zostaną umieszczone w arkuszu DaneWykresu.

Automatyczne zapisywanie kopii zapasowej skoroszytu

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie wskaż strzałkę obok polecenia Zapisz jako.

  2. Kliknij strzałkę obok pozycji Narzędzia, a następnie kliknij pozycję Opcje ogólne.

  3. Zaznacz pole wyboru Zawsze twórz kopię zapasową.

Automatyczne tworzenie pliku odzyskiwania w określonych odstępach

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij przycisk Opcje programu Excel.

  2. W kategorii Zapisywanie w obszarze Zachowaj informacje o kopii zapasowej dla skoroszytów zaznacz pole wyboru Zapisz informacje Autoodzyskiwania co, a następnie wprowadź liczbę minut.

  3. W polu Lokalizacja pliku Autoodzyskiwania wprowadź lokalizację, w której chcesz zapisać plik odzyskiwania.

  4. Upewnij się, że pole wyboru Wyłącz Autoodzyskiwanie tylko dla tego skoroszytu nie jest zaznaczone.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×