Naprawianie uszkodzonego skoroszytu

Ważne : Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

W przypadku, gdy podczas otwierania skoroszytu program Microsoft Excel wykrywa jego uszkodzenie, następuje automatyczne uruchomienie trybu odzyskiwania pliku i próba naprawienia skoroszytu. Jeśli tryb odzyskiwania pliku nie zostanie uruchomiony, spróbuj ręcznie odzyskać skoroszyt:

  1. Kliknij pozycję Plik > Otwórz.

  2. Kliknij lokalizację i folder zawierający uszkodzony skoroszyt.

  3. W oknie dialogowym Otwieranie wybierz uszkodzony skoroszyt.

  4. Kliknij strzałkę obok przycisku Otwórz, a następnie kliknij polecenie Otwórz i napraw.

    Polecenie Otwórz i napraw

  5. Aby odzyskać możliwie największą część danych skoroszytu, wybierz pozycję Napraw.

    Jeśli próba odzyskania danych za pomocą pozycji Napraw nie powiedzie się, wybierz pozycję Wyodrębnij dane, aby wyodrębnić wartości i formuły ze skoroszytu.

Jeśli ani automatyczna, ani ręczna metoda naprawy nie przyniesie rezultatów, istnieje jeszcze kilka sposobów, które mogą być pomocne przy odzyskiwaniu danych. Możesz też stosować środki zapobiegawcze pozwalające uniknąć utraty wykonanej pracy: automatycznie zapisywać kopię zapasową skoroszytu lub okresowo tworzyć plik odzyskiwania.

Odzyskiwanie danych z uszkodzonego skoroszytu

Automatyczne zapisywanie kopii zapasowej skoroszytu

Automatyczne tworzenie pliku odzyskiwania w określonych odstępach

Odzyskiwanie danych z uszkodzonego skoroszytu

Wybierz jedną z poniższych metod w celu odzyskania danych. Jeśli dana metoda nie będzie skuteczna, wypróbuj inną. Możesz także skorzystać z rozwiązań innych producentów i spróbować odzyskać skoroszyt za ich pomocą.

Ważne : Jeśli błąd dysku lub błąd sieciowy uniemożliwia otwarcie skoroszytu, przed wypróbowaniem dowolnej z poniższych opcji odzyskiwania przenieś skoroszyt na inny dysk twardy lub z sieci na dysk lokalny.

Odzyskiwanie danych, gdy skoroszyt jest otwarty w programie Excel

  • Przywracanie skoroszytu do ostatniej zapisanej wersji    Jeśli podczas pracy skoroszyt zostanie uszkodzony przed zapisaniem zmian, możesz przywrócić go do ostatniej zapisanej wersji.

    1. Kliknij pozycję Plik > Otwórz.

    2. Kliknij dwukrotnie nazwę skoroszytu otwartego w programie Excel.

    3. Kliknij przycisk Tak, aby ponownie otworzyć skoroszyt.

      Skoroszyt zostanie otwarty bez jakichkolwiek wprowadzonych zmian, które mogły spowodować uszkodzenie skoroszytu.

Odzyskiwanie danych, gdy nie można otworzyć skoroszytu w programie Excel

  • Ustawianie opcji obliczania w programie Excel na obliczanie ręczne    Spróbuj zmienić ustawienie obliczania z automatycznego na ręczne. Ponieważ skoroszyt nie będzie ponownie obliczany, być może uda się go otworzyć.

    1. Na karcie Plik kliknij pozycję Nowy.

    2. W obszarze Nowy kliknij pozycję Pusty skoroszyt.

    3. Kliknij pozycję Plik > Opcje.

    4. W kategorii Formuły w obszarze Opcje obliczania wybierz pozycję Ręczne, a następnie kliknij przycisk OK.

    5. Kliknij pozycję Plik > Otwórz.

    6. Znajdź i kliknij dwukrotnie uszkodzony skoroszyt, aby go otworzyć.

  • Używanie odwołań zewnętrznych do łączenia z uszkodzonym skoroszytem    Aby pobrać ze skoroszytu tylko dane, a nie formuły i wartości obliczane, spróbuj użyć odwołań zewnętrznych w celu ustanowienia połączenia z uszkodzonym skoroszytem.

    1. Kliknij pozycję Plik > Otwórz.

    2. Przejdź do folderu zawierającego uszkodzony skoroszyt.

    3. Kliknij prawym przyciskiem nazwę pliku uszkodzonego skoroszytu, kliknij polecenie Kopiuj, a następnie kliknij przycisk Anuluj.

    4. Na karcie Plik kliknij pozycję Nowy.

    5. W obszarze Nowy kliknij pozycję Pusty skoroszyt.

    6. W komórce A1 nowego skoroszytu wpisz = nazwy pliku! A1, miejsce, w którym nazwy pliku jest nazwą uszkodzony skoroszyt, który został skopiowany w kroku 3, a następnie naciśnij klawisz Enter.

      Uwaga : Wystarczy wprowadzić tylko nazwę skoroszytu — nie trzeba wpisywać rozszerzenia nazwy pliku.

    7. Jeśli zostanie wyświetlone okno dialogowe Aktualizowanie wartości, wybierz uszkodzony skoroszyt, a następnie kliknij przycisk OK.

    8. Jeśli zostanie wyświetlone okno dialogowe Zaznaczanie arkusza, wybierz odpowiedni arkusz, a następnie kliknij przycisk OK.

    9. Zaznacz komórkę A1.

    10. Kliknij pozycję Narzędzia główne > Kopiuj lub naciśnij klawisze Ctrl+C.

    11. Rozpoczynając w komórce A1, zaznacz obszar, który w przybliżeniu ma taki sam rozmiar, jak zakres komórek zawierających dane w uszkodzonym skoroszycie.

    12. Kliknij pozycję Narzędzia główne > Wklej lub naciśnij klawisze Ctrl+V.

    13. Pozostawiając zaznaczony zakres komórek, ponownie kliknij pozycję Narzędzia główne > Kopiuj lub naciśnij klawisze Ctrl+C.

    14. Na karcie Narzędzia główne kliknij strzałkę pod przyciskiem Wklej, a następnie w obszarze Wklej wartości kliknij pozycję Wartości.

      Wklejenie wartości powoduje usunięcie łączy do uszkodzonego skoroszytu i pozostawienie tylko danych.

  • Wyodrębnianie danych z uszkodzonego skoroszytu za pomocą makra    Jeśli z uszkodzonym skoroszytem jest połączony wykres, spróbuj użyć makra w celu wyodrębnienia danych źródłowych wykresu.

    1. Skopiuj poniższy kod makra i wklej go w arkuszu modułu:

      Sub GetChartValues()

      Dim NumberOfRows jako liczba całkowita

      Dim X jako obiekt

      Licznik = 2

      "Obliczanie liczby wierszy danych.

      NumberOfRows = UBound(ActiveChart.SeriesCollection(1). Wartości)

      Worksheets("ChartData"). Komórki (1, 1) = "X wartości"

      "Zapisze wartości osi x w arkuszu.

      Z Worksheets("ChartData")

      . Zakres (. Komórki (2; 1) _

      . Komórki (NumberOfRows + 1; 1)) = _

      Application.Transpose(ActiveChart.SeriesCollection(1). Wartości_x^nr.kolumny)

      Kończy się

      "Pętli wszystkich serii na wykresie i zapisywanie ich wartości

      ' arkusz.

      Dla każdego X w ActiveChart.SeriesCollection

      Worksheets("ChartData"). Komórki (1, licznik) = X.Name

      Z Worksheets("ChartData")

      . Zakres (. Komórki (2, licznik) _

      . Komórki (NumberOfRows + 1, licznik)) = _

      Application.Transpose(X.Values)

      Kończy się

      Licznik = licznik + 1

      Dalej

      End Sub

    2. Wstaw lub usuń arkusz w skoroszycie, kliknij prawym przyciskiem myszy kartę arkusza i zmień jego nazwę na DaneWykresu.

    3. Wybierz wykres, z którego chcesz wyodrębnić wartości danych źródłowych.

      Uwaga : Wykres można osadzić w arkuszu lub w oddzielnym arkuszu wykresu.

    4. Uruchom makro GetChartValues.

    5. Dane z wykresu zostaną umieszczone w arkuszu DaneWykresu.

Początek strony

Automatyczne zapisywanie kopii zapasowej skoroszytu

Kopia zapasowa skoroszytu zapewnia dostęp do danych na wypadek przypadkowego usunięcia lub uszkodzenia skoroszytu.

  1. Kliknij pozycję Plik > Zapisz jako.

  2. Kliknij pozycję Komputer, a następnie kliknij przycisk Przeglądaj.

    Przycisk Przeglądaj

  3. W oknie dialogowym Zapisywanie jako kliknij strzałkę obok pozycji Narzędzia, a następnie kliknij pozycję Opcje ogólne.

    Pozycja Opcje ogólne w menu Narzędzia

  4. W oknie dialogowym Opcje ogólne zaznacz pole wyboru Zawsze z kopią zapasową.

    Opcja Zawsze z kopią zapasową w oknie dialogowym Opcje ogólne

Początek strony

Automatyczne tworzenie pliku odzyskiwania w określonych odstępach

Plik odzyskiwania skoroszytu również zapewnia dostęp do danych na wypadek przypadkowego usunięcia lub uszkodzenia skoroszytu.

  1. Kliknij pozycję Plik > Opcje.

  2. W kategorii Zapisywanie w obszarze Zapisywanie skoroszytów zaznacz pole wyboru Zapisz informacje Autoodzyskiwania co, a następnie wprowadź liczbę minut (wartością domyślną jest 10).

    Opcja Autoodzyskiwanie na karcie Zapisywanie w oknie dialogowym Opcje programu Excel

  3. W polu Lokalizacja pliku Autoodzyskiwania wprowadź lokalizację, w której chcesz zapisać plik odzyskiwania.

  4. Upewnij się, że pole wyboru Wyłącz Autoodzyskiwanie tylko dla tego skoroszytu nie jest zaznaczone.

Początek strony

Uwaga : Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×