Naprawianie błędu #ARG! w funkcji ZŁĄCZ.TEKSTY

Ważne : W programie Excel 2016, aplikacji Excel Mobile i aplikacji Excel Online funkcja ZŁĄCZ.TEKSTY została zastąpiona przez funkcję ZŁĄCZ.TEKST. Funkcja ZŁĄCZ.TEKSTY jest nadal dostępna w celu zachowania zgodności z poprzednimi wersjami, jednak warto korzystać z funkcji ZŁĄCZ.TEKST, która oferuje większe możliwości.

Jednym z najbardziej typowych scenariuszy wystąpienia błędu #ARG! podczas korzystania z funkcji ZŁĄCZ.TEKSTY jest próba utworzenia ciągu obejmującego odwołanie do komórki zawierającej błąd, na przykład błąd #ARG!.

W poniższym przykładzie chcemy złączyć komórki D2, E2 i F2, a komórka E2 zawiera błąd #ARG!.

Błąd #ARG! w funkcji ZŁĄCZ.TEKSTY

Błąd w komórce E2 powoduje, że funkcja zwraca błąd #ARG!. Aby funkcja działała prawidłowo, należy zastąpić błąd inną wartością. Możesz utworzyć formułę sprawdzającą, czy w komórce występuje błąd, a w przypadku jego wystąpienia wyświetlającą ciąg tekstowy z wartością 0 w miejscu błędu (można również zamiast wartości 0 podstawić własny tekst, umieszczając go w cudzysłowie — "Twój tekst").

Może to być na przykład następująca formuła:

=JEŻELI(CZY.BŁĄD(E2);ZŁĄCZ.TEKSTY(D2;" ";0;" ";F2))

Funkcje JEŻELI i CZY.BŁĄD zastosowane jako obejście w celu złączenia ciągu w przypadku wystąpienia błędu !ARG#

Jak to działa? W funkcji JEŻELI użyto funkcji JEŻELI.BŁĄD w celu określenia, czy komórka E2 zawiera błąd — jeśli tak, funkcja ZŁĄCZ.TEKSTY połączy wartości z komórek D2, E2 i F2 (zastępując błąd wartością 0) i wyświetli wynikowy ciąg tekstowy. W formule użyto również spacji (" "), aby oddzielić wartości.

Naprawianie błędu #ARG! w funkcji ZŁĄCZ.TEKSTY w programie Excel 2003 lub starszej wersji

Jeśli błąd #ARG! występuje w programie Office Excel 2003 lub starszej wersji, należy usunąć zaznaczenie opcji Przeniesienie sposobu szacowania formuł w programie Excel. Aby rozwiązać ten problem, wykonaj czynności opisane w temacie Błąd #ARG! podczas łączenia komórek.

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Naprawianie błędu #ARG!

ZŁĄCZ.TEKSTY, funkcja

ZŁĄCZ.TEKST, funkcja

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach przy użyciu opcji sprawdzania błędów

Wszystkie funkcje programu Excel (alfabetycznie)

Wszystkie funkcje programu Excel (według kategorii)

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×