Naprawianie błędu #ARG! w funkcji SUMA.JEŻELI/SUMA.WARUNKÓW

W tym temacie wymieniono najbardziej typowe przyczyny błędu #ARG! w przypadku funkcji SUMA.JEŻELI i SUMA.WARUNKÓW oraz sposoby ich usuwania.

Problem: formuła odwołuje się do komórek w zamkniętym skoroszycie

Funkcje SUMA.JEŻELI oraz SUMA.WARUNKÓW odwołujące się do komórki lub zakresu w zamkniętym skoroszycie zwrócą błąd #ARG!.

Uwaga: Jest to znany problem dotyczący też kilku innych funkcji programu Excel, takich jak między innymi LICZ.JEŻELI, LICZ.WARUNKI oraz LICZ.PUSTE. Aby uzyskać więcej informacji, zobacz artykuł Funkcje SUMA.JEŻELI, LICZ.JEŻELI i LICZ.PUSTE zwracają błąd „#ARG!”.

Rozwiązanie: otwórz skoroszyt wskazany w formule i naciśnij klawisz F9, aby odświeżyć formułę.

Ten problem można też objeść przy użyciu połączenia funkcji SUMA i JEŻELI w formule tablicowej. Aby uzyskać więcej informacji, zobacz artykuł Funkcje SUMA.JEŻELI, LICZ.JEŻELI i LICZ.PUSTE zwracają błąd „#ARG!”.

Problem: ciąg kryteriów ma więcej niż 255 znaków

Funkcje SUMA.JEŻELI/SUMA.WARUNKÓW zwracają niepoprawne wyniki w razie próbowania dopasowania ciągów mających więcej niż 255 znaków.

Rozwiązanie: Skróć ciąg, jeśli to możliwe. Jeśli nie można go skrócić, podziel tę wartość na wiele ciągów za pomocą funkcji ZŁĄCZ.TEKSTY lub operatora &. Na przykład:

=SUMA.JEŻELI(B2:B12;"długi ciąg"&"inny długi ciąg")

Problem: w funkcji SUMA.WARUNKÓW argument kryteria_zakres jest niezgodny z argumentem suma_zakres

Argumenty zakresu zawsze muszą być takie same w funkcji SUMA.WARUNKÓW. Oznacza to, że argumenty kryteria_zakres i suma_zakres powinny odwoływać się do takiej samej liczby wierszy i kolumn.

W poniższym przykładzie formuła powinna zwrócić sumę dziennej sprzedaży jabłek w Międzyzdrojach. Jednak argument suma_zakres (C2:C10) nie odpowiada tej samej liczbie wierszy i kolumn w argumentach kryteria_zakres (A2:A12 i B2:B12). Użycie składni =SUMA.WARUNKÓW(C2:C10;A2:A12;A14;B2:B12;B14) spowoduje zwrócenie błędu #ARG!.

Niepoprawna formuła to =SUMA.WARUNKÓW(C2:C10;A2:A12;A14;B2:B12;B14), w której zakres C2:C10 musi być zakresem C2:C12
W funkcji SUMA.WARUNKÓW argument kryteria_zakres musi być zgodny z argumentem suma_zakres

Rozwiązanie: Postępując zgodnie z tym przykładem, zmień wartość argumentu suma_zakres na C2:C12 i ponownie sprawdź formułę.

Uwaga :  W funkcji SUMA.JEŻELI można używać zakresów o różnych rozmiarach.

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Naprawianie błędu #ARG!

SUMA.JEŻELI, funkcja

SUMA.WARUNKÓW, funkcja

Klipy wideo dotyczące zaawansowanych funkcji JEŻELI

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach przy użyciu opcji sprawdzania błędów

Wszystkie funkcje programu Excel (alfabetycznie)

Wszystkie funkcje programu Excel (według kategorii)

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×